Only 640x480 resolution on external projector

Bug #1087289 reported by E. Lefty Kreouzis on 2012-12-06
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

When I connect an external projector it is recognised and output is sent to it, however the only resolution
recognized is 640x480 which make it unusable

It used to work properly on the same hardware under ubuntu 12.04

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xorg 1:7.7+1ubuntu4
ProcVersionSignature: Ubuntu 3.5.0-19.30-generic 3.5.7
Uname: Linux 3.5.0-19-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 304.43 Sun Aug 19 20:14:03 PDT 2012
 GCC version: gcc version 4.7.2 (Ubuntu/Linaro 4.7.2-2ubuntu1)
.tmp.unity.support.test.0:

ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,snap,move,obs,resize,regex,place,session,imgpng,unitymtgrabhandles,commands,widget,gnomecompat,grid,mousepoll,vpswitch,animation,wall,expo,ezoom,workarounds,fade,scale,unityshell]
CompositorRunning: compiz
Date: Thu Dec 6 18:46:08 2012
DistUpgraded: 2012-10-19 09:39:22,938 DEBUG enabling apt cron job
DistroCodename: quantal
DistroVariant: ubuntu
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes
GraphicsCard:
 NVIDIA Corporation GT216 [NVS 5100M] [10de:0a2c] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:1521]
JockeyStatus:
 kmod:nvidia_experimental_304 - Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
 kmod:nvidia_experimental_310 - Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
 kmod:nvidia_current - nvidia_current (Proprietary, Enabled, Not in use)
 kmod:nvidia_current_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
MachineType: Hewlett-Packard HP EliteBook 8540p
MarkForUpload: True
PccardctlStatus:
 Socket 0:
   3.3V
  16-bit
  PC Card
   Subdevice 0 (function 0) bound to driver "pata_pcmcia"
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-19-generic root=UUID=9b3ffa35-e88f-4588-b4be-e8111c21d10b ro quiet splash
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to quantal on 2012-10-19 (48 days ago)
dmi.bios.date: 03/29/2012
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68CVD Ver. F.21
dmi.board.name: 1521
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 32.34
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68CVDVer.F.21:bd03/29/2012:svnHewlett-Packard:pnHPEliteBook8540p:pvr:rvnHewlett-Packard:rn1521:rvrKBCVersion32.34:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 8540p
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.8.4+bzr3407-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu3

bugbot (bugbot) on 2012-12-13
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
affects: xorg-server (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Chris Jillings (jillings) wrote :

This bug affetcs me too:

 ~> uname -a
Linux jillings-laptop 3.2.0-40-generic #64-Ubuntu SMP Mon Mar 25 21:22:10 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Toshiba projector.

This bug is sufficiently serious that I will change distros to avoid it.

Thank you.

Ge Gao (chars-gao) wrote :

Same problem on Lenovo W510 with NVIDIA GT216 [Quadro FX 880M] with Toshiba TV, projector etc.

uname -a
Linux athen 3.5.0-28-generic #48-Ubuntu SMP Tue Apr 23 23:03:38 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

I have to switch to nouveau driver when presenting or showing demo. Very annoying!

dino99 (9d9) wrote :

That version is no more supported; please open a new bug report if the actual archive found version also has the same issue.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.