nVidia Driver Randomly Freezing or Producing Artifacts

Bug #1073671 reported by Alix Axel on 2012-10-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

I can't do anything with my system ATM, however I've produced some sort of log on http://askubuntu.com/questions/209891/ubuntu-12-04-12-10-randomly-freezing-nvidia.

I was running Ubuntu 12.04.1 LTS.

-----
My Ubuntu install frequently freezes, sometimes showing a black screen (not very common anymore - in my latest installs), some other times the mouse and keyboard just fail to move and respond (not even <kbd>Ctrl</kbd> + <kbd>Alt</kbd> + <kbd>F1</kbd> works) and some other times I'm able to move the mouse with a huge delay (2-5 seconds) but I'm not able to do/click anything.

I have a pretty strong feeling that this problem is related to my graphic card drivers because:

 - after hard reset, I usually get error reports about X.org / jockey
 - it's common for artifacts to appear during loading / shutdown / whenever, for instance:
   - pattern filled with `£` during log off
   - ugly-colored squared pattern during boot
   - windows that are partially moved (i.e.: only the top half)
   - Firefox renderings that leave the bottom ~30% of the page black

These artifacts appear right before the system freezes.

I've installed Ubuntu 12.04 LTS and after several failed attempts to get my dual monitor setup to work properly I tried installing the new 12.10 version, hoping that this new version would have this problem solved... Unfortunatly, that was not the case, so I reverted to Ubuntu 12.04.

I've tried all the drivers in the *Additional Drivers* application (even the experimental ones), I've also tried the `nvidia-current` package from the PPA repository `ubuntu-x-swat/x-updates` as well as the `nouveau` OSS driver. Nothing (except no driver at all with a 640*480 resolution) at all seems stable.

Here is the info of my graphic card:

    alix@alix-E500:~$ lspci | grep VGA
    01:00.0 VGA compatible controller: NVIDIA Corporation G86 [GeForce 8400M G] (rev a1)
    alix@alix-E500:~$ sudo lshw -C video
    [sudo] password for alix:
      *-display
           description: VGA compatible controller
           product: G86 [GeForce 8400M G]
           vendor: NVIDIA Corporation
           physical id: 0
           bus info: pci@0000:01:00.0
           version: a1
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
           configuration: driver=nouveau latency=0
           resources: irq:16 memory:fd000000-fdffffff memory:d0000000-dfffffff memory:fa000000-fbffffff ioport:cc00(size=128) memory:fe0e0000-fe0fffff

Right now, I don't even have my 22" monitor connected as I can't even get my laptop display to work properly and without freezes. I've searched, read and tried all that I could (over several fresh reinstalls) to fix the problem, but so far, no solution has proven definitive.

I'm sorry I can't precise which symptom maps to each driver but I've been trying to solve this one on my own without logging what I'm doing, perhaps someone here will be able to point me to a certain-fix solution, if not I'll keep updating this question as I go along.

Please let me know if any more info is needed to pinpoint the exact problem.

----------

**Trying out *NVIDIA accelerated graphics driver (version 173)*.**

The scrolling, minimizing / maximizing windows takes between 2 and 5 seconds to finalize. Context menus also pop up very slowly and the typing seems delayed by ~1 second. No critical issues so far.

Firefox rendering of the *Save Edits* button is consistently messed up (random black lines in the top).

**Trying out *NVIDIA accelerated graphics driver (version current) [Recommended]*.**

All the delays mentioned above and the buggy rendering of the *Save Edits* button are gone, but I'm noticing that the whole screen flashes black for a couple of microseconds and while I was writing this test for the first time, the bottom 30% of the screen went black and I couldn't do anything (not even <kbd>Ctrl</kbd> + <kbd>Alt</kbd> + <kbd>F1</kbd> would work). Had to force a hard reset.

Also, the system hanged a little for a couple of seconds with the fade out of the "Restart" menu.

**Trying out *NVIDIA accelerated graphics driver (**experimental**beta) (version experimental-304)*.**

Same symptoms as before, it crashed once while I was trying to install Chromium and again after a hard reset when I was trying to remove the driver. The bottom of the screen did not went black and I could move my mouse both times. <kbd>Ctrl</kbd> + <kbd>Alt</kbd> + <kbd>F1</kbd> didn't work.

The ugly-colored pattern also showed up during the second boot.

**Trying out *NVIDIA accelerated graphics driver (**experimental**beta) (version experimental-307)*.**

The system crashed as soon as I clicked something. Had to do a fresh re-install.

**Trying out *Nouveau: Accelerated Open Source driver for nVidia cards*.**

Artifacts still show up during boot but other than that this one seems stable. As soon as I connected my second monitor, the responsiveness dropped a lot, animations and video are somewhat slow.

I'm gonna try this solution http://askubuntu.com/a/98871/9018 later on.

I tried the above solution, the first command returned that the `--uninstall` argument was not implemented but other than that everything went okay. I rebooted my system and after the login the monitor went black for a couple of seconds and then instead of the Unity interface I just saw artifacts in their place. I could tell the mouse and keyboard worked so I did <kbd>Ctrl</kbd> + <kbd>Alt</kbd> + <kbd>F1</kbd> and typed:

    sudo service lightdm restart

Then the same thing happened again. I rebooted my system once again and this time I couldn't pass the black phase, keyboard didn't worked so I restarted again. This last time, after login, the screen just showed my background image tiled and nothing more for several minutes.
-----

If any more info is needed to identify and get a workaround for the problem please let me know.

bugbot (bugbot) on 2012-11-01
tags: added: kubuntu
Alix Axel (alix-axel) on 2012-11-01
tags: added: ubuntu
removed: kubuntu
bugbot (bugbot) on 2012-11-15
tags: added: kubuntu
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers