Ubuntu

Starting Firefox kills xserver immediately when using 2D desktop

Reported by glmm on 2012-08-17
104
This bug affects 17 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Critical
Unassigned
Quantal
Critical
Unassigned

Bug Description

Starting firefox kills xserver immediately.
Just happens after upgrading xserver this morning.
Running nvidia-current.
Ubuntu Quantal.

glmm (glmm-deactivatedaccount) wrote :

NOT nouveau, nvidia-current!!!
Don't know why nouveau is automatically selected.

Harry (harry33) on 2012-08-17
affects: xserver-xorg-video-nouveau (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Harry (harry33) wrote :

Nvidia-graphics-drivers (nvidia-current) do not work with xserver_1.13 branch if a 3d desktop session is selected.
Also when using a 2d desktop (like gnome classic), you cannot use firefox or thunderbird ATM.
Not even the latest stable nvidia drivers (304.37) work.

Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → Critical
Alberto Milone (albertomilone) wrote :

Subscribing Nvidia to the bug report

Daniel Dadap (ddadap) wrote :

The current release 304 drivers should work fine with 1.13. I'll check this out on my Quantal machine.

Daniel Dadap (ddadap) wrote :

There was a change in the layout of an X server data structure, which caused the NVIDIA OpenGL driver to call into invalid function pointers: http://lists.x.org/archives/xorg-devel/2012-August/033307.html

This should be fixed in the next 304 release after 304.37. Thanks for reporting this.

Changed in nvidia-graphics-drivers (Ubuntu Quantal):
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
R3vo tester (anas-barcawi) wrote :

for me when i use a 2d desktop (like LXDE), i can't use firefox or thunderbird, it's kill xorg immediately, using xserver 1.3

tags: added: quantal
Robbie Williamson (robbiew) wrote :

FYI - As a *workaround*, you can enable the nouveau driver in /etc/X11/xorg:

 Section "Device"
   Identifier "Configured Video Device"
  Driver "nouveau"
 EndSection

and both applications should work, however I noticed my sound quit working afterwards...but not sure how related that is.

>> As a *workaround*, you can enable the nouveau driver in /etc/X11/xorg:

Unless you happen to own a GTX 560/GF114 card like some of us, as there is a curent Nouveau bug that causes it to throw "PFIFO - playist update failed", and "failed to idle channel..." messages while repeatedly restarting LightDM, ever since a commit on April 30th.

summary: - Starting Firefox kills xserver immediately
+ Starting Firefox kills xserver immediately when using 2D desktop
Rocko (rockorequin) wrote :

Is the bug actually in the nvidia driver or in the xserver? X has now applied the ABI bump (http://lists.x.org/archives/xorg-announce/2012-August/002059.html) with the patch that Aaron requested pertaining to this crash, and xserver-xorg-core is now at 2:1.12.99.905-0ubuntu1 so it should have the new ABI. So does the crash still happen with the new xserver?

Yes, Rocko - It's in the nvidia driver. See Daniel's message #6.

Unless I misunderstand what he said: Nvidia built/released the 304.37 drivers to what they thought would be 1.13 compliant around the 13th, but there was a change in the ABI on the 17th, that broke their compatibility, before the finalization of 1.12.99.905 version on the 21st that is now in the repos.

Aaron Plattner (aplattner) wrote :

As Daniel mentioned, the problem is in OpenGL. If you are willing to run without it, you can work around the problem for now by disabling the "glx" module in /etc/X11/xorg.conf by adding the following lines:

Section "Module"
    Disable "glx"
EndSection

This issue was caused because the video driver ABI version was changed correctly, but nobody noticed that the extension module ABI needed to be bumped as well. That's why the problem only affects libglx and not the nvidia X driver.

Please note that we do not officially support pre-release or release candidate X servers.

Rocko (rockorequin) wrote :

OK, with the new Xserver 1.12.99.905-0ubuntu2, nvidia-current 304.37 does load OK, at least for bumblebee. I was keen to try it out to see if it would crash with the "Attempted to yield the CPU while in atomic or interrupt context" that plagued it in Precise while playing opengl games. Sadly, it crashes with this error in Quantal too.

Doug McMahon (mc3man) wrote :

The 304.43 release should resolve this, hopefully also includes the Xorg crash on 3d (unity, gnome-shell

I tested with the 304.43 edgers package and the new drivers do fix the crash with these applications, as well as with the Unity and other 3D desktops.

Jason Conti (jconti) wrote :

This seems be fixed in the latest nvidia-current release:

nvidia-graphics-drivers (304.43-0ubuntu1) quantal; urgency=low

  * debian/rules:
    - Add support for X ABI 13.
  * New upstream release (LP: #1037483):
    - Added support for the following GPUs:
      o GeForce GTX 660 Ti
      o Quadro K5000
      o Quadro K5000M
      o Quadro K4000M
      o Quadro K3000M
      o NVS 510
    - Fixed a bug that caused pre-release versions of
      X.Org xserver 1.13 to crash when certain GLX
      operations were performed, such as when starting
      Firefox.
    - Fixed a bug that caused VDPAU to hang when
      expanding the YouTube Flash Player.
 -- Alberto Milone <email address hidden> Tue, 28 Aug 2012 12:47:45 +0200

Changed in nvidia-graphics-drivers (Ubuntu Quantal):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers