Gnome Session restart

Bug #1009728 reported by John Dempsey on 2012-06-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

I get kicked out of my session, and see the following in my syslog :

Jun 6 16:26:12 jdempsey-pc acpid: client 1063[0:0] has disconnected
Jun 6 16:26:12 jdempsey-pc acpid: client 1063[0:0] has disconnected
Jun 6 16:26:12 jdempsey-pc acpid: client connected from 10187[0:0]
Jun 6 16:26:12 jdempsey-pc acpid: 1 client rule loaded
Jun 6 16:26:12 jdempsey-pc pulseaudio[10189]: [pulseaudio] client-conf-x11.c: xcb_connection_has_error() returned true
Jun 6 16:26:12 jdempsey-pc pulseaudio[10193]: [pulseaudio] pid.c: Stale PID file, overwriting.
Jun 6 16:26:12 jdempsey-pc pulseaudio[10193]: [pulseaudio] bluetooth-util.c: Error from ListAdapters reply: org.freedesktop.DBus.Error.AccessDenied
Jun 6 16:26:12 jdempsey-pc pulseaudio[10193]: [pulseaudio] server-lookup.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NoServer: Failed to
 connect to socket /tmp/dbus-ppxMDUm84r: Connection refused
Jun 6 16:26:12 jdempsey-pc pulseaudio[10193]: [pulseaudio] main.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NoServer: Failed to connect
to socket /tmp/dbus-ppxMDUm84r: Connection refused
Jun 6 16:26:13 jdempsey-pc acpid: client connected from 10187[0:0]

The problem can occur several times a day. I haven't identified a repeatable cause yet..

Any assistance would be appreciated

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+12ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic-pae 3.2.16
Uname: Linux 3.2.0-24-generic-pae i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 295.53 Fri May 11 23:13:15 PDT 2012
 GCC version: gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,workarounds,scale,expo,ezoom]
CompositorRunning: compiz
CurrentDmesg: [ 31.168021] eth0: no IPv6 routers present
Date: Wed Jun 6 16:53:12 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 295.53, 3.2.0-24-generic-pae, i686: installed
 virtualbox, 4.1.12, 3.2.0-24-generic-pae, i686: installed
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 NVIDIA Corporation G84 [Quadro FX 1700] [10de:040f] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: NVIDIA Corporation Device [10de:049a]
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 08bb:2706 Texas Instruments Japan
 Bus 002 Device 003: ID 03f0:2c24 Hewlett-Packard Logitech M-UAL-96 Mouse
MachineType: Hewlett-Packard HP xw9400 Workstation
ProcEnviron:
 LANGUAGE=en_CA:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic-pae root=UUID=dabba426-7de7-45ab-845f-502fc83215db ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 12/08/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 786D6 v03.13
dmi.board.asset.tag: 2UA7460PJC
dmi.board.name: 0A1Ch
dmi.board.vendor: Hewlett-Packard
dmi.board.version: D
dmi.chassis.asset.tag: 2UA7460PJC
dmi.chassis.type: 6
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr786D6v03.13:bd12/08/2008:svnHewlett-Packard:pnHPxw9400Workstation:pvr:rvnHewlett-Packard:rn0A1Ch:rvrD:cvnHewlett-Packard:ct6:cvr:
dmi.product.name: HP xw9400 Workstation
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.7.8-0ubuntu1
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3.1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.19.0-0ubuntu1~xup1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

John Dempsey (johngdempsey) wrote :
John Dempsey (johngdempsey) wrote :

It just happened again, and this time I noticed a segfault:

Jun 6 17:07:13 jdempsey-pc kernel: [167362.909995] show_signal_msg: 54 callbacks suppressed
Jun 6 17:07:13 jdempsey-pc kernel: [167362.910006] Xorg[10187]: segfault at 1000043 ip b483db0d sp bfc2ac50 error 4 in
nvidia_drv.so[b480b000+707000]
Jun 6 17:07:14 jdempsey-pc acpid: client 10187[0:0] has disconnected
Jun 6 17:07:14 jdempsey-pc acpid: client 10187[0:0] has disconnected
Jun 6 17:07:14 jdempsey-pc acpid: client connected from 13645[0:0]
Jun 6 17:07:14 jdempsey-pc acpid: 1 client rule loaded

Timo Aaltonen (tjaalton) on 2012-06-12
affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
To post a comment you must log in.