Ubuntu

[Latitude E6510 / Thinkpad W510/T510] External Video inoperative with nVidia current

Reported by Jeff Lane on 2011-10-18
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
High
Alberto Milone
Oneiric
High
Alberto Milone
nvidia-graphics-drivers-updates (Ubuntu)
High
Alberto Milone
Oneiric
High
Alberto Milone

Bug Description

During testing of Oneiric on the Latitude E6510 I tried both external VGA and DisplayPort using the nvidia driver after installing nvidia_current via Jockey and rebooting the machine.

Neither external port worked using the nVidia driver.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 280.13 Wed Jul 27 16:55:43 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Tue Oct 18 15:20:52 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 280.13, 3.0.0-12-generic, i686: installed
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 nVidia Corporation GT218 [NVS 3100M] [10de:0a6c] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Dell Latitude E6510 [1028:040b]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
JockeyStatus:
 kmod:wl - Broadcom STA wireless driver (Proprietary, Disabled, Not in use) [auto-install]
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: Dell Inc. Latitude E6510
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=8ba496ee-b35c-4ef3-917c-d6869b0ac641 ro quiet splash initcall_debug vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 11/20/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: 0N5KHN
dmi.board.vendor: Dell Inc.
dmi.board.version: A03
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd11/20/2010:svnDellInc.:pnLatitudeE6510:pvr0001:rvnDellInc.:rn0N5KHN:rvrA03:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6510
dmi.product.version: 0001
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu3
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Jeff Lane (bladernr) wrote :
tags: added: blocks-hwcert
Jeff Lane (bladernr) wrote :

Also saw this issue on Lenovo Thinkpad W510 (6974)

bugbot (bugbot) on 2011-10-20
affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Ara Pulido (apulido) on 2011-10-28
summary: - [Latitude E6510] External Video inoperative with nVidia current
+ [Latitude E6510 / Thinkpad W510] External Video inoperative with nVidia
+ current
tags: added: blocks-hwcert-enablement

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Ara Pulido (apulido) on 2011-11-28
Changed in nvidia-graphics-drivers (Ubuntu):
assignee: nobody → Chris Van Hoof (vanhoof)
importance: Undecided → High
Changed in nvidia-graphics-drivers (Ubuntu):
assignee: Chris Van Hoof (vanhoof) → Alberto Milone (albertomilone)
importance: High → Medium
importance: Medium → High
Joshua R. Poulson (jrp) wrote :

This does not reproduce on my Thinkpad W510 on the GA, proposed, or ubuntu-x-swat-x-updates oneiric PPA versions of the nvidia-current driver. Are there some tests I can help perform on my system to help close this bug?

Anthony Wong (anthonywong) wrote :

jrp, thanks for the feedback.

I'd want to wait a little longer for Jeff to verify on his E6510 and possibly W510, the bug may be attributed to some HW difference even though the model name is the same.

Anthony, I have the HW in, what do you need tested? I'm seeing this issue on two different W510 systems.

Ara Pulido (apulido) on 2012-02-02
summary: - [Latitude E6510 / Thinkpad W510] External Video inoperative with nVidia
- current
+ [Latitude E6510 / Thinkpad W510/T510] External Video inoperative with
+ nVidia current
Anthony Wong (anthonywong) wrote :

I found that many people have the problem using nvidia after updated to 11.10:
http://ubuntuforums.org/archive/index.php/t-1858476.html
http://forums.nvidia.com/index.php?showtopic=213799

Alberto, is there a newer driver from nvidia?

Changed in nvidia-graphics-drivers (Ubuntu Oneiric):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: New → Incomplete
Alberto Milone (albertomilone) wrote :

in the changelog of driver 295.20 I can see the following:
"Fixed a bug that could cause X to crash after hotplugging displays."

I'm wondering if, somehow, this is related to our problem.

I've also subscribed Nvidia to this bug report.

Daniel Dadap (ddadap) wrote :

I don't think it's related. I don't see any reports of X crashing here, just inability to use external displays. Furthermore, the bug referenced in that changelog entry was introduced in the 295 timeframe and this bug is reported in 280.

The issue described here also doesn't seem to exactly match the issue described on the ubuntuforums.org and forums.nvidia.com links: here it sounds like neither external display is working, and on the forum posts it sounds like the control panel is freezing when enabling two external monitors simultaneously.

The latter is a known bug in the control panel which was fixed in the 290 timeframe. The former sounds like a distinct issue to me, but maybe I've misunderstood the report. It would be good to clarify with the original reporter.

For the control panel bug, you don't want to do a full driver update for that bug, you can just patch the control panel:

--- a/src/gtk+-2.x/ctkdisplayconfig-utils.c
+++ b/src/gtk+-2.x/ctkdisplayconfig-utils.c

@@ -1111,8 +1111,8 @@
     if (!screen->displays) {
         screen->displays = display;
     } else {
- nvDisplayPtr last = screen->displays;
- while (last) {
+ nvDisplayPtr last;
+ for (last = screen->displays; last; last = last->next_in_screen) {
             if (!last->next_in_screen) {
                 last->next_in_screen = display;
                 break;

Anthony Wong (anthonywong) wrote :

@Daniel @Alberto
What additional information has to be provided to continue debugging this issue?
A 295 nvidia package for Oneiric worth a try?

Daniel Dadap (ddadap) wrote :

The 295 driver package will contain the control panel fix. However, the original problem reported in this bug does not sound like the control panel bug. It's not clear to me if the other comments on this bug are actually reporting the same issue reported in this bug, or the control panel issue as described in the linked forum posts.

Ara Pulido (apulido) on 2012-03-09
tags: added: precise
Alberto Milone (albertomilone) wrote :

the nvidia-current-updates package in oneiric-proposed should fix the issue. Please test it.

Changed in nvidia-graphics-drivers-updates (Ubuntu):
status: New → Fix Committed
Changed in nvidia-graphics-drivers-updates (Ubuntu Oneiric):
status: New → Fix Committed
Changed in nvidia-graphics-drivers-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-updates (Ubuntu Oneiric):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-updates (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-updates (Ubuntu Oneiric):
importance: Undecided → High
Alberto Milone (albertomilone) wrote :

further instructions on how to test the packages are available in bug #919992

Greg Vallande (gvallande) wrote :

Hi All,

   I retested the W510 with the nvideo-graphics-drivers-updates(current) package on Precise beta1 - I installed via jockey then rebooted - The VGA port does NOT work - However the Displayport DOES work.

Alberto Milone (albertomilone) wrote :

sorry, I misunderstood Daniel's words. The fix for the panel's bug is in, I'm not sure about the issue with the VGA port though.

Bryce Harrington (bryce) on 2012-03-16
Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

The 295.33 driver is now included in ubuntu. I can't tell if it fixes this issue, but the changelog does specify a couple display-port related fixes.

Please update to 295.33 and re-test if this issue can still be reproduced with that version.

Changed in nvidia-graphics-drivers (Ubuntu Oneiric):
status: Incomplete → New
status: New → Incomplete
Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Incomplete
Thomas (thomas-eisenbarth) wrote :

Thanks for helping out, Bryce. I have a very similar issue with nvidia-graphics on a T410 (NVS 3100M chipset).

As far as I can say, the problems with the external displayport were introduced here:

Start-Date: 2012-03-04 18:58:02
Commandline: apt-get install nvidia-current
Install: nvidia-current:amd64 (280.13-0ubuntu6), nvidia-settings:amd64 (280.13-0ubuntu2, automatic)

I'm pretty sure things worked well before.

I installed the 295.33 vanilla from Nvidia.com as I couldn't find them within standard repositories. Though, 295.33 doesn't seem to solve the problems, my external display connected via displayport is still not detected in nvidia-settings. Interestingly something is happening when I hit 'Detect' within nvidia-settings as my Dell U2711 changes the status indicator color from Standby/yellow to blue for a short time...

Bryce Harrington (bryce) on 2012-04-04
Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → New
Changed in nvidia-graphics-drivers (Ubuntu Oneiric):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu Oneiric):
status: New → Confirmed
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Greg Vallande (gvallande) wrote :

Hi All,

  I re-tested this with a Lenovo T510 - Installed 11.10+updates; Installed the nvidia drivers via Jockey and now the DisplayPort is functional and also the VGA port.

Changed in nvidia-graphics-drivers (Ubuntu Oneiric):
status: Confirmed → Invalid
Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Invalid
James M. Leddy (jm-leddy) wrote :

Hi,

According to comment #20, this looks to be fixed in oneiric-updates, would you please test on the OEM machines to confirm?

Anthony Wong (anthonywong) wrote :

Latitude E6510 / Thinkpad W510/T510 have all been certified with 12.04 so consider this bug fixed.

Changed in nvidia-graphics-drivers-updates (Ubuntu):
status: Fix Committed → Fix Released
Changed in nvidia-graphics-drivers-updates (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers