Ubuntu

Black screen on boot with Nvidia 310 driver

Reported by graingert on 2012-12-24
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-experimental-310 (Ubuntu)
Undecided
Unassigned

Bug Description

With the 310 drivers installed it seems that lightdm does not operate. Downgrading to 304 fixes the issue

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nvidia-experimental-310 310.14-0ubuntu0.1
ProcVersionSignature: Ubuntu 3.2.0-35.55-generic 3.2.34
Uname: Linux 3.2.0-35-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu15.1
Architecture: amd64
Date: Mon Dec 24 02:07:34 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
MarkForUpload: True
SourcePackage: nvidia-graphics-drivers-experimental-310
UpgradeStatus: Upgraded to precise on 2012-06-02 (204 days ago)

graingert (tagrain) wrote :
Rui Nande (epostalservice) wrote :

Have you tried the nvidia release (310.19) install in a console with the lightdm service stopped?

Download the drivers from the nvidia page and enter console 1 (CTRL+ALT+1) and change to the directory where the install file is,
default is Downloads in your home directory, and type:

sudo stop lightdm
sudo sh ./NVIDIA-Linux-a64-310.19.run

When promped to update xorg.conf say no. With me lightdm didn't work. <-- could be the bug in question

Reboot and see if it works. You can also try saying yes to xorg.conf update, just say to make a backup copy when promped.
If it fails, go to a console, stop lightdm if it's started, run the install with the --uninstall option and restore xorg.conf's backup when promped. Run install again and don't update xorg.conf.

It's also possible that it's a driver related bug, since it's an experimental version, so try the final version for 310 (310.19) from nvidia to exclude that possibility.
I will also try to replicate the bug.

Drop a line afterwards with the results. Take care.

graingert (tagrain) wrote :

When running with the 304 drivers I have no xorg.conf file.

Installing the 301 drivers adds an xorg.conf file, lightdm does not work with or without this file.

I don't particularly want to use unpackaged software.

graingert (tagrain) wrote :

s/301/310/

Rui Nande (epostalservice) wrote :

Ok, I tried to replicate that bug, but nothing so far.
I downgraded from 310.19 (from nvidia) to 304 (package), then installed the 310 (package).
All my 3 screens worked, the configuration was kept.

I did, however, get an error during the 310 install. Re-running apt-get install seemed to install properly. The 304 installed with no problems.

Seems like it might be problem with the package.
I'll try to get it triaged.

Ian Nicholson (imnichol) wrote :

I think that this is a duplicate of bug 1069283, which I experience with all versions of the nvidia drivers.
Does it work if you install gdm and configure ubuntu to use that rather than lightdm?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-experimental-310 (Ubuntu):
status: New → Confirmed
tarron filmer (sephsplace) wrote :

Recently I've been recently pulling my hair out trying to install 325 drivers, having to go back and install 304 to be able to get past a black/blank screen issue, but I found the solution! for me anyway (previously I had tried things like nomodeset, noapic...loads of boot parameters) but all I did was after installing the 325 drivers via xorg edgers ppa, was just to "nvidia-xconfig" in terminal after installation, then I had no more black screen after reboot. so happy right now

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers