Ubuntu

nvidia-experimental-310 does not provide nvidia-current

Reported by Walther on 2012-11-30
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-experimental-310 (Ubuntu)
Undecided
Unassigned

Bug Description

Installing nvidia-experimental-310 causes bumblebee to uninstall, as bumblebee depends on nvidia-current. However, logically, nvidia-experimental-310, being an updated, newer version of the driver, essentially containing all the previous / existing features, should provide nvidia-current, and hence nvidia-experimental-310 should satisfy the requirements of bumblebee similarly as nvidia-current.

This causes a major issue with laptops using Optimus technology; it restricts the users to nvidia-current, allowing no testing of the more up-to-date drivers with improved performance.

What should happen:
User is able to install and use updated, even if experimental, nvidia drivers on a laptop with Optimus
What happens:
Installing nvidia-experimental-310 causes bumblebee to uninstall, and hence on boot-up no nvidia card is detected as there is no bumblebee kernel module to turn it on.

EDIT:
With further inspection, as shown below (see full texts), it seems that the package nvidia-experimental-310 *does* provide nvidia-current. HOWEVER, it also *conflicts* with that package.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-experimental-310 (Ubuntu):
status: New → Confirmed
Walther (veeti-haapsamo) wrote :
Download full text (42.6 KiB)

Reading package lists...
Building dependency tree...
Reading state information...
Starting
Starting 2
Investigating (0) nvidia-experimental-310 [ i386 ] < none -> 310.14-0ubuntu2 > ( restricted/misc )
Broken nvidia-experimental-310:i386 Conflicts on fglrx [ i386 ] < none -> 2:9.000-0ubuntu3 > ( restricted/misc )
  Conflicts//Breaks against version 2:9.000-0ubuntu3 for fglrx but that is not InstVer, ignoring
  Conflicts//Breaks against version 304.48-0ubuntu1 for nvidia-experimental-304 but that is not InstVer, ignoring
  Conflicts//Breaks against version 304.64-0ubuntu1 for nvidia-current-updates but that is not InstVer, ignoring
  Considering nvidia-current:i386 2 as a solution to nvidia-experimental-310:i386 10000
  Added nvidia-current:i386 to the remove list
  Conflicts//Breaks against version 173.14.35-0ubuntu3 for nvidia-173-updates but that is not InstVer, ignoring
  Conflicts//Breaks against version 173.14.36-0ubuntu1 for nvidia-173 but that is not InstVer, ignoring
  Conflicts//Breaks against version 2:9.000-0ubuntu4 for fglrx-updates but that is not InstVer, ignoring
Broken nvidia-experimental-310:i386 Conflicts on fglrx-updates [ i386 ] < none -> 2:9.000-0ubuntu4 > ( restricted/misc )
  Conflicts//Breaks against version 2:9.000-0ubuntu4 for fglrx-updates but that is not InstVer, ignoring
  Conflicts//Breaks against version 304.48-0ubuntu1 for nvidia-experimental-304 but that is not InstVer, ignoring
  Conflicts//Breaks against version 304.64-0ubuntu1 for nvidia-current-updates but that is not InstVer, ignoring
  Considering nvidia-current:i386 2 as a solution to nvidia-experimental-310:i386 10000
  Added nvidia-current:i386 to the remove list
  Conflicts//Breaks against version 173.14.35-0ubuntu3 for nvidia-173-updates but that is not InstVer, ignoring
  Conflicts//Breaks against version 173.14.36-0ubuntu1 for nvidia-173 but that is not InstVer, ignoring
  Conflicts//Breaks against version 2:9.000-0ubuntu3 for fglrx but that is not InstVer, ignoring
Broken nvidia-experimental-310:i386 Conflicts on nvidia-173 [ i386 ] < none -> 173.14.36-0ubuntu1 > ( restricted/misc )
  Conflicts//Breaks against version 173.14.36-0ubuntu1 for nvidia-173 but that is not InstVer, ignoring
  Conflicts//Breaks against version 304.48-0ubuntu1 for nvidia-experimental-304 but that is not InstVer, ignoring
  Conflicts//Breaks against version 304.64-0ubuntu1 for nvidia-current-updates but that is not InstVer, ignoring
  Considering nvidia-current:i386 2 as a solution to nvidia-experimental-310:i386 10000
  Added nvidia-current:i386 to the remove list
  Conflicts//Breaks against version 173.14.35-0ubuntu3 for nvidia-173-updates but that is not InstVer, ignoring
  Conflicts//Breaks against version 2:9.000-0ubuntu4 for fglrx-updates but that is not InstVer, ignoring
  Conflicts//Breaks against version 2:9.000-0ubuntu3 for fglrx but that is not InstVer, ignoring
Broken nvidia-experimental-310:i386 Conflicts on nvidia-173-updates [ i386 ] < none -> 173.14.35-0ubuntu3 > ( restricted/misc )
  Conflicts//Breaks against version 173.14.35-0ubuntu3 for nvidia-173-updates but that is not InstVer, ignoring
  Conflicts//Breaks against version 304.48-0ubuntu1 for nvidia-ex...

Walther (veeti-haapsamo) wrote :
Download full text (16.9 KiB)

Package: nvidia-experimental-310
Priority: optional
Section: restricted/misc
Installed-Size: 103989
Maintainer: Ubuntu Core Developers <email address hidden>
Architecture: i386
Source: nvidia-graphics-drivers-experimental-310
Version: 310.14-0ubuntu2
Replaces: fglrx, fglrx-updates, nvidia-173, nvidia-173-updates, nvidia-180-modaliases, nvidia-185-modaliases, nvidia-96, nvidia-96-updates, nvidia-current, nvidia-current-modaliases, nvidia-current-updates
Provides: fglrx, fglrx-updates, nvidia-173, nvidia-173-updates, nvidia-96, nvidia-96-updates, nvidia-current, nvidia-current-updates, xorg-driver-video
Depends: x11-common (>= 1:7.0.0), make, sed (>> 3.0), dkms, linux-libc-dev, libc6-dev, linux-headers-generic | linux-headers, patch, acpid, libc6 (>= 2.3.6-6~), libgcc1 (>= 1:4.1.1), libx11-6, libxext6, zlib1g (>= 1:1.1.4), xorg-video-abi-11 | xorg-video-abi-12 | xorg-video-abi-13, xserver-xorg-core (>= 2:1.10.99.901)
Recommends: nvidia-settings-experimental-310
Conflicts: fglrx, fglrx-updates, nvidia-173, nvidia-173-updates, nvidia-180-modaliases, nvidia-185-modaliases, nvidia-96, nvidia-96-updates, nvidia-current, nvidia-current-modaliases, nvidia-current-updates
Filename: pool/restricted/n/nvidia-graphics-drivers-experimental-310/nvidia-experimental-310_310.14-0ubuntu2_i386.deb
Size: 37366398
MD5sum: 9873bc851b2fa2e6299d279a427b26d6
SHA1: d6093c3289025c65178d1b13c89275d1757a24f8
SHA256: 60f4b84d9f87ad957a74a775681598c516db84c843030affbb8906ab9446fe45
Description-en: Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library
 3D-accelerated proprietary graphics driver for NVIDIA cards. May be
 required for some newly released 3D software and games.
 .
 WARNING: This is an unstable beta driver. This package is intended for
 testers and early adopters, and not recommended for production hardware.
 .
 Release Notes:
 https://plus.google.com/u/0/118125769023950376556/posts/bHW91CsG4bP
 .
 See /usr/share/doc/nvidia-experimental-310/README.txt.gz for a complete list
 of supported GPUs and PCIIDs
Modaliases: nvidia_experimental_310(pci:v000010DEd00000191sv*sd*bc03sc*i*, pci:v000010DEd00000193sv*sd*bc03sc*i*, pci:v000010DEd00000194sv*sd*bc03sc*i*, pci:v000010DEd00000197sv*sd*bc03sc*i*, pci:v000010DEd0000019Dsv*sd*bc03sc*i*, pci:v000010DEd0000019Esv*sd*bc03sc*i*, pci:v000010DEd00000400sv*sd*bc03sc*i*, pci:v000010DEd00000401sv*sd*bc03sc*i*, pci:v000010DEd00000402sv*sd*bc03sc*i*, pci:v000010DEd00000403sv*sd*bc03sc*i*, pci:v000010DEd00000404sv*sd*bc03sc*i*, pci:v000010DEd00000405sv*sd*bc03sc*i*, pci:v000010DEd00000406sv*sd*bc03sc*i*, pci:v000010DEd00000407sv*sd*bc03sc*i*, pci:v000010DEd00000408sv*sd*bc03sc*i*, pci:v000010DEd00000409sv*sd*bc03sc*i*, pci:v000010DEd0000040Asv*sd*bc03sc*i*, pci:v000010DEd0000040Bsv*sd*bc03sc*i*, pci:v000010DEd0000040Csv*sd*bc03sc*i*, pci:v000010DEd0000040Dsv*sd*bc03sc*i*, pci:v000010DEd0000040Esv*sd*bc03sc*i*, pci:v000010DEd0000040Fsv*sd*bc03sc*i*, pci:v000010DEd00000410sv*sd*bc03sc*i*, pci:v000010DEd00000420sv*sd*bc03sc*i*, pci:v000010DEd00000421sv*sd*bc03sc*i*, pci:v000010DEd00000422sv*sd*bc03sc*i*, pci:v000010DEd00000423sv*sd*bc03sc*i*, pci:v000010DEd00000424sv*sd*bc03sc*i*, pci:v000010DEd000...

Walther (veeti-haapsamo) on 2012-12-01
description: updated
Jean-Baptiste Lallement (jibel) wrote :

I think the problem here is that bumblebee-nvidia dependency on nvidia-current is versioned, so only real packages will be considered (i.e nvidia-current 304.51.really.304.43-0ubuntu2 ) and nvidia-experimental provides the virtual package nvidia-current which conflicts with the real package.

Walther (veeti-haapsamo) wrote :

From what I've discussed with the developers, they tend to disagree. Also, there is this discussion in their PPA (which also links here): https://github.com/Bumblebee-Project/bumblebee-ppa/issues/1

Dave Gilbert (ubuntu-treblig) wrote :

http://www.debian.org/doc/debian-policy/ch-relationships.html says:
'If a relationship field has a version number attached, only real packages will be considered to see whether the relationship is satisfied (or the prohibition violated, for a conflict or breakage). In other words, if a version number is specified, this is a request to ignore all Provides for that package name and consider only real packages. The package manager will assume that a package providing that virtual package is not of the "right" version. A Provides field may not contain version numbers, and the version number of the concrete package which provides a particular virtual package will not be considered when considering a dependency on or conflict with the virtual package name.[52]'

So I'd agree with Jibel that Bumblebee is trying to do something that won't work; so it is Bumblebee's bug.

Having said that; what Bumblebee wants to do is reasonable - i.e. make sure it has at least a particular version of the nvidia driver; I just don't see there is a way to do that.

Walther (veeti-haapsamo) wrote :

Confirmed to be an issue of semantics, standards, and differences between "how things intuitively should be" and "how things are" :) On the concrete side, solution confirmed to be easier done by Bumblebee devs, and action will be taken asap. Thanks for everybody for this brainstorming, in the end that's what fixes bugs.

Hope that's all for now, closing.

--
ArchangeGabriel on https://github.com/Bumblebee-Project/bumblebee-ppa/issues/1 :

Ok, thanks for those informations, I was lacking time to investigate but you've bring the solution.

So only Lucid is concerned with a driver older than 260 currently, however this release doesn't any other flavour of nvidia driver (no -updates version). I will remove version dependency on newer release, and only let this for Lucid. Will try do so today or tomorrow at worse.
---

Changed in nvidia-graphics-drivers-experimental-310 (Ubuntu):
status: Confirmed → In Progress
Walther (veeti-haapsamo) wrote :

Fixed; bumblebee-nvidia now depends only on nvidia-current, unversioned.

Changed in nvidia-graphics-drivers-experimental-310 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers