nvidia-96 and nvidia-173 fail to install in precise pangolin (due to unmet dependency xorg-video-abi-10)

Bug #941325 reported by Sayantan Das on 2012-02-26
224
This bug affects 48 people
Affects Status Importance Assigned to Milestone
Envy
Undecided
Unassigned
nvidia-graphics-drivers-173 (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-96 (Ubuntu)
Undecided
Unassigned

Bug Description

I have a sony system with a legacy nvidia graphics card, Geforce Ti 4600. I have upgraded the system to precise pangolin i386.
I can see nvidia-96 and nvidia-96-updates in the repositories of precise pangolin but when i go to install them, i get the following error:

sudo apt-get install nvidia-96
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 nvidia-96 : Depends: xorg-video-abi-10 but it is not installable
E: Unable to correct problems, you have held broken packages.

 sudo apt-get install nvidia-96-updates
[sudo] password for raja:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 nvidia-96-updates : Depends: xorg-video-abi-10 but it is not installable
                     Recommends: nvidia-settings-updates but it is not going to be installed

Sayantan Das (sayantan13) wrote :

cannot do apport-collect because of the following error

apport-collect 941325
No packages found matching nvidia-graphics-drivers-96.
ERROR: KeyError('ProblemType',)

Gdk-WARNING **: apport-gtk: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting this issue. I get the same error when attempting to install nvidia-96 on Ubunut Precise.

Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: New → Confirmed
summary: - nvidia-96 fails to install in precise pangolin
+ nvidia-96 fails to install in precise pangolin (due to unmet dependency
+ xorg-video-abi-10)
tags: added: i386 precise unmetdeps

I am getting this bug with nvidia-173 also. No drivers show up in the "Additional Drivers" app, and I get the same error message from this bug if I try to install the driver package using apt or software center.
"Depends: xorg-video-abi-10 but it is not installable"
The drivers worked fine before upgrading to Pangolin.
Let me know if you need more info.

Markcortbass (markcortbass) wrote :

Same thing for me. I can't install the Nvidia driver version 96. Because of the missing " xorg-video-abi-10 "
I can't install this package:

mark@mark-MX46-533:~$ sudo apt-get install nvidia-96
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd
De status informatie wordt gelezen... Klaar
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.
De volgende informatie helpt u mogelijk verder:

De volgende pakketten hebben niet-voldane vereisten:
 nvidia-96 : Vereisten: xorg-video-abi-10 maar het is niet installeerbaar
             Aanbevelingen: nvidia-settings maar het zal niet geïnstalleerd worden
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast.

dmiranda (dmiranda) wrote :

Same here, missing xorg-video-abi-10.

Rodger Fox (rodgerfox) wrote :

I'm not sure how virtual packages work, but I think this may actually be a problem with the new "xserver-xorg-core" package.
When trying to install xorg-video-abi-10, I get this:

Package xorg-video-abi-10 is a virtual package provided by:
  xserver-xorg-core 2:1.10.4-1ubuntu4.1 [Not candidate version]
  xserver-xorg-core 2:1.10.4-1ubuntu4.2 [Not candidate version]

E: Package 'xorg-video-abi-10' has no installation candidate

Rodger Fox (rodgerfox) on 2012-03-15
summary: - nvidia-96 fails to install in precise pangolin (due to unmet dependency
- xorg-video-abi-10)
+ nvidia-96 and nvidia-173 fail to install in precise pangolin (due to
+ unmet dependency xorg-video-abi-10)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: New → Confirmed
badrobot (badrobot) wrote :

sudo apt-get install nvidia-96 nvidia-settings
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 nvidia-96 : Зависит: xorg-video-abi-10 но он не может быть установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise

uname -ma
Linux ubuntu 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:52 UTC 2012 i686 athlon i386 GNU/Linux

SD (sadovsky-dmitry) wrote :

try temporarily 173.14.34 (legacy prerelease) for Linux x86/x86_64 released http://www.nvnews.net/vbulletin/showthread.php?t=181248

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers