Ubuntu

[natty] nvidia binary packages for older cards - dependencies not met

Reported by Pawel Jasnos on 2011-03-24
442
This bug affects 79 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
nvidia-graphics-drivers-173 (Ubuntu)
High
Alberto Milone
Natty
Undecided
Unassigned
nvidia-graphics-drivers-96 (Ubuntu)
Medium
Alberto Milone
Natty
Medium
Alberto Milone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Package has broken dependencies that cannot be met.
xorg-video-abi-8.0
xserver-xorg-core (>= 2:1.8.99.905-1ubuntu3)

Steps to reproduce:
1. Install Natty beta & do sudo apt-get upgrade and dist-upgrade
2. Try sudo apt-get install nvidia-96 to get the error.

(confirmed to still occur in beta 1).

Mihai Sucan (mihai-sucan) wrote :

This makes Ubuntu 11.04 unusable on older hardware.

The same problem applies to the nvidia-173 package, which is not installable either, thus affecting a quite large number of PC users that do not have the latest nvidia graphics cards.

Is someone working on a fix for this issue?

Pawel Jasnos (pjasnos) wrote :

Sorry for setting this to nvidia-graphics-drivers - I wasn't sure how to set the bug as affecting multiple packages?

summary: - [natty] nvidia-96 dependencies not met
+ [natty] nvidia binary packages for older cards - dependencies not met
Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: New → Confirmed
affects: nvidia-graphics-drivers-96 (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Changed in nvidia-drivers-ubuntu:
status: New → Confirmed
Pawel Jasnos (pjasnos) on 2011-04-08
Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: New → Confirmed

The same problem on Ubuntu 11.04 Beta.
How can i fix it?

Pawel Jasnos (pjasnos) on 2011-04-11
description: updated
Changed in nvidia-graphics-drivers-96 (Ubuntu):
assignee: nobody → yarekku@gmail.com (yarekku)
assignee: yarekku@gmail.com (yarekku) → nobody
Bryce Harrington (bryce) wrote :

It's not something we can fix at the distro level. NVIDIA provided xserver 1.10 support in their main driver but not the legacy drivers.

This bug report can serve for tracking this regression but there is no work that can be done at this level to solve it. Given how little time remains before release I'm not sure NVIDIA will be distributing fixed drivers in time; if not, we'll distribute them via the x-updates PPA post-release if/when they do become available. Meanwhile, the workaround is to use nouveau, fbdev, or vesa.

Bryce Harrington (bryce) wrote :

The tasks against -93 and -173 are sufficient, there isn't a need for a task against the main driver since it does not have this issue.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Invalid
Changed in nvidia-graphics-drivers-173 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: Confirmed → In Progress
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-173 - 173.14.30-0ubuntu1

---------------
nvidia-graphics-drivers-173 (173.14.30-0ubuntu1) natty; urgency=low

  * New upstream release:
    - Add support for X.Org xserver 1.10 (LP: #741930).
    - Improve compatibility with recent Linux kernels.
 -- Alberto Milone <email address hidden> Wed, 20 Apr 2011 13:08:15 +0200

Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: In Progress → Fix Released

And what about nvidia-96?

Algo (algo-lkma) wrote :

Very very trouble!

Last time upgrade to Ubuntu 10.10, I got deep trouble with nvidia-96.
This time upgrade to Ubuntu 11.04, I got deep trouble with nvidia-96 again!!

Algo, ubuntu is not really at fault here, it's more to do with the
relationship between nvidia and xorg developers.

On 28/04/2011, Algo <email address hidden> wrote:
> Very very trouble!
>
> Last time upgrade to Ubuntu 10.10, I got deep trouble with nvidia-96.
> This time upgrade to Ubuntu 11.04, I got deep trouble with nvidia-96 again!!
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/741930
>
> Title:
> [natty] nvidia binary packages for older cards - dependencies not met
>
> Status in NVIDIA Drivers Ubuntu:
> Confirmed
> Status in “nvidia-graphics-drivers” package in Ubuntu:
> Invalid
> Status in “nvidia-graphics-drivers-173” package in Ubuntu:
> Fix Released
> Status in “nvidia-graphics-drivers-96” package in Ubuntu:
> Confirmed
>
> Bug description:
> Package has broken dependencies that cannot be met.
> xorg-video-abi-8.0
> xserver-xorg-core (>= 2:1.8.99.905-1ubuntu3)
>
> Steps to reproduce:
> 1. Install Natty beta & do sudo apt-get upgrade and dist-upgrade
> 2. Try sudo apt-get install nvidia-96 to get the error.
>
> (confirmed to still occur in beta 1).
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/nvidia-drivers-ubuntu/+bug/741930/+subscribe
>

Algo (algo-lkma) wrote :

Hi Pawel, you are right. I love Ubuntu and she is great ^_^
Just feel disappointing as likewise problem happening again.

Xorg developers should pay great attention to backward compatibility..........
Linux's market is too small, Xorg should do favor for Nvidia, instead of Nvidia doing favor for Xorg......

Felix (apoapo) wrote :

This might be correct but average users are not interested in such relationship crisis. They just drop ubuntu.
"Lol, that shit does not even use my nvidia, omg. I thought Linux was for old devices.."

My opinion is that linux has no room for such regressions. If we want to gain market share and convince people about free software (in the meaning of open source) we have to offer them at least minimal functionality.

Keyboard, mouse, sound, (3D and powersaving) graphics.

(Please do not take this as a flame but as a point of view)

Algo (algo-lkma) wrote :

Exactly! My little son is a pure Ubuntu user, and feel proud of Linux (People can live happily without Windows!!)

However, suddenly, again, he can't play all 3D games (both Linux native and Windows game/Wine) after upgrade.

I don't know how to explain him why he can't play 3D games from now; I can't even tell him when he can play 3D games again.

XOrg must change their direction, otherwise, some Linux users will be forced to switch from Linux to Windows..............

Fix this quick please , nouveau drivers don't works with minecraft !

paercebal (paercebal) wrote :

I can't believe it's happening again.
:-(

My luck is : I'm still stuck with Unbuntu 10.10, with the old (very old) drivers.
:-/

paercebal (paercebal) wrote :

Please note that I *almost* blindly launched the upgrade to 11.04, and the first steps, I had no warning whatsoever.

Thanks Google, I guess.

paercebal (paercebal) wrote :

Please, is there a workaround, enabling the installation of Ubuntu 11.04, but keeping previous versions of XOrg, nvidia-96 drivers, whatever is needed?

Thanks,

ezero (hacker-nz) wrote :

Can this be fixed for nvidia-96 drivers too please.

Thanks

Evan Lin (hairymonkey-evan) wrote :

OmgUbuntu!!! I upgraded my ubuntu installation from 10.10 to 11.04 with the
nvidia-96 package installed and now I have no displayy!! (Im using the 11.04
live cd atm)

On 2 May 2011 11:47, ezero <email address hidden> wrote:

> Can this be fixed for nvidia-96 drivers too please.
>
> Thanks
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/741930
>
> Title:
> [natty] nvidia binary packages for older cards - dependencies not met
>
> Status in NVIDIA Drivers Ubuntu:
> Confirmed
> Status in “nvidia-graphics-drivers” package in Ubuntu:
> Invalid
> Status in “nvidia-graphics-drivers-173” package in Ubuntu:
> Fix Released
> Status in “nvidia-graphics-drivers-96” package in Ubuntu:
> Confirmed
>
> Bug description:
> Package has broken dependencies that cannot be met.
> xorg-video-abi-8.0
> xserver-xorg-core (>= 2:1.8.99.905-1ubuntu3)
>
> Steps to reproduce:
> 1. Install Natty beta & do sudo apt-get upgrade and dist-upgrade
> 2. Try sudo apt-get install nvidia-96 to get the error.
>
> (confirmed to still occur in beta 1).
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/nvidia-drivers-ubuntu/+bug/741930/+subscribe
>

--
Linjin

Evan Lin (hairymonkey-evan) wrote :

I'm switching back to Windows now.

On 2 May 2011 16:29, Evan Lin <email address hidden> wrote:

> OmgUbuntu!!! I upgraded my ubuntu installation from 10.10 to 11.04 with the
> nvidia-96 package installed and now I have no displayy!! (Im using the 11.04
> live cd atm)
>
>
> On 2 May 2011 11:47, ezero <email address hidden> wrote:
>
>> Can this be fixed for nvidia-96 drivers too please.
>>
>> Thanks
>>
>> --
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>> https://bugs.launchpad.net/bugs/741930
>>
>> Title:
>> [natty] nvidia binary packages for older cards - dependencies not met
>>
>> Status in NVIDIA Drivers Ubuntu:
>> Confirmed
>> Status in “nvidia-graphics-drivers” package in Ubuntu:
>> Invalid
>> Status in “nvidia-graphics-drivers-173” package in Ubuntu:
>> Fix Released
>> Status in “nvidia-graphics-drivers-96” package in Ubuntu:
>> Confirmed
>>
>> Bug description:
>> Package has broken dependencies that cannot be met.
>> xorg-video-abi-8.0
>> xserver-xorg-core (>= 2:1.8.99.905-1ubuntu3)
>>
>> Steps to reproduce:
>> 1. Install Natty beta & do sudo apt-get upgrade and dist-upgrade
>> 2. Try sudo apt-get install nvidia-96 to get the error.
>>
>> (confirmed to still occur in beta 1).
>>
>> To unsubscribe from this bug, go to:
>> https://bugs.launchpad.net/nvidia-drivers-ubuntu/+bug/741930/+subscribe
>>
>
>
>
> --
> Linjin
>

--
Linjin

Last release (10.10) we waited around 2 months for AaronP and Alberto Milone could come up with good packages.
(Don't get me wrong. These guys are doing a fantastic job!)
It now seems as this history will repeat itself.

Is there any suggestions on how the community can contribute constructively or do we have to accept the fact that our HW might be to old to keep up?

Also, not forget. The system works very well with Ubuntu classic and default drivers so the only thing we are missing out on is Unity.

stefanivarsson , you forgot minecraft !

AAndres (dejazmach) wrote :

paercebal #16 : I believe you put the finger at the worst thing with this bug.
Of course I understand all the banter around the lack of dialogue between Xorg and Nvidia developers and I know Ubuntu isn't here at fault. But for Christ's sake, there isn't any mention of this bug in Natty's release notes while it can break the display (or I didn't see it and apologise).
I consider myself happy of always checking the uninstalled packages before any upgrade, that saved me (again).

Dart (dragoon-master-10) wrote :

OMG! I just did a clean install of Ubuntu 11.4 to find out that my nVidia Quadro4 900 XGL did not have the option for proprietary drivers. I did however notice some 3D acceleration out of the box :) but after getting the cube going it was very glitchy :(. All i saw was a open source experimental driver which had worse performance then the native driver. Ugh.... I reinstalled 9.10 which worked great and did a upgrade to 10.10 which also worked great. :) Then I tried to do a upgrade to 11.4 hoping it would carry over the driver like 10.10 did, but i saw in the release notes that nVidia 96 driver was going to be removed...I tried it anyway out of desperation and sure enough, it was removed and back to square 1. :'(...I reinstalled 10.4 and upgraded to 10.10 again and I guess that's the best I can do....

Will there ever be a Nvidia 96 driver out for 11.4 or do I need to wait for 11.10? What if one does not come out then? Wonder how long ill be stuck with 10.10... :(

Lars Ola Liavåg (l-liavag) wrote :

I got this too. Didn't notice it before install as running from the Live, it couldn't run unity anyway. I've always had to install proprietary drivers anyway before having any serious eyecandy so expected things to work out after doing that. That being said, when going from Lucid to Natty, I had to go back from nvidia-173 that I used before to nvidia-96 to get things working. Now, if I mark nvidia-96 for install in Synaptic, it threatens to remove my entire Xorg. Why's it even there if it breaks your system? I really hope the right guys, whether at nvidia, X.org, or elsewhere are able to take some action here.

Lars Ola Liavåg (l-liavag) wrote :

I installed the updated driver from NVIDIA's web pages as it was claimed to support xorg-server 1.10. However, it seems that the X server still loads the Noveau routine and I don't know how to prevent that. So no luck for me. Hope that with time, something is done with the distro-provided drivers.

MyR (myr-jedi) wrote :

There are no nvidia-96 packages compatible with Ubuntu 11.04.

Developers are aware of the problem and are working on it.

for the next Ubuntu release, if the nvidia-96 driver are not compatible with xorg again, it's possible add a "legacy xorg" to the repository?

something like:
xserver-xorg-core (new version, for the driver compatible)
xserver-xorg-core-1.9 (legacy, for the driver that not support new xorg)

then the nvidia-96 package require the legacy xorg instead of the new one

Pawel Jasnos (pjasnos) wrote :

I'd say a simpler but still useful thing would be to make sure that if
some hardware isn't compatible at the time of release because a
proprietary driver is required (and that's the situation here - Unity
doesn't work on Nouveau), then a big, red note of that should be made
in the "release notes" prompt encouraging for upgrade, so that people
can wait until Nvidia or any other vendor provides updated driver.

Alternatively, the upgrading script should warn user about such
incompatibilities at the start of the process, allowing them to easily
cancel.

On Tue, May 10, 2011 at 8:09 AM, Andrea Mazzilli
<email address hidden> wrote:
> for the next Ubuntu release, if the nvidia-96 driver are not compatible
> with xorg again, it's possible add a "legacy xorg" to the repository?
>
> something like:
> xserver-xorg-core  (new version, for the driver compatible)
> xserver-xorg-core-1.9 (legacy, for the driver that not support new xorg)
>
> then the nvidia-96 package require the legacy xorg instead of the new
> one
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/741930
>
> Title:
>  [natty] nvidia binary packages for older cards - dependencies not met
>
> Status in NVIDIA Drivers Ubuntu:
>  Confirmed
> Status in “nvidia-graphics-drivers” package in Ubuntu:
>  Invalid
> Status in “nvidia-graphics-drivers-173” package in Ubuntu:
>  Fix Released
> Status in “nvidia-graphics-drivers-96” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  Package has broken dependencies that cannot be met.
>  xorg-video-abi-8.0
>  xserver-xorg-core (>= 2:1.8.99.905-1ubuntu3)
>
>  Steps to reproduce:
>  1. Install Natty beta & do sudo apt-get upgrade and dist-upgrade
>  2. Try sudo apt-get install nvidia-96 to get the error.
>
>  (confirmed to still occur in beta 1).
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/nvidia-drivers-ubuntu/+bug/741930/+subscribe
>

Tom Epperly (tepperly) wrote :

It would be nice if the "do you want to upgrade" window wouldn't come up until a nvidia-96 driver is available. I upgraded my Mythbuntu system because it kept periodically putting the "do you want to upgrade" window on my screen. Because I don't really have a mouse hooked up to my system, I have to go to another system to run xvncviewer to get rid of the upgrade window. I eventually upgraded to get rid of the window. Now that I've upgraded, my system is hosed because nvidia-96 isn't available and I can't seem to get nouveau to use 60Hz.

Have a old Nvidia Geforce2 MX200 - having problems after installing Natty.

John Smigel (jsmigel) wrote :

My Nvidia GeForce4 4200 also no longer works after installing Natty.

Dart (dragoon-master-10) wrote :

Dont you think we could bump the Nvidia-96 driver issue from "Undecided" to "High"?

i can't use 11.04 becouse this bug
please fix it

ezero (hacker-nz) wrote :

Would really like this to be fixed as soon as possible *please*. My system is not completely broken X11 is still loading up but it is very laggy as no hardware acceleration enabled.

Nvidia-96 drivers i.e

yarekku@gmail.com (yarekku) wrote :

Hurry up!

paercebal (paercebal) wrote :

I guess "Hurry up!" comments won't help.

If there are only a handful of people in the world suffering from this bug, I guess its priority will remain low, no matter how much we will complain (or cry... or break furniture...). I guess there must be some way to pay canonical for the support of the nvidia-96 driver, but this problem happened twice in a row, meaning it is quite probable the next version will have the same issue *again*: Won't our money better spent by buying a supported nvidia or ATI (or whatever) board?

Still, I would like some questions answered by the maintainers (or whatever people are handling this case) :

 - 1. Will the nvidia-96 issue be corrected for the current version
 - 2. Is there a way to upgrade to Ubuntu 11.04 while still keeping the 10.10 X.Org/nvidia-96/whatever?
 - 3. Is the nvidia-96 driver considered obsolete, which would mean the middle/long term solution would be to upgrade our graphic card ? (suggestions are welcome)
 - 4. Is it possible to enhance the Ubuntu Upgrade process to tell the user about drivers obsolescence ? (being surprised by having one's system break down after the upgrade is NOT cool).

Thanks,

MyR (myr-jedi) wrote :

I mentioned ten days ago that the developers are working on it.

P.S. Keep in mind this is free software. You do not pay for it. Furthermore you have just as much responsibility to improve it as anyone else.

please don't give up old system user.
please don't forget the spirit of ubuntu!

Changed in nvidia-graphics-drivers-96 (Ubuntu):
assignee: nobody → braydon duckworth (pranker-braydon)
36 comments hidden view all 116 comments

Yes, I did that and it generated the following xorg.conf file:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder75) Sun Jul 17
23:48:28 PDT 2011

Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
EndSection

[CUT....]

Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 30.0 - 110.0
    VertRefresh 50.0 - 150.0
    Option "DPMS"
EndSection

Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
        Depth 24
        Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

On Sat, Jul 30, 2011 at 7:38 AM, Cedric Schieli <email address hidden> wrote:

> @judsonmitchell
>
> You should now be able to run nvidia-xconfig as root
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/741930
>
> Title:
> [natty] nvidia binary packages for older cards - dependencies not met
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/nvidia-drivers-ubuntu/+bug/741930/+subscriptions
>
>
>

For what it's worth, when I run the unity support test, it's still pointing
toward mesa:

OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) IGD GEM 20100330 DEVELOPMENT
x86/MMX/SSE2
OpenGL version string: 1.4 Mesa 7.10.2

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: no
GL framebuffer object: no
GL version is 1.4+: yes

Unity supported: no

On Sat, Jul 30, 2011 at 7:53 AM, Judson Mitchell <email address hidden> wrote:

> Yes, I did that and it generated the following xorg.conf file:
>
> # nvidia-xconfig: X configuration file generated by nvidia-xconfig
> # nvidia-xconfig: version 1.0 (buildmeister@builder75) Sun Jul 17
> 23:48:28 PDT 2011
>
>
> Section "ServerLayout"
> Identifier "Layout0"
> Screen 0 "Screen0" 0 0
> InputDevice "Keyboard0" "CoreKeyboard"
> InputDevice "Mouse0" "CorePointer"
> EndSection
>
> [CUT....]
>
> Section "Monitor"
> Identifier "Monitor0"
> VendorName "Unknown"
> ModelName "Unknown"
> HorizSync 30.0 - 110.0
> VertRefresh 50.0 - 150.0
> Option "DPMS"
> EndSection
>
> Section "Device"
> Identifier "Device0"
> Driver "nvidia"
> VendorName "NVIDIA Corporation"
> EndSection
>
> Section "Screen"
> Identifier "Screen0"
> Device "Device0"
> Monitor "Monitor0"
> DefaultDepth 24
> SubSection "Display"
> Depth 24
> Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
> EndSubSection
> EndSection
>
>
> On Sat, Jul 30, 2011 at 7:38 AM, Cedric Schieli <email address hidden>wrote:
>
>> @judsonmitchell
>>
>> You should now be able to run nvidia-xconfig as root
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/741930
>>
>> Title:
>> [natty] nvidia binary packages for older cards - dependencies not met
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/nvidia-drivers-ubuntu/+bug/741930/+subscriptions
>>
>>
>>
>

Sorry to clog up this thread, but when I did a reinstall of the nvidia-96
driver, I noticed this error message. Does it provide a clue?

Setting up nvidia-96 (96.43.20-0ubuntu1~athome1) ...
update-alternatives: using /usr/lib/nvidia-96/ld.so.conf to provide
/etc/ld.so.conf.d/GL.conf (gl_conf) in auto mode.
update-alternatives: warning: skip creation of
/usr/share/man/man1/nvidia-smi.1.gz because associated file
/usr/share/man/man1/alt-nvidia-96-smi.1.gz (of link group gl_conf) doesn't
exist.
update-alternatives: warning: skip creation of /usr/bin/nvidia-smi because
associated file /usr/lib/nvidia-96/bin/nvidia-smi (of link group gl_conf)
doesn't exist.

On Sat, Jul 30, 2011 at 8:13 AM, Judson Mitchell <email address hidden> wrote:

> For what it's worth, when I run the unity support test, it's still pointing
> toward mesa:
>
> OpenGL vendor string: Tungsten Graphics, Inc
> OpenGL renderer string: Mesa DRI Intel(R) IGD GEM 20100330 DEVELOPMENT
> x86/MMX/SSE2
> OpenGL version string: 1.4 Mesa 7.10.2
>
> Not software rendered: yes
> Not blacklisted: yes
> GLX fbconfig: yes
> GLX texture from pixmap: yes
> GL npot or rect textures: yes
> GL vertex program: yes
> GL fragment program: yes
> GL vertex buffer object: no
> GL framebuffer object: no
> GL version is 1.4+: yes
>
> Unity supported: no
>
>
> On Sat, Jul 30, 2011 at 7:53 AM, Judson Mitchell <email address hidden>wrote:
>
>> Yes, I did that and it generated the following xorg.conf file:
>>
>> # nvidia-xconfig: X configuration file generated by nvidia-xconfig
>> # nvidia-xconfig: version 1.0 (buildmeister@builder75) Sun Jul 17
>> 23:48:28 PDT 2011
>>
>>
>> Section "ServerLayout"
>> Identifier "Layout0"
>> Screen 0 "Screen0" 0 0
>> InputDevice "Keyboard0" "CoreKeyboard"
>> InputDevice "Mouse0" "CorePointer"
>> EndSection
>>
>> [CUT....]
>>
>> Section "Monitor"
>> Identifier "Monitor0"
>> VendorName "Unknown"
>> ModelName "Unknown"
>> HorizSync 30.0 - 110.0
>> VertRefresh 50.0 - 150.0
>> Option "DPMS"
>> EndSection
>>
>> Section "Device"
>> Identifier "Device0"
>> Driver "nvidia"
>> VendorName "NVIDIA Corporation"
>> EndSection
>>
>> Section "Screen"
>> Identifier "Screen0"
>> Device "Device0"
>> Monitor "Monitor0"
>> DefaultDepth 24
>> SubSection "Display"
>> Depth 24
>> Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
>> EndSubSection
>> EndSection
>>
>>
>> On Sat, Jul 30, 2011 at 7:38 AM, Cedric Schieli <email address hidden>wrote:
>>
>>> @judsonmitchell
>>>
>>> You should now be able to run nvidia-xconfig as root
>>>
>>> --
>>> You received this bug notification because you are subscribed to the bug
>>> report.
>>> https://bugs.launchpad.net/bugs/741930
>>>
>>> Title:
>>> [natty] nvidia binary packages for older cards - dependencies not met
>>>
>>> To manage notifications about this bug go to:
>>>
>>> https://bugs.launchpad.net/nvidia-drivers-ubuntu/+bug/741930/+subscriptions
>>>
>>>
>>>
>>
>

NoOp (glgxg) wrote :

On 07/28/2011 11:30 PM, Cedric Schieli wrote:
> @NoOp: You seem to be running maverick. As this bug is only relevant
> on natty, my ppa only contains packages for natty...

Understand. Thanks. I would however like to install on Maverick so that
I can test machines that will upgraded to Natty (that's primarily been
the holdup on my upgrades). I'll try the driver directly from nVidia.

Changed in nvidia-graphics-drivers-96 (Ubuntu):
assignee: braydon duckworth (pranker-braydon) → nobody
importance: Undecided → Medium
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: Confirmed → In Progress
Changed in nvidia-graphics-drivers-96 (Ubuntu):
milestone: none → natty-updates
milestone: natty-updates → none
Changed in nvidia-graphics-drivers-96 (Ubuntu Natty):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers (Ubuntu Natty):
status: New → Invalid
Changed in nvidia-graphics-drivers-173 (Ubuntu Natty):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-96 - 96.43.20-0ubuntu1

---------------
nvidia-graphics-drivers-96 (96.43.20-0ubuntu1) oneiric; urgency=low

  * New upstream release:
    - Fixed a bug that caused freezes and crashes when resizing
      windows in KDE 4 with desktop effects enabled using X.Org
      X server version 1.10 or later.
    - Added support for X.Org xserver 1.10 (LP: #741930).
  * debian/control.in:
    - Drop transitional packages.
  * debian/dkms.conf.in:
    - Prevent DKMS builds with kernels newer than the ones we ship.
  * debian/dkms/patches:
    - Drop obsolete patches.
  * debian/nvidia-96.postinst.in:
    - Add support for multi-arch (LP: #798049).
    - Remove slave link to nvidia-smi since the binary does not
      exist.
    - Remove any previous gl_conf alternative.
  * debian/nvidia-96.README.Debian.in
    - Update the README with the DKMS OBSOLETE_BY option.
  * debian/rules:
    - Do not hardcode the X ABI any more.
    - Install an empty ld.so.conf for the fake alternative
    - Remove obsolete instructions from debian/rules
    - Prevent the build from failing when no patches are available.
 -- Alberto Milone <email address hidden> Mon, 01 Aug 2011 16:18:40 +0200

Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: In Progress → Fix Released
Lars Ola Liavåg (l-liavag) wrote :

I've purged other nvidia stuff, added Cedric's PPA, and installed nvidia-96 successfully. I've set gl_conf to auto, reconfigured nvidia-96, and run sudo nvidia-xconfig. As far as I can see,everything should now be OK but still, I get no 3D effects or Unity support. Either, I'm doing something wrong, or the new driver doesn't cut it for me. I'd be enourmously thankful for any tips on how to check for errors. I've attached a text file with the output of most of the commands mentioned earlier.

ezero (hacker-nz) wrote :
Mithun M (mithun-mohandas) wrote :

I've installed nvidia-96 from Cedric's PPA and it fixed the jittery spliced screen. However, I cannot see the terminal window anymore. I know it is running as I can see it's outline in the Workspace select button. I can move the window around and all, but it's invisible.

Alberto Milone (albertomilone) wrote :

Requesting an SRU

TESTCASE:
Currently there is no Nvidia 96 driver in Natty which is compatible with the X ABI. The new driver restores compatibility with X.

I have already uploaded a driver (96.43.20-0ubuntu1~natty2) in natty-proposed and is waiting for approval.

Changed in nvidia-graphics-drivers-96 (Ubuntu Natty):
status: In Progress → Fix Committed
Sly_tom_cat (slytomcat) wrote :

Thanks Cedric!

I've added PPA and installed nvidia-96 driver.
But XServer failed to start reporting:

(EE) NVIDIA(0): Failed to allocate/map the primary surface!

Looking to the Internet gives the solution - to add nopat option in GRUB kernel loading string.
It helped. Now everything works fine!

uname -a
Linux stc-home 2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:05:41 UTC 2011 i686 athlon i386 GNU/Linux

Xubuntu 11.04

Bleish (manubia) wrote :

@ linusND (christian-remboldt): me too.
I have the answer "no" for GL fragment program and GL framebuffer object.
But, I don't know how to resolve it.

Victor (victor-costache) wrote :

@linusND (christian-remboldt) and @Bleish (manubia):
Same here

/usr/lib/nux/unity_support_test -p
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce3/AGP/SSE2
OpenGL version string: 1.5.8 NVIDIA 96.43.20

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: no
GL vertex buffer object: yes
GL framebuffer object: no
GL version is 1.4+: yes

Unity supported: no

Chris Halse Rogers (raof) wrote :

Alberto: you've made two uploads to natty-proposed. The second one's changes file doesn't have reference to this bug, so it's not appropriate to accept into proposed.

I've rejected both uploads from the queue. Please upload ~natty1 again with the FTBFS fix included.

Alberto Milone (albertomilone) wrote :

Chris: I have reuploaded the package as you suggested

yarekku@gmail.com (yarekku) wrote :

Is there any HowTo to fix this bug?

GomoX (gomox-ar) wrote :

Any news on when this will be available? This is kind of a deal breaker for quite a big user base. Is there any way to grab the package before it goes into natty-updates? I could not find it on Alberto's PPA. Thanks.

Alan (veloceraptor) wrote :

"Any news on when this will be available?"

Sure! Just in time for Ocelot to break it again.

uski (ba-cykian) wrote :

Did you people noticed that NVIDIA released an update on August 17th that adds support for newer Xorg servers ?
Maybe we can have an updated nvidia-96 package that works ?

Hello Pawel, or anyone else affected,

Accepted nvidia-graphics-drivers-96 into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

I installed the new package and I still cannot get Unity started. Here's the output of /usr/lib/nux/unity_support_test -p

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce4 MX 440 with AGP8X/AGP/SSE2
OpenGL version string: 1.5.8 NVIDIA 96.43.20

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: no
GL vertex buffer object: yes
GL framebuffer object: no
GL version is 1.4+: yes

Unity supported: no

Although nvidia-96 appears to be enabled, it does not show up in Jockey as being present or enabled.

Alberto Milone (albertomilone) wrote :

@judsonmitchell (jmitchel-loyno): I doubt you can get Unity to work with that driver.

@Martin: I think we should re-enable nvidia-96 in Jockey too

Albert Pool (albertpool) wrote :

Oneiric gets X.Org 1.10 so as soon as the updated nvidia-96 hits the main repo, the problem is gone for both Natty and Oneiric.

As soon as I get time to assemble a computer out of spare components, I can try my Geforce4 Ti 4600 card to see if the natty-proposed package works on it.

Lars Ola Liavåg (l-liavag) wrote :

I've disabled Cedric's PPA and purged all nvidia stuff, then reinstalled nvidia-96 again from natty-proposed making sure to set gl_conf to auto, reconfigure nvidia-96, and run sudo nvidia-xconfig. Still, I get no Unity support or 3D effects in neither Classic nor Unity 2D. I've attached again some command line output. Any comments, or advice would be greatly appreciated.

@Lars: as I said, nvidia-96 is a very old legacy driver which is not expected to work with Unity 3D. You should use unity 2D instead.

Lars Ola Liavåg (l-liavag) wrote :

@Alberto: I think your point would be very valid if the hardware that was very old too. But in Lucid, I got full 3D effects using the nvidia-173 driver, in Maverick, I had to downgrade to nvidia-96, and in Natty, there's seems to be no way to get 3D neither in Ubuntu Classic or Unity. Maybe I'm spoilt but I've actually gotten used to Linux and Ubuntu supporting older hardware (also older than this) and and I don't like the thought of ripping out my perfectly functional GeForce 7300 to save me a second of boot time since it's anyway never going to work with my favourite OS again.

Does anybody have experience with this graphics card and other drivers than nvidia-96? Any tricks I could use when I can't seem to make it work with nvidia-173 or nvidia-current?

Ximo Duarte (ximo-duarte) wrote :

I have an old computer with a Nvidia GeForce2 MX200 graphic card, more than enough for the use I make of the computer.
It worked well with Maverick. After Natty upgrade I could not start X, as stated in the bug.
Following what was advised here, I activated natty-proposed repos and installed nvidia-96.
When launch nvidia-settings it says I don't have any Nvidia driver. And it also doesn't show in jockey (nothing new for you).
In terminal glxinfo gives an error, I believe I don't have any glx at all. I read in some post to set gl_conf to auto.
I don't know how to do that, need some clue.
Or would it be better to wait until it is given a final solution to this problem?

NoOp (glgxg) wrote :

I've just finished upgrading a system from 10.10 to 11.04. Initially I couldn't get compiz 3D working with the new nvidia-96 driver (96.43.20-0ubuntu1~natty1 ). However after modifying my compiz settings to match those on this 10.10 machine (with the addition of turning on OpenGL) and rebooting all is working again (Ubuntu Classic). Video card is:

          *-display
                description: VGA compatible controller
                product: NV25GL [Quadro4 900 XGL]
                vendor: nVidia Corporation
                physical id: 0
                bus info: pci@0000:01:00.0
                version: a3
                width: 32 bits
                clock: 66MHz
                capabilities: pm agp agp-2.0 vga_controller bus_master cap_list rom
                configuration: driver=nvidia latency=248 maxlatency=1 mingnt=5
                resources: irq:16 memory:fd000000-fdffffff memory:d0000000-d7ffffff memory:dc780000-dc7fffff memory:fe9e0000-fe9fffff

I'm able to do Cube Reflection and Deformation, Wobbly Windows (tested & turned back off), Desktop Cube, Rotate Cube, etc., etc. Thank's Alberto! Now I can go ahead and upgrade this twin machine. My Compiz settings (only showing items that are checked):

General:
- Commands
- Compsite
- Gnome Compatibility
- OpenGL
Desktop:
- Desktop Cube
- Rotate Cube
Effects:
- Cube Reflection and Deformation (I have the added plugins for this)
- Wobbly Windows
- Window Decoration
Image Loading:
- jpeg
- svg
Utility:
- D-bus
- Mouse position polling
- Session Management
- Regex Matching
Window Management:
- Place Windows
- Windows Rules
- Move Window
- Resize Window

Hope that helps.

@Ximo Duarte: if you want you can test the driver in the proposed repository as suggested here:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/741930/comments/95

@Lars: according to the file that you attached, your card has 3D acceleration but is blacklisted in Unity (probably also in compiz):
"Not blacklisted: no"

Ximo Duarte (ximo-duarte) wrote :

@Alberto; thank you for your answer. I had already followed the suggestion in that post and installed the driver. I then run nvidia-xconfig to create a new xorg.conf (I had previously vesa driver).
But as I told you nvidia-settings doesn't "see" the driver installed. And apparently glx is not enabled, according to glxinfo.

NoOp (glgxg) wrote :

Added note to comment #103: Unity is now working with that NV25GL [Quadro4 900 XGL] and 96.43.20-0ubuntu1~natty1. It's a little wonkey as the left panel sidebar doesn't hide when a window should cause the sidebar to hide. But it is working.

Thought that perhaps it is due to my install of unity-2d, so I purged unity-2d* and restarted the system (soft-boot). Now having issues with gdm (virtualbox 'Shared Memory Available' halt) so having to use login in Recovery mode & startx to start. Purged virtualbox & rebooted. gdm works again. Can start from the gdm screen, choose 'Unity' and 'Ubuntu Classic' starts. Compiz settings are screwed up, so I reset them to those of #103 (Desktop Cube, Rotate Cube, etc., has been unset. Window-decorator is crashing. Very odd. The odd part is that I was able to get Unity (standard not 2D working) via Recovery mode, so this indicates that the issue _may_ be with Unity/Compiz setup configs. I'll have to try to troubleshoot more tomorrow; in the interim, perhaps Alberto can have a look & give me some logs/tests that I can do tomorrow?

NoOp (glgxg) wrote :

Scratch the last... I think it was unity-2d that was starting somehow. Back to standard 'Ubuntu Classic' - compiz settings are reset & all 3D is working again in that desktop mode. Sorry for the noise.

NoOp (glgxg) wrote :

Yesterday's excitment was short lived. Today boot halts with xorg errors. Attaching Xorg.0.log and dmesg.

NoOp (glgxg) wrote :
NoOp (glgxg) wrote :

Boot issues apparently not related to nvidia-96 proposed (96.43.20-0ubuntu1~natty1). I temporarily resolved the boot issue by adding 'nopat' in grub2 per:
<https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/537218>
[" Failed to allocate video memory" nvidia-current on lucid]

Workaround:

$ gksu gedit /etc/default/grub

modify:
GRUB_CMDLINE_LINUX=""
to
GRUB_CMDLINE_LINUX="nopat"

save.

$ sudo update-grub

reboot.

I've cold-booted & rebooted multiple times now & each time works.

Lars Ola Liavåg (l-liavag) wrote :

@Alberto: I noticed that blacklisting entry also in the first output i posted. Is it possible to change or remove the blacklisting? How?

Lars Ola Liavåg (l-liavag) wrote :

I tested the tip in this link to force Unity to start:

http://askubuntu.com/questions/37629/geforce-go-7300-7400-blacklisted-can-i-still-run-unity

It did start but the launcher was a mess. I then deactivated nvidia-96 and activated nvidia-173 in stead, and now I have Unity working with Compiz effects. The slowness warned about in the link does not seem any intrusive so far. I might test nvidia-current again but will probably try running like this for a while and monitor the performance.

Luigi Maselli (grigio) wrote :

Are there news about this bug?
Which is latest Ubuntu/xorg/nvidia-96 working system?
Is my Geforce4 deadware?

Marc Deslauriers (mdeslaur) wrote :

I have tested the package in natty-proposed, and it appears to be working fine.

Martin Pitt (pitti) on 2012-04-11
tags: added: verification-done
removed: verification-needed
Lars Ola Liavåg (l-liavag) wrote :

I've upgraded to Oneiric since my last post. I used again the tip above to force Unity to starat, and it worked fine even with nvidia-current. Looking forward to Precise as Unity is said to be even snappier in that version.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-96 - 96.43.20-0ubuntu1~natty1

---------------
nvidia-graphics-drivers-96 (96.43.20-0ubuntu1~natty1) natty-proposed; urgency=low

  * New upstream release:
    - Fixed a bug that caused freezes and crashes when resizing
      windows in KDE 4 with desktop effects enabled using X.Org
      X server version 1.10 or later.
    - Added support for X.Org xserver 1.10 (LP: #741930).
  * debian/dkms.conf.in:
    - Prevent DKMS builds with kernels newer than the ones we ship.
  * debian/dkms/patches:
    - Drop obsolete patches.
  * debian/nvidia-96.postinst.in:
    - Remove slave link to nvidia-smi since the binary does not
      exist.
  * debian/nvidia-96.postrm.in:
    - Make sure that all of the libraries are removed in the postrm.
      This should work around cases such as LP: #540143 where some
      misteriously unremoved links cause the directory removal to
      fail.
  * debian/nvidia-96.README.Debian.in
    - Update the README with the DKMS OBSOLETE_BY option.
  * debian/rules:
    - Do not hardcode the X ABI any more.
    - Remove obsolete instructions from debian/rules
    - Prevent the build from failing when no patches are available.
 -- Alberto Milone <email address hidden> Fri, 19 Aug 2011 17:39:19 +0200

Changed in nvidia-graphics-drivers-96 (Ubuntu Natty):
status: Fix Committed → Fix Released
Displaying first 40 and last 40 comments. View all 116 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions