[Intrepid] nvidia_drv.so: undefined symbol: AllocateScreenPrivateIndex

Bug #251107 reported by Gianfranco Liporace on 2008-07-23
428
This bug affects 34 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
High
Unassigned
nvidia-graphics-drivers-71 (Ubuntu)
Medium
Alberto Milone
Intrepid
Undecided
Unassigned
Jaunty
Medium
Alberto Milone
nvidia-graphics-drivers-96 (Ubuntu)
Medium
Alberto Milone
Intrepid
Undecided
Unassigned
Jaunty
Medium
Alberto Milone

Bug Description

Binary package hint: nvidia-glx-96

Hi all,
just upgraded to Intrepid. Installed the proprietary driver for my old nvidia card (NV17GL [Quadro NVS] [10DE:17A]).
Restarted X, but got the failsafe window instead of GDM. Looking at th Xorg logs I noted this error:

 (II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
 dlopen: /usr/lib/xorg/modules/drivers//nvidia_drv.so: undefined symbol: Allo cateScreenPrivateIndex
 (EE) Failed to load /usr/lib/xorg/modules/drivers//nvidia_drv.so
 (II) UnloadModule: "nvidia"
 (EE) Failed to load module "nvidia" (loader failed, 7)

Attached the complete log file.

Gianfranco Liporace (dr.kabuto) wrote :
Alberto Milone (albertomilone) wrote :

Currently nvidia-glx-96 and nvidia-glx-71 don't work with the new xserver. There is nothing we can do about it. NVIDIA should release a add the support for it sooner or later.

Gianfranco Liporace (dr.kabuto) wrote :

Thanks Alberto,
soon after my bug report, I've found this:
http://www.nvnews.net/vbulletin/showthread.php?t=110899

Changed in nvidia-graphics-drivers-71:
assignee: nobody → albertomilone
importance: Undecided → Medium
status: New → Confirmed
Changed in nvidia-graphics-drivers-96:
assignee: nobody → albertomilone
status: New → Confirmed
importance: Undecided → Medium
Matt Behrens (zigg) wrote :

Shouldn't the -71 and -96 legacy drivers be made incompatible on a package level with the new xorg?

Something like Requires a version before whatever version the ABI change was made on. It seems to me it should not be possible to install these drivers on a system they will not work on.

Alberto Milone (albertomilone) wrote :

Matt: I'm aware of the problem and I'm working on it. I'll also make sure that dist-upgrades to Intrepid go smoothly.

Steve Langasek (vorlon) wrote :

In the past, driver packages would declare which ABI they provide, and later versions of xserver-xorg-video-core could conflict with these. Indeed, nvidia-glx-71 *currently* declares such a field:

 Package: nvidia-glx-71
 Provides: nvidia-glx, xserver-xorg-video-2.9

Should xserver-xorg-video-core conflict with xserver-xorg-video-2.9?

Steve Langasek (vorlon) wrote :

I see that the nvidia-glx-legacy package in hardy Provides: xserver-xorg-video-2, and the current xserver-xorg-core Conflicts: with this. So this doesn't appear to be a problem on upgrades.

Steve Langasek (vorlon) wrote :

I've added initial documentation of this issue at <https://wiki.ubuntu.com/IntrepidReleaseNotes#nVidia%20%22legacy%22%20video%20support>.

Alberto, will there be an automated upgrade path for nvidia users to xserver-xorg-video-nv or nvidia-glx-{173,177}, as appropriate? If so, do you have an ETA for this?

Changed in ubuntu-release-notes:
status: New → In Progress
importance: Undecided → High
Alberto Milone (albertomilone) wrote :

Steve: all the nvidia packages provide an ABI which is not hardcoded. For example (currently) nvidia-glx-177 provides xserver-xorg-video-4 while -96 and -71 provide xserver-xorg-video-2.9. All it would take to make, say, -71, provide the current Xorg ABI it to rebuild it (which is what we will do when the new NVIDIA drivers are ready).

As regards dist-upgrades, I have worked with Michael Vogt so as to make sure that systems which require the -96 and -71 drivers will be migrated to the open source driver ("nv"). A package named nvidia-common does hardware detection so that Update Manager knows which driver should be installed while X-Kit (my xorg.conf parser/validator), which Michael has included in Update Manager, will set the driver to "nv" in the xorg.conf and remove the unsupported "RGBPath" option from the Files section (otherwise Xorg will crash, see #274866) when available.

Driver 173 and 177 don't support all the cards that -71 and -96 do, therefore the only fallback we have is the "nv" driver.

On Sat, Oct 04, 2008 at 09:18:36AM -0000, Alberto Milone wrote:
> Driver 173 and 177 don't support all the cards that -71 and -96 do,
> therefore the only fallback we have is the "nv" driver.

Correct - but what will happen on upgrade for cards that *are* supported by
173 and/or 177? Will update-manager pull in one of these (I hope the answer
is yes)?

How much of this is implemented/tested in update-manager today?

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Alberto Milone (albertomilone) wrote :

If cards are supported by either 173 or 177, nvidia-common will suggest the right package to install in 2 cases:
* if you're doing the dist-upgrade with Update Manager, then Update Manager will install the right driver automatically
* if you're doing the dist-upgrade from the command line, a debconf interface will show up and suggest the user to do, say, "sudo apt-get install nvidia-glx-177", to install the new driver (and of course it will explain the problem).

As far as I know this is all implemented. Maybe Michael could confirm what I said.

Ori Avtalion (salty-horse) wrote :

Steve, the release notes should mention GeForce3 as well.

Steve Langasek (vorlon) wrote :

thanks, added GeForce3 to the list.

Changed in ubuntu-release-notes:
status: In Progress → Fix Released
Arthur Peters (amp) wrote :

So I see we are waiting on NVidia (and that could take a very long time), so I get the sense that Intrepid will be released with out working drivers for any of the older NVidia cards.

However I was wondering if it is planned to release an update which fixes this problem after the release. Is that planned?

Also this seems like a pretty severe issue and could hurt the image of Ubuntu with people who try it. Is canonical leaning on NVidia to try to get drivers out of them?

Sorry if this is not bug report material.

cabbie (cabbiebatman) wrote :

Same problem with a Nvidia GeForce4 440 Go 64MB video card.
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
dlopen: /usr/lib/xorg/modules/drivers//nvidia_drv.so: undefined symbol: miZeroLineScreenIndex
(EE) Failed to load /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (loader failed, 7)
(EE) No drivers available.

Solitaire (bill-s0l) wrote :

Just to add myself to this bug list..

I have same problem as "cabbie" above but my card is the 16mb version..

Gavin Jones (gavinj44) wrote :

Also just to add myself to this bug list..

Mine is an Nvidia Quadro 280 NVS

okmijn (azatom) wrote :

Same problem.
Before the X error message:
"Running DKMS auto installation service for kernel 2.6.27-7-generic
  nvidia (96.43.05) [fail]"
---
"sudo dpkg-reconfigure nvidia-96-kernel-source" :

Removing all DKMS Modules
Done.
Adding Module to DKMS build system
driver version= 96.43.05
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Doing initial module build
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Error! Bad return status for module build on kernel: 2.6.27-7-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/nvidia/96.43.05/build/ for more information.
Installing initial module
shell-init: error retrieving current directory: getcwd: cannot access parent directories: Nincs ilyen fájl vagy könyvtár

Error! Could not locate nvidia.ko for module nvidia in the DKMS tree.
You must run a dkms build for kernel 2.6.27-7-generic (i686) first.
Done.

okmijn (azatom) wrote :

..continue:
(uname-r: 2.6.27-7-generic)
"dkms build -m nvidia -v 2.6.27-7-generic"

Error! DKMS tree does not contain: nvidia-2.6.27-7-generic
Build cannot continue without the proper tree.

Michael Devenish (mdevenish) wrote :

Also adding myself to this bug list.

Nvidia GeForce2 MX 32mb (71 series driver).

It's useless that everyone comment on this bugreport "I'm experiencing
that problem".

Both the bug and the solution is simple: wait a new nvidia driver for
GeForce cards before FX series.
Ubuntu can't fix this bug until nvidia releases a new driver.

If you want to suscribe, just click on the right.

Sorry for the OT, but I'm very angry for this and other things!
I have an OpenChrome video card and I have a lot of problems.
I'm asking myself: I bought a graphic card, I PAID it, why can't I use it???
I consider it a theft, 'cause it IS a theft! They don't allow me to
use a thing that I bought!
Closed drivers... why???
Drivers are always freeware, so what's the difference for factories if
they make them open source???
I really can't take it anymore, we must do something!!!

Ok sorry for this unuseful mail, ban me if you want, but I become very
angry when I see those things!!!

--
Per favore non mandatemi allegati in formati proprietari, come DOC o PPT.
Si veda http://www.gnu.org/philosophy/no-word-attachments.it.html

Gene Caldwell (gene-caldwell) wrote :

I did lots of searching on the net regarding this problem, what I found is that 2.6.27 has been out there for months and this OLD driver has been known for a good long while. several distros have been "waiting" for months for this updated old drivers release. Alberto makes it seem like it just around the corner, but might not make it for the release date.

So, I'm asking: has anyone ACTUALLY contacted Nvidia and discussed with them their intent ? WHEN do they plan on releasing updated OLD drivers ? or are the devs here just assuming that Nivida will get around to it someday ?

I have a notebook, I don't have the options of changing my video card - Geforce2 GO. it ran fine with the old drivers on hardy, however the new kernel 2.6.27 is far superior to 2.6.24 and memory requirements for 8.10 are much less than 8.04, I would much more like to run ubuntu 8.10 than 8.04 but if I cannot get the drivers I need then I can't use 8.10.

SO, again, as much as we CAN know, what has Nvidia actually said about the old drivers and support for the new xorg ?

Gene Caldwell (gene-caldwell) wrote :

just to be clear, several people here said just be patient and wait, it will be fixed and old drivers updated by Nvidia....my point was that several distros have been waiting already for months for this bug fix for the old drivers and they are still waiting. Telling people to be patient implies that a release fix is impending from Nvidia. People are reporting this bug because they want to use the Nvidia drivers, NOT the nv open source drivers.

we need something more definitive than just be patient, nv drivers prevent me from using googleearth, nv drivers are too slow or don't work at all with VM's. so open source video drivers are not a solution for me, and I would guess not for the other people who are reporting the bug.

Silently migrating to nv drivers is NOT the solution if you do not tell the end user that they have no other choice until Nvidia comes thru. Like I said above, other distros have been waiting for Nvidia to come thru for months now.

Alberto Milone (albertomilone) wrote :

Gene:
Update Manager will inform users about the current situation so that they can decide whether it's wise for them to dist-upgrade to Intrepid or not.

We don't know when NVIDIA will release new legacy drivers and it looks like their employees are not allowed to give estimates:
http://www.nvnews.net/vbulletin/showpost.php?p=1797121&postcount=64

I am a volunteer and as such I can only promise to do my best to get the new drivers into Intrepid (NOTE: the SRU team will have to approve this) when they are released.

Gene Caldwell (gene-caldwell) wrote :

and Alberto, you do an awesome job ! there was no dissatisfaction with your work regarding this, it was the absence of statements about this problem and concerns about how to know if we should upgrade or not if we have a working accelerated driver in hardy.

This is really frustrating as the new 8.10 appears to be the very best release I have seen, I actually booted the live CD and installed 8.10 RC on a computer with only 256 mb ram and a celeron 600 CPU. I really wanted this release on my old notebook that has an Nvidia card and would have loved to use the new wireless networking.

Someone needs to post and let the world know that 8.10 uses far less memory at run time and requires far less memory to install.

Alberto Milone [2008-10-27 10:42 -0000]:
> I am a volunteer and as such I can only promise to do my best to get the
> new drivers into Intrepid (NOTE: the SRU team will have to approve this)
> when they are released.

Since they can hardly become worse, that bit is a no-op. :-)

However, I can only echo the call for not making more noise here. As
the hardware drivers window and the place in the archive
("restricted") point out, we cannot do *anything* to fix it, but
begging nvidia. If they don't do anything about it and shrug at their
customers for older graphics cards, you should take this into account
when you buy your next computer or graphics card.

--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Takahani (simon-esneault) wrote :

Thx nvidia, this beta driver is working fine for me.

Fixed !

Sweetness! Now I just have to track down a tutorial on how to get it built and installed. Unless Alberto has already provided the info and I simply haven't seen it yet.

Takahani (simon-esneault) wrote :

- Download NVIDIA-Linux-x86-96.43.09-pkg1.run (or the other one if you're running a 64 bit system) to your home folder (/home/simon/ for me)
- switch to pty1 (CTRL+ALT+F1)
- log in
- sudo service kdm stop (will kill X server) (or gdm if you are running gnome)
- sudo sh ./NVIDIA-Linux-x86-96.43.09-pkg1.run
- say yes to everything (will compile nvidia kernel module)
- sudo reboot now (reboot now !!)

And that should be enough, login and check that "glxinfo | grep direct" says "YES"

Worked for me, kubuntu 8.10 32 bits, old geforce TI 4200
Good luck !
Simon

Gene Caldwell (gene-caldwell) wrote :

guess I'll have to wait for Alberto too, no clue how to grab it and get it installed/working. However I did not see anything posted about which legacy cards were supported. I have a notebook with a Geforce2 Go and had to use the 71.xx legacy driver in hardy, I see nothing about this new driver supporting the same cards that the 71.xx driver did.

Charly (charles-burry) wrote :

Working fine with my GeForce4 TI 4200. Fixed!

Thks!!!!!

Charles

Thanks, Takahani! I copied your steps to my PDA and it worked like a charm. I can run Compiz again! Now I just have to pull up http://www.nvnews.net/vbulletin/showthread.php?p=1826952#post1826952 and fix the white window issue.

I owe you a beer, Takahani. :)

Gene Caldwell (gene-caldwell) wrote :

actually I posted at the same time as the post with instructions above, new drivers are installed and working just fine for a Geforce2 Go. One little issue, compiz will not enable ( desktop effects ) but I believe that the compiz test says the old card just does not meet minimal requirements (32mb). I don't remember how to override the test now since compiz worked just fine in hardy, and I stopped having to use the override. if anyone can shed some light please do so.....

Joel Barker (j-cimb-barker) wrote :

I tried to install Takahani and it failed compiling. I've attached my nvidia-installer.log -- do I need to install more packages for this to work...?

Takahani (simon-esneault) wrote :

Yo,
I think you need the package "linux-headers-2.6.27-7" (that's his ubuntu name). Also check that you don't have some old kernel headers left like 2.6.24 or something. But i'm not sure of this :)

Joel Barker (j-cimb-barker) wrote :

I have linux-headers-2.6.27-7 installed. I'll give it a go with old headers moved away.

Joel Barker (j-cimb-barker) wrote :

No change :(

Alberto Milone (albertomilone) wrote :

I warmly recommend you to wait for my new packages since the NVIDIA installer may break symlinks of the official packages and therefore cause problems if you decide to go back to the packages provided by Ubuntu (this is something I would like to solve together with NVIDIA).

I'll make sure that the new packages are made available in the -proposed repositories ASAP.

Martin Pitt (pitti) on 2008-11-03
Changed in nvidia-graphics-drivers-71:
status: New → Fix Committed
Changed in nvidia-graphics-drivers-96:
status: New → Fix Committed
Martin Pitt (pitti) on 2008-11-06
Changed in nvidia-graphics-drivers-96:
status: Confirmed → Fix Released
status: Fix Committed → Fix Released
Changed in nvidia-graphics-drivers-71:
status: Fix Committed → Confirmed
152 comments hidden view all 232 comments

I am on the Intrepid list and I would like to stop
I have tried to stop but don't know what list to stop. (all I have tried
didn't work)

Is there a way to find out what lists I am on and stop them ?
thanks
Harold

On 11/12/2008 09:12 AM, dancer58 wrote:
> I am on the Intrepid list and I would like to stop
> I have tried to stop but don't know what list to stop. (all I have tried
> didn't work)
>
> Is there a way to find out what lists I am on and stop them ?
> thanks
> Harold
>

Right side of the page: click 'Unsubscribe' & follow the directions.

To find out which bugs you are associated with: click your username next
to the login box, then click on 'Bugs'.

daveh (david-huckfield) wrote :

To those of you who, like me, have had text rendering problems with 96.43.09 drivers I have some good news.
The good people at Compiz-Fusion have just advised me that adding:

Option "RenderAccel" "0" to the Device section of xorg.conf will solve this problem.

For me it has at last resolved all issues.

I believe nvidia see this as a workaround that may slow 2D drawing so they have suggested the alternative of reverting instead to version 96.43.07.

But this simple mod to xorg has been the solution for me.

If it works for you it will help all if you let us know here.

Good luck.

dancer58 (dancer581) wrote :

The Intrepid mailing list
It has too high a volume

Thanks for the replies

NoOp wrote:
> On 11/12/2008 09:12 AM, dancer58 wrote:
>
>> I am on the Intrepid list and I would like to stop
>> I have tried to stop but don't know what list to stop. (all I have tried
>> didn't work)
>>
>> Is there a way to find out what lists I am on and stop them ?
>> thanks
>> Harold
>>
>>
>
> Right side of the page: click 'Unsubscribe' & follow the directions.
>
> To find out which bugs you are associated with: click your username next
> to the login box, then click on 'Bugs'.
>
>

Jakson Alves de Aquino wrote:
> This workaround for fixing fonts in wine worked for my system (Intrepid amd64):
> http://www.nvnews.net/vbulletin/showthread.php?t=122695
>
>
I can confirm this workaround for Wine worked with my Geforce 4 MX and
the beta drivers.

Jackdaw28 (simoncsoka) wrote :

Using Option "RenderAccel" "0" has fixed the font problem in Opera and Google Earth for me with Geforce Go MX 440 64MB.

s.O.f.o.s (sogomaru) wrote :

the "RenderAccel" "0" worked for me too, geforce4 ti 4200.

Laurent (lduplantie) wrote :

96.43.09 works with my Quadro2 (32MB) although the autodetection for my monitor failed. I am stuck in low res. I am trying to find out how to manually set the monitor and resolution. I have edited xorg.conf with no success.

Laurent

GourdCaptain (saunders-52) wrote :

Laurent wrote:
> 96.43.09 works with my Quadro2 (32MB) although the autodetection for my
> monitor failed. I am stuck in low res. I am trying to find out how to
> manually set the monitor and resolution. I have edited xorg.conf with no
> success.
>
> Laurent
>
>
The nvidia-settings package gives a GUI for editing xorg.conf if you're
using the Nvidia drivers. It's worth checking out. (I used it to fix the
resolution when mine was misidentified, too.)

jackie999 (micjacmartin) wrote :

I'm just new so will try to provide useful info.
Running 8.10 with nvidia GeForce FX 5500. The 173.14.12.1 doesn't seem to work, it will not allow me to enable desktop effects.
I was able to install the 96.43.09 and am able to enable effects. But I find when running Konversation all the text will blank out on screen refreshes. The same thing is happening with Open Office applications - anywhere you'd normally see text is blank.

Marius Bock (marius) wrote :

jackie999

see the comment above from daveh which I copy here:

To those of you who, like me, have had text rendering problems with 96.43.09 drivers I have some good news.
The good people at Compiz-Fusion have just advised me that adding:

Option "RenderAccel" "0" to the Device section of xorg.conf will solve this problem.

For me it has at last resolved all issues.

I believe nvidia see this as a workaround that may slow 2D drawing so they have suggested the alternative of reverting instead to version 96.43.07.

But this simple mod to xorg has been the solution for me.

If it works for you it will help all if you let us know here.

Good luck.

See if this solves your problem. I had the same issue and it solved mine.

jackie999 (micjacmartin) wrote :

Marius, that xorg.conf change did the trick, thanks very much for passing that along.

TitoN (titon2k) wrote :

I just want to confirm that Marius tip about adding
Option "RenderAccel" "0"
To the Device part in xorg.conf fixed the problem with the font rendering problem.
Thank you very much.

macro182 (macro182-gmail) wrote :

I had a nVidia 8500 GT that works 'out of the box' in a native installation of intrepid.
But I had to upgrade from Hardy and now I only managed to log in whit Vesa driver (wrong resolution).

What can I do?

Thank you for helping me

Jackdaw28 (simoncsoka) wrote :

Re: macro182: I had the same problem on another system with a Geforce 7300GT. No nvidia driver would install properly after an upgrade from Hardy. I tried everything to no avail. On a clean install of Intrepid the 177 driver worked fine and was installed through Hardware Drivers (jockey.) I think that there is a separate bug in the upgrade process.

Hein van Rensburg (hvralpha) wrote :

Jackie,
The problem with open office is not the same driver problem reported here. OOO2.4 and OOO3.0 call a specific font which is sometimes missing in the system. I fixed the problem in Ubuntu by going to the system-preferences-appearance-fonts and changing the fonts there. It worked after restarting OOO.

jackie999 (micjacmartin) wrote :

Thank you Hein. My problem wasn't just the open office fonts, it was also "Konversation" fonts, but the main problem was I was unable to enable desktop effects and the fix Marius posted above fixed everything.

Timothy Burk (b-tburk) wrote :

Just wanted to confirm the 96 beta driver worked for me. GeForce4 Ti 4200. I can also confirm the workaround for WINE.

oren (orengolan) wrote :

I am not sure if I am in the right place.
my problem is I can't play games anymore since everything is very slow.
I have GeForce4 MX 440
running this: glxgears -info
shows the following info:
GL_RENDERER = Software Rasterizer
and also:
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 790 requests (352 known processed) with 0 events remaining.

I tried following this thread and tried this line:
sudo aptitude install nvidia-glx-96
but it didn't help.

Please provide me a simple step by step for solving it.
Thank you very much!

alienexplorers (dfsjr47) wrote :

96.43.09 works great as long as renderaccel is turned off.

Ravindran K (ravindran-k) wrote :

I see a new version on NVIDIA site
ftp://download.nvidia.com/XFree86/Linux-x86/71.86.08/

trying it now.

Ravindran K (ravindran-k) wrote :

No luck.. same error undefined symbol: AllocateScreenPrivateIndex

RainS (slnice) wrote :

My card is TNT2 M64.
After update to 71.86.08, the error is the same: undefined symbol:AllocateScreenPrivateIndex.
System is Ubuntu 8.10. Why? Does the 71.86.08 still have this bug?

mclaudt (mclaudt) wrote :

My card TNT2 ULTRA.

71.86.06 and 71.86.08 give

undefined symbol:AllocateScreenPrivateIndex.

OpenSUSE 11.1

jtholmes (jtholmes) wrote :

I can certainly confirm the undefined symbol: AllocateScreenPrivateIndex

in the 71.86.09 version from nvidia's site.

I don't expect instant service (i can go back to 8.04) but I am wondering
why the bug is 'undecided' for the 71.86.04 and want to know if it shouldnt be medium.

I will be glad to do what ever testing albert etc. wants to help fix the problem.
thanks
jt

Steve Langasek (vorlon) on 2009-04-09
Changed in nvidia-graphics-drivers-71 (Ubuntu Jaunty):
milestone: none → jaunty-updates
ranman (eatdespain) wrote :

Him

tested as well the latest 71 release from nvidia (09) , the same error, my X are broken

Ran,

Unfortunately driver 71.xx won't be updated to work with the new xserver and there is nothing we can do about it. Should things change in the future, feel free to reopen this bug report.

Changed in nvidia-graphics-drivers-71 (Ubuntu):
status: Confirmed → Won't Fix
Changed in nvidia-graphics-drivers-71 (Ubuntu Intrepid):
status: Confirmed → Won't Fix
Changed in nvidia-graphics-drivers-71 (Ubuntu Jaunty):
status: Confirmed → Won't Fix
dyl_yati (dnb.yati) wrote :

Did the exact same thing with my parents Xubuntu, which has the old nvidia RIVA TNT2 Model 64 (which also uses the same nvidia 71 driver thingy).
installed, rebooted and so started X...
only to get failsafe window
I too got this message at the end of the xorg log
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
dlopen: /usr/lib/xorg/modules/drivers//nvidia_drv.so: undefined symbol: AllocateScreenPrivateIndex
(EE) Failed to load /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (loader failed, 7)
(EE) No drivers available.

Hi,
I bought a TV last week from a website:www.hkeles.com. I have
received the product. The quality is very good. They also sell
phones,motor,psp and so on. Because of the financial crisis, their
products are very cheap. by the way, they only sell new and original
products .If you need these products, you can have a look . I think
you will get many benefits.
Greetings!

Gene Caldwell (gene-caldwell) wrote :

someone please remove this jerks account so that he cannot spam again !!! what an ass !

Jacob Godserv (fun2program8) wrote :

Gene, please report spam to the proper forums. (And, passing judgment without all the facts and without the authority is a dangerous thing to do, and doing it in public makes the community look bad.)

Gene Caldwell (gene-caldwell) wrote :

@Jacob
you have a lot of gall telling me that I am not the only decision maker about who sends me email to my private email account. I did not sign up to report bugs here only to get harassed and SPAMED by members - this forum is about posting bug reports, not about giving personal opinions about webs site from someone who I don't know or want an option from.

you got side tracked, if YOU know the proper place to report improper posts to this forum, then you can report it ( because I have no clue or time to search where I would report it). I have no clue where the proper place is to report it, however there are moderators in all forums who can take the action needed, and I do not see a mod doing anything about this and was hoping that my post would get a mod to remove the OFFENDERS account. In what world is it ok to spam people with UNWANTED opinions and not even try to take action against the offenders posted spam ?

Gene Caldwell (gene-caldwell) wrote :

I would also note that by leaving the SPAM in place and not trying to get it removed is what makes the community look bad, not to mention saying nothing about the spammer.

Ori Avtalion (salty-horse) wrote :

Gene, Jacob, and everyone else,

I have talked with Andrea Cimitan, whose email account was hacked and was used to send spam.
Andrea wants this spam removed as much as you do.

Please do not start an off-topic discussion about spam in an already crowded bug report.

Gene Caldwell (gene-caldwell) wrote :

That I can accept and live with but should have been posted for the benefit for offended receivers of the SPAM. T/Y for the info Ori.

Today I've tried the driver on my old machine with a TNT 2 Model 64 video-card. It is still not working... is this issue going to be resolved by nVIDIA in the near future?

I use Ubuntu Jaunty on my old computer (X Server 1.6).

And is there any sense in trying Ubuntu 8.10?

papukaija (papukaija) on 2010-06-17
tags: added: intrepid jaunty
papukaija (papukaija) wrote :

@Miro: Intrepid isn't any more supported. Anyway, this bug is fixed for the nvidia 96 series. The Tnt2 is part of the older 71 driver which does not support the new xservers (Jaunty and higher) but this bug report isn't about xserver support (and don't open a bug about xserver's compatibility, only nvidia can provide a fix). Nvidia isn't probably going to release a fix for it in the near future. However, starting with Lucid (10.04 LTS), Ubuntu uses by default the free (gpl) nouveau driver which is better and faster than the nv driver but it doesn't yet provide 3d support.

I know about the Nouvoeau driver in Lucid but after Jaunty, the newer Ubuntu version use at least 100-150 mb more RAM than Jaunty, Intrepid, Hardy and so on. And this computer is really old after all.

Thanks for informing me, papukaija!

Displaying first 40 and last 40 comments. View all 232 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.