[nvidia][Lenovo P51] Mini-DP and HDMI ports are missing

Bug #1875892 reported by Bill Zhong on 2020-04-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-440 (Ubuntu)
Undecided
Unassigned

Bug Description

My laptop (Lenovo ThinkPad P51) has 2 display interfaces. One mini-dp and one HDMI. But none of them is shown in xrandr, and my external display connected through mini-dp is not detected also.

When I used LiveCD, the external monitor works normally. The above situation happens when my boot from SSD with the fully-installed system.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
ProcVersionSignature: Ubuntu 5.4.0-28.32-generic 5.4.30
Uname: Linux 5.4.0-28-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
.proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0000:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.suspend: suspend hibernate resume
.proc.driver.nvidia.suspend_depth: default modeset uvm
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 440.64 Fri Feb 21 01:17:26 UTC 2020
 GCC version:
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: skip
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Wed Apr 29 21:37:28 2020
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation HD Graphics P630 [8086:591d] (rev 04) (prog-if 00 [VGA controller])
   Subsystem: Lenovo HD Graphics P630 [17aa:224d]
   Subsystem: Lenovo GM206GLM [Quadro M2200 Mobile] [17aa:224d]
InstallationDate: Installed on 2020-04-29 (0 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
MachineType: LENOVO 20HHCTO1WW
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-28-generic root=UUID=05a90498-4cfc-4877-8f08-b096eb36e91b ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/10/2020
dmi.bios.vendor: LENOVO
dmi.bios.version: N1UET77W (1.51 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20HHCTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40709 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrN1UET77W(1.51):bd02/10/2020:svnLENOVO:pn20HHCTO1WW:pvrThinkPadP51:rvnLENOVO:rn20HHCTO1WW:rvrSDK0J40709WIN:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad P51
dmi.product.name: 20HHCTO1WW
dmi.product.sku: LENOVO_MT_20HH_BU_Think_FM_ThinkPad P51
dmi.product.version: ThinkPad P51
dmi.sys.vendor: LENOVO
nvidia-settings:
 ERROR: Unable to load info from any available system

 ERROR: Unable to load info from any available system
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.101-2
version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.4-2ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

Bill Zhong (billzhonggz) wrote :
Daniel van Vugt (vanvugt) wrote :

Your mini-DP and HDMI ports are probably connected to the Nvidia GPU so this is something of a bug in the Nvidia driver, or a misconfiguration.

affects: xorg (Ubuntu) → nvidia-graphics-drivers-440 (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

The reason it works in the LiveCD is probably because you're using a different driver there (the open source 'nouveau' driver). So a solution here might just be to uninstall the nvidia-440 driver.

summary: - Display Interfaces Not Detected
+ [nvidia][Lenovo P51] Mini-DP and HDMI ports are missing
Bill Zhong (billzhonggz) wrote :

I tried to use Ubuntu Drivers to switch my GPU driver from NVIDIA to nouveau driver. But nothing happens and the ports are still missing.

Daniel van Vugt (vanvugt) wrote :

Please make sure you reboot after doing that. If the problem still happens then please run these commands:

  lspci -k > lspcik.txt
  grep . /sys/class/drm/*/status > connectors.txt

and then attach the two resulting text files.

Changed in nvidia-graphics-drivers-440 (Ubuntu):
status: New → Incomplete
Bill Zhong (billzhonggz) wrote :

I solved this problem by re-install the OS. When I install the OS, I did not check the checkboxes to install updates and third-party software (I checked to install third-party software last time). Therefore the nouveau driver instead of the NVIDIA one will be installed. Then I changed the apt source to a local software mirror, and use Ubuntu Drivers to install the NVIDIA driver. And everything now works fine.
  I think the problem may caused by incomplete install on the NVIDIA driver. Since I am in mainland China, the network may be the primary reason for this incomplete install.

During the above procedure, I found that the OS will become extremely slow in the following situation.
- Using nouveau driver.
- The laptop internal display is disabled (lip off or disabled in Display Setting).
- The external monitor is the only display.
I did not investigate deeper and I quickly installed the NVIDIA driver.

Thanks for the help!

Launchpad Janitor (janitor) wrote :

[Expired for nvidia-graphics-drivers-440 (Ubuntu) because there has been no activity for 60 days.]

Changed in nvidia-graphics-drivers-440 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers