[nvidia] Display scaling results in a blank screen (power save state)

Bug #1870758 reported by PerJensen on 2020-04-04
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)
High
Unassigned
nvidia-graphics-drivers-440 (Ubuntu)
High
Alberto Milone

Bug Description

Working on fully updated focal fossy

Procedure to make bug happen:

1. open gnome control center and select screen (skærme in danish)

2. click the "fractional scaling" switch

3. select 150% scaling and click the green button at top right

4. Result is a blank screen and the monitor going into a power save state

A reboot doesn't help. The login screen appears, when I log in the screen goes blank again and the monitor power save kicks in.

If I select the "unity" environment, the display does work.

If I do this on the command line "gsettings set org.gnome.mutter experimental-features ['']", I can log in as usual and fractional scaling has been turned off.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: gnome-control-center 1:3.36.1-1ubuntu3
ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
Uname: Linux 5.4.0-21-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu22
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sat Apr 4 12:11:39 2020
InstallationDate: Installed on 2018-01-14 (810 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=da_DK.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to focal on 2020-04-03 (0 days ago)

PerJensen (per-net-es) wrote :
PerJensen (per-net-es) wrote :

Selecting scaling to 175% gives the same result as 150% -> blank screen and monitor power save state

tags: added: regression-update rls-ff-incoming
tags: added: regression-release
removed: regression-update
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Michael Haworth (bailtree) wrote :

I tried this with a NVIDIA graphics card, and surely enough, the bug is present. With my AMDGPU system it doesn't happen.

Michael Haworth (bailtree) wrote :

just to clarify, I was using the latest non-free nvidia graphics drivers on the problematic system.

Michael Haworth (bailtree) wrote :

tentatively setting the bug to relate to nvidia-graphics-drivers-440

affects: gnome-control-center (Ubuntu) → nvidia-graphics-drivers-440 (Ubuntu)
Michael Haworth (bailtree) wrote :

PerJensen, could you let us know what version of the nvidia drivers you're running?

PerJensen (per-net-es) wrote :

I am using this package:

nvidia-driver-440/focal,now 440.64-0ubuntu3 amd64 [Installeret]
  NVIDIA driver metapackage

PerJensen (per-net-es) wrote :

This is also installed:

xserver-xorg-video-nvidia-440/focal,now 440.64-0ubuntu3 amd64 [Installeret,automatisk]
  NVIDIA binary Xorg driver

Sebastian Heiden (seb-heiden) wrote :

Have you tried setting the screen scaling factor to 200% without fractional scaling enabled? I am experiencing a pretty similar issue in bug #1870922

Corey Wood (coreymwood) wrote :

I also have a similar issue with scale set to 200%. The screen does not go blank after applying the 200% scaling and things seem to work as expected, but when logging in after a reboot the monitor goes into power-save state. So it doesn't appear to be specific to fractional scaling, since 2x scaling has issues for me.

I'm on a fully-updated 20.04 beta with nvidia-440 (440.64) drivers as well. Changing "<scale>" from 2 to 1 in ~/.config/monitors.xml and rebooting is how I managed to reset scaling to 100% and re-access my desktop.

PerJensen (per-net-es) wrote :

@sebastian Heiden:
I have no problem using scaling at 200%. Opening applications is working, gthumb is working fine for instance. I have switched back and forth, and is writing this in chrome at 200%.

gnome-control-center is acting a bit wierd when:

1. at scaling=200%, open gnome-control-center

2. scale back to 100%

3. the app now is now maximised - the dock to the left is visible.

PerJensen (per-net-es) wrote :

@corey wood - I can confirm your finding.

I did this:

1. scale to 200%

2. reboot - the login screen shows

3- login --> screen power save mode happens

4. ctrl-alt-3 and then log in at the console

5. Change "<scale>" from 2 to 1 in ~/.config/monitors.xml

6. ctrl-alt-2 to switch back to graphical environment. The monitor is still in power save mode

7. ctrl-alt-back to kill the X server

8. login screen appears

9. login in and I am back at scaling=100%

tags: added: xrandr-scaling
summary: - Screen scaling 150% results in monitor power save state
+ [nvidia] Screen scaling 150% results in monitor power save state
tags: added: nvidia
summary: - [nvidia] Screen scaling 150% results in monitor power save state
+ [nvidia] Screen scaling results in monitor power save state

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mutter (Ubuntu):
status: New → Confirmed
Changed in mutter (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-440 (Ubuntu):
importance: Undecided → High
summary: - [nvidia] Screen scaling results in monitor power save state
+ [nvidia] Fractional scaling results in monitor power save state

I would suggest changing the summary back to just "Screen Scaling" or "Display Scaling". When I encountered this issue, I did not enable fractional scaling.

Attached is a snapshot of my journalctl log (copied from bug #1870929). 20:54:04 is the timestamp when I clicked Apply. I believe 20:54:25 is the timestamp the monitors woke from sleep.

I would be surprised if the issue was caused by the legacy integer scaling code, so even if you're not using a fractional scale value it might somehow be caused by the fractional scaling logic.

summary: - [nvidia] Fractional scaling results in monitor power save state
+ [nvidia] Display scaling results in monitor power save state
Changed in nvidia-graphics-drivers-440 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Tim Penhey (thumper) on 2020-04-08
tags: added: champagne
summary: - [nvidia] Display scaling results in monitor power save state
+ [nvidia] Display scaling results in a blank screen (power save state)
Daniel van Vugt (vanvugt) wrote :

Excellent news: This appears to be a duplicate of bug 1869750.

Erik Steiner (estebanium) wrote :

Scaling to 200% is fine until I decide to use nvidia-driver, instead of X.Org-X-Server.

Some reported that the monitor would go to power save state when they applied the scaling setting immediately. I can not confirm that. Scaling with nvidia-driver works until I reboot.

S. Jansen (sjansen-w) wrote :

Nvidia 1080 with two 4K screens. After updating to 440 i only have lost fraction scaling, gnome settings only shows 100,200,300,400. The old experimental flag does not work (xorg).

Daniel van Vugt (vanvugt) wrote :

That's a new bug so please log it as such. Though if you are using Pop!OS then it's not a bug at all, since System76 has now removed the feature from their package.

If you are using regular Ubuntu then please open a new bug by running:

  ubuntu-bug mutter

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers