Xorg crashed with SIGABRT in nvidia_drv.so

Bug #1868396 reported by SR on 2020-03-21
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-440 (Ubuntu)
Undecided
Unassigned

Bug Description

I have plugged in my Dell precision 5530 laptop a 4k HDMI screen.
Using it with 200% zoom makes xorg crash.
I have used proprietary 430, and changed to recommended proprietary 435 nvidia driver.
As the system was still very unstable (no to say unusable) I had a go with 440 from ppa.
I also ensured that my system was up to date doing a sudo apt-get update and upgrade. I was suprised to discover a few packages that needed an upgrade although I had previously used the Software Updater tool. Maybe I was doing something wrong.
Anyway, with these updates and the newer 440 driver, I have successfully worked a day (sparsely) without problem, and using only 100% zoom.
As a test, I decided to try to set the zoom to 200% (through devices > display, and I have only the external display enabled).
After several minutes, I clicked on the « full screen » icon to maximize a shell, and the PC froze.
It was so close to my change in the zoom ratio, that I suspect this is related.

dmesg shew me that NVRM had a problem :
[97501.301998] NVRM: GPU at PCI:0000:01:00: GPU-dee28f75-4083-96a8-1a0b-491b6109101a
[97501.302000] NVRM: Xid (PCI:0000:01:00): 32, pid=493, Channel ID 00000018 intr 00040000
[97501.302134] NVRM: Xid (PCI:0000:01:00): 32, pid=2052, Channel ID 00000018 intr 00200000
[97501.317307] NVRM: Xid (PCI:0000:01:00): 69, pid=902, Class Error: ChId 001b, Class 0000902d, Offset 00000250, Data 000055d3, ErrorCode 0000000c

pid 493 is gone

pid 2052 is xorg
stan 2052 2050 1 mars20 tty2 00:25:38 /usr/lib/xorg/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -background none -noreset -keeptty -verbose 3

pid 902 is nvidia driver
root 902 2 0 mars20 ? 00:02:59 [irq/163-nvidia]

ppid 2052 is 2050 :
stan 2050 2004 0 mars20 tty2 00:00:00 /usr/lib/gdm3/gdm-x-session --run-script env GNOME_SHELL_SESSION_MODE=ubuntu /usr/bin/gnome-session --systemd --session=ubuntu

After such an event, the previous days, the system became unstable, and I have got problems with other devices such as audio and network.

If I run the manufacturer self-check test, everything is fine.

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: xorg 1:7.7+19ubuntu12
ProcVersionSignature: Ubuntu 5.3.0-42.34-generic 5.3.18
Uname: Linux 5.3.0-42-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
.proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0000:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.suspend: suspend hibernate resume
.proc.driver.nvidia.suspend_depth: default modeset uvm
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 440.64 Fri Feb 21 01:17:26 UTC 2020
 GCC version: gcc version 9.2.1 20191008 (Ubuntu 9.2.1-9ubuntu2)
ApportVersion: 2.20.11-0ubuntu8.6
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Sat Mar 21 18:36:53 2020
DistUpgraded: 2019-11-04 11:06:46,434 ERROR got error from PostInstallScript ./xorg_fix_proprietary.py (g-exec-error-quark: Failed to execute child process “./xorg_fix_proprietary.py” (No such file or directory) (8))
DistroCodename: eoan
DistroVariant: ubuntu
DkmsStatus:
 nvidia, 440.64, 5.3.0-42-generic, x86_64: installed
 virtualbox, 6.0.14, 5.3.0-40-generic, x86_64: installed
 virtualbox, 6.0.14, 5.3.0-42-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation UHD Graphics 630 (Mobile) [8086:3e9b] (prog-if 00 [VGA controller])
   Subsystem: Dell UHD Graphics 630 (Mobile) [1028:087d]
   Subsystem: Dell GP107GLM [Quadro P2000 Mobile] [1028:087d]
InstallationDate: Installed on 2019-04-26 (329 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
MachineType: Dell Inc. Precision 5530
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-42-generic root=UUID=2262d308-663c-47c3-9e75-b34611c8df1d ro nouveau.blacklist=1 acpi_rev_override=1 acpi_osi=Linux nouveau.modeset=0 pcie_aspm=force drm.vblankoffdelay=1 scsi_mod.use_blk_mq=1 nouveau.runpm=0 mem_sleep_default=deep quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: Upgraded to eoan on 2019-11-04 (138 days ago)
dmi.bios.date: 12/25/2019
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.15.0
dmi.board.name: 0N0DK2
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.15.0:bd12/25/2019:svnDellInc.:pnPrecision5530:pvr:rvnDellInc.:rn0N0DK2:rvrA00:cvnDellInc.:ct10:cvr:
dmi.product.family: Precision
dmi.product.name: Precision 5530
dmi.product.sku: 087D
dmi.sys.vendor: Dell Inc.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.99-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.8-0ubuntu0~19.10.3
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20190815-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

SR (esserre) wrote :
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It sounds like some part of the system has crashed. To help us find the cause of the crash please follow these steps:

1. Look in /var/crash for crash files and if found run:
    ubuntu-bug YOURFILE.crash
Then tell us the ID of the newly-created bug.

2. If step 1 failed then look at https://errors.ubuntu.com/user/ID where ID is the content of file /var/lib/whoopsie/whoopsie-id on the machine. Do you find any links to recent problems on that page? If so then please send the links to us.

3. If step 2 also failed then apply the workaround from bug 994921, reboot, reproduce the crash, and retry step 1.

Please take care to avoid attaching .crash files to bugs as we are unable to process them as file attachments. It would also be a security risk for yourself.

affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
status: New → Incomplete
SR (esserre) wrote :

For the record these already exist :
-rw-r----- 1 stan whoopsie 16008226 mars 19 09:16 _usr_lib_xorg_Xorg.1000.crash
-rw-r--r-- 1 stan whoopsie 0 mars 19 09:16 _usr_lib_xorg_Xorg.1000.upload
-rw------- 1 whoopsie whoopsie 37 mars 19 09:16 _usr_lib_xorg_Xorg.1000.uploaded
If I re-run the tool, it tells me that 19.10 had suffered an internal error. I click send and… that's all.

I've got this now :
-rw------- 1 root root 128 mars 23 08:12 whoopsie-id

Going to the mentionned URL, I find tons of crashes, notably chrome, and the latest is xorg. Here is the link to the latest crash :

https://errors.ubuntu.com/oops/f0b02e76-69b9-11ea-aa6e-fa163e983629

Hope I'm giving you the right information.

SR (esserre) wrote :

Please also note this (probably useless) information : I have no problem at all with this screen and zoom ratio on my old desktop PC using 18.04 and 390 open source nvidia drivers.

SR (esserre) wrote :

Another info : it crashed today with 100% zoom ratio.
Switching to intel drivers.

SR (esserre) wrote :

Sorry to spam, but with « crash », I mean non-responsive PC, not being able to change terminal using key shortcuts, no ssh access, noisy fans. No crash in /var/crash/.

SR (esserre) wrote :

FWIW, I have no crash selecting « Nouveau » driver for nvidia GPU.
But doing so, I'm unable to configure correctly opengl in a chroot from where I launch graphical tools in a Jessie. I can with the NVDIA installer.
Bug set back to « New » as I've completed it the most I could.

Changed in xorg-server (Ubuntu):
status: Incomplete → New
summary: - crashes or freezes with nividia/xorg
+ Xorg crashed with SIGABRT in nvidia_drv.so
affects: xorg-server (Ubuntu) → nvidia-graphics-drivers-440 (Ubuntu)
tags: added: nvidia
SR (esserre) wrote :

New crash report with Ubuntu 20.04 LTS : https://errors.ubuntu.com/oops/db6bc67c-98d7-11ea-9b32-fa163e102db1

Now, the behaviour is :
 - black screen, unrecoverable. Have to press 10 seconds on power-off button.

The scenario is :
 - having an external display 4K connected to HDMI, set resolution to maximum (3840x2060), and zoom to 200%.

I use the external screen with these settings with less or no problem :
 - half resolution on X and on Y (that is : Full HD resolution, 1920x1080), zoom 100%.

Daniel van Vugt (vanvugt) wrote :

Thanks, but that's still not readable. I suspect there's a bug in the crash reporting system because it gives up way too easily, way too often:

> This problem failed to retrace because there was no crash signature after retracing and missing ddebs.
>
> The following packages are missing debug symbols: libnvidia-gl-440 xserver-xorg-video-nvidia-390.
>
> More information may be found in incident db6bc67c-98d7-11ea-9b32-fa163e102db1

SR (esserre) wrote :

Thank you very much for getting back !
Is there a way I can check/fix something in order to improve the reports ?
As I can easily reproduce (so it seems at this very moment), it would be easy for me to try to send reports with different configurations.
I can even try to build something on my side if it can help.
I see a mix of 440 and 390 in the package names you pointed out. Seems ok to you ?

Daniel van Vugt (vanvugt) wrote :

Instead of trying to change or fix the drivers, please consider upgrading the whole OS to Ubuntu 20.04 - https://ubuntu.com/download/desktop

Ubuntu 19.10 that you are using will reach end of life in July so you would need to upgrade anyway.

SR (esserre) wrote :

Latest reported crash is under 20.04 LTS.

tags: added: focal
SR (esserre) wrote :

According to this discussion, it *might* be a duplicate of https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1878105 :

https://forums.developer.nvidia.com/t/quadro-p2000-440-64-crash-under-ubuntu/123718

I remember having problems with cursor at max size a year ago, probably with 19.04.

SR (esserre) wrote :

For the record : it crashed today.
I am using a 4k resolution screen at 4k resolution and 200% zoom.
I have set the cursor size to of 31 (as reported by dconf read /org/gnome/desktop/interface/cursor-size).

https://errors.ubuntu.com/oops/83819e4a-9f6d-11ea-9ba9-fa163e102db1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers