package nvidia-dkms-435 435.21-0ubuntu1 failed to install/upgrade: installed nvidia-dkms-435 package post-installation script subprocess returned error exit status 10

Bug #1847549 reported by Katie on 2019-10-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-435 (Ubuntu)
Undecided
Unassigned

Bug Description

failed to install after upgrade to eoan ermin beta

ProblemType: Package
DistroRelease: Ubuntu 19.10
Package: nvidia-dkms-435 435.21-0ubuntu1
ProcVersionSignature: Ubuntu 5.3.0-13.14-generic 5.3.0
Uname: Linux 5.3.0-13-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
Date: Wed Oct 9 23:46:26 2019
ErrorMessage: installed nvidia-dkms-435 package post-installation script subprocess returned error exit status 10
InstallationDate: Installed on 2019-10-07 (2 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
Python3Details: /usr/bin/python3.7, Python 3.7.5rc1, python3-minimal, 3.7.3-1
PythonDetails: N/A
RelatedPackageVersions:
 dpkg 1.19.7ubuntu2
 apt 1.9.4
SourcePackage: nvidia-graphics-drivers-435
Title: package nvidia-dkms-435 435.21-0ubuntu1 failed to install/upgrade: installed nvidia-dkms-435 package post-installation script subprocess returned error exit status 10
UpgradeStatus: Upgraded to eoan on 2019-10-09 (0 days ago)

Katie (katie-cochrane1988) wrote :
tags: removed: need-duplicate-check
Bob H (bobbicat) wrote :

I attempted 'sudo do-release-upgrade -d' a couple of days ago over an updated version of kubuntu 1904
The process appeared to progress successfully and I am writing this report in the resulting kubuntu 1910 [eoan ermine]
However when I checked drivers it seemed nvidia-driver-430 was installed.
This is not the recommended driver which is nvidia-driver-435 and which I could only install after purging the nvidia-driver-430 files.
The 430 driver appeared to be working okay as does the 435 driver that I have now installed.
The recommended driver in Kubuntu 1904 was 418 if I remember rightly, the upgrade which should happen is not to 430 but to 435. Something seems to be preventing 435 being created if there is already a version of the nvidia driver present. It will install over the nouveau driver.
Thi might not be the same bug originally reported here.

Bob H (bobbicat) wrote :

Purging any nvidia driver files present by 'sudo apt --purge autoremove nvidia*' followed by a reboot and then 'sudo ubuntu-drivers autoinstall' will set up the recommended drivers, as a workaround.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-435 (Ubuntu):
status: New → Confirmed
Bob H (bobbicat) wrote :

nvidia-graphics-drivers-435[recommended](Ubuntu) are not installed,
in my case nvidia-graphics-drivers-430 (Ubuntu) were installed instead.

Bob H (bobbicat) wrote :

incidentally 'dpkg -l | grep nvidia' will tell you what, if any, nvidia files you have installed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers