package nvidia-* failed to install/upgrade: nvidia-current kernel module failed to build / make[2]: *** No rule to make target `modules'. Stop.

Bug #563265 reported by Sakumatti Luukkonen on 2010-04-14
148
This bug affects 32 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-331 (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-367 (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-390 (Ubuntu)
Undecided
Unassigned

Bug Description

After getting the latest updates in lucid, including the 2.6.32-20 kernel, and rebooting the machine, X only started in low graphics mode. After I started to investigate it seemed like the nvidia kernel module failed to build. I tried to reinstall nvidia-current (apt-get autoremove nvidia-current, apt-get install nvidia-current) but it failed with the following message.

root@thor:~# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up nvidia-current (195.36.15-0ubuntu2) ...
Removing old nvidia-current-195.36.15 DKMS files...

------------------------------
Deleting module version: 195.36.15
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-current-195.36.15 DKMS files...
Building for 2.6.32-19-generic and 2.6.32-20-generic
Building for architecture x86_64
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
Building initial module for 2.6.32-20-generic

Error! Bad return status for module build on kernel: 2.6.32-20-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-current/195.36.15/build/ for more information.
dpkg: error processing nvidia-current (--configure):
 subprocess installed post-installation script returned error exit status 10
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for python-support ...
Errors were encountered while processing:
 nvidia-current
E: Sub-process /usr/bin/dpkg returned an error code (1)

The make.log contains the following information

root@thor:~# cat /var/lib/dkms/nvidia-current/195.36.15/build/make.log
DKMS make.log for nvidia-current-195.36.15 for kernel 2.6.32-20-generic (x86_64)
Wed Apr 14 20:34:45 EEST 2010
NVIDIA: calling KBUILD...
make[2]: *** No rule to make target `modules'. Stop.
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2

If I try to activate the nvidia drivers using jockey-gtk or jockey-text, I get the following error

root@thor:~# jockey-text -e xorg:nvidia_current

Searching for available drivers...

SystemError: installArchives() failed

Meanwhile, the proprietary nvidia drivers continue to happily work in 2.6.32-19 kernel. Only building the module for 2.6.32-20 seems to fail.

Thank you for your help. Please let me know if I can give you any more relevant debugging information. This machine was upgraded from 9.04 to 10.04, for all that it matters.

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: nvidia-current 195.36.15-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
Architecture: amd64
CurrentDmesg:
 [ 22.352714] ppdev: user-space parallel port driver
 [ 31.600005] eth0: no IPv6 routers present
 [ 35.870840] UDF-fs: Partition marked readonly; forcing readonly mount
 [ 35.899382] UDF-fs INFO UDF: Mounting volume 'CIVCOMPLETEEU', timestamp 2007/09/22 01:42 (10b4)
Date: Wed Apr 14 21:07:06 2010
DkmsStatus: nvidia-current, 195.36.15: added
ErrorMessage: nvidia-current kernel module failed to build
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: System manufacturer P5Q
PackageVersion: 195.36.15-0ubuntu2
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=2846018c-2e2a-4803-8a02-ad3c18f7c317 ro quiet splash
SourcePackage: nvidia-graphics-drivers
Title: package nvidia-current 195.36.15-0ubuntu2 failed to install/upgrade: nvidia-current kernel module failed to build
XorgConf:

dmi.bios.date: 08/20/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1306
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5Q
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1306:bd08/20/2008:svnSystemmanufacturer:pnP5Q:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5Q:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5Q
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-19-generic

Tony Mugan (tmugan) wrote :

This happened for me also on upgrade to kernel 2.6.32-21 today on Lucid.

Looks like the latest upgrades which included 2.6.32-21 fixed this for me.

Tony Mugan (tmugan) wrote :

Just applied the latest updates now and still have a problem loading the nvidia driver in 2.6.32-21

Tony Mugan (tmugan) wrote :

Just tried a reinstall and it now works!

sudo apt-get autoremove nvidia-current
sudo apt-get install nvidia-current

summary: package nvidia-current 195.36.15-0ubuntu2 failed to install/upgrade:
- nvidia-current kernel module failed to build
+ nvidia-current kernel module failed to build / make[2]: *** No rule to
+ make target `modules'. Stop.
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed

I'm getting this since the latest kernel upgrade. Installing linux-source hasn't helped.

$ sudo apt-get install nvidia-current
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  nvidia-settings
The following NEW packages will be installed
  nvidia-current nvidia-settings
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/24.1MB of archives.
After this operation, 74.4MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Selecting previously deselected package nvidia-current.
(Reading database ... 332300 files and directories currently installed.)
Unpacking nvidia-current (from .../nvidia-current_195.36.15-0ubuntu2_i386.deb) ...
Selecting previously deselected package nvidia-settings.
Unpacking nvidia-settings (from .../nvidia-settings_195.36.08-0ubuntu2_i386.deb) ...
Processing triggers for man-db ...
Setting up nvidia-current (195.36.15-0ubuntu2) ...
update-alternatives: using /usr/lib/nvidia-current/ld.so.conf to provide /etc/ld.so.conf.d/GL.conf (gl_conf) in auto mode.
update-alternatives: warning: skip creation of /usr/lib32/vdpau/libvdpau_nvidia.so.1 because associated file /usr/lib32/nvidia-current/vdpau/libvdpau_nvidia.so.1 (of link group gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/lib32/libvdpau_nvidia.so because associated file /usr/lib32/nvidia-current/vdpau/libvdpau_nvidia.so (of link group gl_conf) doesn't exist.
update-initramfs: deferring update (trigger activated)
Loading new nvidia-current-195.36.15 DKMS files...
Building only for 2.6.32-22-generic
Building for architecture i686
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.

Setting up nvidia-settings (195.36.08-0ubuntu2) ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_GB.utf8.cache...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-22-generic
Processing triggers for python-support ...

JorgeT (jorget) wrote :

I got exactly the same error than Ian Johnston after the last update and the X crashed after reboot. I usually update my system each 2 weeks or less. To make that the X worked at least with the nouveau driver I had to erase the /etc/X11/xorg.conf file and restart. Now I have not acceleration with OpenGL and therefore no usefull XBMC neither KDE desktop effects. It is a bit frustrating.

I have lucid x86 in a Acer Aspire AX3900 with Nvidia Geforce315.

Ajay Roopakalu (ajay-roopakalu) wrote :

Had the same issue! For me, it was because I upgraded 9.10 -> 10.04 and kept my modified menu.lst file. Running uname -r returned 2.6.31-14 even though I was running Lucid. The latest updates messed up my nvidia drivers. I ended up manually editing the kernels that were being booted in my menu.lst file, updated grub, and uninstalled, reinstalled the nvidia drivers and it worked.

JorgeT (jorget) wrote :

I had solved my problem installing the kernel sources/headers and manually installing the nvidia-185 driver. Exactly I have executed the following commands:

sudo apt-get install linux-headers-2.6.32-22-generic (this was the key, the package that should be installed automatically in the update)
sudo apt-get remove --purge nvidia*
sudo apt-get install nvidia-185-kernel-source
sudo apt-get install nvidia-185-modaliases
sudo nano /etc/modprobe.d/blacklist.conf
(added the folowing lines to the end
blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv
)
sudo nvidia-xconfig

And it works perfectly, includng vdpau. XBMC now works like a charm.

I hope that this help somebody else.

Perfecto (perfecto) wrote :
Download full text (3.7 KiB)

I run this lines without problems:
sudo apt-get install linux-headers-2.6.32-22-generic (this was the key, the package that should be installed automatically in the update)
sudo apt-get remove --purge nvidia*

But when I tried the next line this is what I got:
perfe@mv64x2:~$ sudo apt-get install nvidia-185-kernel-source
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes extras:
  nvidia-current nvidia-settings
Se instalarán los siguientes paquetes NUEVOS:
  nvidia-185-kernel-source nvidia-current nvidia-settings
0 actualizados, 3 se instalarán, 0 para eliminar y 0 no actualizados.
1 no instalados del todo o eliminados.
Se necesita descargar 846kB/41,6MB de archivos.
Se utilizarán 135MB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? S
Des:1 http://archive.ubuntu.com/ubuntu/ lucid-updates/restricted nvidia-185-kernel-source 195.36.15-0ubuntu3 [4508B]
Des:2 http://archive.ubuntu.com/ubuntu/ lucid/main nvidia-settings 195.36.08-0ubuntu2 [841kB]
Descargados 846kB en 1s (451kB/s)
Seleccionando el paquete nvidia-current previamente no seleccionado.
(Leyendo la base de datos ... 00%
772008 ficheros y directorios instalados actualmente.)
Desempaquetando nvidia-current (de .../nvidia-current_195.36.15-0ubuntu3_amd64.deb) ...
Seleccionando el paquete nvidia-185-kernel-source previamente no seleccionado.
Desempaquetando nvidia-185-kernel-source (de .../nvidia-185-kernel-source_195.36.15-0ubuntu3_amd64.deb) ...
Seleccionando el paquete nvidia-settings previamente no seleccionado.
Desempaquetando nvidia-settings (de .../nvidia-settings_195.36.08-0ubuntu2_amd64.deb) ...
Procesando disparadores para man-db ...
Configurando adobereader-deu (9.3.2-2) ...
/var/lib/dpkg/info/adobereader-deu.postinst: 206: nspluginwrapper: not found
dpkg: error al procesar adobereader-deu (--configure):
 el subproceso script post-installation instalado devolvió el código de salida de error 127
Configurando nvidia-current (195.36.15-0ubuntu3) ...
update-alternatives: usar /usr/lib/nvidia-current/ld.so.conf para proporcionar /etc/ld.so.conf.d/GL.conf (gl_conf) en modo automático
update-initramfs: deferring update (trigger activated)
Loading new nvidia-current-195.36.15 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.32-22-generic
Building for architecture x86_64
Building initial module for 2.6.32-22-generic

Error! Bad return status for module build on kernel: 2.6.32-22-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-current/195.36.15/build/ for more information.
dpkg: error al procesar nvidia-current (--configure):
 el subproceso script post-installation instalado devolvió el código de salida de error 10
dpkg: problemas de dependencias impiden la configuración de nvidia-185-kernel-source:
 nvidia-185-kernel-source depende de nvidia-current; sin embargo:
 El paquete `nvidia-current' no está configurado todavía.
dpkg: error al procesar nvidia-185-kernel-source (--configure):
 problemas de dependencias - se deja sin configurar
Configurando nvidia-settings (195.36.08-0ubuntu2) .....

Read more...

Bryce Harrington (bryce) wrote :

Sounds like this was an error in the packaging that was subsequently resolved. Don't think there's anything needing to be done here.

affects: nvidia-graphics-drivers (Ubuntu) → dkms (Ubuntu)
Changed in dkms (Ubuntu):
status: Confirmed → Fix Released
Ian Johnston (ian-orbister) wrote :

'Fraid not. The problem persists - most recently in the kernel update last week.

Bryce Harrington (bryce) on 2011-01-18
Changed in dkms (Ubuntu):
status: Fix Released → New
Mario Limonciello (superm1) wrote :

It's certainly not an issue with DKMS if it's got the NVIDIA build log errors, assigning to right package.

affects: dkms (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: New → Confirmed
summary: - package nvidia-current 195.36.15-0ubuntu2 failed to install/upgrade:
- nvidia-current kernel module failed to build / make[2]: *** No rule to
- make target `modules'. Stop.
+ package nvidia-* failed to install/upgrade: nvidia-current kernel module
+ failed to build / make[2]: *** No rule to make target `modules'. Stop.
Daniel van Vugt (vanvugt) wrote :

Newer nvidia drivers with the error mentioning `module' instead of `modules' are experiencing similar bug 1410916.

dino99 (9d9) wrote :

This version has expired a while ago

Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: Confirmed → Invalid
Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Invalid
Changed in nvidia-graphics-drivers-367 (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers