nvidia-drivers-390 fail to build with kernel 5.3

Bug #1851162 reported by Ken Sharp on 2019-11-03
178
This bug affects 31 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-390 (Ubuntu)
High
Unassigned
Bionic
High
Alberto Milone

Bug Description

nvidia-graphics-drivers-390 fails to build against linux 5.3.

SRU Request:

[Test Case]
1) Enable the -proposed repository, and install the new 390 NVIDIA driver (nvidia-graphics-drivers-390_390.116-0ubuntu0.18.04.2).

2) Check that the kernel module can be built against the new kernel.

3) Restart your computer, and see if everything works correctly when
accessing the desktop.

[Regression Potential]
Low. The update only fixes build issues with Linux versions 5.3.
__________________________________
With linux-image-5.0.0-23 I had no problems. Following an update linux-image-5.3.0-19 was installed, the DKMS build failed, and the system became unusable.

Removing 5.3.0 brings the system back.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: nvidia-driver-390 390.116-0ubuntu0.18.04.1
ProcVersionSignature: Ubuntu 5.0.0-23.24~18.04.1-generic 5.0.15
Uname: Linux 5.0.0-23-generic x86_64
NonfreeKernelModules: nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu7.8
Architecture: amd64
CurrentDesktop: MATE
Date: Sun Nov 3 19:55:57 2019
InstallationDate: Installed on 2019-06-09 (147 days ago)
InstallationMedia: Ubuntu-MATE 18.04.2 LTS "Bionic Beaver" - Release amd64 (20190210)
SourcePackage: nvidia-graphics-drivers-390
UpgradeStatus: No upgrade log present (probably fresh install)

Ken Sharp (kennybobs) wrote :
Ken Sharp (kennybobs) wrote :

Build log attached.

description: updated
Ken Sharp (kennybobs) wrote :

The HWE package now force-upgrades to 5.3.0, rendering that entire package useless.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Confirmed
summary: nvidia-drivers-390 fail to build with DKMS and linux-image-5.3.0-19
+ [error: redefinition of ‘list_is_first’]
tags: added: eoan
Changed in nvidia-graphics-drivers-390 (Ubuntu):
importance: Undecided → High
summary: - nvidia-drivers-390 fail to build with DKMS and linux-image-5.3.0-19
- [error: redefinition of ‘list_is_first’]
+ nvidia-drivers-390 fail to build kernel 5.3 [error: redefinition of
+ ‘list_is_first’]
tags: added: rls-bb-incoming rls-ee-incoming
summary: - nvidia-drivers-390 fail to build kernel 5.3 [error: redefinition of
- ‘list_is_first’]
+ nvidia-drivers-390 fail to build with kernel 5.3
tags: added: regression-release
tags: added: regression-update
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux-hwe (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-390 (Ubuntu Bionic):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
description: updated

Hello Ken, or anyone else affected,

Accepted nvidia-graphics-drivers-390 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/390.116-0ubuntu0.18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in nvidia-graphics-drivers-390 (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Ken Sharp (kennybobs) wrote :

Updated Bionic with all the latest packages before adding -proposed.

Building module:
cleaning build area...
unset ARCH; env NV_VERBOSE=1 'make' -j16 NV_EXCLUDE_BUILD_MODULES='' KERNEL_UNAME=5.3.0-26-generic IGNORE_XEN_PRESENCE=1 IGNORE_CC_MISMATCH=1 SYSSRC=/lib/modules/5.3.0-26-generic/build LD=/usr/bin/ld.bfd modules......(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.3.0-26-generic (x86_64)
Consult /var/lib/dkms/nvidia/390.116/build/make.log for more information.
   ...done.

It seems to try twice during the update:

Building module:
cleaning build area...
unset ARCH; env NV_VERBOSE=1 'make' -j16 NV_EXCLUDE_BUILD_MODULES='' KERNEL_UNAME=5.3.0-26-generic IGNORE_XEN_PRESENCE=1 IGNORE_CC_MISMATCH=1 SYSSRC=/lib/modules/5.3.0-26-generic/build LD=/usr/bin/ld.bfd modules......(bad exit status: 2)
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/nvidia-kernel-source-390.0.crash'
Error! Bad return status for module build on kernel: 5.3.0-26-generic (x86_64)
Consult /var/lib/dkms/nvidia/390.116/build/make.log for more information.
   ...done.

Build log attached.

tags: added: verification-failed-bionic
removed: verification-needed-bionic
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu Bionic):
status: New → Confirmed
Changed in linux-hwe (Ubuntu Bionic):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

Hello Ken, or anyone else affected,

Accepted nvidia-graphics-drivers-390 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/390.116-0ubuntu0.18.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed-bionic
removed: verification-failed-bionic
Ingar Smedstad (ingsme) wrote :

Adding the patch from https://gist.github.com/wheresvic/1e526c3cd937414661ce6be7c5e4667d worked. I managed to build and install the driver.

Patch https://gist.github.com/wheresvic/a118420b9592088ea23c7414e7f2d676 resulted in failed build.

Théo Bueno (tbueno) wrote :

Problem fixed for me with 390.116-0ubuntu0.18.04.3 from bionic-proposed

Timo Aaltonen (tjaalton) on 2020-01-22
tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Ken Sharp (kennybobs) wrote :

All good here too with 390.116-0ubuntu0.18.04.3

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-390 - 390.116-0ubuntu0.18.04.3

---------------
nvidia-graphics-drivers-390 (390.116-0ubuntu0.18.04.3) bionic; urgency=medium

  * debian/dkms_nvidia/patches/buildfix_kernel_5.3.patch,
    debian/templates/dkms_nvidia.conf.in:
    - Fix build failure with Linux 5.3 (LP: #1851162).

nvidia-graphics-drivers-390 (390.116-0ubuntu0.18.04.2) bionic; urgency=medium

  * debian/dkms_nvidia/patches/buildfix_kernel_5.2.patch,
    debian/templates/dkms_nvidia.conf.in:
    - Fix build failure again Linux 5.3 (LP: #1851162).

 -- Alberto Milone <email address hidden> Wed, 22 Jan 2020 11:24:10 +0100

Changed in nvidia-graphics-drivers-390 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nvidia-graphics-drivers-390 has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: Confirmed → Fix Released
no longer affects: linux (Ubuntu)
no longer affects: linux-hwe (Ubuntu)
no longer affects: linux (Ubuntu Bionic)
no longer affects: linux-hwe (Ubuntu Bionic)
Jizhou Yang (teamchalise) wrote :

Confirming that updated drivers work on kernel 5.3.0-26. Thanks a million!

Bill (franksmcb) (franksmcb) wrote :

These are not working on 5.3.0-28

km (km-mathcs) wrote :

I took the kernel update to 5.3.0-28.30~18.04.1 as well as the 390.116-0ubuntu0.18.04.3 nvidia driver updaate. The driver built fine, and its running fine on 5.3.0-28 for me.

Alberto Milone (albertomilone) wrote :

@Bill: which driver doesn't work for you with 5.3.0-28?

Bill (franksmcb) (franksmcb) wrote :

@Alberto 390.116

There is more info on a duplicate bug but for brevity this is a T430 using NVIDIA GF108M [NVS 5400M]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions