nvidia-drivers-* are not on the ISO

Bug #1826844 reported by Jean-Baptiste Lallement on 2019-04-29
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-390 (Ubuntu)
High
Jean-Baptiste Lallement
Eoan
High
Jean-Baptiste Lallement
ubuntustudio-meta (Ubuntu)
Eoan
Undecided
Unassigned

Bug Description

On Ubuntu desktop, without a network connection, the user can select to install 3rd party drivers (which states that it'll install graphics driver) but even if he selects this option, nVidia proprietary drivers won't be installed because they are not on the pool of the ISO.

also tracked in the desktop trello board as card:
https://trello.com/c/rPiwDpPe/130-bug1826844-nvidia-drivers-are-not-on-the-iso

Adding both ubuntu-driver-390 and ubuntu-driver-418 to the pool, adds 114MB to the ISO.

Here is the list of packages that will be added to the pool:
libnvidia-cfg1-390
libnvidia-cfg1-418
libnvidia-common-390
libnvidia-common-418
libnvidia-compute-390
libnvidia-compute-418
libnvidia-decode-390
libnvidia-decode-418
libnvidia-encode-390
libnvidia-encode-418
libnvidia-fbc1-390
libnvidia-fbc1-418
libnvidia-gl-390
libnvidia-gl-418
libnvidia-ifr1-390
libnvidia-ifr1-418
libvdpau1
libxnvctrl0
mesa-vdpau-drivers
nvidia-compute-utils-390
nvidia-compute-utils-418
nvidia-dkms-390
nvidia-dkms-418
nvidia-driver-390
nvidia-driver-410
nvidia-driver-418
nvidia-kernel-common-390
nvidia-kernel-common-418
nvidia-kernel-source-390
nvidia-kernel-source-418
nvidia-prime
nvidia-settings
nvidia-utils-390
nvidia-utils-418
vdpau-driver-all
xserver-xorg-video-nvidia-390
xserver-xorg-video-nvidia-418

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: nvidia-driver-390 (not installed)
ProcVersionSignature: Ubuntu 5.0.0-13.14-generic 5.0.6
Uname: Linux 5.0.0-13-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Apr 29 10:22:44 2019
InstallationDate: Installed on 2014-07-15 (1749 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140520)
SourcePackage: nvidia-graphics-drivers-390
UpgradeStatus: Upgraded to eoan on 2018-03-24 (400 days ago)

Jean-Baptiste Lallement (jibel) wrote :
tags: added: rls-ee-incoming
Will Cooke (willcooke) on 2019-04-30
Changed in nvidia-graphics-drivers-390 (Ubuntu):
assignee: nobody → Will Cooke (willcooke)
tags: removed: rls-ee-incoming
Jean-Baptiste Lallement (jibel) wrote :

Need confirm any potential licensing issue.

description: updated
Changed in nvidia-graphics-drivers-390 (Ubuntu):
assignee: Will Cooke (willcooke) → nobody
importance: Undecided → High
status: New → Incomplete
Will Cooke (willcooke) wrote :

Have confirmed with Nvidia via sverdy. We are clear to distribute the drivers on the ISO.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: Incomplete → New
Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Triaged
Changed in nvidia-graphics-drivers-390 (Ubuntu Eoan):
assignee: nobody → Jean-Baptiste Lallement (jibel)
description: updated
description: updated
Changed in nvidia-graphics-drivers-390 (Ubuntu Eoan):
status: Triaged → Fix Released
Ramon Marquez (remarqueze) wrote :

This will be backported in the future next to 18.04 in one of your punctual updates? Are there no plans to include legacy versions for old hardware (nvidia-340 for example)?

Erich Eickmeyer (eeickmeyer) wrote :

Added ubuntustudio-meta to get this into our live session.

Michel-Ekimia (michel.ekimia) wrote :

Just to say we'd love to see this in 18.04.3.

Today (like system76 ) we have to handle 2 iso because 18.04.2 iso will not boot on nvidia hardware.

Fixing basic usage with nouveau could also be a solution, so user could at least install ubuntu.

Changed in ubuntustudio-meta (Ubuntu Eoan):
assignee: nobody → Erich Eickmeyer (eeickmeyer)
status: New → In Progress
Changed in ubuntustudio-meta (Ubuntu Eoan):
status: In Progress → Fix Committed
Changed in ubuntustudio-meta (Ubuntu Eoan):
assignee: Erich Eickmeyer (eeickmeyer) → nobody
no longer affects: ubuntustudio-meta (Ubuntu)
Changed in ubuntustudio-meta (Ubuntu Eoan):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers