Broken dependencies with nvidia-driver-390 and xserver-xorg-hwe-18.04 in bionic

Bug #1815579 reported by Leopoldo on 2019-02-12
44
This bug affects 10 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-340 (Ubuntu)
Critical
Alberto Milone
Bionic
Undecided
Unassigned
nvidia-graphics-drivers-390 (Ubuntu)
Critical
Alberto Milone
Bionic
Undecided
Unassigned

Bug Description

I am trying to test new HWE stack from 18.10 in my destkop Ubuntu 18.04.1 (expected release 18.04.2 this week) and I have broken dependencies when installing `xserver-xorg-hwe-18.04` package with NVidia drivers:

me@me-H110M-DS2:~$ sudo apt install xserver-xorg-hwe-18.04 xserver-xorg-video-nvidia-390
Reading package lists... Done
Building dependency tree
Reading state information... Done
xserver-xorg-video-nvidia-390 is already the newest version (390.77-0ubuntu0.18.04.1).
xserver-xorg-video-nvidia-390 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-hwe-18.04 : Depends: xserver-xorg-core-hwe-18.04 (>= 2:1.17.2-2) but it is not going to be installed
                          Conflicts: xserver-xorg-core (>= 0~)
                          Recommends: xserver-xorg-video-all-hwe-18.04 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Otherwise, if I try to install it without `xserver-xorg-video-nvidia-390` this happens:

me@me-H110M-DS2:~$ sudo apt install xserver-xorg-hwe-18.04
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  dkms libbsd0:i386 libdrm-amdgpu1:i386 libdrm-intel1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libelf1:i386 libexpat1:i386 libffi6:i386 libgl1:i386 libgl1-mesa-dri:i386
  libglapi-mesa:i386 libglvnd0:i386 libglx-mesa0:i386 libglx0:i386 libllvm7:i386 libnvidia-cfg1-390 libnvidia-common-390 libnvidia-compute-390 libnvidia-compute-390:i386 libnvidia-decode-390
  libnvidia-decode-390:i386 libnvidia-encode-390 libnvidia-encode-390:i386 libnvidia-fbc1-390 libnvidia-fbc1-390:i386 libnvidia-gl-390 libnvidia-gl-390:i386 libnvidia-ifr1-390 libnvidia-ifr1-390:i386
  libpciaccess0:i386 libsensors4:i386 libstdc++6:i386 libvdpau1 libwayland-client0:i386 libwayland-server0:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386
  libxcb-glx0:i386 libxcb-present0:i386 libxcb-sync1:i386 libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxnvctrl0 libxshmfence1:i386 libxxf86vm1:i386 mesa-vdpau-drivers
  nvidia-compute-utils-390 nvidia-dkms-390 nvidia-kernel-common-390 nvidia-kernel-source-390 nvidia-prime nvidia-settings nvidia-utils-390 pkg-config screen-resolution-extra vdpau-driver-all
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  xserver-xorg-core-hwe-18.04 xserver-xorg-input-all-hwe-18.04 xserver-xorg-input-libinput-hwe-18.04 xserver-xorg-video-all-hwe-18.04 xserver-xorg-video-amdgpu-hwe-18.04 xserver-xorg-video-ati-hwe-18.04
  xserver-xorg-video-fbdev-hwe-18.04 xserver-xorg-video-intel-hwe-18.04 xserver-xorg-video-nouveau-hwe-18.04 xserver-xorg-video-qxl-hwe-18.04 xserver-xorg-video-radeon-hwe-18.04
  xserver-xorg-video-vesa-hwe-18.04 xserver-xorg-video-vmware-hwe-18.04
Suggested packages:
  xfonts-100dpi | xfonts-75dpi firmware-amd-graphics xserver-xorg-video-r128 xserver-xorg-video-mach64 firmware-misc-nonfree
Recommended packages:
  xserver-xorg-input-wacom-hwe-18.04
The following packages will be REMOVED:
  nvidia-driver-390 xserver-xorg xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-libinput xserver-xorg-video-nvidia-390
The following NEW packages will be installed:
  xserver-xorg-core-hwe-18.04 xserver-xorg-hwe-18.04 xserver-xorg-input-all-hwe-18.04 xserver-xorg-input-libinput-hwe-18.04 xserver-xorg-video-all-hwe-18.04 xserver-xorg-video-amdgpu-hwe-18.04
  xserver-xorg-video-ati-hwe-18.04 xserver-xorg-video-fbdev-hwe-18.04 xserver-xorg-video-intel-hwe-18.04 xserver-xorg-video-nouveau-hwe-18.04 xserver-xorg-video-qxl-hwe-18.04
  xserver-xorg-video-radeon-hwe-18.04 xserver-xorg-video-vesa-hwe-18.04 xserver-xorg-video-vmware-hwe-18.04
0 upgraded, 14 newly installed, 6 to remove and 0 not upgraded.
Need to get 2.595 kB of archives.
After this operation, 4.327 kB disk space will be freed.
Do you want to continue? [Y/n]

------------------------------------------------------------------------

lsb_release -rd output:
Description: Ubuntu 18.04.2 LTS
Release: 18.04

apt-cache policy nvidia-driver-390 xserver-xorg-hwe-18.04 xserver-xorg-video-nvidia-390
nvidia-driver-390:
  Installed: 390.77-0ubuntu0.18.04.1
  Candidate: 390.77-0ubuntu0.18.04.1
  Version table:
 *** 390.77-0ubuntu0.18.04.1 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages
        100 /var/lib/dpkg/status
     390.48-0ubuntu3 500
        500 http://archive.ubuntu.com/ubuntu bionic/restricted amd64 Packages
xserver-xorg-hwe-18.04:
  Installed: (none)
  Candidate: 1:7.7+19ubuntu8~18.04.2
  Version table:
     1:7.7+19ubuntu8~18.04.2 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
xserver-xorg-video-nvidia-390:
  Installed: 390.77-0ubuntu0.18.04.1
  Candidate: 390.77-0ubuntu0.18.04.1
  Version table:
 *** 390.77-0ubuntu0.18.04.1 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages
        100 /var/lib/dpkg/status
     390.48-0ubuntu3 500
        500 http://archive.ubuntu.com/ubuntu bionic/restricted amd64 Packages

Expected to install xserver-xorg-hwe-18.04 without uninstalling any Nvidia related packages.

Broken packages and uninstalling nvidia-driver-390 is what happened instead.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-390 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → Critical
Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: New → Triaged
Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: Confirmed → Triaged
Changed in nvidia-graphics-drivers-340 (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Alberto Milone (albertomilone)

Hello Leopoldo, or anyone else affected,

Accepted nvidia-graphics-drivers-340 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-340/340.107-0ubuntu0.18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in nvidia-graphics-drivers-340 (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in nvidia-graphics-drivers-390 (Ubuntu Bionic):
status: New → Fix Committed
Andy Whitcroft (apw) wrote :

Hello Leopoldo, or anyone else affected,

Accepted nvidia-graphics-drivers-390 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/390.77-0ubuntu0.18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1815579

tags: added: iso-testing
Leopoldo (leops) wrote :

Tested `sudo apt install xserver-xorg-hwe-18.04` after activating proposed in the affected machine. Now working as intended. Rebooted, checked Xorg version with `sudo X -version` (X.Org X Server 1.20.1) and run `nvidia-smi` showing driver 390.77 version and installed cards without any issues.

So, this specific bug is fixed (I didn't test any further).

tags: added: verification-done-bionic
removed: verification-needed-bionic
Alberto Milone (albertomilone) wrote :

I can't reproduce the problem any more with 340 either:

~$ apt-cache policy nvidia-340
nvidia-340:
  Installed: 340.107-0ubuntu0.18.04.2
  Candidate: 340.107-0ubuntu0.18.04.2
  Version table:
 *** 340.107-0ubuntu0.18.04.2 400
        400 http://archive.ubuntu.com/ubuntu bionic-proposed/restricted amd64 Packages
        100 /var/lib/dpkg/status
     340.107-0ubuntu0.18.04.1 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages
     340.106-0ubuntu3 500
        500 http://archive.ubuntu.com/ubuntu bionic/restricted amd64 Packages

:~$ apt-cache policy xserver-xorg-hwe-18.04
xserver-xorg-hwe-18.04:
  Installed: 1:7.7+19ubuntu8~18.04.2
  Candidate: 1:7.7+19ubuntu8~18.04.2
  Version table:
 *** 1:7.7+19ubuntu8~18.04.2 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-340 - 340.107-0ubuntu0.18.04.2

---------------
nvidia-graphics-drivers-340 (340.107-0ubuntu0.18.04.2) bionic; urgency=medium

  * Add support for xserver-xorg-core-hwe-18.04 (LP: #1815579).

 -- Alberto Milone <email address hidden> Thu, 14 Feb 2019 16:48:59 +0100

Changed in nvidia-graphics-drivers-340 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nvidia-graphics-drivers-340 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-390 - 390.77-0ubuntu0.18.04.2

---------------
nvidia-graphics-drivers-390 (390.77-0ubuntu0.18.04.2) bionic; urgency=medium

  * debian/rules.defs:
    - Add support for xserver-xorg-core-hwe-18.04 (LP: #1815579).

 -- Alberto Milone <email address hidden> Thu, 14 Feb 2019 16:14:57 +0100

Changed in nvidia-graphics-drivers-390 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Roberto (roby-programmer) wrote :

Hello,
I was affected, I just now tried to re-install nvidia-390 (I purged everything about nvidia)

"sudo apt-get install nvidia-390", and after that and reboot everything works fine with 18.04 hwe kernel

390.87 nvidia driver installed (the link in the posts above is about 390.77 version), I don't know if my box get it from main repository or from nvidia-ppa, maybe second one

for me bug is closed

Petrika Janeku (janeku) wrote :

Hello.

Does this patch is included in Software&Updates -> Additional Drivers page and will be installed along proposed driver ?

I mean on my HP 8440p with Nvidia's NVS3100M (GT218M) suggested driver is 340.107 (proprietary, tested) .

Last time I tried tu upgrade from Nouveau to Nvidia drivers got stuck with black screen and broken

packages.

Petrika Janeku (janeku) wrote :
Download full text (14.5 KiB)

Just Downloaded
When I try to install with GDEBI , Lintian output says:
W: nvidia-340: package-name-doesnt-match-sonames libEGL1 libGL1 libGLESv1-CM1 libGLESv2-2 libnvcuvid1 libnvidia-cfg1 libnvidia-compiler340.107 libnvidia-eglcore340.107 libnvidia-encode1 libnvidia-fbc1 libnvidia-glcore340.107 libnvidia-glsi340.107 libnvidia-ifr1 libnvidia-ml1 libnvidia-tls340.107 libnvidia-wfb1
W: nvidia-340: hardening-no-relro usr/bin/nvidia-cuda-mps-control
W: nvidia-340: hardening-no-pie usr/bin/nvidia-cuda-mps-control
W: nvidia-340: hardening-no-relro usr/bin/nvidia-cuda-mps-server
W: nvidia-340: hardening-no-pie usr/bin/nvidia-cuda-mps-server
E: nvidia-340: embedded-library usr/bin/nvidia-debugdump: zlib
W: nvidia-340: hardening-no-relro usr/bin/nvidia-debugdump
W: nvidia-340: hardening-no-pie usr/bin/nvidia-debugdump
W: nvidia-340: hardening-no-relro usr/bin/nvidia-persistenced
W: nvidia-340: hardening-no-pie usr/bin/nvidia-persistenced
W: nvidia-340: hardening-no-relro usr/bin/nvidia-smi
W: nvidia-340: hardening-no-pie usr/bin/nvidia-smi
W: nvidia-340: hardening-no-relro usr/bin/nvidia-xconfig
W: nvidia-340: hardening-no-pie usr/bin/nvidia-xconfig
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/libEGL.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/libGL.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/libGLESv1_CM.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/libGLESv2.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/libnvcuvid.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/libnvidia-cfg.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/libnvidia-compiler.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/libnvidia-eglcore.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/libnvidia-encode.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/libnvidia-fbc.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/libnvidia-glcore.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/libnvidia-glsi.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/libnvidia-ifr.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/libnvidia-ml.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/libnvidia-tls.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/tls/libnvidia-tls.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/vdpau/libvdpau.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/vdpau/libvdpau_nvidia.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/i386-linux-gnu/vdpau/libvdpau_trace.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/nvidia-340/xorg/libglx.so.340.107
E: nvidia-340: embedded-library usr/lib/nvidia-340/xorg/nvidia_drv.so: libpng
E: nvidia-340: embedded-library usr/lib/nvidia-340/xorg/nvidia_drv.so: zlib
W: nvidia-340: hardening-no-relro usr/lib/nvidia-340/xorg/nvidia_drv.so
W: nvidia-340: hardening-no-relro usr/lib/x86_64-linux-gnu/libEGL.so.340.107
W: nvidia-340: hardening-no-relro usr/lib/x86_64-linux-gnu/libGL.so.340.107
W: nvidia-340: h...

Alberto Milone (albertomilone) wrote :

@Petrika: lintian errors or warnings won't affect the driver. As for broken packages and black screens, this fix is specific to users who have the xserver-xorg-hwe-18.04 package installed. A black screen can be caused by different things.

I am not sure why you would install the nvidia-340 package using gdebi.

Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: Triaged → Invalid
Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: Triaged → Invalid
Stefan (1tp93n) wrote :

This should also be fixed in the PPA:
ppa:graphics-drivers/ppa

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers