nvidia-dkms-390 390.77-0ubuntu0.18.04.1: nvidia kernel module failed to build [Cannot use CONFIG_STACK_VALIDATION=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel]

Bug #1810406 reported by mnovait on 2019-01-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-390 (Ubuntu)
Undecided
Unassigned

Bug Description

While upgrading kernel, whiptail process stucks and the update process hangs forever

nvidia-dkms-390 390.77-0ubuntu0.18.04.1: nvidia kernel module failed to build

root 25534 0.0 0.0 63712 4316 pts/0 S+ 13:02 0:00 | \_ sudo dpkg --configure -a
root 25535 0.0 0.0 26600 10952 pts/0 S+ 13:02 0:00 | \_ dpkg --configure -a
root 25570 0.0 0.0 4628 784 pts/0 S+ 13:02 0:00 | \_ /bin/sh /var/lib/dpkg/info/linux-headers-4.15.0-43-generic.postinst configure
root 25571 0.0 0.0 4520 768 pts/0 S+ 13:02 0:00 | \_ run-parts --report --exit-on-error --arg=4.15.0-43-generic /etc/kernel/header_postinst.d
root 25572 0.0 0.0 4628 1896 pts/0 S+ 13:02 0:00 | \_ /bin/sh /usr/lib/dkms/dkms_autoinstaller start 4.15.0-43-generic
root 25582 0.0 0.0 15896 6452 pts/0 S+ 13:02 0:00 | \_ /bin/bash /usr/sbin/dkms autoinstall --kernelver 4.15.0-43-generic
root 26396 0.0 0.0 16016 5724 pts/0 S+ 13:02 0:00 | \_ /bin/bash /usr/sbin/dkms autoinstall --kernelver 4.15.0-43-generic
root 1718 0.1 0.1 104160 22504 pts/0 S+ 13:02 0:00 | \_ /usr/bin/perl -w /usr/share/debconf/frontend /usr/sbin/update-secureboot-policy --enroll-key
root 1750 0.0 0.0 4628 1864 pts/0 S+ 13:02 0:00 | \_ /bin/sh /usr/sbin/update-secureboot-policy --enroll-key
root 1897 0.0 0.0 24924 4320 pts/0 S+ 13:03 0:00 | \_ whiptail --backtitle Package configuration --title Configuring Secure Boot --output-fd 12 --inputbox --
teo 22242 0.0 0.0 26560 8896 pts/2 Ss 13:00 0:00 \_ /bin/bash
teo 2054 0.0 0.0 37528 3596 pts/2 R+ 13:03 0:00 \_ ps ufax

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: nvidia-dkms-390 390.77-0ubuntu0.18.04.1
ProcVersionSignature: Ubuntu 4.15.0-42.45-generic 4.15.18
Uname: Linux 4.15.0-42-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
DKMSKernelVersion: 4.15.0-43-generic
Date: Thu Jan 3 13:02:14 2019
InstallationDate: Installed on 2017-04-06 (637 days ago)
InstallationMedia: Ubuntu 16.04.2 LTS "Xenial Xerus" - Release amd64 (20170215.2)
PackageVersion: 390.77-0ubuntu0.18.04.1
Python3Details: /usr/bin/python3.6, Python 3.6.7, python3-minimal, 3.6.7-1~18.04
PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 2.7.15~rc1-1
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu2.1
 apt 1.6.6
SourcePackage: nvidia-graphics-drivers-390
Title: nvidia-dkms-390 390.77-0ubuntu0.18.04.1: nvidia kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

mnovait (mnovait) wrote :
Daniel van Vugt (vanvugt) wrote :

Looks like a repeat of bug 1760876. But that's meant to be fixed already!?

DKMS make.log for nvidia-390.77 for kernel 4.15.0-43-generic (x86_64)
gio 3 gen 2019, 13.02.14, CET
make[1]: Entering directory '/usr/src/linux-headers-4.15.0-43-generic'
Makefile:975: "Cannot use CONFIG_STACK_VALIDATION=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel"
test -e include/generated/autoconf.h -a -e include/config/auto.conf || ( \
echo >&2; \
echo >&2 " ERROR: Kernel configuration is invalid."; \
echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
echo >&2 ; \
/bin/false)
mkdir -p /var/lib/dkms/nvidia/390.77/build/.tmp_versions ; rm -f /var/lib/dkms/nvidia/390.77/build/.tmp_versions/*

summary: - Whiptail stucks during kernel upgrade
+ nvidia-dkms-390 390.77-0ubuntu0.18.04.1: nvidia kernel module failed to
+ build [Cannot use CONFIG_STACK_VALIDATION=y, please install libelf-dev,
+ libelf-devel or elfutils-libelf-devel]

I could reproduce it at every kernel upgrade in the past 2 months.

Let me verify if it happens again.

thank you

Il giorno mer 9 gen 2019 alle ore 04:10 Daniel van Vugt <
<email address hidden>> ha scritto:

> Looks like a repeat of bug 1760876. But that's meant to be fixed
> already!?
>
> DKMS make.log for nvidia-390.77 for kernel 4.15.0-43-generic (x86_64)
> gio 3 gen 2019, 13.02.14, CET
> make[1]: Entering directory '/usr/src/linux-headers-4.15.0-43-generic'
> Makefile:975: "Cannot use CONFIG_STACK_VALIDATION=y, please install
> libelf-dev, libelf-devel or elfutils-libelf-devel"
> test -e include/generated/autoconf.h -a -e include/config/auto.conf || (
> \
> echo >&2; \
> echo >&2 " ERROR: Kernel configuration is invalid."; \
> echo >&2 " include/generated/autoconf.h or
> include/config/auto.conf are missing.";\
> echo >&2 " Run 'make oldconfig && make prepare' on kernel src to
> fix it."; \
> echo >&2 ; \
> /bin/false)
> mkdir -p /var/lib/dkms/nvidia/390.77/build/.tmp_versions ; rm -f
> /var/lib/dkms/nvidia/390.77/build/.tmp_versions/*
>
> ** Summary changed:
>
> - Whiptail stucks during kernel upgrade
> + nvidia-dkms-390 390.77-0ubuntu0.18.04.1: nvidia kernel module failed to
> build [Cannot use CONFIG_STACK_VALIDATION=y, please install libelf-dev,
> libelf-devel or elfutils-libelf-devel]
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1810406
>
> Title:
> nvidia-dkms-390 390.77-0ubuntu0.18.04.1: nvidia kernel module failed
> to build [Cannot use CONFIG_STACK_VALIDATION=y, please install libelf-
> dev, libelf-devel or elfutils-libelf-devel]
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1810406/+subscriptions
>

--

: : perchè usare formati aperti: *http://it.wikipedia.org/wiki/Formato_aperto
<http://it.wikipedia.org/wiki/Formato_aperto>*

: : Please, consider your environmental responsibility.
: : Before printing this e-mail ask yourself: "Do I need a hard copy?"

mnovait (mnovait) wrote :
Download full text (3.4 KiB)

I confirm that this still happens

  └─x-terminal-emul,30456 /usr/bin/x-terminal-emulator
      ├─bash,4624
      │ └─sudo,7217 apt dist-upgrade
      │ └─apt,7218 dist-upgrade
      │ └─dpkg,7845 --status-fd 62 --configure --pending
      │ └─linux-headers-4,9209 /var/lib/dpkg/info/linux-headers-4.15.0-44-generic.postinst configure
      │ └─run-parts,9210 --report --exit-on-error --arg=4.15.0-44-generic /etc/kernel/header_postinst.d
      │ └─dkms_autoinstal,9211 /usr/lib/dkms/dkms_autoinstaller start 4.15.0-44-generic
      │ └─dkms,9219 /usr/sbin/dkms autoinstall --kernelver 4.15.0-44-generic
      │ └─dkms,10053 /usr/sbin/dkms autoinstall --kernelver 4.15.0-44-generic
      │ └─frontend,11100 -w /usr/share/debconf/frontend /usr/sbin/update-secureboot-policy --enroll-key
      │ ├─update-securebo,11114 /usr/sbin/update-secureboot-policy --enroll-key
      │ └─whiptail,11129 --backtitle Package configuration --title Configuring Secure Boot --output-fd 12 --nocancel --msgbox...

teo 4624 0.0 0.0 26592 9236 pts/1 Ss 10:55 0:00 \_ /bin/bash
root 7217 0.0 0.0 63580 4228 pts/1 S+ 10:56 0:00 | \_ sudo apt dist-upgrade
root 7218 0.2 0.5 136428 85692 pts/1 S+ 10:56 0:01 | \_ apt dist-upgrade
root 7845 0.0 0.0 26548 10796 pts/2 Ss+ 10:56 0:00 | \_ /usr/bin/dpkg --status-fd 62 --configure --pending
root 9209 0.0 0.0 4628 776 pts/2 S+ 10:56 0:00 | \_ /bin/sh /var/lib/dpkg/info/linux-headers-4.15.0-44-generic.postinst configure
root 9210 0.0 0.0 4520 732 pts/2 S+ 10:56 0:00 | \_ run-parts --report --exit-on-error --arg=4.15.0-44-generic /etc/kernel/header_postinst.d
root 9211 0.0 0.0 4628 1732 pts/2 S+ 10:56 0:00 | \_ /bin/sh /usr/lib/dkms/dkms_autoinstaller start 4.15.0-44-generic
root 9219 0.0 0.0 15896 6348 pts/2 S+ 10:56 0:00 | \_ /bin/bash /usr/sbin/dkms autoinstall --kernelver 4.15.0-44-generic
root 10053 0.0 0.0 16012 5652 pts/2 S+ 10:56 0:00 | \_ /bin/bash /usr/sbin/dkms autoinstall --kernelver 4.15.0-44-generic
root 11100 0.0 0.1 104136 22572 pts/2 S+ 10:56 0:00 | \_ /usr/bin/perl -w /usr/share/debconf/frontend /usr/sbin/update-secureboot-policy --enroll-key
root 11114 0.0 0.0 4628 1780 pts/2 S+ 10:56 0:00 | \_ /bin/sh /usr/sbin/update-secureboot-policy --enroll-key
root 11129 0.0 0.0 25412 4664 pts/2 S+ 10:56 0:00 | \_ whiptail --backtitle Package configuration --title Configuring Secure Boot --output-fd 12 --nocancel -

teo@ux:/var/log/apt$ tail -n 6 term.log
Setting up linux-image-4.15.0-44-generic (4.15.0-44.47) ...
I: /vmlinuz.old is now a symlink to boot/vmlinuz-4.15.0...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers