Nvidia driver causes Xorg to use 100% CPU and huge lag when dragging glxgears or glxheads

Bug #1799679 reported by Daniel van Vugt on 2018-10-24
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-390 (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-410 (Ubuntu)
Undecided
Unassigned

Bug Description

Nvidia driver causes Xorg to use 100% CPU and shows high lag and stutter... but only when dragging glxgears/glxheads, or any window over them. Other apps do not exhibit the problem.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: nvidia-driver-390 390.87-0ubuntu1
ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
Uname: Linux 4.18.0-10-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
Date: Wed Oct 24 19:11:15 2018
InstallationDate: Installed on 2018-05-26 (151 days ago)
InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Alpha amd64 (20180525)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: nvidia-graphics-drivers-390
UpgradeStatus: No upgrade log present (probably fresh install)

Daniel van Vugt (vanvugt) wrote :
tags: added: performance
Daniel van Vugt (vanvugt) wrote :

Bug confirmed in two separate window managers so far:

  * Mutter / Gnome Shell

  * Metacity

description: updated
Daniel van Vugt (vanvugt) wrote :

Xorg profile of when I was just moving the glxgears window.

Daniel van Vugt (vanvugt) wrote :

Workaround:

  env __GL_SYNC_TO_VBLANK=0 glxgears

This seems to be why unsynchronized apps like glmark2 are unaffected by the bug.

summary: - Nvidia driver causes Xorg to use 100% CPU, but only when dragging
- glxgears, or any window over glxgears
+ Nvidia driver causes Xorg to use 100% CPU and huge lag when dragging
+ glxgears
summary: Nvidia driver causes Xorg to use 100% CPU and huge lag when dragging
- glxgears
+ glxgears or glxheads
description: updated
Daniel van Vugt (vanvugt) wrote :

A video showing the lag.

tags: added: disco
Daniel van Vugt (vanvugt) wrote :

The bug is also in nvidia-410.93 and nvidia-418.30 :(

tags: added: nvidia

I don't think it affects just glxgears, I experience it with pretty much any app that utilizes opengl, like Chromium or any Electron-based app like Slack or Discord.

Daniel van Vugt (vanvugt) wrote :

Yeah, it seems to be a general type of OpenGL application.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-410 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers