package libnvidia-compute-390 (not installed) failed to install/upgrade: '/usr/lib/x86_64-linux-gnu/libnvidia-ml.so'의 덮어쓰기를 시도합니다. 이 파일은 nvidia-340 340.106-0ubuntu3 패키지에도 들어있습니다

Bug #1773768 reported by Seongho Bae on 2018-05-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-390 (Ubuntu)
Undecided
Unassigned

Bug Description

Just tried the nvidia-cuda-dev on Quadro FX 1700.

seongho@onmyway:~$ sudo apt install nvidia-cuda-dev
패키지 목록을 읽는 중입니다... 완료
의존성 트리를 만드는 중입니다
상태 정보를 읽는 중입니다... 완료
다음 패키지가 자동으로 설치되었지만 더 이상 필요하지 않습니다:
  linux-headers-4.13.0-41
Use 'sudo apt autoremove' to remove it.
다음의 추가 패키지가 설치될 것입니다 :
  libaccinj64-9.1 libcublas9.1 libcudart9.1 libcufft9.1 libcufftw9.1
  libcuinj64-9.1 libcurand9.1 libcusolver9.1 libcusparse9.1 libnppc9.1
  libnppial9.1 libnppicc9.1 libnppicom9.1 libnppidei9.1 libnppif9.1
  libnppig9.1 libnppim9.1 libnppist9.1 libnppisu9.1 libnppitc9.1 libnpps9.1
  libnvblas9.1 libnvgraph9.1 libnvidia-compute-390 libnvrtc9.1 libnvtoolsext1
  libnvvm3 libthrust-dev libvdpau-dev
제안하는 패키지:
  nvidia-cuda-toolkit libvdpau-doc
추천하는 패키지:
  libnvcuvid1
다음 새 패키지를 설치할 것입니다:
  libaccinj64-9.1 libcublas9.1 libcudart9.1 libcufft9.1 libcufftw9.1
  libcuinj64-9.1 libcurand9.1 libcusolver9.1 libcusparse9.1 libnppc9.1
  libnppial9.1 libnppicc9.1 libnppicom9.1 libnppidei9.1 libnppif9.1
  libnppig9.1 libnppim9.1 libnppist9.1 libnppisu9.1 libnppitc9.1 libnpps9.1
  libnvblas9.1 libnvgraph9.1 libnvidia-compute-390 libnvrtc9.1 libnvtoolsext1
  libnvvm3 libthrust-dev libvdpau-dev nvidia-cuda-dev
0개 업그레이드, 30개 새로 설치, 0개 제거 및 37개 업그레이드 안 함.
547 M바이트 아카이브를 받아야 합니다.
이 작업 후 1,432 M바이트의 디스크 공간을 더 사용하게 됩니다.
계속 하시겠습니까? [Y/n] y
받기:1 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libaccinj64-9.1 amd64 9.1.85-3ubuntu1 [1,748 kB]
받기:2 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libcublas9.1 amd64 9.1.85-3ubuntu1 [25.0 MB]
받기:3 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libcudart9.1 amd64 9.1.85-3ubuntu1 [121 kB]
받기:4 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libcufft9.1 amd64 9.1.85-3ubuntu1 [76.1 MB]
받기:5 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libcufftw9.1 amd64 9.1.85-3ubuntu1 [131 kB]
받기:6 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/restricted amd64 libnvidia-compute-390 amd64 390.48-0ubuntu3 [20.6 MB]
받기:7 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libcuinj64-9.1 amd64 9.1.85-3ubuntu1 [1,878 kB]
받기:8 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libcurand9.1 amd64 9.1.85-3ubuntu1 [38.9 MB]
받기:9 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libcusolver9.1 amd64 9.1.85-3ubuntu1 [28.2 MB]
받기:10 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libcusparse9.1 amd64 9.1.85-3ubuntu1 [25.2 MB]
받기:11 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnppc9.1 amd64 9.1.85-3ubuntu1 [127 kB]
받기:12 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnppial9.1 amd64 9.1.85-3ubuntu1 [3,169 kB]
받기:13 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnppicc9.1 amd64 9.1.85-3ubuntu1 [1,376 kB]
받기:14 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnppicom9.1 amd64 9.1.85-3ubuntu1 [497 kB]
받기:15 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnppidei9.1 amd64 9.1.85-3ubuntu1 [1,673 kB]
받기:16 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnppif9.1 amd64 9.1.85-3ubuntu1 [20.9 MB]
받기:17 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnppig9.1 amd64 9.1.85-3ubuntu1 [9,960 kB]
받기:18 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnppim9.1 amd64 9.1.85-3ubuntu1 [2,295 kB]
받기:19 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnppist9.1 amd64 9.1.85-3ubuntu1 [4,910 kB]
받기:20 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnppisu9.1 amd64 9.1.85-3ubuntu1 [120 kB]
받기:21 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnppitc9.1 amd64 9.1.85-3ubuntu1 [714 kB]
받기:22 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnpps9.1 amd64 9.1.85-3ubuntu1 [2,568 kB]
받기:23 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnvblas9.1 amd64 9.1.85-3ubuntu1 [132 kB]
받기:24 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnvgraph9.1 amd64 9.1.85-3ubuntu1 [6,252 kB]
받기:25 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnvrtc9.1 amd64 9.1.85-3ubuntu1 [6,309 kB]
받기:26 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/main amd64 libvdpau-dev amd64 1.1.1-3ubuntu1 [35.8 kB]
받기:27 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnvtoolsext1 amd64 9.1.85-3ubuntu1 [31.3 kB]
받기:28 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libnvvm3 amd64 9.1.85-3ubuntu1 [4,274 kB]
받기:29 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 libthrust-dev all 1.9.1~9.1.85-3ubuntu1 [461 kB]
받기:30 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 nvidia-cuda-dev amd64 9.1.85-3ubuntu1 [263 MB]
내려받기 547 M바이트, 소요시간 35초 (15.7 M바이트/초)
Selecting previously unselected package libaccinj64-9.1:amd64.
(데이터베이스 읽는중 ...현재 559978개의 파일과 디렉터리가 설치되어 있습니다.)
Preparing to unpack .../00-libaccinj64-9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libaccinj64-9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libcublas9.1:amd64.
Preparing to unpack .../01-libcublas9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libcublas9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libcudart9.1:amd64.
Preparing to unpack .../02-libcudart9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libcudart9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libcufft9.1:amd64.
Preparing to unpack .../03-libcufft9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libcufft9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libcufftw9.1:amd64.
Preparing to unpack .../04-libcufftw9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libcufftw9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnvidia-compute-390:amd64.
Preparing to unpack .../05-libnvidia-compute-390_390.48-0ubuntu3_amd64.deb ...
Unpacking libnvidia-compute-390:amd64 (390.48-0ubuntu3) ...
dpkg: error processing archive /tmp/apt-dpkg-install-2KRnz0/05-libnvidia-compute-390_390.48-0ubuntu3_amd64.deb (--unpack):
 '/usr/lib/x86_64-linux-gnu/libnvidia-ml.so'의 덮어쓰기를 시도합니다. 이 파일은 nvidia-340 340.106-0ubuntu3 패키지에도 들어있습니다
Selecting previously unselected package libcuinj64-9.1:amd64.
Preparing to unpack .../06-libcuinj64-9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libcuinj64-9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libcurand9.1:amd64.
Preparing to unpack .../07-libcurand9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libcurand9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libcusolver9.1:amd64.
Preparing to unpack .../08-libcusolver9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libcusolver9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libcusparse9.1:amd64.
Preparing to unpack .../09-libcusparse9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libcusparse9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnppc9.1:amd64.
Preparing to unpack .../10-libnppc9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnppc9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnppial9.1:amd64.
Preparing to unpack .../11-libnppial9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnppial9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnppicc9.1:amd64.
Preparing to unpack .../12-libnppicc9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnppicc9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnppicom9.1:amd64.
Preparing to unpack .../13-libnppicom9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnppicom9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnppidei9.1:amd64.
Preparing to unpack .../14-libnppidei9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnppidei9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnppif9.1:amd64.
Preparing to unpack .../15-libnppif9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnppif9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnppig9.1:amd64.
Preparing to unpack .../16-libnppig9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnppig9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnppim9.1:amd64.
Preparing to unpack .../17-libnppim9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnppim9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnppist9.1:amd64.
Preparing to unpack .../18-libnppist9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnppist9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnppisu9.1:amd64.
Preparing to unpack .../19-libnppisu9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnppisu9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnppitc9.1:amd64.
Preparing to unpack .../20-libnppitc9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnppitc9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnpps9.1:amd64.
Preparing to unpack .../21-libnpps9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnpps9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnvblas9.1:amd64.
Preparing to unpack .../22-libnvblas9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnvblas9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnvgraph9.1:amd64.
Preparing to unpack .../23-libnvgraph9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnvgraph9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnvrtc9.1:amd64.
Preparing to unpack .../24-libnvrtc9.1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnvrtc9.1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libvdpau-dev:amd64.
Preparing to unpack .../25-libvdpau-dev_1.1.1-3ubuntu1_amd64.deb ...
Unpacking libvdpau-dev:amd64 (1.1.1-3ubuntu1) ...
Selecting previously unselected package libnvtoolsext1:amd64.
Preparing to unpack .../26-libnvtoolsext1_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnvtoolsext1:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libnvvm3:amd64.
Preparing to unpack .../27-libnvvm3_9.1.85-3ubuntu1_amd64.deb ...
Unpacking libnvvm3:amd64 (9.1.85-3ubuntu1) ...
Selecting previously unselected package libthrust-dev.
Preparing to unpack .../28-libthrust-dev_1.9.1~9.1.85-3ubuntu1_all.deb ...
Unpacking libthrust-dev (1.9.1~9.1.85-3ubuntu1) ...
Selecting previously unselected package nvidia-cuda-dev.
Preparing to unpack .../29-nvidia-cuda-dev_9.1.85-3ubuntu1_amd64.deb ...
Unpacking nvidia-cuda-dev (9.1.85-3ubuntu1) ...
처리하는데 오류가 발생했습니다:
 /tmp/apt-dpkg-install-2KRnz0/05-libnvidia-compute-390_390.48-0ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
seongho@onmyway:~$ apt-cache policy nvidia-cuda-
nvidia-cuda-dev nvidia-cuda-gdb
nvidia-cuda-doc nvidia-cuda-toolkit
seongho@onmyway:~$ apt-cache policy nvidia-cuda-dev
nvidia-cuda-dev:
  설치: 9.1.85-3ubuntu1
  후보: 9.1.85-3ubuntu1
  버전 테이블:
 *** 9.1.85-3ubuntu1 500
        500 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu bionic/multiverse amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: libnvidia-compute-390 (not installed)
ProcVersionSignature: Ubuntu 4.15.0-20.21-lowlatency 4.15.17
Uname: Linux 4.15.0-20-lowlatency x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
Date: Mon May 28 19:53:11 2018
ErrorMessage: '/usr/lib/x86_64-linux-gnu/libnvidia-ml.so'의 덮어쓰기를 시도합니다. 이 파일은 nvidia-340 340.106-0ubuntu3 패키지에도 들어있습니다
InstallationDate: Installed on 2016-07-30 (667 days ago)
InstallationMedia: It
Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal, 3.6.5-3
PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 2.7.15~rc1-1
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu2
 apt 1.6.1
SourcePackage: nvidia-graphics-drivers-390
Title: package libnvidia-compute-390 (not installed) failed to install/upgrade: '/usr/lib/x86_64-linux-gnu/libnvidia-ml.so'의 덮어쓰기를 시도합니다. 이 파일은 nvidia-340 340.106-0ubuntu3 패키지에도 들어있습니다
UpgradeStatus: Upgraded to bionic on 2018-05-12 (16 days ago)

Seongho Bae (seongho) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers