Activity log for bug #1769857

Date Who What changed Old value New value Message
2018-05-08 10:21:20 nastys bug added bug
2018-05-08 10:30:44 nastys bug task added gdm3 (Ubuntu)
2018-05-08 10:31:15 nastys description OS: Ubuntu 18.04 bionic Kernel: x86_64 Linux 4.15.0-20-generic DE: GNOME CPU: Intel Core i5-7200U @ 4x 3.1GHz GPU: Intel HD 620 + NVIDIA GeForce 940MX (Optimus) UEFI boot, Secure Boot disabled. I installed the proprietary graphics driver with Software Properties and Vulkan applications (e.g. vulkan-smoketest, Unreal Editor, SDK examples, Dolphin) were working fine. To get rid of tearing I added nvidia-drm.modeset=1 to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub, then ran update-grub && update-initramfs -u and rebooted. After doing that, Vulkan applications stopped working because they couldn't initialize the Vulkan swap chain until I reverted the changes to GRUB. Other GNU/Linux distributions such as Manjaro don't seem to be affected which is why I'm reporting this here. OS: Ubuntu 18.04 bionic Kernel: x86_64 Linux 4.15.0-20-generic DE: GNOME CPU: Intel Core i5-7200U @ 4x 3.1GHz GPU: Intel HD 620 + NVIDIA GeForce 940MX (Optimus) UEFI boot, Secure Boot disabled. I installed the proprietary graphics driver with Software Properties and Vulkan applications (e.g. vulkan-smoketest, Unreal Editor, SDK examples, Dolphin) were working fine. To get rid of tearing I added nvidia-drm.modeset=1 to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub, then ran update-grub && update-initramfs -u and rebooted. After doing that, Vulkan applications stopped working because they couldn't initialize the Vulkan swap chain until I reverted the changes to GRUB. Everything works fine if lightdm is used instead of gdm3.
2018-05-08 10:31:32 nastys summary Vulkan not working if nvidia-drm.modeset=1 is set (Optimus) Vulkan not working if nvidia-drm.modeset=1 is set and gdm3 is used (Optimus)
2018-05-08 10:31:54 nastys description OS: Ubuntu 18.04 bionic Kernel: x86_64 Linux 4.15.0-20-generic DE: GNOME CPU: Intel Core i5-7200U @ 4x 3.1GHz GPU: Intel HD 620 + NVIDIA GeForce 940MX (Optimus) UEFI boot, Secure Boot disabled. I installed the proprietary graphics driver with Software Properties and Vulkan applications (e.g. vulkan-smoketest, Unreal Editor, SDK examples, Dolphin) were working fine. To get rid of tearing I added nvidia-drm.modeset=1 to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub, then ran update-grub && update-initramfs -u and rebooted. After doing that, Vulkan applications stopped working because they couldn't initialize the Vulkan swap chain until I reverted the changes to GRUB. Everything works fine if lightdm is used instead of gdm3. OS: Ubuntu 18.04 bionic Kernel: x86_64 Linux 4.15.0-20-generic DE: GNOME CPU: Intel Core i5-7200U @ 4x 3.1GHz GPU: Intel HD 620 + NVIDIA GeForce 940MX (Optimus) UEFI boot, Secure Boot disabled. I installed the proprietary graphics driver with Software Properties and Vulkan applications (e.g. vulkan-smoketest, Unreal Editor, SDK examples, Dolphin) were working fine. To get rid of tearing I added nvidia-drm.modeset=1 to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub, then ran update-grub && update-initramfs -u and rebooted. After doing that, Vulkan applications stopped working because they couldn't initialize the Vulkan swap chain until I reverted the changes to GRUB. Everything works as expected if lightdm is used instead of gdm3.
2018-05-08 15:55:17 nastys description OS: Ubuntu 18.04 bionic Kernel: x86_64 Linux 4.15.0-20-generic DE: GNOME CPU: Intel Core i5-7200U @ 4x 3.1GHz GPU: Intel HD 620 + NVIDIA GeForce 940MX (Optimus) UEFI boot, Secure Boot disabled. I installed the proprietary graphics driver with Software Properties and Vulkan applications (e.g. vulkan-smoketest, Unreal Editor, SDK examples, Dolphin) were working fine. To get rid of tearing I added nvidia-drm.modeset=1 to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub, then ran update-grub && update-initramfs -u and rebooted. After doing that, Vulkan applications stopped working because they couldn't initialize the Vulkan swap chain until I reverted the changes to GRUB. Everything works as expected if lightdm is used instead of gdm3. Lenovo ideapad 510-15IKB OS: Ubuntu 18.04 bionic Kernel: x86_64 Linux 4.15.0-20-generic DE: GNOME CPU: Intel Core i5-7200U @ 4x 3.1GHz GPU: Intel HD 620 + NVIDIA GeForce 940MX (Optimus) UEFI boot, Secure Boot disabled. I installed the proprietary graphics driver with Software Properties and Vulkan applications (e.g. vulkan-smoketest, Unreal Editor, SDK examples, Dolphin) were working fine. To get rid of tearing I added nvidia-drm.modeset=1 to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub, then ran update-grub && update-initramfs -u and rebooted. After doing that, Vulkan applications stopped working because they couldn't initialize the Vulkan swap chain until I reverted the changes to GRUB. Everything works as expected if lightdm is used instead of gdm3.
2018-05-09 02:08:35 Daniel van Vugt gdm3 (Ubuntu): status New Invalid
2018-05-10 02:40:57 Daniel van Vugt gdm3 (Ubuntu): status Invalid New
2018-10-16 21:58:38 Launchpad Janitor gdm3 (Ubuntu): status New Confirmed
2018-10-16 21:58:38 Launchpad Janitor nvidia-graphics-drivers-390 (Ubuntu): status New Confirmed
2018-10-17 01:41:49 Daniel van Vugt tags bionic nvidia
2018-11-10 16:09:40 Dario Jorge Vázquez Arguija bug added subscriber Dario Jorge Vázquez Arguija
2018-11-16 13:23:22 Jaap Buurman bug added subscriber Jaap Buurman
2019-01-05 10:57:22 Asa Zernik bug added subscriber Asa Zernik
2019-03-05 04:40:03 Griffin Nicoll bug added subscriber Griffin Nicoll
2019-03-05 04:40:46 Griffin Nicoll removed subscriber Griffin Nicoll
2019-04-23 01:49:46 Daniel van Vugt bug task added nvidia-graphics-drivers-418 (Ubuntu)
2019-04-23 01:49:53 Daniel van Vugt nvidia-graphics-drivers-418 (Ubuntu): status New Confirmed
2019-04-23 01:50:04 Daniel van Vugt tags bionic nvidia bionic disco nvidia nvidia-drm.modeset
2019-06-13 09:20:13 Daniel van Vugt gdm3 (Ubuntu): status Confirmed Invalid
2019-06-16 02:08:01 Bradley Clemetson bug added subscriber Bradley Clemetson
2019-08-08 13:54:01 Rocko bug added subscriber Rocko
2019-09-08 14:28:18 Thomas Barbier bug added subscriber Thomas Barbier
2019-10-17 11:16:59 Tom Reynolds bug added subscriber Ubuntu-discuss Bug team
2019-12-01 22:21:01 Anton Palmqvist bug added subscriber Anton Palmqvist
2020-03-15 12:51:42 Arthur Blair bug added subscriber Arthur Blair
2020-06-27 19:37:53 Sérgio Faria bug added subscriber Sérgio Faria