[nvidia] Xorg crashes after system sleep / wakeup, in libwfb.so+25597 → nvidia_drv.so+60a46c → [heap]+d35cb0

Bug #1769819 reported by Ákos Maróy on 2018-05-08
38
This bug affects 9 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-390 (Ubuntu)
High
Unassigned
xorg-server (Ubuntu)
High
Unassigned

Bug Description

after putting the system to sleep, and waking it up, Xorg crashes, and I'm lead to a new greeter / login screen. naturally the state of my desktop is lost in this process, and I'm stuck with a new login with no apps running.

the error reporter says:

Error: [Errno 21] is a directory: '/proc/driver/nvidia/gpus/0000:01:00.0/'

which is indeed true:

$ ls /proc/driver/nvidia/gpus/0000\:01\:00.0/
information registry

the same system worked fine with ubuntu 17.10

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xserver-xorg-core 2:1.19.6-1ubuntu4
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
.proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0000:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 390.48 Thu Mar 22 00:42:57 PDT 2018
 GCC version: gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)
.proc.driver.nvidia.warnings.fbdev:
 Your system is not currently configured to drive a VGA console
 on the primary VGA device. The NVIDIA Linux graphics driver
 requires the use of a text-mode VGA console. Use of other console
 drivers including, but not limited to, vesafb, may result in
 corruption and stability problems, and is not supported.
.tmp.unity_support_test.0:

ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Tue May 8 07:51:42 2018
DistUpgraded: 2018-05-04 09:38:04,874 DEBUG Running PostInstallScript: './xorg_fix_proprietary.py'
DistroCodename: bionic
DistroVariant: ubuntu
DkmsStatus:
 nvidia, 390.48, 4.13.0-39-generic, x86_64: installed
 nvidia, 390.48, 4.15.0-20-generic, x86_64: installed
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: Gigabyte Technology Co., Ltd Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [1458:d000]
 NVIDIA Corporation GK104 [GeForce GTX 680] [10de:1180] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: eVga.com. Corp. GK104 [GeForce GTX 680] [3842:3687]
InstallationDate: Installed on 2016-04-03 (764 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
MachineType: Gigabyte Technology Co., Ltd. Z97X-UD5H
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-20-generic root=UUID=e56cb504-229d-4c7a-b16c-b259d05e992b ro noprompt quiet splash vt.handoff=1
SourcePackage: xorg-server
UpgradeStatus: Upgraded to bionic on 2018-05-04 (3 days ago)
dmi.bios.date: 08/03/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: F10
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z97X-UD5H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF10:bd08/03/2015:svnGigabyteTechnologyCo.,Ltd.:pnZ97X-UD5H:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnZ97X-UD5H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: Z97X-UD5H
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.13.1+18.04.20180302-0ubuntu1
version.libdrm2: libdrm2 2.4.91-2
version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.0~rc5-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.0~rc5-1ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2
xserver.bootTime: Mon May 7 08:48:46 2018
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.19.6-1ubuntu4

Ákos Maróy (akos-maroy) wrote :
Daniel van Vugt (vanvugt) wrote :

In order to debug a crash we will need a crash report. To create one, please:

1. Apply the workaround from bug 994921.

2. Reproduce the crash.

3. Look in /var/crash for crash files and when found, run:
   ubuntu-bug /var/crash/YOURFILE.crash

4. Add a comment here telling us the ID of the new bug that was created in step 3.

Changed in xorg-server (Ubuntu):
status: New → Incomplete
Ákos Maróy (akos-maroy) wrote :

can you be more specific about the workaround. I read but 994921, but didn't find a clear reference as to what would need to be done

Daniel van Vugt (vanvugt) wrote :

It's at the top of bug 994921.

Additionally, or alternatively please uncomment this option from /etc/gdm3/custom.conf:

# Additionally lets the X server dump core if it crashes
#Enable=true

and reboot.

Ákos Maróy (akos-maroy) wrote :

done. the new bug is bug #1770322

this was created by running ubuntu-bug xserver-xorg-core

I wasn't able to determine the big ID when running ubuntu-bug /var/crash/_usr_lib_xorg_Xorg.0.crash . also the system seemed to automatically run ubuntu-bug /var/crash/_usr_lib_xorg_Xorg.0.crash after logging in

Daniel van Vugt (vanvugt) wrote :

To see previously reported crashes, try this:

https://errors.ubuntu.com/user/ID
where ID is the contents of /var/lib/whoopsie/whoopsie-id

Launchpad Janitor (janitor) wrote :

[Expired for xorg-server (Ubuntu) because there has been no activity for 60 days.]

Changed in xorg-server (Ubuntu):
status: Incomplete → Expired
Changed in xorg-server (Ubuntu):
status: Expired → New
Daniel van Vugt (vanvugt) wrote :

Thanks for the link.

It appears your crash occurred in the nvidia graphics driver (version 390):

Xorg (7) /lib/x86_64-linux-gnu/libgcc_s.so.1+11ba4 → /lib/x86_64-linux-gnu/libc-2.27.so+165f21 → /lib/x86_64-linux-gnu/libgcc_s.so.1+12da5 → /lib/x86_64-linux-gnu/libgcc_s.so.1+f373 → /lib/x86_64-linux-gnu/libgcc_s.so.1+10550 → /lib/x86_64-linux-gnu/libgcc_s.so.1+1138c → /lib/x86_64-linux-gnu/libc-2.27.so+131168 → /usr/lib/xorg/Xorg+1b88ad → /usr/lib/xorg/Xorg+1bc649 → /lib/x86_64-linux-gnu/libpthread-2.27.so+12890 → /lib/x86_64-linux-gnu/ld-2.27.so+fe47 → /lib/x86_64-linux-gnu/ld-2.27.so+1770a → /usr/lib/xorg/modules/libwfb.so+25597 → /usr/lib/x86_64-linux-gnu/nvidia/xorg/nvidia_drv.so+60a46c → [heap]+d35cb0

That's something which isn't open source but hopefully a future update from Nvidia will resolve it.

If the cause of the crash is in the open source parts of that stack trace, we can't tell, unfortunately.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
importance: Undecided → High
Changed in xorg-server (Ubuntu):
importance: Undecided → High
tags: added: nvidia
summary: - Xorg crashes after system sleep / wakeup
+ [nvidia] Xorg crashes after system sleep / wakeup
summary: - [nvidia] Xorg crashes after system sleep / wakeup
+ [nvidia] Xorg crashes after system sleep / wakeup, in libwfb.so+25597 →
+ nvidia_drv.so+60a46c → [heap]+d35cb0
Alan Jenkins (aj504) wrote :

CurrentDmesg.txt:

[58189.152330] PM: suspend exit
[58189.162027] Read-error on swap-device (253:0:361608)
[58189.167038] Read-error on swap-device (253:0:361672)

"People die when they are killed". Specifically "Read-error on swap-device" kills you with SIGBUS. Mystery solved.

I really expect if you looked at the crash, you would notice it is SIGBUS, with si_code == BUS_ADRERR (2). This means a read error when trying to load a page of virtual memory back in from swap or from the filesystem.

There's a common bug which matches this, so please read #1776887
"Critical upstream bugfix missing in Ubuntu 18.04 - frequent Xorg crash after suspend".

I'm sure this applies to at least some users who marked themselves as affected, or some duplicates of this bug. This particular kernel log includes some other errors as well though, so I can't rule out that they also have some relation.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Confirmed
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Karl Kastner (kastner-karl) wrote :

This happens to my XMG/Clevo W230s with GM107M [GeForce GTX 860M]. I have an external monitor connected and disable the laptop screen with xrandr --output eDP-1-1 --off. When I suspend and close the lid, then disconnect the VGA cable and therefafter resuspend, Xorg crashes and I have to login again. It also kills screen sessions running in the background. This seems to be related to bug #1421808

To post a comment you must log in.