Needs udev rule to create /dev/nvidia-uvm-tools device node

Bug #1767777 reported by Graham Inggs on 2018-04-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-390 (Ubuntu)
Medium
Alberto Milone
Bionic
Undecided
Unassigned

Bug Description

Without nvidia-modprobe installed, attempting to profile a CUDA executable using nvprof as a normal user fails with:
======== Error: unified memory profiling failed.

After installing nvidia-modprobe, profiling succeeds.

After rebooting, with or without nvidia-modprobe installed:

$ lsmod | grep nv
nvidia_uvm 757760 0
nvidia_drm 40960 5
nvidia_modeset 1110016 7 nvidia_drm
nvidia 14340096 386 nvidia_modeset,nvidia_uvm
drm_kms_helper 167936 1 nvidia_drm
drm 401408 8 nvidia_drm,drm_kms_helper
ipmi_msghandler 53248 2 nvidia,ipmi_devintf

ls -l /dev/nv*
crw-rw-rw- 1 root root 195, 0 Apr 29 10:16 /dev/nvidia0
crw-rw-rw- 1 root root 195, 255 Apr 29 10:16 /dev/nvidiactl
crw-rw-rw- 1 root root 195, 254 Apr 29 10:16 /dev/nvidia-modeset
crw-rw-rw- 1 root root 241, 0 Apr 29 10:16 /dev/nvidia-uvm

With nvidia-modprobe installed, after successfully running nvprof:

$ lsmod | grep nv
nvidia_uvm 757760 0
nvidia_drm 40960 5
nvidia_modeset 1110016 7 nvidia_drm
nvidia 14340096 389 nvidia_modeset,nvidia_uvm
drm_kms_helper 167936 1 nvidia_drm
drm 401408 8 nvidia_drm,drm_kms_helper
ipmi_msghandler 53248 2 nvidia,ipmi_devintf

$ ls -l /dev/nv*
crw-rw-rw- 1 root root 195, 0 Apr 29 10:45 /dev/nvidia0
crw-rw-rw- 1 root root 195, 255 Apr 29 10:45 /dev/nvidiactl
crw-rw-rw- 1 root root 195, 254 Apr 29 10:45 /dev/nvidia-modeset
crw-rw-rw- 1 root root 241, 0 Apr 29 10:45 /dev/nvidia-uvm
crw-rw-rw- 1 root root 241, 1 Apr 29 10:56 /dev/nvidia-uvm-tools

See also:
https://bugs.launchpad.net/ubuntu/+source/nvidia-modprobe/+bug/1421209/comments/4
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-352/+bug/1540896

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Alberto Milone (albertomilone)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-390 - 390.48-0ubuntu4

---------------
nvidia-graphics-drivers-390 (390.48-0ubuntu4) cosmic; urgency=medium

  [ Alberto Milone ]
  * debian/templates/nvidia-kernel-common-flavour.{install|maintscript}.in:
    - Install the modprobe file in /lib (LP: #1761593).

  [ Graham Inggs ]
  * debian/create-uvm-dev-node:
    - Create the /dev/nvidia-uvm-tools device node (LP: #1767777).

 -- Alberto Milone <email address hidden> Tue, 15 May 2018 12:42:43 +0200

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers