Nvidia+XFCE: Totem window is see-through during playback, colours washed out

Bug #1767711 reported by Moses Moore on 2018-04-28
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-390 (Ubuntu)
Undecided
Unassigned
totem (Ubuntu)
Undecided
Unassigned
xfce4 (Ubuntu)
Undecided
Unassigned

Bug Description

Since the upgrade to Ubuntu 18.04, the Totem player will show everything behind it during playback, and the colours of the video are washed-out. https://i.imgur.com/0AwJMmf.jpg I did not find 'tranparency' nor 'opacity' setting in the program preferences, and the colour adjudgement settings are pinned to +/-0.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: totem 3.26.0-0ubuntu6
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat Apr 28 14:56:29 2018
InstallationDate: Installed on 2016-06-05 (692 days ago)
InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
SourcePackage: totem
UpgradeStatus: Upgraded to bionic on 2018-04-27 (1 days ago)

Moses Moore (moses-ubuntu) wrote :
Daniel van Vugt (vanvugt) wrote :

Do you find the same problem in gedit and gnome-calculator? (bug 1760818)

description: updated
Changed in totem (Ubuntu):
status: New → Incomplete
Moses Moore (moses-ubuntu) wrote :

gnome-calculator (3.28.0): does not have the same problem.
gedit (3.28.1): does not have the same problem.

Other video players (VLC, mplayer, parole) do not have the same problem.

summary: - window is see-through during playback, colours washed out
+ Nvidia+XFCE: Totem window is see-through during playback, colours washed
+ out
Changed in totem (Ubuntu):
status: Incomplete → New
tags: added: nvidia

What output do you get when opening the Totem player from a terminal window?

The builtin compositor can be disabled via xfwm4-tweaks-settings, and that will most likely prevent the issue from occurring. Other than that, I suggest to test with a different window manager (e.g. "marco --replace", afterwards "xfwm4 --replace").

Changed in xfce4 (Ubuntu):
status: New → Incomplete
Moses Moore (moses-ubuntu) wrote :

> what output do you get when launching totem from a terminal

moses@jolyne:~/Videos$ totem vapourwave.mp4

(totem:27938): Gtk-WARNING **: 15:09:23.719: Calling org.xfce.Session.Manager.Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: Method "Inhibit" with signature "susu" on interface "org.xfce.Session.Manager" doesn't exist

... nothing else while the video is playing. After quitting totem I see this:

(totem:27938): GLib-GObject-WARNING **: 15:10:38.356: invalid (NULL) pointer instance

(totem:27938): GLib-GObject-CRITICAL **: 15:10:38.356: g_signal_handlers_disconnect_matched: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(totem:27938): GLib-GObject-WARNING **: 15:10:38.356: invalid (NULL) pointer instance

(totem:27938): GLib-GObject-CRITICAL **: 15:10:38.356: g_signal_handlers_disconnect_matched: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(totem:27938): GLib-GObject-WARNING **: 15:10:38.356: invalid (NULL) pointer instance

(totem:27938): GLib-GObject-CRITICAL **: 15:10:38.356: g_signal_handlers_disconnect_matched: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(totem:27938): Totem-CRITICAL **: 15:10:38.356: totem_object_empty_menu_section: assertion 'TOTEM_IS_OBJECT (totem)' failed

> the builtin compositor can be disabled via xfwm4-tweaks-settings...

launched xfwm4-tweaks-settings, to Compositor tab, unchecked the box [ ] Enable display compositing. Tried totem again, and no washed-out transparency. Workaround confirmed.

Why this happens with totem and not mplayer, vlc, parole, mpv, or OpenShot, that's a head-scratcher. Especially mpv, since mpv & totem are linked to almost all the same libraries (mpv also uses libz.so.1 and linux-vdso.so.1)

Moses Moore (moses-ubuntu) wrote :

Forgot to mention: after turning off display compositing in xfwm4-tweaks-settings, and running parole, the output to stderr is exactly the same as when display compositing was turned on.

I suggested to test with MATE's compositing window manager "marco" also. Any results?

Another test case would be to use xfwm4 with disabled compositor plus "compton" (standalone compositing manager).

Moses Moore (moses-ubuntu) wrote :

I didn't try 'marco' because I didn't know what that is. Installing it now.

totem used with 'marco' and 'compton' are not washed out, but strangely transparent. See attached image for 'marco' -- compton is the same just no messages on stderr from compton.

Looks like the next step would be to test with an older NVIDIA driver version from the Ubuntu repository, and maybe with the slightly newer version 390.77 from the NVIDIA website also.

Changed in xfce4 (Ubuntu):
status: Incomplete → Invalid
Moses Moore (moses-ubuntu) wrote :

What does "status: invalid" mean?

In XFCE > Settings > Additional Drivers > Additional Drivers, it's
currently set to "NVIDIA Corporation GF106M [GeForce GTX 460M] "[x] Using
NVIDIA driver metapackage from nvidia-driver-390 (proprietary, tested)".
Other options are "[ ] Using NVIDIA bindary driver - version 340.106
from nvidia-340 (proprietary)" and "[ ] Using X.Org server - Nouveau
display driver from xserver-xorg-video-nouveau (open source)"

Tried to install nvidia-340, but it cocked up and left the system
in a bad state. I couldn't even revert to nvidia-driver-390 without
doing a lot of "apt --fix-broken install ... dpkg-divert --remove" loops.

Installed the nouveau driver, doesn't send output to the primary display,
had to plug in a second display. (???) used "xfwm4-tweaks-settings"
to make sure Compositing is turned on. Started "totem vapourwave.mp4"
and... no transparency. does_not_reproduce

NVIDIA website says the latest "long lived" (stable?) version is 390.77
(2018-07-16). https://www.nvidia.com/Download/driverResults.aspx/136120/en-us .
It won't let me install it because of the kernel modules already
installed, which I can't remove with modprobe nor rmmod because "resource
is in use" despite no dependencies and I already stopped X.Org. I'll keep trying.

Looking like it's a bad interaction between Totem and the NVIDIA
proprietary driver (nvidia-driver-390). Weird that the other video
players, even the gstreamer-based ones, don't suffer the same problem.

Daniel van Vugt (vanvugt) wrote :

xfce4 (Ubuntu) → Invalid means that Theo believes this bug is not a bug in xfce4. But it is still a bug in another component(s).

See that task and others at the top of the page.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Confirmed
Changed in totem (Ubuntu):
status: New → Confirmed
Liran Funaro (fonaro) wrote :

I found out that disabling FXAA (NVIDIA X Server Settings -> X Screen 0 -> Antialiasing Settings) solves this issue.
Ubuntu 18.10, Gnome 3.30, NVIDIA Driver: 390.87, X-Server: 11.0, GTX 950.

Moses Moore (moses-ubuntu) wrote :

"turn off FXAA" workaround works here too.
Ubuntu 18.10, Nvidia driver 390.87-0ubuntu1

Mike Gresens (msg-72) wrote :

Same problem on Ubuntu 18.04 (with Gnome Shell).
"turn off FXAA" workaround works here too.

iBART (mogio) wrote :

18.04.02... Gnome Shell. Turning off FXAA works.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers