nvidia-driver-390 GDM black screen / hang after login

Bug #1763774 reported by Bodie Solomon on 2018-04-13
100
This bug affects 20 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-390 (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 18.04 x64 / gdm
AMD 1800x
Aorus Gaming K7 (x370 chipset) motherboard
NVidia GTX 1080Ti w/ DisplayPort attached 4k monitor
USB keyboard / mouse

I've recently upgraded from Ubuntu 17.10 x64 to 18.04 x64 via
`do-release-upgrade -d` and uninstalled / purged / reinstalled my NVidia
native drivers using the `ubuntu-drivers autoinstall` approach.

I am able to boot the system and it displays the X login shell at native
resolution with a functioning keyboard and mouse, but I cannot
ctrl+alt+F{1,2,3,4,...} to a non-graphical terminal.

When I click "Sign in" using gnome 3, gnome classic, or Unity, I get a
black screen and my input devices hang (keyboard caps lock key no longer
functions.) If I unplug and replug my input devices, they remain
hanging, with a stuck-on capslock indicator. The mouse is also
illuminated.

I am able to SSH into the machine, and it is still usable. systemctl
status gdm.service indicates that gdm is "running" and does not show an
error, but it shows that the login session opened and closed very quickly.

I rebooted and SSH'd into the machine before the hang, halted GDM via
`systemctl stop gdm.service` and was able to ctrl+alt+F1 into another
shell on the attached keyboard. I then executed `systemctl restart
gdm.service` and got the expected X login shell. I was then able to log
into the desktop environment normally.

My Xorg.0.log is here for the successful login:
https://paste.ubuntu.com/p/SNqJPxV938/

I'll reproduce the behavior and attach an xorg log for the unexpected
behavior.

Bodie

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: nvidia-driver-390 390.48-0ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-15.16-generic 4.15.15
Uname: Linux 4.15.0-15-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu4
Architecture: amd64
Date: Fri Apr 13 12:43:48 2018
InstallationDate: Installed on 2017-10-30 (165 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
SourcePackage: nvidia-graphics-drivers-390
UpgradeStatus: No upgrade log present (probably fresh install)

Bodie Solomon (bodie) wrote :
Bodie Solomon (bodie) wrote :

Wasn't sure whether to file this as an xorg bug instead. I noticed that the native driver functions up to the point when I click "sign in", and xorg functions on its own. It seems to be an interaction between the xorg native nvidia package and the nvidia driver.

Bodie Solomon (bodie) wrote :

BTW, I was able to resolve the hang using the fix from this report https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-384/+bug/1705369

(switching to LightDM)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Confirmed
Bodie Solomon (bodie) wrote :

I am still affected by this after the 18.04 release.

omar reddam (omarreddam) wrote :

Just wanted to confirm that I'm affected by this as well.
I'm getting a black screen at startup whenever I enable the Nvidia driver (tried both 390 and 396).
I have a GTX 1050 Ti (with an Asus Prime X299-Deluxe Mobo).
Tried deleting xorg.conf with no results. On 18.04 final.

omar reddam (omarreddam) wrote :

I've tried multiple approaches for 2 months and I'm still not able to install boot with the Nvidia drivers enabled.

"I'm getting a black screen at startup whenever I enable the Nvidia driver (tried both 390 and 396).
I have a GTX 1050 Ti (with an Asus Prime X299-Deluxe Mobo).
Tried deleting xorg.conf with no results. On 18.04 final."

Have you tried running GDM with X instead of Wayland ?

Sebastian Potthoff (sebpo) wrote :

I am also affected by this since the latest upgrade which included among others libX11, libmutter, mutter and libvulkan (full list attached). I am using the Nvidia binary 396 drivers and everything was runnning fine before. I could however circumvent the problem by ssh'ing into the machine and simply stoping the gdm3.service and then restarting it. However I could not switch to another TTY as suggested in the first post. Hope this helps a bit to solve the issue.

Norbert (asterix52) wrote :

I have the same experience since last week as sebastian. I'm using the nvidia 340.

Norbert (asterix52) wrote :

I can login if I choose the recover mode at the boot menu and then the option resume.

Moritz (moritzh) wrote :

I also have the same problem on Ubuntu 18.04.2.
The login screen starts normally, but right after typing my password and pressing enter the screen is black.

The problem started after an NVIDIA driver update with "apt upgrade". I was using the nvidia driver form the CUDA Repository.
I tried removing and reinstalling nvidia-390 from Ubuntu repos, 410 and 418 from cuda repo and 418 runfile installer from NVIDIA Homepage. The bug is the same for all driver versions.

When I uninstall nvidia driver und use nouveau, everything is fine.
Also when using the nvidia driver i can login with SSH and `systemctl stop gdm.service` + `systemctl start gdm.service`, then login works fine.
Finally switching to lightdm also works now as workaround.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers