Conflict between libglx-mesa and nvidia-390 on Ubuntu 18.04 (pre-release)

Bug #1753796 reported by Joshua R. Poulson on 2018-03-06
52
This bug affects 11 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-390 (Ubuntu)
Undecided
Alberto Milone

Bug Description

On Ubuntu 18.04 with the NVIDIA development repository PPA, installing cuda-drivers I get the following error during the installation of nvidia-390:

dpkg: error processing archive /var/cache/apt/archives/nvidia-390_390.30-0ubuntu1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLX_indirect.so.0', which is also in package libglx-mesa0:amd64 18.0.0~rc4-1ubuntu3

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: libglx-mesa0 18.0.0~rc4-1ubuntu3
ProcVersionSignature: User Name 4.15.0-1002.2-azure 4.15.3
Uname: Linux 4.15.0-1002-azure x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
Date: Tue Mar 6 17:38:47 2018
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Microsoft Corporation Hyper-V virtual VGA [1414:5353] (prog-if 00 [VGA controller])
   Subsystem: NVIDIA Corporation GK210GL [Tesla K80] [10de:106c]
Lsusb: Error: command ['lsusb'] failed with exit code 1:
MachineType: Microsoft Corporation Virtual Machine
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-1002-azure root=UUID=950907d2-f8b1-431a-8195-e06fbf9a814b ro console=tty1 console=ttyS0 earlyprintk=ttyS0 rootdelay=300
SourcePackage: mesa
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/02/2017
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 090007
dmi.board.name: Virtual Machine
dmi.board.vendor: Microsoft Corporation
dmi.board.version: 7.0
dmi.chassis.asset.tag: 7783-7084-3265-9085-8269-3286-77
dmi.chassis.type: 3
dmi.chassis.vendor: Microsoft Corporation
dmi.chassis.version: 7.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr090007:bd06/02/2017:svnMicrosoftCorporation:pnVirtualMachine:pvr7.0:rvnMicrosoftCorporation:rnVirtualMachine:rvr7.0:cvnMicrosoftCorporation:ct3:cvr7.0:
dmi.product.name: Virtual Machine
dmi.product.uuid: 94AF2AB7-6288-E94C-9C01-1305DF401054
dmi.product.version: 7.0
dmi.sys.vendor: Microsoft Corporation
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.90-1
version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.0~rc4-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.0~rc4-1ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.10.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

Joshua R. Poulson (jrp) wrote :
Timo Aaltonen (tjaalton) on 2018-03-07
affects: mesa (Ubuntu) → nvidia-graphics-drivers-390 (Ubuntu)
Changed in nvidia-graphics-drivers-390 (Ubuntu):
assignee: nobody → DAVIDE MILONE (milone)
assignee: DAVIDE MILONE (milone) → Alberto Milone (albertomilone)
Alberto Milone (albertomilone) wrote :

nvidia-390 is not in the archive, and I recommend that you use the driver in Bionic instead.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Invalid
Joshua R. Poulson (jrp) wrote :

Indeed, as I said I get it from NVIDIA's CUDA development archive, as that is the NVIDIA-supported path for using GPUs on Azure... I just want to make sure everything is in place when 18.04 is GA.

Gilles (gdpo22) wrote :

I am facing exactly the same issue.
Trying to install Cuda Toolkit 8.1 from NVIDIA developement archive : impossible.

It's really annoying for opencv, tensorflow users...

The most annoying thing is that /usr/lib/x86_64-linux-gnu/libGLX_indirect.so.0 doesn't exist.

Michael Heyman (mheyman-1) wrote :

My workaround after receiving the same error was to run:

dpkg -i -force-overwrite /var/cache/apt/archives/nvidia-390_390.30-0ubuntu1_amd64.deb

After that, the install succeeds and I haven't noticed any resulting issues.

Hemen Kapadia (hemen-kap) wrote :

I also faced the same issue. Resolution command I used was

sudo apt-get -o Dpkg::Options::="--force-overwrite" install cuda-9-0

Luca Capra (luca-capra) wrote :

Confirm and thanks to H.Kapadia for the command above that worked for me too

sudo apt-get -o Dpkg::Options::="--force-overwrite" install --fix-broken

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers