[regression] hibernation (freezes on resume) since 4.13.0-25.29

Bug #1743094 reported by Jørgen Best on 2018-01-13
This bug affects 134 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
linux-hwe (Ubuntu)
nvidia-graphics-drivers-384 (Ubuntu)
xserver-xorg-video-nouveau (Ubuntu)

Bug Description

After hibernating the system and than resuming it the system reboots notifying that it is resuming and than stops/freezes. The system does not respond to anything (no tty's other notifying textg are available).

After booting kernel 4.10-042 the hibernation and hibride hibernation/sleep functions as proposed.
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
 /dev/snd/controlC0: jb 1717 F.... pulseaudio
CurrentDesktop: X-Cinnamon
DistroRelease: Linux 18.3
HibernationDevice: RESUME=UUID=00059f88-0cf2-44a0-a23d-f0a995cb1478
InstallationDate: Installed on 2017-12-10 (34 days ago)
InstallationMedia: Linux Mint 18.3 "Sylvia" - Release amd64 20171124
MachineType: Acer Aspire S3-391
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-26-generic root=UUID=5397ffb7-8114-45c4-824f-b1da7cce468c ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.13.0-26.29~16.04.2-generic 4.13.13
 linux-restricted-modules-4.13.0-26-generic N/A
 linux-backports-modules-4.13.0-26-generic N/A
 linux-firmware 1.157.14
Tags: sylvia
Uname: Linux 4.13.0-26-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 10/31/2012
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V2.10
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: Hummingbird2
dmi.board.vendor: Acer
dmi.board.version: V2.10
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V2.10
dmi.modalias: dmi:bvnInsydeCorp.:bvrV2.10:bd10/31/2012:svnAcer:pnAspireS3-391:pvrV2.10:rvnAcer:rnHummingbird2:rvrV2.10:cvnAcer:ct10:cvrV2.10:
dmi.product.family: ChiefRiver System
dmi.product.name: Aspire S3-391
dmi.product.version: V2.10
dmi.sys.vendor: Acer

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1743094

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

kernel 4.4.0-109 (with kaiser patch against meltdown) does also function all-right.

See attachment for system info.

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: apport-collected sylvia
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Can also confirm that 4.13.0-26-generic causes the computer to fail to resume from hibernation. Downgrading to 4.10.0-42-generic fixes the problem.

Computer: Dell XPS 13 9360
BIOS: 2.5.0

When attempting to resume from hibernation, the LUKS password prompt is displayed, but the screen goes black immediately after entering the password. The Caps Lock key does not work, so I assume the kernel hangs. After leaving the computer for ~30 seconds, the fans begin to run at full speed.

I'm experiencing the same problem with kernel 4.13.0-26-generic, 4.10 series works fine.

Intel i7-6700k (using intel-microcode 3.20180108.0~ubuntu16.04.2)
16 GB RAM, 4 GiB Swap
NVidia GTX 970 (nvidia-384.111-0ubuntu0.16.04.1 drivers)

Launchy (launchy-0) wrote :

Hi there,
I face the same problem: 4.13.0-26-generic causes freeze on resume from hibernation.
The 4.10.x kernel series works flawless on my Medion Core i3 Notebook.

Leif Arne Storset (lastorset) wrote :

4.13.0-30.33 (available in artful-proposed) appears to have fixed it for me.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: needs-bisect
Dirk Bachmann (bacdi) wrote :

tested hibenate-resume cycles with a couple of other 4.13 kernels: - works - works - broken - broken (from Canonical Kernel Team PPA)

HP 250 G6 Notebook w/ Intel i3-6006U
Linux Mint 18.2 Sonya

no resume log available in kernel log.

Jørgen Best (jorgenbest) wrote :

If I knew how I might be able to bisect. I found some info on the issue (see links), I think I can compile a kernel if I knew the options that the kernel I used was compiled with. I'm not really a programmer so if I have to read through (too much) code I will fail. Is there a link for Ubuntu standard kernel compiling?

I understand from Dirk Bachmann that some where between en 25 thinks got broken. I understand that I need the first kernel that broke and the one before and somehow have to compare them with git. At least I should be able to find out at what update things got broken.

How can I successfully run the script "git bisect run" step by step if I have to hibernate the system and each time I do this the system will freeze at resume? I assume the analysis will be aborted each time.

If someone has a link to some more info (for a not really programmer), I'll give it a try.


Maarten Sijm (mpsijm) wrote :

Same issue here: when trying to resume from hibernation, my laptop screen stays black and I have to force kill it.
Been scrolling through the logs, but there seems to be no data between when I started hibernation and after I restarted my laptop after the force-kill.

Christian Sarrasin (sxc731) wrote :

Same issue here, fresh install of stock Ubuntu 17.10(.1) on a ThinkPad X1 Carbon gen5, kernel 4.13.0-25-generic, with LUKS-encrypted swap partition sitting alongside the root partition. The same hardware/setup worked fine on Zesty but as we know, that just went EoL.

Just to add: the machine seems completely frozen at resume based on the keyboard caps-lock LED test. I do get the LUKS password prompt so that part seems fine.

Hibernation is critical functionality from a security standpoint as an alternative to far less secure suspend to RAM functionality.

Please let us know how/if we can help progressing this bug.

Zsone (zsone) wrote :

Same issue with a Lenovo W520 on 16.04.3 LTS with 4.13.0-26. The quite fresh 4.14.13 kernel (Canonical Kernel Team PPA) solves this "resuming from hibernation" problem. I agree that this is a very important bug that should be solved soon.

Dirk Bachmann (bacdi) wrote :

Kernel 4.14.13 fixes the issue for me too.
(installed as outlined by http://linuxg.net/install-kernel-4-14-on-ubuntu/)

Nonny Moose (moosenonny10) wrote :

I found part of the kernel log describing the failed boot.
Line 642 seems relevant:

    Jan 21 09:12:41 laptop kernel: [ 1.254367] PM: Hibernation image not present or could not be loaded.

Lu Do (tchio.ludo) wrote :

4.13.0-30.33 (available in artful-proposed) don't work for me

4.14.14 works well

I can also confirm that with 4.13.0-30, hibernate did not work, but installing 4.14.13-041413-generic works perfectly.

DenisP (denisp) wrote :

I can confirm that my Laptop freezes on resume from hibernate with Kernel 4.13.0-25 and 4.13.0-31. Last working Kernel version is 4.13.0-21 .
My Laptop is Lenovo Thinkpad T470.

Ariel (rellieberman) wrote :

Same issue affects me after updating to kernel 4.13.0-31.

Resuming starts but after a few seconds screen goes dark and nothing can be done except forcing off the laptop.

Also found "Hibernation image not present or could not be loaded" in kernel log.

Maurice (mak-5) wrote :

Same issue with a Lenovo Y580 on 16.04.3 LTS with 4.13.0-26. I agree that this is a very important bug that should be solved soon.

Maurice (mak-5) on 2018-01-25
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Mikko Suniala (suniala) wrote :

I can confirm the issue on (but not necessarily limited to) 4.13.0-31 and 4.13.0-32 (that I just got 15 minutes ago while upgrading).

I'm running Xubuntu 16.04.3 LTS on a Lenovo Thinkpad X220 with i5-2450M.

DenisP (denisp) wrote :

I can confirm that issue is still present with the kernel 4.13.0-32.

richbl (richbl) wrote :

Also still failing under kernel 4.13.0-32.

I'm running 17.10 on a Dell XPS 15 9560.

                       | systemctl hibernate | systemctl hybrid-sleep | s2disk
4.13.0-25 : ?? : ?? : broken
4.13.0-31 : ?? : ?? : broken
4.13.0-32 : broken : ?? : broken
4.14.15-041415-generic : work : broken : ??

Ubuntu 17.10
Lenovo ThinkPad T470p

TJ (tj) wrote :

Looking at Dirk Bachmann's comment #23 I did a:

gitlog Ubuntu-4.13.0-18.21..Ubuntu-4.13.0-25.29

That shows the major changes are the x86/mm PTI patches to address the Meltdown issue.

Dirk: can you boot 4.13.0-25 with the kernel command-line option "nopti" and do your hibernate/resume tests and report back?

TJ (tj) on 2018-01-27
summary: - hibernation broken (freezes with resume) in kernel linux-
- image-4.13.0-26-generic
+ [regression] hibernation (freezes on resume) due to PTI
tags: added: regression-release suspend-resume

User confirmed on IRC that "nopti" allowed 4.13.0-25 to resume from hibernation.

TJ (tj) on 2018-01-29
summary: - [regression] hibernation (freezes on resume) due to PTI
+ [regression] hibernation (freezes on resume) since 4.13.0-25.29
tags: removed: needs-bisect
Andy Whitcroft (apw) on 2018-02-07
tags: added: kernel-pti
tags: added: pti
Changed in linux (Ubuntu Artful):
status: New → Confirmed
importance: Undecided → Medium
Changed in linux (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Changed in linux-hwe (Ubuntu):
status: New → Confirmed
no longer affects: linux-hwe (Ubuntu Artful)
80 comments hidden view all 160 comments

apport information

tags: added: bionic

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Raphaël Droz (raphael-droz) wrote :

On freshly installed bionic.
When suspending from a text tty I can see a couple of lines at resume (mostly related to wifi and icc profile in ~/.local/share/icc), then it hangs after a couple of seconds.

May 15 01:22:54 kratos systemd[1]: Started Getty on tty4.
May 15 01:22:54 kratos gnome-shell[1924]: Failed to apply DRM plane transform 0: Permission denied
May 15 01:22:54 kratos gnome-shell[1924]: Failed to set power save mode for output eDP-1: Permission denied
May 15 01:22:54 kratos gsd-color[2258]: failed to set screen _ICC_PROFILE: Failed to open file “/home/yug/.local/share/icc/edid-2a314e28a76ee089ed6b07ab7269ee33.icc”: Permission denied
May 15 01:24:13 kratos NetworkManager[1401]: <info> [1526358253.1419] manager: sleep: sleep requested (sleeping: no enabled: yes)
May 15 01:24:13 kratos NetworkManager[1401]: <info> [1526358253.1421] device (wlp4s0): state change: disconnected -> unmanaged (reason 'sleeping', sys-iface-state: 'managed')
May 15 01:24:13 kratos gnome-shell[1924]: Screen lock is locked down, not locking
May 15 01:24:13 kratos NetworkManager[1401]: <info> [1526358253.1455] manager: NetworkManager state is now ASLEEP
May 15 01:24:13 kratos wpa_supplicant[1397]: nl80211: deinit ifname=p2p-dev-wlp4s0 disabled_11b_rates=0
May 15 01:24:13 kratos whoopsie[2589]: [01:24:13] offline
May 15 01:24:13 kratos gnome-shell[1924]: Failed to set power save mode for output eDP-1: Permission denied
May 15 01:24:13 kratos gsd-color[2258]: failed to set screen _ICC_PROFILE: Failed to open file “/home/yug/.local/share/icc/edid-2a314e28a76ee089ed6b07ab7269ee33.icc”: Permission denied
May 15 01:24:13 kratos wpa_supplicant[1397]: nl80211: deinit ifname=wlp4s0 disabled_11b_rates=0
May 15 01:24:18 kratos systemd[1]: Reached target Sleep.
May 15 01:24:18 kratos systemd[1]: Starting Suspend...
May 15 01:24:18 kratos systemd-sleep[22018]: Suspending system...

Brett Johnson (linuxturtle) wrote :

This is still a problem in bionic as well. I just did a clean install on a workstation which exhibits the problem, but I also have a laptop which was upgraded from 17.10, which has not ever exhibited the problem.

I've attached lshw output for the two machines (inara is the machine for which suspend/resume works, vera is the one that doesn't)

Brett Johnson (linuxturtle) wrote :

Hmm, in a somewhat disheartening turn of events, I thought I'd try installing the nvidia proprietary driver on my workstation (that's what I had installed on 16.04, when suspend/resume worked). ...And now, suspend/resume works perfectly (and quickly) on the workstation. So maybe this is a nouveau bug? Is everyone else having problems using nvidia graphics hardware with the nouveau driver?

Raphaël Droz (raphael-droz) wrote :

Intel on Entroware laptop for me so hardly a driver problem (but maybe not even the same bug)
efficient diagnosis procedure welcomed.

Pablo180 (paultait22) wrote :

I have Nvidia graphics and I am using the Nvidia drivers so it isn't just a nouveau driver problem. But it may be worth re-installing the nvidia drivers again to see if that solves the problem for me.

Pablo180 (paultait22) wrote :

Re-installing the nouveau and nvidia drivers didn't work for me sadly. The problem persists.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
Hans Hansen (hans005) wrote :

I have a variant of this problem that I can not find anywhere else:

I have the same problem of black screen (white cursor not blinking in the left upper corner) when I do a lock screen!

Suspend problem is also present. Computer goes down correctly after pressing suspend, but when it is supposed to wake up, I get the above described screen (NO splash screen, NO message from grub).

I am not sure if I should open a new bug for this....

Kernel: 4.15.0-22
OS: Xubuntu bionic
PC: Lenovo P51
GDriver: NVidia proprietry, Lenovo BIOS already set to NOT use CPU internal graphics

Happy to provide further infos if anybody is interested.

I can't wake from standby with linux-image-4.15.0-22-generic

But: linux-image-4.15.0-1006-oem is working for me

GDriver: NVidia proprietry
Adding "nouveau.modeset=0" to GRUB_CMDLINE_LINUX didn't work either.

Small update to #139

my syslog was getting spammed with:
kernel: nouveau 0000:01:00.0: fifo: SCHED_ERROR 20 []

which led to a full /tmp

Adding "nouveau.modeset=0" to GRUB_CMDLINE_LINUX_DEFAULT got rid of that.

Is there any update on this issue? Hibernation works with kernel 4.10 but I can't keep using that forever...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-384 (Ubuntu):
status: New → Confirmed
Rus Sh (break1) wrote :

Have a same bug on desktop PC
Motherboard HB7-Plus, 16Mb RAM, Intel i7-4770 3.4 CPU

uname -a
Linux rtuser-break-G 4.13.0-43-generic #48~16.04.1-Ubuntu SMP Thu May 17 12:56:46 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

After each restoring hibernate PC freeze tight.

Rus Sh (break1) wrote :

I manually install 4.13.0-21 from here https://launchpad.net/~canonical-kernel-team/+archive/ubuntu/ppa/+build/13870500 and hibernate began to work!

Hans Hansen (hans005) wrote :

Update to #138:

My problem seems to be related to Bug #1752053 and Bug #1773113. And for me now everything more or less works again by using this workaround from Bug #1752053 posting #123:

I found a silly workaround (after trying many many other suggestions / driver re-installs), now using nvidia-driver-396 or nvidia-driver-390; create (if not exists) a file /etc/rc.local, with this content:


sleep 1

exit 0

And make it executable: chmod 755 /etc/rc.local

Maybe this helps some people.

Christian Sarrasin (sxc731) wrote :

Just to clarify above comment from hans005: from what I can read here his problem (#138, #145) was a completely different issue: standby with nvidia GPU.

This regression relates to *hibernation* (not mere standby) and AFAIK, has been experienced with a variety of GPUs (included Intel integrated GPUs as in my case) so it's quite likely *not* a condition related to GPU drivers or model in use - although it's common for less run-of-the-mill dGPUs to exacerbate such issues I suppose.

I don't believe there are any workarounds to the issue accurately captured by the bug's headline.

Juancho (cabajuan) wrote :

I manually install 4.17.0-041700-generic from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17/ and hibernate is working very fine!

Maurice (mak-5) wrote :

Now, there is a solution for all people on Ubuntu 16.04.

You can now install the package "linux-image-generic-hwe-16.04" and it's recommended dependencies. The package contains Kernel 4.15 which will make hibernate work again.

Just tested and confirmed on Lenovo Y580 with Ubuntu 16.04.

Maurice (mak-5) wrote :

Sorry, the correct package in the post above is called "linux-image-generic-hwe-16.04-edge".

Edge is important so you get the newest version.

Taylor Raack (track16) wrote :

Confirmed with a Lenovo V570 that using the generic HWE 16.04 edge kernel restores hibernation ability. I needed to install both linux-image-generic-hwe-16.04-edge" and "linux-headers-generic-hwe-16.04-edge".

Maarten Sijm (mpsijm) wrote :

Using a HP ZBook Studio G3 Mobile Workstation, hibernation works for me again using the HWE kernels on Linux 16.04.

$ apt-mark showmanual | grep ^linux
$ uname -a
Linux zbook-workstation 4.15.0-24-generic #26~16.04.1-Ubuntu SMP Fri Jun 15 14:35:08 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

This bug was nominated against a series that is no longer supported, ie artful. The bug task representing the artful nomination is being closed as Won't Fix.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu Artful):
status: Confirmed → Won't Fix

I have installed the "edge" hwe packages as denoted in these two comments:



I can confirm that after this action hibernation is working properly for me. Previously I was stuck on a specific mainline 4.15 release and was afraid to move off it; hibernation is vital for my workflow (and sanity in general).

: uname -a
Linux hostname 4.15.0-38-generic #41~16.04.1-Ubuntu SMP Wed Oct 10 20:16:04 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Basil K Y (basilky) wrote :

Please fix this bug soon. It affects many distributions based on Ubuntu and there are no workarounds available for Ubuntu 18.04. I have attached my system details. I couldn't find any relevant logs in syslog or pm logs which leads to failure in hibernation.

EDEMPCO (edemco) wrote :

I've been dealing with this issue since December 2018. It acted to me like a graphic problem, so I posted a bug #1807264 as a video crash. No help or comment on the bug report. In the hopes that a new kernel will help, I'm continually upgrading to the newest. No luck, so far. I would be satisfied to be able to turn off hibernation/suspend completely, but there is no help with that either. This needs to be addressed.

Emiliano (retorquere) wrote :

18.04 didn't exhibit the problem for me (HP Elitebook 820 G3), but I have had it since the upgrade to 18.10.

Haydenbriese (haydenbriese) wrote :

Fixed since upgrading from 18.10 (4.18) to 19.04 (5.0) on the same configuration.

Haydenbriese (haydenbriese) wrote :

Linux: 5.0.0-13-generic
intel-microcode: 3.20190312.1

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
EDEMPCO (edemco) wrote :

Since 18.04 is the latest LTS, how does this change get distributed to those of us who rely on the LTS to be upgraded and effective until the next LTS? In other words, how and when does it get integrated into 18.04LTS?

Steve (stevebot) wrote :

@EDEMPCO I haven't had the issue since I updated to Ubuntu 18.04 (or stopped using the 4.13.x series on 16.04). Are you using the kernel provided by the distribution? Can you try running one of the 4.10.x kernels to see if that fixes it? Also are you sure you have this specific bug, and not any of the many other hibernation bugs?

Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc
Displaying first 40 and last 40 comments. View all 160 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers