brightness control broken nvidia

Bug #1720438 reported by Brinstar on 2017-09-29
94
This bug affects 19 people
Affects Status Importance Assigned to Milestone
gnome-power
Confirmed
Medium
gnome-power-manager (Ubuntu)
Undecided
Unassigned
gnome-shell (Ubuntu)
Undecided
Unassigned
mutter (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-384 (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 17.10 beta 2
Nvidia 310M, 340.x official driver installed with Additional Drivers program

The brightness control built into the laptop (Dell Vostro 3300) isn't changing the brightness. Normally I can use Fn + Up/Down arrow keys to change the brightness.
The brightness control works fine in Ubuntu 16.04 with the same driver series.

I don't know if this is a GNOME 3.26 bug but it's likely as I'm having the exact same problem with Fedora 26 on this laptop.

Brinstar (brinstar) wrote :

I think this is more of a GNOME3 bug than a bug with the Nvidia driver

affects: nvidia-graphics-drivers-340 (Ubuntu) → gnome-desktop3 (Ubuntu)
affects: gnome-desktop3 (Ubuntu) → gnome-power-manager (Ubuntu)
Brinstar (brinstar) wrote :

I've managed to use a workaround to make the hotkeys work.

I added acpi_osi=Linux to the grub config file and did an update-grub and it works. But I think it would be better if this was looked into as it did work fine without the acpi addition on Ubuntu LTS.

Simone Bordet (simone-bordet) wrote :

Same problem here.

Ubuntu 17.10 beta 2
NVIDIA Corporation GM204M [GeForce GTX 970M]
Driver NVIDIA binary 375.82

Changing the brightness via Fn keys or via Settings/Power does not work.
Adding acpi_osi=Linux does nothing for me, the problem remains.

Brinstar (brinstar) wrote :

remember to click the 'This bug affects you' link near the top

Brinstar (brinstar) wrote :

also did you do the update-grub part? but I do think this bug needs a proper fix

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
Simone Bordet (simone-bordet) wrote :

@brinstar, yes I did the sudo update-grub part, and tried acpi_brightness=[native|vendor] which for me makes the Fn hot keys not working (when you press them, no brightness icon appears).

Last update brought in NVidia drivers 384.90, but no joy, the problem is still present.

Simone Bordet (simone-bordet) wrote :

I tried also: sudo su -c 'echo 10 > /sys/class/backlight/acpi_video0/brightness'.

Pressing the Fn keys brings up the OSD brightness control, which reflects the value of the /sys/class/backlight/acpi_video0/brightness file (and viceversa), but the actual screen brightness does not change.

affects: gnome-power-manager (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Jussi Saarinen (jms) wrote :

After upgrade from 17.04 to 17.10 I can only change brightness if I log in to unity desktop and from there adjust brightness setting in system settings.

With Ubuntu 17.10 I have tried following combinations:
Xorg, nvidia & unity: ok
Xorg, nvidia & gnome: not ok
Wayland, nouveau & gnome: not ok

affects: nvidia-graphics-drivers (Ubuntu) → nvidia-graphics-drivers-384 (Ubuntu)
no longer affects: nvidia-drivers-ubuntu
tags: added: artful
Andrii Prokopenko (anprok) wrote :

Confirmed on 17.10 and Nvidia drivers 384.111

Persists on 18.04 beta 2 with Nvidia driver 390

Pablo Cabrera (pablo-rocka) wrote :

I'm having the same issue in 18.04 Nvidia driver 390.48. I found this workaround at the moment if anyone is interested https://askubuntu.com/a/1013767

Bump (bump55) wrote :

I think it has to do with Unity or Wayland. If you use KDE instead it just works.

Bump (bump55) wrote :

Ok tried several graphical environments with the line "WaylandEnable=false" commented and uncommented, and the proprietary nvidia graphics driver, and those are the results:

- Desktop Session: Ubuntu: Fn to control screen backlight doesn't work in any case, neither line enabled nor disabled.

- Desktop Session: Ubuntu on Wayland (Wayland): can't even enter to the desktop in either case. After entering the password for my username the screen goes black a few seconds and then returns to the login manager.

- Desktop Session: Plasma: Fn + up arrrow /down arrow work perfectly in both cases, with line enabled or disabled. I recommend everyone to use KDE Plasma instead.

Daniel van Vugt (vanvugt) wrote :

If your backlight is wired through Nvidia then I think you may need to use the xbacklight interface. You can do it manually by installing:

  sudo apt install xbacklight

and running xbacklight ...

If that works for you then I think the problem is that mutter/gnome-shell isn't using/supporting/checking the X backlight interface. Only the kernel interfaces.

Changed in mutter (Ubuntu):
status: New → Incomplete
tags: added: bionic
Daniel van Vugt (vanvugt) wrote :

Also, obviously, the above only works in Xorg logins.

Changed in gnome-shell (Ubuntu):
status: New → Incomplete
Daniel van Vugt (vanvugt) wrote :

Note to developers: The tricky thing about this bug is that you may need a pure Nvidia system. Not a hybrid.

Daniel van Vugt (vanvugt) wrote :

Please try the 'xbacklight' command. And see also https://bugzilla.gnome.org/show_bug.cgi?id=688052

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
status: Confirmed → Incomplete
Changed in gnome-power:
importance: Unknown → Medium
status: Unknown → Confirmed
Bump (bump55) wrote :

I confirm that 'xbacklight -set 60' works (as user, no root required), in both desktop sessions: ubuntu and plasma. However, the Fn key + arrow only works on plasma.

Being on ubuntu session, inside the directory '/sys/class/backlight' there is nothing, yet xbacklight works. So it's almost sure a gnome/wayland whatever issue.

The graphics card is a nvidia 1060 on a gaming notebook, which you can switch to IGPU instead of DGPU on the BIOS but you need to reboot, doesn't have "optimus" or "on-the-fly" switching.

I'll answer here as well:

https://bugzilla.gnome.org/show_bug.cgi?id=688052

Bump (bump55) wrote :

Probably just waiting for the gnome team to fix it is just enough.

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Confirmed
Bump (bump55) wrote :

Switching to integrated graphics the Fn works perfectly on gnome. Also:

ls -l /sys/class/backlight/
total 0
lrwxrwxrwx 1 root root 0 may 5 12:12 intel_backlight -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-eDP-1/intel_backlight

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.