bumblebee / primusrun does not work with NVIDIA 375.66

Bug #1700672 reported by Giuseppe D'Angelo on 2017-06-26
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
nvidia-graphics-drivers-375 (Ubuntu)
Undecided
Unassigned

Bug Description

In Ubuntu 16.04.2, after upgrading nvidia-375 to 375.66-0ubuntu0.16.04.1, bumblebee stopped working. Attempting to launch anything with primusrun results in errors.

Upstream bug report seems to be pointing at a flaw in /usr/lib/nvidia-375-prime/ld.so.conf , that's why I'm assigning to nvidia-375 and not bumblebee: https://github.com/Bumblebee-Project/Bumblebee/issues/879

From syslog:

Jun 27 01:08:54 ubuntu1604 bumblebeed[892]: [ 20.414721] [WARN]Unable to disable discrete card.[ 2606.504423] [ERROR][XORG] (EE) /dev/dri/card1: failed to set DRM interface version 1.4: Permission denied
Jun 27 01:08:54 ubuntu1604 bumblebeed[892]: [ 2606.504433] [WARN][XORG] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
Jun 27 01:08:54 ubuntu1604 bumblebeed[892]: [ 2606.504435] [ERROR][XORG] (EE) Failed to load /usr/lib/nvidia-375/xorg/libglx.so: libnvidia-tls.so.375.66: cannot open shared object file: No such file or directory
Jun 27 01:08:54 ubuntu1604 bumblebeed[892]: [ 2606.504438] [ERROR][XORG] (EE) Failed to load module "glx" (loader failed, 7)
Jun 27 01:08:54 ubuntu1604 bumblebeed[892]: [ 2606.504441] [WARN][XORG] (WW) Warning, couldn't open module mouse
Jun 27 01:08:54 ubuntu1604 bumblebeed[892]: [ 2606.504443] [ERROR][XORG] (EE) Failed to load module "mouse" (module does not exist, 0)
Jun 27 01:08:54 ubuntu1604 bumblebeed[892]: [ 2606.504448] [ERROR][XORG] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
Jun 27 01:08:54 ubuntu1604 bumblebeed[892]: [ 2606.504451] [ERROR][XORG] (EE) NVIDIA(0): log file that the GLX module has been loaded in your X
Jun 27 01:08:54 ubuntu1604 bumblebeed[892]: [ 2606.504453] [ERROR][XORG] (EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
Jun 27 01:08:54 ubuntu1604 bumblebeed[892]: [ 2606.504455] [ERROR][XORG] (EE) NVIDIA(0): you continue to encounter problems, Please try
Jun 27 01:08:54 ubuntu1604 bumblebeed[892]: [ 2606.504458] [ERROR][XORG] (EE) NVIDIA(0): reinstalling the NVIDIA driver.
Jun 27 01:08:54 ubuntu1604 bumblebeed[892]: [ 2606.504460] [WARN][XORG] (WW) NVIDIA(0): Unable to get display device for DPI computation.
Jun 27 01:08:54 ubuntu1604 bumblebeed[892]: [ 2606.504464] [WARN][XORG] (WW) Warning, couldn't open module mouse
Jun 27 01:08:54 ubuntu1604 bumblebeed[892]: [ 2606.504465] [ERROR][XORG] (EE) Failed to load module "mouse" (module does not exist, 0)
Jun 27 01:08:54 ubuntu1604 bumblebeed[892]: [ 2606.504470] [ERROR][XORG] (EE) /dev/dri/card1: failed to set DRM interface version 1.4: Permission denied

affects: unity (Ubuntu) → nvidia-graphics-drivers-375 (Ubuntu)
Giuseppe D'Angelo (dangelo) wrote :

This is still valid, by the way.

Giuseppe D'Angelo (dangelo) wrote :

Still an issue with 384.90. In Xorg8.log I see

[272208.772] (II) Loading /usr/lib/nvidia-384/xorg/libglx.so
[272208.773] (EE) Failed to load /usr/lib/nvidia-384/xorg/libglx.so: libnvidia-tls.so.384.90: cannot open shared object file: No such file or directory
[272208.773] (II) UnloadModule: "glx"
[272208.773] (II) Unloading glx
[272208.773] (EE) Failed to load module "glx" (loader failed, 7)

Is it just a packaging issue?

Another issue as well in Ubuntu 18.04 and NVIDIA 390.00

They managed a way to solve it.

https://askubuntu.com/questions/1029169/bumblebee-doesnt-work-on-ubuntu-18-04/1042950#1042950

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers