Boot splash with luks password prompt broken after nvidia upgrade to 367

Bug #1638983 reported by vvhk on 2016-11-03
86
This bug affects 17 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-367 (Ubuntu)
Critical
Unassigned

Bug Description

Just got the nvidia driver update from 361 to 367. Upon reboot, the boot splash (plymouth?) with the password prompt for the encrypted root is missing.

The screen flashes dark purple and the switches to black with a blinking cursor echoing anything typed. Ctrl-alt-del reboots. Booting with kernel options "quiet splash" removed results in a text-mode boot process where the password prompt is present, proceeding normally.

Wasn't sure if this was plymouth or nvidia issue, I'm guessing nvidia because that's what upgraded and broke functionality.

Tried redoing update-grub and update-initramfs, didn't help. Found I had both nvidia-361 and nvidia-367 installed (why didn't -361 uninstall?), but manually removing -361 (and redoing initramfs just in case) didn't change anything.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: nvidia-367 367.57-0ubuntu0.16.04.1
ProcVersionSignature: Ubuntu 4.4.0-36.55-generic 4.4.16
Uname: Linux 4.4.0-36-generic x86_64
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Nov 3 17:45:14 2016
InstallationDate: Installed on 2016-07-23 (103 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
SourcePackage: nvidia-graphics-drivers-367
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-367 (Ubuntu):
status: New → Confirmed
Mike Berkley (mike-berkley) wrote :

Worked around the problem by:
0. Use "Esc" key to interrupt boot, edit boot to remove "quiet splash" from boot line, then boot.
1. Replace "quiet splash" with "" in /etc/default/grub
2. Run "sudo update-grub".

Changed in nvidia-graphics-drivers-367 (Ubuntu):
importance: Undecided → Critical
Rahul Daga (marji09) wrote :

Is there a way to go back to 361? When I purge all nvidia and try installing 361 it installs 367 instead.

I don't know if this is related, but the initrd looks broken, though the system obviously boots fine (encrypted root). I tried running update-initramfs, but it's the same:

$ file /boot/initrd.img-4.4.0-36-generic
/boot/initrd.img-4.4.0-36-generic: ASCII cpio archive (SVR4 with no CRC)

$ stat /boot/initrd.img-4.4.0-36-generic | grep Size
  Size: 45048327 Blocks: 87988 IO Block: 1024 regular file

$ cpio -id < /boot/initrd.img-4.4.0-36-generic
44 blocks

$ tree ./
./
└── kernel
    └── x86
        └── microcode
            └── GenuineIntel.bin

$ du -sh kernel/
36K kernel/

So, where's the rest of the 45MB? Why isn't it gzipped? How does the system boot without cryptsetup in initrd?

Tesla (teesla) wrote :

7 dats without activity.
Is this going to be fixed?

Jeremy LaCroix (j-jlacroix) wrote :

I am also facing this issue. I will either get the results mentioned here, or I'll see a password prompt, but keyboard support isn't accepted. For me, it also happened when installing the latest nvidia driver.

GavMan (gavduffy) wrote :

I have something similar. While I can enter my encryption passwords fine, when it comes to login page screen goes black. Can hear the login noise in the background though.

Echo Nolan (echonolan) wrote :

Is there anything I can do to help get this fixed? It's a big deal for me, even with "quiet splash" removed from the grub options. I have several encrypted partitions. On boot, I get a password prompt for the root partition and the boot proceeds for a while. Then I get password prompts for each other partition separately. Sometimes it works, but sometimes it sits there waiting for 1 minute 30 seconds on some task. I think it's something like "x2d-dev-mapper", but I don't have it written down. If I see the wait message at all, the boot fails and I get dropped into emergency mode. It might not happen if I type in the passwords fast enough, but I'm not entirely sure.

Before this bug, I only had to type the password once (it's the same for all the partitions) and it would always succeed.

Installed 16.10. Without nvidia drivers the boot splash and password prompt are fine. With nvidia drivers, the boot splash appears (unlike in 16.04), but it's not interactive. Removing "splash" and "quiet" from the kernel command line again allows a normal text-only prompt and continued boot.

Rahul Daga (marji09) wrote :

16.10 with 367 is very buggy especially if using multiple monitors. I rue the day i upgraded to 367.

vambo põldra (vpoldra) wrote :

Experienced the same with 16.04.1 LTS and 378.13 nvidia drivers. Removed "splash" from GRUB_CMDLINE_LINUX_DEFAULT as recommended in comment #3 to work around this.

Michael D. (dobmeier-michael) wrote :

Same with 17.10 and nvidia-384 (384.90).

Daniel A. (alive-dienub) wrote :

Ubuntu 17.10 and nvidia-387, still a problem. Actually, it got even worse.

On a freshly installed system, fully updated via apt dist-upgrade:

When I edit the boot options and remove "quiet splash", the screen just goes black.

The only way to boot the system, is to go into rescue mode and continue normal boot.

Zurd (zurd3) wrote :

Bug still present, even if you do not see your password at the screen, you can still type it in, press enter, then type your user's password if you do not have auto-login, press enter, I've done it multiple times and I was able to log in, the screen will stay black a long time.

After this, to patch the bug just run in terminal:
sudo sed -i -e '/s/quiet splash//g' /etc/default/grub

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers