The cursor disappears on the top of the screen

Bug #1440012 reported by fcole90 on 2015-04-03
130
This bug affects 28 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
nvidia-graphics-drivers-346 (Ubuntu)
High
Unassigned
Nominated for Vivid by Alberto Salvia Novella

Bug Description

Move the cursor at the very top of the screen.
Expected: the cursor to be visible in its position.
What happens: the cursor becomes invisible until it is moved down again.

It is annoying especially when trying to close maximized windows or trying to enter in the menus.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: nvidia-346 346.47-0ubuntu4
ProcVersionSignature: Ubuntu 3.19.0-11.11-generic 3.19.3
Uname: Linux 3.19.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.17-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Apr 3 11:41:28 2015
InstallationDate: Installed on 2015-03-21 (12 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150321)
SourcePackage: nvidia-graphics-drivers-346
UpgradeStatus: No upgrade log present (probably fresh install)

fcole90 (fcole90) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-346 (Ubuntu):
status: New → Confirmed
Sean V Kelley (seanvk) wrote :

Duplicated behaviour on Dell XPS 13 (Broadwell) running Ubuntu 15.04
Using Intel Graphics (integrated)

Linux 3.19.0-13-generic #13-Ubuntu SMP Thu Apr 9 22:56:40 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

mesa-common-dev 10.5.2-0ubuntu1
xserver-xorg-video-intel 2:2.99.917-1~exp1ubuntu2build1
libdrm2 2.4.60-2

Sean

Sean V Kelley (seanvk) wrote :

This issue is not specific to a GPU driver (integrated or discrete). Rather, I think the problem isolation may be identified elsewhere. I've also seen this on Fedora. Will try to find a matching Bugzilla.

Changed in nvidia-graphics-drivers-346 (Ubuntu):
status: Confirmed → New
fcole90 (fcole90) wrote :

This didn't happen with nvidia-331

Martino jo (martinojones-2009) wrote :

I'm also seeing this issue.

uname: Linux mylappy 3.19.0-15-generic #15-Ubuntu SMP Thu Apr 16 23:32:37 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Nvidia: 346.59
Ubuntu: 15.04

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-346 (Ubuntu):
status: New → Confirmed
ACOSW (acosw) wrote :

Confirm this bug. Ubuntu 15.04, nvidia-346.

Changed in nvidia-graphics-drivers-346 (Ubuntu):
importance: Undecided → High
Changed in nvidia-drivers-ubuntu:
status: New → Confirmed
Changed in nvidia-graphics-drivers-346 (Ubuntu):
status: Confirmed → Triaged
Chris Cowan (agentme49) wrote :

I'm getting this too in Ubuntu 15.04 with nvidia 346.59, but only on my left monitor when I'm in dual monitor mode.

Heath Jones (hjones014) wrote :

I am also affected.

Nvidia-346.59
Linux Kernel 4.0 - Ubuntu version
Vivid

cl-netbox (cl-netbox) wrote :

On my notebook with hybrid graphics intel chip is not affected, nvidia chip is affected.
This is a known bug in the 346 driver release that was fixed in the 349 driver release.
Is it possible to add the latest nvidia 349.16 driver to ubuntu restricted repository ?

https://devtalk.nvidia.com/default/topic/807168/linux/possible-346-35-regression-hardware-cursor-not-drawn-on-top-screen-edge/

Goran Janković (gogeccc) wrote :

I am using this ppa:

https://launchpad.net/~mamarley/+archive/ubuntu/nvidia

I haven't tried installing nvidia-349 yet, though.

Goran Janković (gogeccc) wrote :

I have just installed nvidia-349 and issue is gone.

Leonardo Torok (leotorok) wrote :

I'm also affected by this issue, since upgrading to 15.04. I'm using a Sony VAIO Fit 14 (SVF14A17PBS) notebook, with a GT735M Nvidia GPU (proprietary driver, v 364). When I switch to my integrated Intel GPU, the issue is gone, so it seems related to the Nvidia driver.

Two solution to work the bug around :
– using driver 304.125 (provided with Ubuntu 15.04)
– fearlessly install driver 349 :
    sudo apt-add-repository ppa:mamarley/nvidia
    sudo apt-get update
    sudo apt-get install nvidia349

Heath Jones (hjones014) wrote :

I tried using the mamarley ppa with no luck. it would not install nvidia-349. Secondly I also tried using the xorg edgers ppa for 349, again with no luck. After installing driver 349, my laptop reboots and the cpu freezes. Cannot get to a shell or anything.

Heath Jones (hjones014) wrote :

I finally remedied the problem, using the xorg-edgers ppa. This is what I did -

1. sudo apt-add-repository ppa:xorg-edgers/ppa
2. sudo apt-get update
3. goto additional drivers and select driver 349.16
4. reboot
5. goto software/updates and goto the "Other Software" tab and UNCHECK the xorg-edgers ppa. I DID NOT PURGE THIS PPA.

The reason why I nixed this ppa is because after selecting driver 349, the software updater would try to pull in other updates from the xorg-edgers ppa which kept crashing my system. This allowed me to keep the driver 349 and not pull in any other updates. If you do a ppa-purge, it will also nix the driver, hence why i just unchecked it in the sources tab.

The_Legacy (es-ei6hel-n1) wrote :

Hi !!
I had the same issue on Ubuntu 15.04 with nvidia drivers 304.
I managed to solve the problem installing Nvidia 352 form xorg-edgers PPA.

Now, it works fine.
Thks

dfgsdgfsd (caganitasderato) wrote :

Same problem using intel video chipset:
 lshw -c video | grep 'configuration'
       configuration: driver=i915 latency=0
       configuration: latency=0

Taha KONUK (taha-konuk) wrote :

It also affects me. I'm using Ubuntu 14.04LTS with nvidia-346-driver

LaurentR (yknet-laurent) wrote :

Same problem on XUbuntu 14.04LTS since yesterday after upgrading nvidia 340 to nvidia 346.

Koen van Vliet (koen9410) wrote :

I am affected as well. I'm on Xubuntu 14.04LTS and I use the nvidia346.82 proprietary driver. I had tearing issues with my new NVIDIA card. To resolve it I added the following line to /etc/X11/xorg.conf :

Option "metamodes" "nvidia-auto-select +0 +0 { ForceFullCompositionPipeline = On }"

The tearing problems are now gone, but now my cursor disappears when I move it to the top of my screen.

Ipeacocks (ipeacocks) wrote :

This problem was fixed for me after update nvidia drivers to 355v from https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa repo.

Jason Yang (yangjinlong86) wrote :

Fixed after update nvidia drivers to 355
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update && sudo apt-get install nvidia-355

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers