10de:0cbc [HP EliteBook 8540w] Flickering with Ubuntu 14.04 and nvidia driver

Bug #1314367 reported by Tom Winterhalder on 2014-04-29
288
This bug affects 60 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
nvidia-graphics-drivers-346 (Ubuntu)
High
Unassigned

Bug Description

With a previous version of Ubuntu I already had this flickering. With additional options for the kernel module I was able to fix the flickering.

options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222" NVreg_Mobile=3 NVreg_ModifyDeviceFiles=0

With version 14.04 and the nvidia-331 (331.38-0ubuntu7) driver the flickering reappeared although the line is still present in options.conf.

Using modprobe --resolve-alias nvidia I found the correct driver module name which in my case is nvidia_331. Changing the module name in options.conf to nvidia_331 X doesn't start anymore. Removing the NVreg_ModifyDeviceFiles option X is starting again, but does not solve the issue.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xorg 1:7.7+1ubuntu8
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 331.38 Wed Jan 8 19:32:30 PST 2014
 GCC version: gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: Unity
Date: Tue Apr 29 21:09:41 2014
DistUpgraded: 2014-04-17 23:47:50,572 DEBUG enabling apt cron job
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.7, 3.13.0-24-generic, x86_64: installed
 nvidia-331, 331.38, 3.13.0-24-generic, x86_64: installed
 vboxhost, 4.3.10, 3.13.0-24-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 NVIDIA Corporation GT215GLM [Quadro FX 1800M] [10de:0cbc] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:1521]
InstallationDate: Installed on 2012-11-17 (528 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: Hewlett-Packard HP EliteBook 8540w
PccardctlStatus:
 Socket 0:
   3.3V
  16-bit
  PC Card
   Subdevice 0 (function 0) bound to driver "pata_pcmcia"
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=c6af930a-63f1-4015-9c42-bdde793e3e5a ro quiet splash
SourcePackage: xorg
UpgradeStatus: Upgraded to trusty on 2014-04-17 (11 days ago)
dmi.bios.date: 09/13/2013
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68CVD Ver. F.24
dmi.board.name: 1521
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 32.35
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68CVDVer.F.24:bd09/13/2013:svnHewlett-Packard:pnHPEliteBook8540w:pvr:rvnHewlett-Packard:rn1521:rvrKBCVersion32.35:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 8540w
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.11+14.04.20140409-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0-4ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0-4ubuntu5
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Tue Apr 29 21:06:04 2014
xserver.configfile: default
xserver.errors: open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.15.1-0ubuntu2

Tom Winterhalder (thwint) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Zach (z-buildrocks) on 2014-05-03
tags: added: nvidia
Zach (z-buildrocks) wrote :

The screen seems to not be updating correctly, right? I will switch back an forth between old and current views of various system programs, as well as applications like Chrome. Switching tabs seem sto cause this sometimes, and as I type this, my Gmail is popping on and off screen with every letter I type. Is this the same thing that is happening to you?

Tom Winterhalder (thwint) wrote :

Yes it is not updating correctly. Especially when switching between different aplications.

The Gmail thin I have never noticed so far. But I'm rarely using it.

Zach (z-buildrocks) wrote :

I was just using what gmail was doing as an example of what it does, full-screen applications work just fine, no issues. Only normal applications are affected.

I am pretty sure that I am being affected by this bug too so I made a screen recording of what I am seeing: http://youtu.be/p-iBqNlGhMI

Symptoms include:

 * Flickering when I have two google chrome windows open. It flickers between the two.
 * Other programs showing on top of others when I change XMonad viewports.

I am more that happy to try and work with somebody to figure out what is going on but I don't really know where to start.

Alexander Pavel (alexpavel97) wrote :

It's a Compiz problem. I figured this out about a week after I installed 14.04 (which was a week after 14.04 was released). To fix it, you get CompizConfig Settings Manager (ccsm) and you go down to "Workarounds" in the "Utility" Category and check the box that says "Force full screen redraws (buffer swap) on repaint". This will fix the problems as it forces the system to draw only the latest info and discard of any old buffers that cause it to flicker between old and new draws. I recently reset unity and I was trying to find out how I fixed it and then I remembered while I was on this page, so I decided to tell you guys how to fix it and maybe help Canonical developers fix this annoying problem.

Tom Winterhalder (thwint) wrote :

Unfortunately I can't confirm this workaround. In my case it just doesn't flicker directly after starting the computer. After a short moment using it the flickering reappears.

Eric Vlasov (eric-vlasov) wrote :

Anything above 331.79 causes flickering for me.

JW (jweill35) wrote :

340.17 still flickers

JW (jweill35) wrote :

I seem to have fixed it by going into CCSM>Workarounds>Force synchronization between X and GLX

Tom Winterhalder (thwint) wrote :

Thanks, but also this workaround does not help in my case. It improves the situation a little bit, but the flickering is still there.

Especially when switching between multiple windows.

Dalibor Dukic (kicdu) wrote :

Chrome heavily flickers on Ubuntu 14.04 with Awesome VM and 340.17 nvidia.
For me CCSM workaround does not help at all. ;(

Is there any other workaround to this annoying problem?

Mark Mandel (mark-mandel) wrote :

I just installed nvidia 340.24 (and several other updates) through ppa:xorg-edgers/ppa, and so far, no problems for the past hour.

Hoping this will end up being a valid workaround, as this update was driving me crazy.

Tom Winterhalder (thwint) wrote :

Also this workaround does not solve the issue for me. I hope there will be a solution soon.

Miguel Ángel Molina (sslapp) wrote :

The bug is not fixed in 340.24.

With 14.04.1 desktop 64b and this nvidia driver version the issue is still there. I checked the "Force full screen redraws (buffer swap) on repaint" option in compiz and this works for me.

Cade Lambert (crl0901) wrote :

Also using 340.24 and Ubuntu 14.04.1. The workaround Miguel mentioned above, checking the "Force full screen redraws (buffer swap) on repaint" option in Compiz, resolved the flickering issue for me.

Tom Winterhalder (thwint) wrote :

Still no luck. All workarounds don't help in my case.

Miguel Ángel Molina (sslapp) wrote :

Still not fixed in nvidia driver 340.32.
This issue doesn't occur with nouveau driver in 14.04.1 neither with nvidia driver and ubuntu 12.04.4

Thiru (thiru0130-s) wrote :

Just another confirmation. I'm running Ubuntu 14.04.1 with nvidia driver 340.32 and it's still and issue unless the Compiz workaround above is applied.

Dave Einerson (deinerson1) wrote :

Turning on "Force full screen redraws (buffer swap) on repaint" resolved the flickering - yay! I attached a screen shot of the setting.

Tom Winterhalder (thwint) wrote :

Still for me there is no workaround. Even if the above mentioned workaround seems to be working for some it does not for me.

I just loaded Ubuntu 14.04LTS 64-bit on a Dell D630 with an integrated Nvidia Quadro NVS 135m display adapter, removed nouveau completely and installed 340.32 from the Nvidia site (not the edgers PPA), andthe flicker was present. A common suggestion is to disable dithering in nvidia-settings, which did not help. The workaround posted by Alexander Pavel above resolved this. I previously was running an Ubuntu 14.04LTS 64-bit build using the latest properietary driver that is native to Ubuntu 14.4 (331.something) and did not have this issue.

Graham Walter (mailinggraham) wrote :

Just installed Ubuntu 14.04 and installed Nvidia driver 340.24 and the flicker was there especially on firefox. Managed get rid of it by unchecking "Allow Flipping" under OpenGL in Nvidia settings. However when switching tabs, parts of the page will not display properly until I scroll. Will try downgrading to 331 ver and check if that helps. Also haven't tried the workaround on compiz.

Gintautas Miliauskas (gintas) wrote :

I also ran into this issue after upgrading to Trusty (nvidia driver 331.38). Checking "Force full screen redraws" and "Force synchronization between X and GLX" seems to have helped.

Gintautas Miliauskas (gintas) wrote :

Actually, scratch that, the two options did not help at all. The flickering is terrible as before. I restarted the machine to make sure. When I have two Chrome browser windows open, one works fine, but the other flickers like crazy when switching tabs.

I am using xmonad as my window manager, that might be contributing to the problem.

parinay (parinay) wrote :

The workaround of changing the settings "Force full screen redraws (buffer swap) on repaint" through CCSM, seems to help resolve the issue for me. I am running Ubuntu 14.04 with NVIDIA 340.32.

Thanks.

Changed in xorg (Ubuntu):
importance: Undecided → High
nicolas_dh (nicolas-dh) wrote :

Your Workaround:
  ccsm Utility->Workaround->"Force full screen redraws (buffer swap) on repaint" [x]
stopped "flickering" also for me:
with NVIDIA's 343.22 (Latest Short Lived Branch version) on Ubuntu 14.04 amd64 with GeForce GTX 550 Ti

johntosh (j-hentosh) wrote :

My 14.04 system also suffers from a variation of this problem. FWIW, I find that the "flicker problem" is tied to the PERFORMANCE LEVEL of my GTX 275. If I watch the GPU from the PowerMizer panel of the "NVIDIA X Server Settings" application, the "flicker problem" appears when the Performance Level drops to 0. At Performance Level 1 or 2, the problem disappears.

By "flicker problem", I mean that the screen erratically switches between a partially-updated display and a fully-updated display. All applications that don't "sufficiently challenge" the GPU, and cause the nVidia Performance Level to climb, suffer from this problem! However, if I run one of my high frame-rate OpenGL programs, the problem disappears, until I exit the application, and give the nVidia driver stack a chance to settle back down to Performance Level 0.

BTW, none of the Compiz tweaks mentioned in this thread, or any other, has helped my situation, only the Performance Level matters. I'm now running nVidia Driver version 340.46, but the problem existed when I was running 331. My system is an "old" LGA 1366 Quad Core i7 with 12GB of memory, and a GTX 275.

johntosh (j-hentosh) wrote :

An "edit" to my previous comment. This problem does not appear when running 331.38 (for me). I've rolled back the driver.

Tom Winterhalder (thwint) wrote :

Still no success. Freshly installed Ubuntu 14.10 with Nvidia driver 331.89-0ubuntu5.

CCSM workaround mentioned above in this thresd still does not solve the issue.

The system is completely useless with this flickering.

karoshi (whatisor) wrote :

Compiz works for me:
Ubuntu 14.04 with updated
Nvidia GeForce GTX 560/PCIe/SSE2

$ nvidia-smi
Wed Oct 29 09:09:59 2014
+------------------------------------------------------+
| NVIDIA-SMI 340.29 Driver Version: 340.29 |
|-------------------------------+----------------------+----------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 560 Off | 0000:01:00.0 N/A | N/A |
| 20% 38C P12 N/A / N/A | 336MiB / 1023MiB | N/A Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Compute processes: GPU Memory |
| GPU PID Process name Usage |
|=============================================================================|
| 0 Not Supported |
+-----------------------------------------------------------------------------+

Juan Simón (simonbcn) wrote :

Nvidia GeForce GT220
Driver Version: 340.58 (downloaded from Nvidia page and compiled directly with kernel 3.17.2, no DKMS)
Ubuntu 14.04 64 bits

I have to set "Performance Level" to "Prefer Maximum Performance" to decrease greatly this problem. Although it still fails in a very few occasions.

This change isn't permanent if you use the "Nvidia X Server Settings" tool. For permanent change it's necessary execute the next line on every start: "nvidia-settings -a GPUPowerMizerMode=1"

Olli Niemi (olliniem) wrote :

This happens also for me. Ubuntu 14.10 Geforce GTX 750 and xorg edgers nvidia-346. But so far I've seen it only in Image Viewer and in gnome Terminal.

Olli Niemi (olliniem) wrote :

Some status update: I enabled "Don't wait for video sync" and "Force full screen redraws" from compizconfig. I've not yet experienced the flickering problem. Before the compizconfig modification the problem was severe in gnome image viewer, right after rebooting.

I have never seen problems as severe as in Robert's video: for me, the flickering never occurred between different windows. The flickering occurred mostly in gnome image viewer and gnome terminal: for example, when I exited vim, I could see the vim screen still there, painted over by the command line prompt and the flickering was the same rate as the cursor blink rate. It was worse in image viewer however, making it almost unusable.

Even though the flickering happens inside window borders I would still rate this very severe bug, disabling common out-of-the-box media functionality.

david6 (andrew-dowden) wrote :

Compiz works for me: (Force full screen redraws (buffer swap) on repaint [x])
Ubuntu 14.04 fully updated
Quadro K420/PCIe/SSE2

Needed to switch from Nouveau (to edgers Nvidia 340.58) to resolved DisplayPort not handling screen saver / blanking, and poor performance (or X server crash) with DVI (Dual Link).

I have just upgraded to a Samsung 27" with 2560 x 1440 resolution. The K420 video card was also required, as earlier cards (NSA 310, NVS 315) could not keep up with higher resolution. Tearing and remnants on full screen video or larger scaling of some applications.

Compiz workaround also works for me: force full screen redraws (buffer swap) on repaint [x]
Ubuntu 14.04.1 fully updated
nVidia driver versión 346.35 (from xorg edgers PPA)
nVidia GeForce GTX 570

tags: added: bios-outdated-f.50
Changed in xorg (Ubuntu):
status: Confirmed → Incomplete
tags: added: utopic
Tom Winterhalder (thwint) wrote :

I already installed the latest BIOS long time ago.

dmidecode -s bios-version
68CVD Ver. F.50

dmidecode -s bios-release-date
07/08/2014

Mike Loebl (mloebl) wrote :

@penalvch many of us are using different hardware vendors so I don't believe this is an HP bios thing at all. I've got a GIGABYTE GA-Z77X-UP5 TH Z77 motherboard running the latest bios. My video card is a nVidia GeForce GTX 570 and I've been trying both release and beta NVIDIA binary drivers on with the same flickering problems (terminal being the worst offender)

Tom Winterhalder, could you please test http://cdimage.ubuntu.com/daily-live/current/ and advise if this is reproducible?

tags: added: latest-bios-f.50
removed: bios-outdated-f.50
Tom Winterhalder (thwint) wrote :

I'm afraid I can't install it on my laptop for now. How do I use the nvidia driver from the live cd? By default the nouveau driver is loaded.

Dan Kegel (dank) wrote :

fwiw: I hit this using the latest from Nvidia's download site, and
also using the xorg-edgers ppa ( 346.47-0ubuntu1-xedgers14.04.1 ).
The flipping in the terminal seems to be at the same speed as the cursor blink.
I only noticed it in gnome terminal. xterm does not exhibit the problem.
My system's a Dell T7500 with a Geforce gtx 570 running somewhat up to date ubuntu 14.04.1

"CCSM>Workarounds>Force synchronization between X and GLX"
seemed to help a bit initially, but the problem is still present enough
to make gnome terminal nearly unusable.

"nvidia-settings -a GPUPowerMizerMode=1" seems to help more. With that,
I haven't seen the flipping in my 30 seconds of extensive testing.

Like Tom, I don't think I can install a new OS on this system, but I guess I might
have time to boot the live cd sometime.

Tom Winterhalder (thwint) wrote :

Finally I could not wait and installed the new version of Ubuntu today.

Even installing all the updates did not change anything. The flickering is still there and none of the described workarounds are working.

Tom Winterhalder, could you please advise which driver and version specifically are you testing in Vivid?

Mike Loebl (mloebl) wrote :
Tom Winterhalder (thwint) wrote :

I'm using the nvidia driver which is included in the 15.04 version:
340.76-0ubuntu1

ii nvidia-340 340.76-0ubuntu1 amd64 NVIDIA binary driver - version 340.76
ii nvidia-340-uvm 340.76-0ubuntu1 amd64 NVIDIA Unified Memory kernel module
ii nvidia-opencl-icd-340 340.76-0ubuntu1 amd64 NVIDIA OpenCL ICD
ii nvidia-prime 0.7 amd64 Tools to enable NVIDIA's Prime
ii nvidia-settings 346.35-0ubuntu1 amd64 Tool for configuring the NVIDIA graphics driver

I haven't tried any other drivers so far. What I did is try the workaround with options.conf described in the first post. This permanently solved the issue in older versions of Ubuntu. Now the screen goes black and does not boot if the options are enabled.

Tom Winterhalder, as the latest version of the driver in the repository is also the latest one available from nvidia.com, the bug you are reporting is an upstream one. Could you please report this to them via https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia#Reporting_an_upstream_bug ?

As well, could you please comment to if using nouveau offers a WORAKROUND?

summary: - Flickering with Ubuntu 14.04 and nvidia card reappeared
+ 10de:0cbc Flickering with Ubuntu 14.04
description: updated
tags: added: vivid
affects: xorg (Ubuntu) → nvidia-graphics-drivers-346 (Ubuntu)
Changed in nvidia-graphics-drivers-346 (Ubuntu):
status: Incomplete → Triaged
summary: - 10de:0cbc Flickering with Ubuntu 14.04
+ 10de:0cbc [HP EliteBook 8540w] Flickering with Ubuntu 14.04

Not that's it's a realistic resolution, but noticed this week when upgrading from a 570 GTX to 970 GTX card, the flickering so far seem s to have gone away. As a work around for the flickering within the NVidia server settings I'd set the Preferred Mode to "Maximum performance". However I haven't had to do that yet with the 970 and fine in "Auto". Also noticed it went from 3 to 4 performance levels as well and it has no problem being at the lowest level unlike the 570. I'll make sure to report back if it reappears and not just "lucky" and not seen it.

Tom Winterhalder (thwint) wrote :

I opened a bug at Nvidia. Short answer: no fix :-(

So I am left alone with an almost useless notebook

Tom Winterhalder, could you please clarify what you mean by "no fix"?

Did nvidia say they refuse to fix it?

Tom Winterhalder (thwint) wrote :

Yes that is exactly what they said.

Mail from support:
The bug looks bad and we would love to fix it.

But I discussed this with our product manager, and was informed that there are no updates planned to the 340 driver branch and that this older tesla generation graphics card will only be supported in a legacy driver branch.

Typically we provide very few updates to legacy drivers and the updates are usually only security related or perhaps related to very significant business impact.

So based on the above it is extremely unlikely that this issue will be fixed, and I will close this case.

Tom Winterhalder, wow that got ugly quickly.

Despite this, would nouveau avoid you this issue in your present release?

Tom Winterhalder (thwint) wrote :

Yesterday I uninstalled the nvidia driver and tried to get the nouveau to work. As the nouveau does not recognize the proper resolution I have to use xrandr to create and add a new one.

As a lack of time I have not completely solved this issue yesterday. At least with the default (and maximal recognized) resolution of 1024x768 there is no flickering visible.

When adding a new resolution for 1920x1080 I have seen some sort of flickering. But in the current configration the size of virtual screen and the configuration in the xorg.conf does not match. In this setting I have seen that it does not correctly refresh the screen.
But I don't know If this is related to the wrong configuration.

Is there a way to get the X configuration from the live cd and use it on the installed system? I think when installing last time I almost had a correct resolution.

Tom Winterhalder, just to clarify, are you testing nouveau with the latest release of Ubuntu via http://cdimage.ubuntu.com/daily-live/current/ ?

If not, could you please do this and advise to how it works by default (i.e. no configuration modifications)?

Tom Winterhalder (thwint) wrote :

On the 02.03 I installed the 15.04 development version from scatch. With nouveau I never had a resolution available wich was more than 1024x768 unless using xrandr after installation.

Tom Winterhalder, regarding nouveau, given it still fully supports your chipset, you may want to file a new reported scoped to nouveau about the resolution issue via a terminal:
ubuntu-bug xorg

Please ensure you have xdiagnose installed, and that you click the Yes button for attaching additional debugging information.

Also, please feel free to subscribe me to it.

summary: - 10de:0cbc [HP EliteBook 8540w] Flickering with Ubuntu 14.04
+ 10de:0cbc [HP EliteBook 8540w] Flickering with Ubuntu 14.04 and nvidia
+ driver
To post a comment you must log in.