10de:0dda [HP EliteBook 8560w] Brightness controls are not working nvidia-319 and nvidia-331

Bug #1281019 reported by Priyantha Bleeker
68
This bug affects 13 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-346 (Ubuntu)
Low
Unassigned

Bug Description

The Brightness keys (FN+F9 and FN+FN10) are doing 'something' in the right corner of the screen the brightness control window does show-up and changes, but the brightness of the screen itself does not via Nvidia drivers version 319 or 331.

There is the bugreport at the official Nvidia forums:
https://devtalk.nvidia.com/default/topic/539462/linux/-nvidia-319-12-brightness-controls-not-working-on-laptop-ubuntu-13-03-/2/

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: xorg 1:7.7+1ubuntu6
ProcVersionSignature: Ubuntu 3.11.0-15.25-generic 3.11.10
Uname: Linux 3.11.0-15-generic x86_64
NonfreeKernelModules: nvidia appassure_vss
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is een map: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 331.38 Wed Jan 8 19:32:30 PST 2014
 GCC version: gcc version 4.8.1 (Ubuntu/Linaro 4.8.1-10ubuntu9)
.tmp.unity.support.test.0:

ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Mon Feb 17 10:05:44 2014
DistUpgraded: Fresh install
DistroCodename: saucy
DistroVariant: ubuntu
DkmsStatus:
 appassure-vss, 5.3.6, 3.11.0-15-generic, x86_64: installed
 nvidia-331, 331.38, 3.11.0-15-generic, x86_64: installed
 nvidia-331-uvm, 331.38, 3.11.0-15-generic, x86_64: installed
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 NVIDIA Corporation GF106GLM [Quadro 2000M] [10de:0dda] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:1631]
MachineType: Hewlett-Packard HP EliteBook 8560w
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-15-generic root=UUID=caf0bb2d-fbef-46ff-be64-0ec601243262 ro splash quiet
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/15/2013
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68SVD Ver. F.42
dmi.board.name: 1631
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 01.3D
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68SVDVer.F.42:bd07/15/2013:svnHewlett-Packard:pnHPEliteBook8560w:pvrA0001D02:rvnHewlett-Packard:rn1631:rvrKBCVersion01.3D:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 8560w
dmi.product.version: A0001D02
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52+git20140121.46d451c9-0ubuntu0sarvatt~saucy
version.libgl1-mesa-dri: libgl1-mesa-dri 10.2.0~git20140215.1020d893-0ubuntu0sarvatt~saucy
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.2.0~git20140215.1020d893-0ubuntu0sarvatt~saucy
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.14.5-1ubuntu2~saucy1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.99+git20140206.8de6f7b2-0ubuntu0sarvatt~saucy
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910+git20140210.5142d1ca-0ubuntu0sarvatt~saucy
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.9+git20130730.300c5a32-0ubuntu0sarvatt
xserver.bootTime: Mon Feb 17 10:03:57 2014
xserver.configfile: /etc/X11/xorg.conf
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.14.5-1ubuntu2~saucy1

Revision history for this message
Priyantha Bleeker (priyantha-priyantha) wrote :
Ingo Gerth (igerth)
Changed in xorg (Ubuntu):
status: New → Confirmed
tags: added: latest-bios-f.42
removed: xorg
Changed in xorg (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
description: updated
summary: - Brightness controls are not working nvidia-319 and nvidia-331
+ 10de:0dda [HP EliteBook 8560w] Brightness controls are not working
+ nvidia-319 and nvidia-331
Revision history for this message
Ingo Gerth (igerth) wrote :

Christopher, I can confirm that this bug still occurs. It is directly related to, no need to previous reports.

Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Ingo Gerth, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report by executing the following in a terminal:
ubuntu-bug xorg

Please ensure you have xdiagnose installed, and that you click the Yes button for attaching additional debugging information.

For more on this, please see the official Ubuntu documentation:
Ubuntu X.Org Team, Ubuntu Bug Control, and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report will delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Revision history for this message
Ingo Gerth (igerth) wrote :

Christopher, my hardware is being tracked here:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-319/+bug/1241745

I hope the bug report is complete.

Martin Spacek (mspacek)
Changed in xorg (Ubuntu):
status: Incomplete → Confirmed
Changed in xorg (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
James Ramsay (f-jack) wrote :

I marked it as affecting the Linux package. The kernel team should pick up this bug and do further testing.

Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Jack Ramsay, please do not add stray bug tasks to this report, without full, technical justification on why this is a kernel issue, versus an issue within the nvidia driver. As is known, linux kernel upstream does not WORKAROUND or fix bugs in the nvidia driver, as it is proprietary, and bugs within it are fixed by nvidia.

no longer affects: xorg (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
affects: linux → xorg (Ubuntu)
Changed in xorg (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Revision history for this message
Martin Spacek (mspacek) wrote :

Ingo Gerth, is this a new problem that occurs only in the more recent nvidia blobs, or does it also occur with older ones (say 304)? If the latter, since you have a Quadro 2000M, this bug should probably be marked as a duplicate of Bug #562005:

Backlight controls of laptops with NVIDIA NVS and Quadro FX 880M GPUs no longer function while using proprietary drivers
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/562005

Revision history for this message
Ingo Gerth (igerth) wrote :

Occurs since 13.10, with drivers >304. With 304 everything works fine.

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for xorg (Ubuntu) because there has been no activity for 60 days.]

Changed in xorg (Ubuntu):
status: Incomplete → Expired
Ingo Gerth (igerth)
Changed in xorg (Ubuntu):
status: Expired → Confirmed
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Ingo Gerth, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report by executing the following in a terminal:
ubuntu-bug xorg

Please ensure you have xdiagnose installed, and that you click the Yes button for attaching additional debugging information.

For more on this, please see the official Ubuntu documentation:
Ubuntu X.Org Team, Ubuntu Bug Control, and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report will delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Changed in xorg (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Ingo Gerth (igerth) wrote :

These automated messages are starting to be annoying.

My hardware is already being tracked here:
https://bugs.launchpad.net/nvidia/+bug/1241745

Why is the status "Incomplete"?

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for xorg (Ubuntu) because there has been no activity for 60 days.]

Changed in xorg (Ubuntu):
status: Incomplete → Expired
Ingo Gerth (igerth)
Changed in xorg (Ubuntu):
status: Expired → Confirmed
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Ingo Gerth, please stop toggling this report, as it's not scoped to you, your hardware, or your problem. If you have comments, please post them in the bug report you made.

Thank you for your understanding.

Changed in xorg (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for xorg (Ubuntu) because there has been no activity for 60 days.]

Changed in xorg (Ubuntu):
status: Incomplete → Expired
Revision history for this message
Priyantha Bleeker (priyantha-priyantha) wrote :

This is still a problem, and not solved by the Nvidia guys.

https://devtalk.nvidia.com/default/topic/539462/linux/-nvidia-319-12-brightness-controls-not-working-on-laptop-ubuntu-13-03-/4/

So no solution yet for us...

Changed in xorg (Ubuntu):
status: Expired → Confirmed
no longer affects: nvidia-graphics-drivers-340 (Ubuntu)
no longer affects: nvidia-graphics-drivers-346 (Ubuntu)
Changed in xorg (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for xorg (Ubuntu) because there has been no activity for 60 days.]

Changed in xorg (Ubuntu):
status: Incomplete → Expired
Revision history for this message
sandipt (sandipt) wrote :

NVIDIA internal Bug 1351054 : Linux EU/OEM: [NVidia 319.12] HP EliteBook 8560w Brightness controls not working on laptop (Ubuntu 13.03).

We have investigated this issue and found this is not NVIDIA driver bug. There is issue in HP notebook SBIOS. For further assistance good to contact HP support.

Changed in xorg (Ubuntu):
importance: Low → Undecided
status: Expired → Invalid
Revision history for this message
xtsbdu3reyrbrmroezob (xtsbdu3reyrbrmroezob) wrote :

still broken in version 375

Changed in nvidia-graphics-drivers-375 (Ubuntu):
status: New → Confirmed
Revision history for this message
xtsbdu3reyrbrmroezob (xtsbdu3reyrbrmroezob) wrote :

this issue is more generic than the HP hardware.

this bug appears to affect ALL QUADRO CARDS

no longer affects: xorg (Ubuntu)
tags: added: bios-outdated-f.50
removed: latest-bios-f.42 nvidia-319 nvidia-331
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Priyantha Bleeker, as per your forum post, NVIDIA advised to update the BIOS, and another user advised that updating the driver to 375.66 worked for them.

Could you please advise on your BIOS version, and if testing a NVIDIA driver later than the last one you tested (346) works?

affects: nvidia-graphics-drivers-375 (Ubuntu) → nvidia-graphics-drivers-346 (Ubuntu)
Changed in nvidia-graphics-drivers-346 (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
tags: added: bios-outdated-f.63
removed: bios-outdated-f.50
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for nvidia-graphics-drivers-346 (Ubuntu) because there has been no activity for 60 days.]

Changed in nvidia-graphics-drivers-346 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.