nvidia-340 340.108-0ubuntu2: nvidia-340 kernel module failed to build (oem 5.6 kernel)

Bug #1885344 reported by Petar Velkovski on 2020-06-27
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-340 (Ubuntu)
Undecided
Unassigned

Bug Description

Nvidia kernel module fails to build with linux kernel 5.6.0. Exits with error code 2.

Description: Ubuntu 20.04 LTS
Release: 20.04

linux-image-unsigned-5.6.0-1018-oem:
  Installed: 5.6.0-1018.18
  Candidate: 5.6.0-1018.18
  Version table:
 *** 5.6.0-1018.18 500
        500 http://archive.ubuntu.com/ubuntu focal-proposed/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: nvidia-340 340.108-0ubuntu2
ProcVersionSignature: Ubuntu 5.4.0-40.44-generic 5.4.44
Uname: Linux 5.4.0-40-generic x86_64
NonfreeKernelModules: talpa_vfshook talpa_pedconnector talpa_pedevice talpa_vcdevice talpa_core talpa_linux talpa_syscallhook nvidia
ApportVersion: 2.20.11-0ubuntu27.3
Architecture: amd64
CasperMD5CheckResult: skip
DKMSKernelVersion: 5.6.0-1018-oem
Date: Sat Jun 27 02:15:51 2020
DuplicateSignature: dkms:nvidia-340:340.108-0ubuntu2:/var/lib/dkms/nvidia-340/340.108/build/nv-drm.c:54:25: error: implicit declaration of function ‘drm_pci_init’; did you mean ‘drm_mm_init’? [-Werror=implicit-function-declaration]
InstallationDate: Installed on 2020-04-24 (63 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
PackageVersion: 340.108-0ubuntu2
Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 3.8.2-0ubuntu2
PythonDetails: N/A
RelatedPackageVersions:
 dpkg 1.19.7ubuntu3
 apt 2.0.3
SourcePackage: nvidia-graphics-drivers-340
Title: nvidia-340 340.108-0ubuntu2: nvidia-340 kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

Petar Velkovski (pvelkovski) wrote :
tags: removed: need-duplicate-check
summary: nvidia-340 340.108-0ubuntu2: nvidia-340 kernel module failed to build
+ (oem 5.6 kernel)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: New → Confirmed
Witold Krecicki (wpk) wrote :

Same thing happens on fresh install of 20.10 with 5.8.0-23-generic kernel.

Humphrey (humphrey2635) wrote :

After updating the nvidia drivers, the login screen stopped showing.
It helped to switch to the console ctrl + alt + f(1-9).
Completely removed everything related to nvidia drivers.
Reinstalled all drivers on a clean one.

Pablo Piaggio (papibe) wrote :

Same problem here. It also affects: 5.8.0-34-generic

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.1 LTS
Release: 20.04
Codename: focal

$ uname -a
Linux vanhalen 5.8.0-34-generic #37~20.04.2-Ubuntu SMP Thu Dec 17 14:53:00 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Also, this is valid: https://askubuntu.com/questions/969352/uninstalling-and-then-reinstalling-nvidia-384-kills-colord

In other words the shell bug is still there, however, fixing manually does not fix the problem, as some header problem stops the creation of the module.

Any alternative? nouveau is heating up my system.

Thanks in advance,

farlander762 (farlander762) wrote :

Don't know if this helps, but it started for me during a normal Ubuntu kernel update (5.8.0-34-generic). This morning, 5.8.0-36-generic was pushed down and still doesn't work.

I am still able to boot my system using 5.4.0-59-generic. I am using the manually installed Nvidia GK208B [GeForce GT 710] driver.

I'm assuming you guys can reach me so please do if I can provide any information.
Thanks!

TJust to report one more case, same here. This morning could not load video driver. In recovery mode upgraded system but video driver failed to compile in kernel 5.8. Booting normally with kernel 5.4.

Thanks.

Andrea (andrea-amoroso81) wrote :

Ubuntu 20.04..using the PPA as explained in this other bug https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-340/+bug/1872950 it builds and works too..
sudo add-apt-repository ppa:kelebek333/nvidia-legacy

Philip J. Smith (philjsmith67) wrote :

Confirmed, using PPA kelebek333/nvidia-legacy works with my ancient GT216M [GeForce GT 230M].
Thank you Andrea (andrea-amoroso81).

Confirmed, using PPA kelebek333/nvidia-legacy with GeForce 8400 GS/PCIe/SSE2 kernel 5.8 loads fine.

Thanks Andrea (andrea-amoroso81).

Spiros Kantas (spi-k) wrote :

Confirmed, using PPA kelebek333/nvidia-legacy with GeForce 9600M GT (Ubuntu 20.04.1 LTS with kernel 5.8.0-36-generic).

A big thank you to Andrea (andrea-amoroso81) from me as well.

MARCO RUGIADOSI (marcorugia) wrote :

Confirmed, using PPA kelebek333/nvidia-legacy with GeForce GT9600 Linux 5.8.0-36-generic x86_64 ubuntu 20.04 works fine

Thanks Andrea

Mahmoud F.Elshazly (elshazly5) wrote :

Great effort @Andrea (andrea-amoroso81). I can confirm that using PPA kelebek333/nvidia-legacy with GeForce GTS 250 (Ubuntu 20.04.1 LTS with kernel 5.8.0-36-generic) works like a charm.

Thanks again Andrea.

Alex (alexfjara666) wrote :

Hi, i also got the issue of the last days.
Unfortunately my tries to fix it, doesn't works:
> 20.04 LTS/ 5.8.0-36-generic -> not able to boot
> 20.04 LTS/ 5.4.0-59-generic -> able to boot

I've tried to fix it via the recovery-mode of '5.8.0-36-generic'
-> sudo add-apt-repository ppa:kelebek333/nvidia-legacy
The download seems to be ok, but '5.8.0-36-generic' is still not able to boot.

What have i done wrong, or are there some other advises?
Kind regards, Alex

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers