With nvidia-340 driver installed it won't boot to SDDM

Bug #1806817 reported by Jonty Gamao on 2018-12-05

This bug report will be marked for expiration in 15 days if no further activity occurs. (find out why)

12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-340 (Ubuntu)
Undecided
Unassigned
nvidia-prime (Ubuntu)
Undecided
Unassigned
sddm (Ubuntu)
Undecided
Unassigned

Bug Description

It's hard to report this bug on a laptop with this driver installed, so I'm reporting this with on my laptop with a much newer NVIDIA driver (but not recommended).

My laptop, Lenovo Z40, has NVIDIA GeForce GT820M. With nvidia-340 driver installed it won't boot to SDDM (also tried with LightDM). Opening up another TTY is useless because the same message "PKCS#7 signature not signed with a trusted key" keeps getting spammed. I had to go to recovery to switch to Intel graphics.

[CODE]
$ lspci
03:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] (rev a1)
[/CODE]
---
ProblemType: Bug
ApportVersion: 2.20.10-0ubuntu13.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: yamiyukisenpai 2601 F.... pulseaudio
 /dev/snd/controlC1: yamiyukisenpai 2601 F.... pulseaudio
CurrentDesktop: KDE
Dependencies:

DistroRelease: Ubuntu 18.10
InstallationDate: Installed on 2018-08-05 (121 days ago)
InstallationMedia: Kubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
MachineType: LENOVO 20366
NonfreeKernelModules: wl
Package: nvidia-prime 0.8.10
PackageArchitecture: all
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.18.0-12-generic root=UUID=3ac3d3b6-dc27-4365-a548-82d3be4e5ac9 ro quiet splash vt.handoff=1
ProcVersionSignature: Ubuntu 4.18.0-12.13-generic 4.18.17
RelatedPackageVersions:
 linux-restricted-modules-4.18.0-12-generic N/A
 linux-backports-modules-4.18.0-12-generic N/A
 linux-firmware 1.175.1
Tags: cosmic
Uname: Linux 4.18.0-12-generic x86_64
UpgradeStatus: Upgraded to cosmic on 2018-10-10 (55 days ago)
UserGroups: adm cdrom dip kvm lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 07/21/2015
dmi.bios.vendor: LENOVO
dmi.bios.version: 9BCN91WW
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Lancer 4A5
dmi.board.vendor: LENOVO
dmi.board.version: 31900058STD
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo Z40-70
dmi.modalias: dmi:bvnLENOVO:bvr9BCN91WW:bd07/21/2015:svnLENOVO:pn20366:pvrLenovoZ40-70:rvnLENOVO:rnLancer4A5:rvr31900058STD:cvnLENOVO:ct10:cvrLenovoZ40-70:
dmi.product.family: IDEAPAD
dmi.product.name: 20366
dmi.product.sku: LENOVO_MT_20366_BU_idea_FM_Lenovo Z40-70
dmi.product.version: Lenovo Z40-70
dmi.sys.vendor: LENOVO

Jonty Gamao (yamiyukisenpai) wrote :

One thing I forgot to mention: nvidia-prime is also broken on nvidia-340. Even with Intel graphics in use instead of NVIDIA, the laptop remains unusable.

It's fine for newer drivers, like nvidia-driver-415

Daniel van Vugt (vanvugt) wrote :

Sounds like bug 1798863.

Please run this command to send us more system info:

  apport-collect 1806817

Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: New → Incomplete
Changed in nvidia-prime (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected cosmic
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

It's fine even if I don't have nvidia-340 installed?

I can't really run my laptop with it because it's unusable even with NVIDIA GPU switched off (as mentioned).

Daniel van Vugt (vanvugt) wrote :

I'm not sure the log messages are related to the laptop failing to boot. Let's make this bug just about the laptop failing to boot.

In theory those log messages were bug 1798863, but you already have the fix for that installed.

summary: - PKCS#7 signature not signed with a trusted key
+ With nvidia-340 driver installed it won't boot to SDDM
Daniel van Vugt (vanvugt) wrote :

This sounds like bug 1765923. Do you agree?

Changed in sddm (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers