Uninstall left nouveau blacklisted

Bug #1761593 reported by Kev Bowring on 2018-04-05
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-340 (Ubuntu)
High
Alberto Milone
Bionic
Undecided
Alberto Milone
nvidia-graphics-drivers-390 (Ubuntu)
High
Alberto Milone
Bionic
High
Alberto Milone

Bug Description

SRU Request:

[Impact]

The driver package won't remove the blacklist file from /etc (/etc/modprobe.d/nvidia-340.conf), preventing nouveau from being loaded.

[Test case]

1) Enable proposed, install the new nvidia-340

2) Uninstall nvidia-340

3) See if either /etc/modprobe.d/nvidia-340.conf or /lib/modprobe.d/nvidia-340.conf.

[Regression potential]

Low, since it should move a blacklist file from /etc to /lib

______________________________________________________________

Following a successful install and subsequent use of nvidia-340 - uninstallation of nvidia via Additional Drivers led to a reboot to a desktop at 640x480 px.

Investigation found an nvidia created file left on the system blacklisting nouveau, deleted file and rebooted to normal desktop.

Didn't think about ubuntu-reporting this - can try and replicate and apport-collect if it's of any use.

Kev Bowring (flocculant) on 2018-04-05
summary: - Uninstall left nouveau blacklist
+ Uninstall left nouveau blacklisted
Kev Bowring (flocculant) wrote :

someone turned up in #ubuntu+1 - they had nvidia-340.conf left after uninstallation

Vitor Luis (exterminador) wrote :

I've had exactly the same problem described above. Installed Nvidia drivers via via Additional Drivers and all was working fine.
After that I decided to remove the Nvidia drivers and rebooted the laptop. My screen resolution was set as 640x480, without any possibility of changing it.
Asking for help, on #ubuntu+1 @ Freenode, someone told me to check /etc/modprobe.d for a nvidia conf file. I've done that and it was there.
Deleting the file and rebooting the laptop solved the issue.

Exterminador

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: New → Confirmed
Kev Bowring (flocculant) wrote :

apport-collect failed to collect new information for this bug as nvidia is no longer installed.

test@test-MBB-44608:~$ ls /etc/modprobe.d/
alsa-base.conf blacklist-framebuffer.conf dkms.conf
blacklist-ath_pci.conf blacklist-modem.conf iwlwifi.conf
blacklist.conf blacklist-oss.conf nvidia-340.conf
blacklist-firewire.conf blacklist-rare-network.conf
test@test-MBB-44608:~$ cat /etc/modprobe.d/nvidia-340.conf
# This file was installed by nvidia-340
# Do not edit this file manually

blacklist nouveau
blacklist lbm-nouveau
alias nouveau off
alias lbm-nouveau off

sudo apt autoremove did:
The following packages will be REMOVED
  dkms lib32gcc1 libc6-i386 libcuda1-340 libxnvctrl0 nvidia-settings
  pkg-config screen-resolution-extra

Kev Bowring (flocculant) wrote :

Rechecked this (multiple times)

Using the GUI at Software & Updates>Additional Drivers appears to now not remove conf files and hence user is left with 640x480px (assume because of the blacklist file left in /etc/modprobe.d)

If one installs via apt and then purges - the nvidia conf file is removed and a normal at reboot results.

The same behaviour is seen if installed via Software & Updates and then removed with apt purge.

Pretty positive this was not previously the case when using the GUI to install nvidia driver.

Only have 1 card to test against - so possibly only affects nvidia-340.

Notes from testing and some pastebin of terminal logs attached.

affects: nvidia-graphics-drivers-340 (Ubuntu) → software-properties (Ubuntu)
Kev Bowring (flocculant) wrote :

Just booted xubuntu 17.10.1 iso - installed nvidia with software-properties - additional drivers.

Blacklist file added.

Removed nvidia with software-properties - additional drivers.

Blacklist file removed.

tags: added: regression
Kev Bowring (flocculant) on 2018-04-06
tags: added: regression-update
removed: regression
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: New → Confirmed
Adam Conrad (adconrad) wrote :

This is very much a bug in nvidia-graphics-drivers-340. One can debate if software-properties should or shouldn't purge (though traditionally, the argument was that silent frontends shouldn't purge because the user hasn't explicitly asked for that), but if a removed package's unpurged conffiles cause the system to misbehave, that package needs to be rethought to avoid that situation.

affects: nvidia-settings (Ubuntu) → nvidia-graphics-drivers-340 (Ubuntu)
Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: New → Confirmed
Adam Conrad (adconrad) wrote :

The real answer here is we should rm_conffile those files in /etc and ship them in /lib/modprobe.d instead.

Jeremy Bicha (jbicha) on 2018-04-09
Changed in nvidia-graphics-drivers-340 (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-340 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-390 (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: Confirmed → Triaged
Changed in nvidia-graphics-drivers-390 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Doug McMahon (mc3man) wrote :

As stated in duped bug removing nvidia drivers (nvidia-390 here) via software-properties only removes the driver meta package so actually nothing is removed.
(- and of course /etc/modprobe.d/nvidia-graphics-drivers.conf will still be there ..

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: Triaged → In Progress
Alberto Milone (albertomilone) wrote :

@Doug: I'm working on the meta-package part for LP: #1753333 , this is a separate bug report, only about the blacklist file.

no longer affects: software-properties (Ubuntu)
no longer affects: software-properties (Ubuntu Bionic)
Changed in nvidia-graphics-drivers-390 (Ubuntu Bionic):
importance: Undecided → High
status: New → Triaged
assignee: nobody → Alberto Milone (albertomilone)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-390 - 390.48-0ubuntu4

---------------
nvidia-graphics-drivers-390 (390.48-0ubuntu4) cosmic; urgency=medium

  [ Alberto Milone ]
  * debian/templates/nvidia-kernel-common-flavour.{install|maintscript}.in:
    - Install the modprobe file in /lib (LP: #1761593).

  [ Graham Inggs ]
  * debian/create-uvm-dev-node:
    - Create the /dev/nvidia-uvm-tools device node (LP: #1767777).

 -- Alberto Milone <email address hidden> Tue, 15 May 2018 12:42:43 +0200

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-340 - 340.106-0ubuntu5

---------------
nvidia-graphics-drivers-340 (340.106-0ubuntu5) cosmic; urgency=medium

  * debian/nvidia-340.maintscript,
    debian/templates/nvidia-graphics-drivers.maintscript.in,
    debian/templates/nvidia-graphics-drivers.postinst.in:
    - Remove the blacklist file manually, since dpkg-maintscript-helper
      won't work in this case. Fixes FTBFS.

 -- Alberto Milone <email address hidden> Wed, 16 May 2018 19:30:39 +0200

Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: Triaged → Fix Released
Iain Lane (laney) wrote :

Alberto, can you have a look to see if there's anything to be done for -340 in bionic please?

Changed in nvidia-graphics-drivers-340 (Ubuntu Bionic):
assignee: nobody → Alberto Milone (albertomilone)
Alberto Milone (albertomilone) wrote :

@Iain: a backport is in the plans.

description: updated

Hello Kev, or anyone else affected,

Accepted nvidia-graphics-drivers-340 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-340/340.107-0ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nvidia-graphics-drivers-340 (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Kev Bowring (flocculant) wrote :

@tjaalton - thanks - all done and tagged

tags: added: verification-done-bionic
removed: verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

What packages and versions have been tested during verification?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments