SRU request: dkms build fails with zesty hwe kernel [error: too few arguments to function ‘NV_GET_USER_PAGES’]

Bug #1677327 reported by Seth Forshee on 2017-03-29
46
This bug affects 16 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-340 (Ubuntu)
High
Alberto Milone
Xenial
High
Alberto Milone

Bug Description

SRU Request:

[Impact]
The patch for Linux 4.9 in nvidia-340 in Ubuntu 16.04 does not match the one in 17.04. As a result, the module fails to build against the hwe 4.10 kernel.

[Test Case]
1) Enable the xenial-proposed repository, and install linux-headers-generic-hwe-16.04-edge, linux-image-generic-hwe-16.04-edge, and nvidia-340.

2) Check that DKMS builds the module, then restart the system, and see if it boots correctly. If unsure, please attach your /var/log/gpu-manager.log and /var/log/Xorg.0.log

[Regression Potential]
Low, the exact same patch is already available in the package in 17.04.

_________________
ADT test failure against linux-hwe-edge 4.10.0-14.16~16.04.1.

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/n/nvidia-graphics-drivers-340/20170328_225401_6519b@/log.gz
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/i386/n/nvidia-graphics-drivers-340/20170328_230514_6519b@/log.gz

We need to backport build fixes for 4.9/4.10 kernels.

/var/lib/dkms/nvidia-340/340.102/build/os-mlock.c: In function ‘os_lock_user_pages’:
/var/lib/dkms/nvidia-340/340.102/build/os-mlock.c:50:65: warning: passing argument 4 of ‘NV_GET_USER_PAGES’ makes integer from pointer without a cast [-Wint-conversion]
                             page_count, write ? FOLL_WRITE : 0, user_pages, NULL);
                                                                 ^
In file included from /var/lib/dkms/nvidia-340/340.102/build/os-mlock.c:15:0:
/var/lib/dkms/nvidia-340/340.102/build/nv-linux.h:2094:28: note: expected ‘int’ but argument is of type ‘struct page **’
         static inline long NV_GET_USER_PAGES(unsigned long start,
                            ^
/var/lib/dkms/nvidia-340/340.102/build/os-mlock.c:48:11: error: too few arguments to function ‘NV_GET_USER_PAGES’
     ret = NV_GET_USER_PAGES((unsigned long)address,

summary: - dkms build fails with zesty hwe kernel
+ dkms build fails with zesty hwe kernel [error: too few arguments to
+ function ‘NV_GET_USER_PAGES’]

Hi Seth, please attach the full log: /var/lib/dkms/nvidia-340/340.102/build/make.log

Also, I backported the patches for 4.9 and 4.10 in 340.102-0ubuntu0.16.04.1. There must be something else going on.

Seth Forshee (sforshee) wrote :
Alberto Milone (albertomilone) wrote :

I've just found out that the patch for Linux 4.9 in xenial is not the same as the one in zesty. I'll have to refresh that.

Changed in nvidia-graphics-drivers-340 (Ubuntu):
importance: Undecided → High
status: New → In Progress
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-340 (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: In Progress → Fix Released
Alberto Milone (albertomilone) wrote :

Please accept nvidia-graphics-drivers-340 340.102-0ubuntu0.16.04.2 into xenial-proposed.

description: updated
summary: - dkms build fails with zesty hwe kernel [error: too few arguments to
- function ‘NV_GET_USER_PAGES’]
+ SRU request: dkms build fails with zesty hwe kernel [error: too few
+ arguments to function ‘NV_GET_USER_PAGES’]
Alireza (azolfagharj) on 2017-04-04
Changed in nvidia-graphics-drivers-340 (Ubuntu Xenial):
status: In Progress → Confirmed
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
Andy Whitcroft (apw) on 2017-04-25
tags: added: kernel-adt-failure kernel-adt-failure-hwe-edge-4.10
Timo Aaltonen (tjaalton) wrote :

accepted -0ubuntu0.16.04.2 to -proposed

Changed in nvidia-graphics-drivers-340 (Ubuntu Xenial):
status: Fix Released → In Progress
Amr Ibrahim (amribrahim1987) wrote :

Please test nvidia-graphics-drivers-340 (340.102-0ubuntu0.16.04.2) in xenial-proposed.

tags: added: verification-needed

As part of a recent change in the Stable Release Update verification policy we would like to inform that for a bug to be considered verified for a given release a verification-done-$RELEASE tag needs to be added to the bug where $RELEASE is the name of the series the package that was tested (e.g. verification-done-xenial). Please note that the global 'verification-done' tag can no longer be used for this purpose.

Thank you!

Alberto Milone (albertomilone) wrote :

I can confirm that the driver in -proposed works correctly.

tags: added: verification-done-xenial
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-340 - 340.102-0ubuntu0.16.04.2

---------------
nvidia-graphics-drivers-340 (340.102-0ubuntu0.16.04.2) xenial-proposed; urgency=medium

  * debian/dkms_nvidia/patches/buildfix_kernel_4.9.patch:
    - Sync patch with the one in Zesty to fix build issue with
      linux-image-generic-hwe-16.04-edge (LP: #1677327).

 -- Alberto Milone <email address hidden> Mon, 03 Apr 2017 17:36:55 +0200

Changed in nvidia-graphics-drivers-340 (Ubuntu Xenial):
status: In Progress → Fix Released

The verification of the Stable Release Update for nvidia-graphics-drivers-340 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Felix Moreno (info-justdust) wrote :

the bug is still happening after today updates....

iGadget (igadget) wrote :

Just happened to me as well. "Just update the system" proved unexpectedly hard since the "bad" update broke X and I couldn't log in using the GUI.
Had to switch to the plain terminal and update manually from there. After that and a reboot, my system was working again.

To anyone unfamiliar with applying non-gui workarounds:

1. From the graphical login screen (that is, if you make it there), switch to the console by pressing CTRL + ALT + F1 simultaneously. If your system is broken to the point that you're dropped to a root shell, skip to step 3.
2. Log in with your username and password
3. Check for new updates: sudo apt update
4. Install updates: sudo apt dist-upgrade
5. When all updates have been installed, reboot the system: sudo reboot

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments