nvidia-340-updates 340.76-0ubuntu2: nvidia-340-updates kernel module failed to build [FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol 'flush_workqueue']

Bug #1477593 reported by Валера on 2015-07-23
218
This bug affects 42 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
High
Unassigned
nvidia-graphics-drivers-304 (Ubuntu)
High
Unassigned
nvidia-graphics-drivers-340 (Ubuntu)
High
Unassigned
nvidia-graphics-drivers-340-updates (Ubuntu)
High
Unassigned
nvidia-graphics-drivers-346-updates (Ubuntu)
High
Unassigned
nvidia-graphics-drivers-352 (Ubuntu)
High
Unassigned

Bug Description

Dont build modules nvidia for kernel 4.2.*

ProblemType: Package
DistroRelease: Ubuntu 15.04
Package: nvidia-340-updates 340.76-0ubuntu2 [modified: usr/src/nvidia-340-updates-340.76/nv-pat.c]
Uname: Linux 4.1.2-040102-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.17.2-0ubuntu1.1
Architecture: amd64
DKMSKernelVersion: 4.2.0-040200rc3-generic
Date: Thu Jul 23 16:46:29 2015
InstallationDate: Installed on 2015-05-25 (58 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
PackageVersion: 340.76-0ubuntu2
RelatedPackageVersions:
 dpkg 1.17.25ubuntu1
 apt 1.0.9.7ubuntu4
SourcePackage: nvidia-graphics-drivers-340-updates
Title: nvidia-340-updates 340.76-0ubuntu2: nvidia-340-updates kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

Валера (lapotinval) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-340-updates (Ubuntu):
status: New → Confirmed
summary: nvidia-340-updates 340.76-0ubuntu2: nvidia-340-updates kernel module
- failed to build
+ failed to build [FATAL: modpost: GPL-incompatible module nvidia.ko uses
+ GPL-only symbol 'flush_workqueue']
Changed in nvidia-graphics-drivers-346-updates (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-340 (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in nvidia-graphics-drivers-346-updates (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-340-updates (Ubuntu):
importance: Undecided → High
Simon Eisenmann (longsleep) wrote :

To fix this, https://lkml.org/lkml/2015/8/4/802 needs to be applied to the 4.2 kernel tree.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bcmwl (Ubuntu):
status: New → Confirmed
Changed in bcmwl (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-352 (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-352 (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-304 (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Jim (jimkag155) on 2016-02-16
Changed in nvidia-graphics-drivers-352 (Ubuntu):
status: Confirmed → Fix Released
Ads20000 (ads20000) on 2016-05-01
tags: added: yakkety
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers