ICC profile doesn't get applied when proprietary Nvidia driver is in use

Bug #1469273 reported by Mario Vukelic on 2015-06-26
120
This bug affects 51 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-340-updates (Ubuntu)
Low
Unassigned

Bug Description

New bug opened because this is still happening in Ubuntu 15.04, as recommended in original bug #533961
https://bugs.launchpad.net/ubuntu/+source/gnome-color-manager/+bug/533961

Quoting original report:
"Hi dear packagers!

The ICC profile set in gnome-color-manager doesn't get applied at system startup when the proprietary Nvidia driver is in use.

To reproduce this:
Use the Nvidia driver and change nvidia-xserver-settings. For example, force the use of anisotropic filtering. Log out.

As soon as the nvidia-settings tool ist started, the ICC profile is lost.
I guess this the drivers fault, but it could be avoided if the color profile is loaded after the custom Nvidia Xserver settings.

I don't really know if this is bug of the color-manager, Gnome or the Nvidia driver. But it can be avoided.

Many thanks for taking the time to read this report.
I hope it helps.

- Laryllan"

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: nvidia-340-updates 340.76-0ubuntu2
ProcVersionSignature: Ubuntu 3.19.0-21.21-generic 3.19.8
Uname: Linux 3.19.0-21-generic x86_64
NonfreeKernelModules: wl nvidia
ApportVersion: 2.17.2-0ubuntu1.1
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Jun 26 20:36:09 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2012-09-15 (1014 days ago)
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
SourcePackage: nvidia-graphics-drivers-340-updates
UpgradeStatus: Upgraded to vivid on 2015-04-26 (61 days ago)

Mario Vukelic (mario-vukelic) wrote :
Mario Vukelic (mario-vukelic) wrote :

I submitted the issue to Nvidia via http://www.nvidia.com/page/support.html
They gave me incident number #150626-000228

no longer affects: gnome-color-manager
Changed in nvidia-graphics-drivers-340-updates (Ubuntu):
status: New → Confirmed
description: updated
description: updated
Laryllan (laryllan) wrote :

Thanks for adding a new bug report.

Changed in nvidia-graphics-drivers-340-updates (Ubuntu):
importance: Undecided → Low
Mario Vukelic (mario-vukelic) wrote :

I got this answer from Nvidia support:

"We have an open problem report in our system to interact better with ICC color profile management software. Unfortunately there is no schedule for working on this."

My ICC profile was not used, too (Xubuntu 14.04, loading ICC with xcalib in XFCE's autostart options). I realized that the NVIDIA X Server Settings tool is always loaded at startup and resets the display's color. After I deactivated it (removed the mark in Settings Manager - Session and Startup) my ICC profile works.

On my System (14.04) all works fine with deinstalled nvidia-modprobe...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers