NVIDIA Prime fails with Linux 3.13

Bug #1268771 reported by Giorgio Dramis on 2014-01-13
164
This bug affects 31 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-331 (Ubuntu)
High
Alberto Milone
nvidia-graphics-drivers-331-updates (Ubuntu)
High
Alberto Milone

Bug Description

When I select the Nvidia® graphics card from control panel using nvidia-prime, after logging out, the screen goes black and the only way to approach it is in text mode. I also used the nvidia-prime 4.2 in Ubuntu 13.10 but I have never encountered such problems.

---------------------------- Specifications ---------------------------

Operative System : Ubuntu 14.04LTS 64bit (Daily Build)
Package: nvidia-prime 0.5.3
Driver: nvidia-331-updates
Graphics: Nvidia® GeForce® 610M
Processor: Intel® Core™ i7-2670QM

-----------------------------------------------------------------------

Giorgio Dramis (jorged) on 2014-01-13
description: updated
description: updated
description: updated
Alberto Milone (albertomilone) wrote :

Unfortunately prime doesn't seem to work well with Linux 3.13. I'm still investigating the issue

Changed in nvidia-prime (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
summary: - black screen when i select nvidia graphics card
+ NVIDIA Prime fails with Linux 3.13

same problem here, with kernel 3.13 don t work

evilman (ewileta) wrote :

Same problem for me. waiting for fix

same problem only with kernel 3.13 (upstream or ubuntu)

Alberto Milone (albertomilone) wrote :
Alberto Milone (albertomilone) wrote :

Subscribing NVIDIA to the bug report

evilman (ewileta) wrote :

the last working kernel 3.12.0-7-generic newer ones fails

petrus (steur-petrus5) wrote :

Nvidia - Prime 331/319 kernel 3.13 fails

petrus (steur-petrus5) wrote :

Ubuntu 14.04LTS Nvidia - Prime 331/319 kernel 3.13 fails

kao (kao1985) wrote :

Same problem with Ubuntu 14.04, Linux 3.13, nvidia-331 and prime
X does not start

Marcin Sągol (soee) wrote :

I can confirm this issue on 14.04

Aaahh Ahh (woohoomoo2u) on 2014-01-27
Changed in nvidia-prime (Ubuntu):
status: Triaged → Opinion
status: Opinion → Confirmed
status: Confirmed → In Progress
status: In Progress → Confirmed
Aaahh Ahh (woohoomoo2u) wrote :

No it didnt make a diffrence, also sorry about above...

Changed in nvidia-prime (Ubuntu):
status: Confirmed → In Progress
Alberto Milone (albertomilone) wrote :

Good find nenon1ks!

So it seems that this is the commit that breaks it:
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=3a83f992490f8235661b768e53bd5f14915420ac

If this is the case, I can stop bisecting the kernel and move on to writing a patch to work around it.

Harry (harry33) wrote :

Now the newest version in the official repository (331.38-0ubuntu2) breaks the X.
I have tried this with the nvidia graphics card 285GTX and with the package nvidia-331_331.38-0ubuntu2_amd64.deb and with the newest kernel 3.13.1 from mainline.
X will not start and only console is left to use.

However, the previous version (331.38-0ubuntu1) works fine, so downgrading to that one solves this.

Alberto Milone (albertomilone) wrote :

Sorry for the inconvenience. 331.38-0ubuntu3 will solve the problem.

affects: nvidia-prime (Ubuntu) → nvidia-graphics-drivers-331 (Ubuntu)
Changed in nvidia-graphics-drivers-331-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-331 - 331.38-0ubuntu3

---------------
nvidia-graphics-drivers-331 (331.38-0ubuntu3) trusty; urgency=low

  * debian/dkms_nvidia/patches/buildfix_kernel_3.13.patch:
    - Fix check for acpi_os_wait_events_complete() (LP: #1268771).
 -- Alberto Milone <email address hidden> Thu, 30 Jan 2014 11:47:27 +0100

Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-331-updates - 331.38-0ubuntu3

---------------
nvidia-graphics-drivers-331-updates (331.38-0ubuntu3) trusty; urgency=low

  * debian/dkms_nvidia/patches/buildfix_kernel_3.13.patch:
    - Fix check for acpi_os_wait_events_complete() (LP: #1268771).
 -- Alberto Milone <email address hidden> Thu, 30 Jan 2014 11:51:20 +0100

Changed in nvidia-graphics-drivers-331-updates (Ubuntu):
status: In Progress → Fix Released
Un_loco (tdgeddes) wrote :

Optimus machines: black screen with ubuntu drum login sound.
drivers work with 3.12-7 kernel

3.13-0 and 3.13-1 - black screen, ubuntu login sounds, tried every config file in the world. Also switching back from kernel 3.13 to 3.12 makes the video unrecoverable as if booting in 3.13. Some .conf I am unaware of being written to in 3.13 that breaks all working kernels nvidia video?

Assuming nvidia not sending to intel to display on screen in 3.13 variations.

medzarka (mohamed-ezzarka) wrote :

Same problem as Un_loco : black screen with ubuntu login sounds.
I tried many configs but the problem persists.

---
lenovo z510
i5 - 4200m
intel 4600 + nvidia 740m.

Alberto Milone (albertomilone) wrote :

are you using version 331.38-0ubuntu3?

Please attach the output of the following commands:

apt-cache policy nvidia-331

apt-cache policy nvidia-331-updates

Aneesh Neelam (aneesh-neelam) wrote :

Here is the output on my optimus laptop.

I suffer from the same issue of no video output on Nvidia, but Intel's working fine.
Have to go to VT and purge nvidia and restart. Then reinstall nvidia and switch to Intel using nvidia-settings.

Ubuntu Trusty.
Dell XPS L502X,
Intel HD Graphics,
Nvidia 540M.

Marcin Sągol (soee) wrote :

Tested on Dell Inspiron. Booting ends with command line after plymouth is presented for a few seconds and asking for login :/

Alberto Milone (albertomilone) wrote :

This is a regression in the nvidia-prime package.

nvidia-prime 0.5.5 solves the problem.

medzarka (mohamed-ezzarka) wrote :

nvidia-prime works perfectly after updating nvidia-prime to 0.5.5.
Thanks.

Antti Leppik (antti-parksepa) wrote :

nvidia-prime works great now, but on my kubuntu system I had to install python-gtk2 to use PRIME Profiles in nvidia settings

Marcin Sągol (soee) wrote :

Strange. I'v installed it on Kubuntu and had the same problem (only command line to enter login). Did you do anything else than installing this package?

Marcin Sągol (soee) wrote :

I tried also to reinstall drivers and nvidia-prime. Now booting ends with black screen.

Giorgio Dramis (jorged) wrote :

Now it works, but after login Unity and Compiz do not work and I can only see the background image. I open a new bug here https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-331-updates/+bug/1274733

Giorgio Dramis (jorged) wrote :

I have this problem another time with Kernel 3.13.0-11-generic, nvidia-331-updates (331.38-ubuntu3) and nvidia-prime (0.5.7)

Giorgio Dramis (jorged) on 2014-02-22
Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: Fix Released → In Progress
Alberto Milone (albertomilone) wrote :

there was a bug that caused a configuration file to be removed. Please type the following commands and restart your computer:

sudo apt-get --purge remove nvidia-prime

sudo apt-get install nvidia-prime

Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: In Progress → Fix Released
amias (amias) wrote :

this is still a problem for me on my dell inspiron 7737 .

works fine with 3.11 but every other kernel just crashes at the plymouth screen.

additionally now that the kernel headers package for the 3.11 kernel is gone nvidia-prime users are now unable to use DKMS to build things like vbox drivers and other things.

Please either fix this bug or reinstate the headers package as many others will be effected

ncordon (ncordon) wrote :

I've got a Nvidia Geforce gtx 860M discrete gpu. I've installed the drivers by running in the terminal:
    sudo apt-get install nvidia-343 nvidia-settings nvidia-prime
But when I select NVIDIA card in the nvidia-settings I cannot get the login screen anymore when I reboot, and I have to change my gpu to the integrated one, by running in tty1:
    sudo prime-nvidia intel

I have tried all kinds of solutions, like getting an older and a newer kernel, but I've still got the problem with those kernels. My current version of the kernel is: `3.13.0-37`. Has anyone fixed the problem?

Alberto Milone (albertomilone) wrote :

This problem is fixed. Feel free to file a separate bug report by using the following command:

ubuntu-bug nvidia-331 (or nvidia-331-updates, if that is what you use).

Charl P. Botha (cpbotha) wrote :

I'm seeing exactly this behaviour with nvidia-346 (from xorg-edgers, because I urgently need libGLESv2.so which is NOT included in the nvidia-331 packages for amd-64; a bug) and nvidia-340 (same reason) on kernel 3.13.0-45 and Ubuntu 14.04

I can get bumblebee working on this setup, and can confirm with glxinfo that the nvidia is being used. However, with bumblebee completely purged, nvidia-prime always gives me the black login screen after "prime-select nvidia". Intel mode works fine.

Any hints on gettings this to work would be greatly appreciated.

positivcheg (positivcheg94) wrote :

GPU : Nvidia GTX 660M
Driver : nvidia-graphics-drivers-340.76

Tried all drivers with purging before installing and nothing. When i try "sudo prime-select nvidia" i have black screen at next login. Btw i even tried to log in entering password and then opened terminal. After that i did "sudo restart now" and i saw restarting screen but it froze =(.
The only thing i can do is CTRL+ALT+F6, login and
sudo prime-select intel
sudo service lightdm restart
And then the login screen appears.

The same here!

GPU : Nvidia GeForce 840M
Driver : nvidia-graphics-drivers-340.76

worked fine on 340.46 at least.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers