nvidia-331 update installs bumblebee [xorg-edgers]

Bug #1265570 reported by Tareeq on 2014-01-02
104
This bug affects 22 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-331 (Ubuntu)
Undecided
Unassigned

Bug Description

Hi xorg-edgers team,

I just got the nvidia-331 update, from nvidia-319, but the update installs bumblebee, however when bumblebee is installed it blacklists the nvidia kernel modules. Which bumblebee is suppossed to do but it breaks xorg if you aren't running an optimus based GPU. Uninstalling bumblebee does not remove the /etc/modprobe.d/bumblebee.conf config file and as such the driver is still blacklisted until you either modify the file to not black list the nvidia-331 module or remove bumblebee.conf. I have an nvidia 560 GTX video card.

Tareeq

Ricardo Costa (rjscost) wrote :

It left me in the dark too (booting to text mode console) and i lost 3 hours looking for the problem.
At first my solution was to manually load the nvidia-331 module with modprobe and then I found this bug report sating that bumblebee blacklists the nvidia drivers.

Uninstalling (apt-get remove) doesn't remove /etc/modprobe.d/bumblebee.conf but purging does (apt-get remove --purge).

Now I'm wondering what will happen to not so tech savy users...
In systems without dual graphics it prevents X from loading at all and even using ppa-purge to remove xorg-edgers packages does nothing (it was my first try) as /etc/modprobe.d/bumblebee.conf is still left behind.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: New → Confirmed
Ferry Toth (ftoth) wrote :

I spent about 3 hours too. I was completely baffeled that downgrading nvidia (from aptitude which is a pain compared to synaptic) didn't solve the problem. Worse, ppa-purge also didn't change anything (downgrading everything to the original state right?).

I tried modprobe nvidia which completes without any message but doesn't load nvidia. And modprobe nouveau also didn't load (with error messages).

Desperately, I removed all nvidia stuff (after the ppa-purge) and managed to boot into kde with now the nouveau driver. Then purged all removed packages and installed nvidia again with jockey.

Good to know bumblebee.conf is causing the problem.

Ferry Toth (ftoth) wrote :

It might also bee that the nvidia driver should just be working with bumblebee eventhough we don't have optimus. Question is, what is missing?

Tareeq (spock-rock) wrote :

Hi Ferry,

It should be that when installing bumblebee it should install nvidia, but installing the nvidia drivers should not install bumblebee. Bumblebee is a 'hack' to get dual video cards working until nvidia supports it in their linux drivers. What bumblebee does is it stops the nvidia module (nvidia-331 in this case, hence why modprobing nvidia-331 and restarting x works) from loading at boot time, the kernel loads the intel driver only. Then when you use the optirun or primus commands it then loads the nvidia module and runs that application on the nvidia card. The whole point is not to load the nvidia module at all, until needed, to save power, using bbswitch-dkms package, I use bumblebee on my work laptop and hence why I was able to decipher the issue.

As you can imagine, since we don't have another video card on our setups, X bombs on loading because its configured to used the nvidia driver but bumblebee has stopped it from loading at boot time.

I suspect the packages dependency is wrong.

Ferry Toth (ftoth) wrote :

@Tareeq: I understand, but I have the impression that it is bumblebee that should load the nividia driver. What I think is happenening is that bumblebee bails our because there is no optimus support on my system, and thus I'm left without video driver.

I see xorg-edgers pushes bumblebee 3.2.1-5~xedgers~saucy1 since 2014-01-06, but I didn't have the nerve yet to try this one out.

Did anybody try this?

Ferry Toth (ftoth) wrote :

On my system the bumblebee gets pulled because synaptics has been configured to treat recommends as dependencies. I guess that bumblebee maybe should have been marked as 'suggests'?

Anyway, after selecting / upgrading nvidia 331 but before actually applying the upgrade I have deselected bumblebee, bbswitch, primus and socal (whatever that may be), now works.

Also now changed by synaptics setting to not automatically pull recommends.

Peter Wu (lekensteyn) wrote :

Looks like the issue entered in 331.20-0ubuntu7. From the changelog[1]:

+nvidia-graphics-drivers-331 (331.20-0ubuntu7) trusty; urgency=low
+
+ * debian/rules, debian/templates/control.in,
+ debian/templates/nvidia-graphics-drivers.dirs.in,
+ debian/templates/nvidia-graphics-drivers.install.in,
+ debian/templates/nvidia-graphics-drivers.postinst.in,
+ debian/templates/nvidia-graphics-drivers.postrm.in,
+ debian/nvidia-persistenced.conf:
+ - Add support for nvidia-persistenced.
+ - Conflict/replace/provide with nvidia-persistenced
+ to avoid potential problems with packages from
+ xorg-edgers or other PPAs.
+ - Depend on passwd and adduser.
+ - Drop Recommend nvidia-persistenced.
+ - Recommend nvidia-prime. Keep bumblebee as an
+ alternative, so that users who prefer to use
+ bumblebee, can keep doing so.
+ - Drop cdbs and switch to debhelper 7.
+
+ -- Alberto Milone <email address hidden> Tue, 17 Dec 2013 13:08:33 +0100

The control file[2] recommends either nvidia-prime (>= 0.5) or bumblebee. nvidia-prime does not exist for Quantal or Raring. Saudy and Precise have 0.4.2-something. Since recommended packages are installed by default, shouldn't these packages be marked as "Suggested"? Installing bumblebee-nvidia will blacklist the nvidia drivers, bringing grief to users.

 [1]: https://launchpadlibrarian.net/162426597/nvidia-graphics-drivers-331_331.38-0ubuntu1~xedgers~trusty1.diff.gz
 [2]: https://launchpadlibrarian.net/162426956/buildlog_ubuntu-trusty-amd64.nvidia-graphics-drivers-331_331.38-0ubuntu1~xedgers~trusty1_UPLOADING.txt.gz

Luis Alvarado (luisalvarado) wrote :

OMG this is my problem. 2 days working on what in the world was happening because the screen went black. Digging and digging until finally I realized nvidia 331 was installing bumblebee and primus (What in the world?) to my computer which only has one video card, the Nvidia 440 GT on the PCI Express slot. I am writing this in another computer since I haven't had any luck solving this. Will try to change the modprobe advise in the first post to see if that is the problem.

Luis Alvarado (luisalvarado) wrote :

Excellente, only did 2 steps and rebooted. All is working fine with nvidia-331. After installing the nvidia-331 package and before rebooting do the following:

sudo apt-get purge bumblebee
sudo rm -fr /etc/modprobe.d/bumblebee.conf
sudo reboot

Done.

Many thanks Tareeq

Darren Long (darren-long-5) wrote :

By way of a note, I'd like to point out that my 'puter has built-in Intel grpahics on the motheboard and an NVIDIA graphics card. I normally use the latter, but when I was hit with this issue, I reconfigured the BIOS to use the Intel graphics instead, but that too was broken due to this issue with the spurious installation of bumbelbee!

Fred Rocha (john-fisherman) wrote :

This is a pretty nasty one. All I did was updating my system as I do on a regular basis and boom. 4h of cursing against the Ubuntu devs. (not really)

Purging Bumblebee solved it for me.

Good thing I found this via askubuntu, just as I was about to ask for help.

I was also just trying to install the newest NVIDIA driver only. I was quite lucky that it took me just a few minutes to find out what was happening... It also helped me choosing NVIDIA Optimus option in the BIOS settings. However, only Intel GPU started to work. Bumblebee was unable to start nvidia (driver), even if I fixed its /etc/bumblebee/bumblebee.conf with correct nvidia driver paths...

=> Since I rather prefer performance, I'll purge the bumblebee package too.

Anyway, there is an interesting report below "Unresolved symbol: fbGetGCPrivateKey". I suggest that this means that it wouldn't be working on Saucy (13.10) anyway. Not without installing also other packages (kernel?, Xorg?).

cat /var/log/syslog
 Feb 6 18:40:05 mycomputername kernel: [ 326.227829] thinkpad_acpi: asked for hotkey mask 0x0071ffbf, but firmware forced it to 0x0071ffbb
 Feb 6 18:40:05 mycomputername bumblebeed[3955]: [XORG] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
 Feb 6 18:40:05 mycomputername bumblebeed[3955]: [XORG] (WW) "xmir" is not to be loaded by default. Skipping.
 Feb 6 18:40:05 mycomputername bumblebeed[3955]: [XORG] (WW) Unresolved symbol: fbGetGCPrivateKey
 Feb 6 18:40:05 mycomputername bumblebeed[3955]: [XORG] (WW) NVIDIA(0): Unable to get display device for DPI computation.
 Feb 6 18:40:11 mycomputername kernel: [ 332.158024] [drm] Module unloaded
 Feb 6 18:40:11 mycomputername kernel: [ 332.159714] bbswitch: disabling discrete graphics
 Feb 6 18:40:11 mycomputername kernel: [ 332.159725] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130517/nsarguments-95)
 Feb 6 18:40:11 mycomputername acpid: client 4274[0:998] has disconnected
 Feb 6 18:40:11 mycomputername acpid: client 4274[0:998] has disconnected
 Feb 6 18:40:11 mycomputername kernel: [ 332.174134] pci 0000:01:00.0: Refused to change power state, currently in D0
 Feb 6 18:40:11 mycomputername kernel: [ 332.174739] thinkpad_acpi: EC reports that Thermal Table has changed
 Feb 6 18:40:11 mycomputername bumblebeed[3955]: [XORG] (EE) Server terminated successfully (0). Closing log file.

uname -a
 Linux mycomputername 3.11.0-17-generic #31-Ubuntu SMP Mon Feb 3 21:52:43 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/lsb-release
 DISTRIB_ID=Ubuntu
 DISTRIB_RELEASE=13.10
 DISTRIB_CODENAME=saucy
 DISTRIB_DESCRIPTION="Ubuntu 13.10"

Tareeq (spock-rock) wrote :

Hi Rostislav Stříbrný,

When using bumblebee, the goal is to use the nvidia driver and then use optirun or primus commands to lauch your apps to use the nvidia driver. If you don't want to bother with the intel chip, then I would suggest you just purge bumblee bee and use the nvidia-xconfig command to create your xorg config. Just take a back up just incase.

https://bbs.archlinux.org/viewtopic.php?pid=1328851

According to that forum thread it might be an issue with the version of the kernel you are on. I was using 3.12-Saucy from (http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-saucy/). Also the xorg-edgers ppa; https://launchpad.net/~xorg-edgers/+archive/ppa and install the nvidia 331 driver.

Any whoo, sorry I can't be more help, but I have since switch from ubuntu/mint to debian sid (siduction).

Wayne P Myers (waynepmyers) wrote :

You guys rock!!!!!!!
I've spent a week trying to figure this out, pulled out all of my OLD Linux/Unix manuals(left CMU in 1994) and really haven't done anythign with Linux since probably '98. I'm here to tell you things have changed. If I hadn't been searching the net for ways to load nvidia-331.38 in Ubuntu, I would't hae found your post, you see I have reloaded my system, with mint, cent, debian 7, sparky,,, you name it, trying to resolve this issue. I came back to Ubuntu 13.10, because, it is so stable. So I removed bumblebee, ie. apt-get remove bumblebee and removed the bumblebee.conf, ie. < cd/etc/modprobe.d > rm bumblebee.conf, and rebooted. And... TA-DA! It's alive!!!!!! :) You have made me ONE HAPPY CAMPER!!!! Thanks.

monkeybrain2012 (kammon101) wrote :

There has been many updates from xorg-edgers since this bug was reported. Many people are left witha black screen without knowing what is going on. Any comment from the maintainer??

Nanodesu (nan0desu) wrote :

Optimus users can install nvidia prime:

$ apt-cache show nvidia-331 | grep prime
Recommends: nvidia-settings (>= 331.20), nvidia-prime (>= 0.5) | bumblebee, libcuda1-331, nvidia-libopencl1-331, nvidia-opencl-icd-331

But saucy/updates has old one:
$ dpkg -l nvidia-prime
...
ii nvidia-prime 0.4.2~ubuntu13.10.1 all Tools to enable NVIDIA's Prime

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers