[SRU] nvidia-opencl-icd-* should not conflicts/replaces on opencl-icd

Bug #1247736 reported by Jorma Vesterinen on 2013-11-04
318
This bug affects 68 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-304 (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
nvidia-graphics-drivers-304-updates (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
nvidia-graphics-drivers-331 (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
nvidia-graphics-drivers-331-updates (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned

Bug Description

[Impact]
Users with proprietary Nvidia graphics drivers are unable to co-install CUDA and OpenCL applications.
The patches in comment #21 and #22 backport the fix from Utopic and resolve this issue by allowing nvidia-opencl-icd-* (Nvidia's OpenCL ICD) to be co-installed with ocl-icd-libopencl1 (the generic OpenCL ICD loader).

[SRU Verification Test Case #1]
sudo apt-get remove nvidia-opencl-icd-* nvidia-libopencl1-* ocl-icd-ibopencl1

sudo apt-get install nvidia-opencl-icd-331

With the 331.38-0ubuntu7 drivers, the Nvidia OpenCL ICD will be installed without any dependencies.

With the 331.38-0ubuntu7.1 drivers, ocl-icd-libopencl1 will be installed as a dependency:

The following extra packages will be installed:
  ocl-icd-libopencl1
Suggested packages:
  opencl-icd
The following NEW packages will be installed:
  nvidia-opencl-icd-331 ocl-icd-libopencl1

Repeat the above for nvidia-opencl-icd-331-updates.

[SRU Verification Test Case #2]
sudo apt-get install nvidia-opencl-icd-331
OR
sudo apt-get install nvidia-opencl-icd-331-updates
(does not require an Nvidia graphics card)

sudo apt-get install beignet
(an alternate OpenCL ICD)

With the 331.38-0ubuntu7 drivers, the Nvidia OpenCL ICD will be removed:

The following packages will be REMOVED:
  nvidia-opencl-icd-331
The following NEW packages will be installed:
  beignet
0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.

With the 331.38-0ubuntu7.1 drivers, beignet and nvidia-opencl-icd-331 (or nvidia-opencl-icd-331-updates) can be co-installed.

[Test Case]
sudo apt-get install nvidia-331 or sudo apt-get install nvidia-331-updates (does not require an Nvidia graphics card)
sudo apt-get install python-pycuda
sudo apt-get install python-pyopencl

This will result in the error message below.

The following packages have unmet dependencies:
 python-pyopencl : Depends: libopencl-1.1-1
                   Depends: libopencl-1.2-1
                   Depends: ocl-icd-libopencl1 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

A similar conflict exists between wine and nvidia-cuda-toolkit.

sudo apt-get install nvidia-331 or sudo apt-get install nvidia-331-updates (does not require an Nvidia graphics card)
sudo apt-get install wine
sudo apt-get install nvidia-cuda-toolkit

This will result in a warning similar to the one below.

The following extra packages will be installed:
  nvidia-libopencl1-331 nvidia-opencl-dev
The following packages will be REMOVED:
  ocl-icd-libopencl1 ocl-icd-libopencl1:i386 wine wine1.6 wine1.6-amd64
  wine1.6-i386:i386
The following NEW packages will be installed:
  nvidia-cuda-toolkit nvidia-libopencl1-331 nvidia-opencl-dev

[Regression Potential]
This fix only affects the relationships between packages and should not introduce any new bugs. However, since packages that were previously difficult to install together will now be co-installable, new bugs in those packages may be exposed.

[Other Info]
It is possible to work around this issue by first installing the CUDA application, then installing ocl-icd-opencl-dev, and finally installing the OpenCL application. (See comment #7)

---------------------------------------------------------------------------

Don't know.

ProblemType: Package
DistroRelease: Ubuntu 13.10
Package: ocl-icd-libopencl1 (not installed)
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Sun Nov 3 14:03:41 2013
DpkgTerminalLog:
 Unpacking ocl-icd-libopencl1:amd64 (from .../ocl-icd-libopencl1_2.0.2-1ubuntu1_amd64.deb) ...
 dpkg: error processing /var/cache/apt/archives/ocl-icd-libopencl1_2.0.2-1ubuntu1_amd64.deb (--unpack):
  trying to overwrite '/usr/lib/x86_64-linux-gnu/libOpenCL.so', which is also in package nvidia-opencl-dev:amd64 5.0.35-7ubuntu1
DuplicateSignature: package:ocl-icd-libopencl1:(not installed):trying to overwrite '/usr/lib/x86_64-linux-gnu/libOpenCL.so', which is also in package nvidia-opencl-dev:amd64 5.0.35-7ubuntu1
ErrorMessage: trying to overwrite '/usr/lib/x86_64-linux-gnu/libOpenCL.so', which is also in package nvidia-opencl-dev:amd64 5.0.35-7ubuntu1
InstallationDate: Installed on 2013-10-28 (6 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
SourcePackage: ocl-icd
Title: package ocl-icd-libopencl1 (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/x86_64-linux-gnu/libOpenCL.so', which is also in package nvidia-opencl-dev:amd64 5.0.35-7ubuntu1
UpgradeStatus: No upgrade log present (probably fresh install)

Jorma Vesterinen (jvesteri) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ocl-icd (Ubuntu):
status: New → Confirmed
Roy Stogner (roy-stogners) wrote :

The conflict with nvidia-opencl-dev isn't so much of a problem - the two packages are both implementations of the OpenCL loader, right? So while it could be nice to be able to have both installed and use alternatives to select one, it's not really necessary. You can use one implementation of the OpenCL loader to load a different implementor's OpenCL ICD.

The more serious problem is that you have to work around the libopencl1 conflict between ocl-icd-libopencl1 and nvidia-304 (i.e. nvidia-current). In order to get hardware-acceleration I need nvidia-304; to get an OpenCL-1.2 compatible loader I need ocl-icd-libopencl1, and so I have to install the latter with --force-conflicts.

IRIE Shinsuke (irie) wrote :

Same here on Ubuntu 14.04.
Last night the package system attempted to update a lot of packages (644 packages) and newly install ocl-icd-libopencl1, but that failed for this...

"apt-get -f install" cannot resolve this problem.

ocl-icd-libopencl1: 2.1.3-4
nvidia-opencl-dev: 5.0.35-7ubuntu1

tags: added: trusty
Changed in ocl-icd (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-cuda-toolkit (Ubuntu):
status: New → Confirmed

For instance, can't install wine along with nvidia-cuda-toolkit because of this bug. Any workaround?

Graham Inggs (ginggs) wrote :

The problem here is two packages are installing the same binary file '/usr/lib/*/libOpenCL.so' without declaring a breaks/replaces or conflicts relationship between them, and so apt-get does not know to remove the other.
This either needs to be fixed in nvidia-cuda-toolkit or ocl-icd.

ocl-icd is shipping this file in ocl-icd-libopencl1 instead of ocl-icd-opencl-dev, which is against Debian policy, see https://bugs.debian.org/679228

nvidia-cuda-toolkit lists 'nvidia-opencl-dev (= 5.5.22-3ubuntu2~ppa1) | opencl-dev' among its dependencies, so as a workaround, we can help apt-get by installing ocl-icd-opencl-dev to provide opencl-dev, but we need to do it in the correct order:

sudo apt-get install nvidia-cuda toolkit
sudo apt-get install ocl-icd-opencl-dev (this will remove nvidia-libopencl1-* and nvidia-opencl-dev)
sudo apt-get install wine

Graham Inggs (ginggs) wrote :

While ocl-icd-libopencl1 and nvidia-opencl-dev are shipping the same binary file '/usr/lib/*/libOpenCL.so', it doesn't seem to cause a problem in Debian. In Ubuntu, we have the same ocl-icd and nvidia-cuda-toolkit packages as in Debian, however our nvidia-graphics-drivers* packages are packaged differently.

In Ubuntu, nvidia-opencl-icd-331 has the following package relationships:
Depends: libc6 (>= 2.2.5), zlib1g (>= 1:1.1.4)
Suggests: nvidia-libopencl1-331
Conflicts: opencl-icd
Replaces: opencl-icd
Provides: opencl-icd

In Debian, the equivalent nvidia-opencl-icd has the following:
Depends: nvidia-opencl-common (= 331.67-1), ocl-icd-libopencl1 | nvidia-libopencl1 | libopencl1, libnvidia-compiler (= 331.67-1), libc6 (>= 2.2.5), zlib1g (>= 1:1.1.4)
Enhances: libopencl1
Conflicts: nvidia-opencl-icd-ia32
Replaces: nvidia-opencl-icd-ia32
Provides: opencl-icd

I believe the conflicts/replaces on opencl-icd in nvidia-opencl-icd-331 are causing this problem when trying to co-install nvidia-cuda-toolkit and wine (LP: #1310267) and preventing the co-installation of python-pycuda and python-pyopencl (LP: #1312422).

Graham Inggs (ginggs) on 2014-04-30
summary: - package ocl-icd-libopencl1 (not installed) failed to install/upgrade:
- trying to overwrite '/usr/lib/x86_64-linux-gnu/libOpenCL.so', which is
- also in package nvidia-opencl-dev:amd64 5.0.35-7ubuntu1
+ nvidia-opencl-icd-* should not conflicts/replaces on opencl-icd
Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-331-updates (Ubuntu):
status: New → Confirmed
Changed in nvidia-cuda-toolkit (Ubuntu):
status: Confirmed → Invalid
Changed in ocl-icd (Ubuntu):
status: Confirmed → Invalid

Hi,

I'm seeing this problem on Ubuntu 14.04 trying to install Wine in a box with nvidia-304-updates driver.

$ sudo aptitude install wine
The following NEW packages will be installed:
  libasn1-8-heimdal:i386{a} libcapi20-3{a} libcapi20-3:i386{a} libexif12:i386{a} libgd3:i386{a} libgif4:i386{a} libglu1-mesa:i386{a} libgphoto2-6:i386{a} libgphoto2-port10:i386{a}
  libgssapi3-heimdal:i386{a} libgstreamer-plugins-base0.10-0:i386{a} libgstreamer0.10-0:i386{a} libhcrypto4-heimdal:i386{a} libheimbase1-heimdal:i386{a} libheimntlm0-heimdal:i386{a}
  libhx509-5-heimdal:i386{a} libieee1284-3:i386{a} libkrb5-26-heimdal:i386{a} liblcms2-2:i386{a} libldap-2.4-2:i386{a} libltdl7:i386{a} libmpg123-0:i386{a} libopenal1:i386{a}
  libosmesa6{a} libosmesa6:i386{a} libp11-kit-gnome-keyring:i386{a} libroken18-heimdal:i386{a} libsane:i386{a} libsasl2-2:i386{a} libsasl2-modules:i386{a}
  libsasl2-modules-db:i386{a} libusb-1.0-0:i386{a} libv4l-0:i386{a} libv4lconvert0:i386{a} libvpx1:i386{a} libwind0-heimdal:i386{a} libxcomposite1:i386{a} libxcursor1:i386{a}
  libxinerama1:i386{a} libxpm4:i386{a} libxrandr2:i386{a} ocl-icd-libopencl1{ab} ocl-icd-libopencl1:i386{ab} p11-kit-modules:i386{a} p7zip{a} wine wine-gecko2.21{a}
  wine-gecko2.21:i386{a} wine-mono0.0.8{a} wine1.6{a} wine1.6-amd64{a} wine1.6-i386:i386{a} winetricks{a}
0 packages upgraded, 53 newly installed, 0 to remove and 0 not upgraded.
Need to get 128 MB/130 MB of archives. After unpacking 371 MB will be used.
The following packages have unmet dependencies:
 nvidia-libopencl1-304-updates : Conflicts: libopencl1 which is a virtual package.
                                 Conflicts: libopencl1:i386 which is a virtual package.
 ocl-icd-libopencl1 : Conflicts: libopencl1 which is a virtual package.
 ocl-icd-libopencl1:i386 : Conflicts: libopencl1 which is a virtual package.
The following actions will resolve these dependencies:

     Remove the following packages:
1) nvidia-libopencl1-304-updates

     Leave the following dependencies unresolved:
2) nvidia-304-updates recommends nvidia-libopencl1-304-updates

Accept this solution? [Y/n/q/?]

Graham Inggs (ginggs) wrote :

Did you try the workaround in comment #7?

I'm sorry, I don't know how I missed that. Now I did and it worked. Thank you!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-304-updates (Ubuntu):
status: New → Confirmed
Damien Boyd (ashfallen0) wrote :

I also ran into this behavior while doing an optimus install on a Sony Vaio S with Xubuntu 14.04 (Trusty). Following this guide: http://www.muktware.com/2013/12/install-nvidia-331-bumblebee-optimus-cards/18271

During the install, nvidia-331 wishes to remove wine1.6-amd64 and subcomponents thanks to ocl-icd.

Using the following from comment #7: sudo apt-get install ocl-icd-opencl-dev
Then: sudo apt-get install wine1.6-amd64

solves the issue.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-331 - 331.38-0ubuntu8

---------------
nvidia-graphics-drivers-331 (331.38-0ubuntu8) utopic; urgency=medium

  [ Graham Inggs ]
  * debian/templates/control.in, package nvidia-opencl-icd-*:
    - Remove breaks/replaces on opencl-icd (LP: #1247736).
    - Depend on ocl-icd-libopencl1 | nvidia-libopencl1-*.
 -- Alberto Milone <email address hidden> Thu, 22 May 2014 16:03:40 +0200

Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-331-updates - 331.38-0ubuntu8

---------------
nvidia-graphics-drivers-331-updates (331.38-0ubuntu8) utopic; urgency=medium

  [ Graham Inggs ]
  * debian/templates/control.in, package nvidia-opencl-icd-*:
    - Remove breaks/replaces on opencl-icd (LP: #1247736).
    - Depend on ocl-icd-libopencl1 | nvidia-libopencl1-*.
 -- Alberto Milone <email address hidden> Thu, 22 May 2014 16:06:22 +0200

Changed in nvidia-graphics-drivers-331-updates (Ubuntu):
status: Confirmed → Fix Released
Graham Inggs (ginggs) on 2014-05-22
Changed in nvidia-cuda-toolkit (Ubuntu Trusty):
status: New → Invalid
Changed in ocl-icd (Ubuntu Trusty):
status: New → Invalid
Graham Inggs (ginggs) wrote :

Nvidia-graphics-drivers-331 version 331.38-0ubuntu7.1~ppa1 for Trusty is available in my PPA for testing:
https://launchpad.net/~ginggs/+archive/sru

Brian Hicks (bhicks1000) wrote :

It looks like proposed updates is among the dependencies for the Trusty test driver; I think I'll have to wait until the driver will run without this. I appreciate everyone's help.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-304-updates (Ubuntu Trusty):
status: New → Confirmed
Changed in nvidia-graphics-drivers-331 (Ubuntu Trusty):
status: New → Confirmed
Changed in nvidia-graphics-drivers-331-updates (Ubuntu Trusty):
status: New → Confirmed
tags: added: patch
Graham Inggs (ginggs) on 2014-05-25
description: updated
summary: - nvidia-opencl-icd-* should not conflicts/replaces on opencl-icd
+ [SRU] nvidia-opencl-icd-* should not conflicts/replaces on opencl-icd
Brian Hicks (bhicks1000) on 2014-05-31
Changed in ocl-icd (Ubuntu Trusty):
status: Invalid → Confirmed
Clark Malmgren (cmalmgren) wrote :

`apt-get update; apt-get upgrade` with https://launchpad.net/~ginggs/+archive/sru did not seem to help.

Graham Inggs (ginggs) wrote :

@cmalmgren: Did not seem to help what exactly?
Are you trying to follow the test cases in the bug description?

Clark Malmgren (cmalmgren) wrote :

@ginggs, Sorry for the vague report. I was trying to install playonlinux which was requiring that it remove nvidia-libopencl1-331. I updated the nvidia packages using your PPA but still saw the message requiring the removal of nvidia-libopencl1-331 in order to install playonlinux.

I followed the instructions on #7 which make it clear that an alternative implementation for that lib is installed instead of just removing something potentially vital. This seems to work just fine.

Graham Inggs (ginggs) wrote :

@cmalmgren: Thanks for clarifying :)

Stefano Rivera (stefanor) wrote :

Slightly modified the changelog (with Graham's approval) and uploaded, pending SRU team review.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-340 (Ubuntu Trusty):
status: New → Confirmed
Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: New → Confirmed
dino99 (9d9) on 2014-06-25
tags: added: utopic
Changed in ocl-icd (Ubuntu Trusty):
status: Confirmed → Invalid
Scott Ritchie (scottritchie) wrote :

This SRU seems to have stalled. What's needed?

Graham Inggs (ginggs) on 2014-07-12
no longer affects: ocl-icd (Debian)
Changed in nvidia-graphics-drivers-304 (Ubuntu):
status: New → Fix Released
Graham Inggs (ginggs) on 2014-07-12
Changed in nvidia-graphics-drivers-340 (Ubuntu Trusty):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-304-updates - 304.123-0ubuntu1

---------------
nvidia-graphics-drivers-304-updates (304.123-0ubuntu1) utopic; urgency=medium

  [ Graham Inggs ]
  * debian/templates/control.in:
    - Remove conflicts/replaces on opencl-icd, and depend on
      ocl-icd-libopencl1 | nvidia-libopencl1-* (LP: #1247736).
  [ Alberto Milone ]
  * debian/substvars:
    - Add support for X ABI 18.
  * debian/templates/dkms.conf.in:
    - Drop all kernel patches.
  * New upstream release:
    - Improved compatibility with recent Linux kernels.
    - Fixed a bug that could result in system instability while
      restoring the VGA console.
    - Fixed an interaction problem with xserver 1.15 that
      occasionally caused OpenGL applications to continue rendering
      when they are minimized or unmapped.
    - Updated nvidia-bug-report.sh to search the systemd journal for
      X server logs and messages from the NVIDIA kernel module.
    - Added support for X.org xserver ABI 18 (xorg-server 1.16).
    - Fixed a bug that caused corruption or blank screens on monitors
      that use EDID version 1.3 or older when they are connected via
      DisplayPort on graphics boards that use external DisplayPort
      encoders, such as the Quadro FX 4800.
 -- Alberto Milone <email address hidden> Wed, 16 Jul 2014 16:01:18 +0200

Changed in nvidia-graphics-drivers-304-updates (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-304 (Ubuntu Trusty):
status: New → Confirmed
William Leibzon (j-william) wrote :

I've documented how I dealt with newest nvidia drivers & wine installation conflicts here:
https://devtalk.nvidia.com/default/topic/738594/cuda-6-installation-on-ubuntu-14-04/

I'm now going through all the threads I've read before I realized conflicts can't be resolved with existing packages and I ended up having to create custom ones. In my opinion both wine and nvidia are at fault (but more nvidia).

The core of the conflict is nvidia drivers package includes only libopenc1 but did not include libopencl-1.1-1 in its Provides while Wine requires both libopencl1 and libopencl-1.1-1. Specifying last one like that instead of just 1.1 seems wrong and besides is it really necessary when you already specified libopencl1? I think wine should remove it "libopencl-1.1-1" from its depends and just keep libopencl1.

For nvidia drivers there are other issues as you can see in the thread. One of the biggest is that while package provided both amd64 and i386 libraries for opencl, there was no Multiarch specification. This should certainly be listed as a bug for fixing of the spec.

Hello Jorma, or anyone else affected,

Accepted nvidia-graphics-drivers-331 into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-331/331.38-0ubuntu7.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nvidia-graphics-drivers-331 (Ubuntu Trusty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in nvidia-graphics-drivers-331-updates (Ubuntu Trusty):
status: Confirmed → Fix Committed
Chris J Arges (arges) wrote :

Hello Jorma, or anyone else affected,

Accepted nvidia-graphics-drivers-331-updates into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-331-updates/331.38-0ubuntu7.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Graham Inggs (ginggs) on 2014-07-30
description: updated
Graham Inggs (ginggs) wrote :

Please note the new, simpler, test case for SRU verification in the bug description.

The problem that the original reporter reported (/usr/lib/*/libOpenCL.so being shipped in both nvidia-opencl-dev and ocl-icd-libopencl1) is still a bug and does affect Debian too (see comment #7 and #8).
Please use LP: #1311975 for tracking that issue.

Graham Inggs (ginggs) on 2014-07-30
no longer affects: nvidia-graphics-drivers-340 (Ubuntu)
Graham Inggs (ginggs) on 2014-07-31
description: updated
Mathew Hodson (mathew-hodson) wrote :

Verified SRU Verification Test Case #1 and #2 with 331.38-0ubuntu7.1 in trusty-proposed.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for nvidia-graphics-drivers-331 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-331-updates - 331.38-0ubuntu7.1

---------------
nvidia-graphics-drivers-331-updates (331.38-0ubuntu7.1) trusty; urgency=medium

  * Backport the followings changes from 331.38-0ubuntu8 in Utopic to make
    packages using CUDA and OpenCL co-installable:
    - debian/templates/control.in, package nvidia-opencl-icd-*:
      - Remove breaks/replaces on opencl-icd (LP: #1247736).
      - Depend on ocl-icd-libopencl1 | nvidia-libopencl1-*.
 -- Graham Inggs <email address hidden> Sun, 08 Jun 2014 11:59:01 +0200

Changed in nvidia-graphics-drivers-331-updates (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-331 - 331.38-0ubuntu7.1

---------------
nvidia-graphics-drivers-331 (331.38-0ubuntu7.1) trusty; urgency=medium

  * Backport the followings changes from 331.38-0ubuntu8 in Utopic to make
    packages using CUDA and OpenCL co-installable:
    - debian/templates/control.in, package nvidia-opencl-icd-*:
      - Remove breaks/replaces on opencl-icd (LP: #1247736).
      - Depend on ocl-icd-libopencl1 | nvidia-libopencl1-*.
 -- Graham Inggs <email address hidden> Sun, 08 Jun 2014 11:58:18 +0200

Changed in nvidia-graphics-drivers-331 (Ubuntu Trusty):
status: Fix Committed → Fix Released
Scott Ritchie (scottritchie) wrote :

We're not done here, right? Doesn't the 304-updates from utopic still need to be SRU'd?

Also, even with the fix to 331, wine is still not co-installable with nvidia-libopencl1-331-updates for the reason in comment #33. Since that is a problem in the wine dependencies rather than the nividia/opencl dependencies, I am unduping bug 1320217 to cover the wine issue.

Graham Inggs (ginggs) wrote :

@scottrichie: Yes, this should probably still be SRU'd for Trusty, but I'm reluctant to do it on its own as nvidia-304* doesn't provide libcuda-5.5-1 and so only nvidia-331-* should directly be affected by this bug. I believe there are still nvidia-304* fixes coming to Utopic, when these land I'll look at an SRU and include a fix for LP: #1247746.

Sayantan Das (sayantan13) wrote :
Download full text (3.3 KiB)

I dont think this issue is resolved.
 sudo dpkg -l nvidia-331
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==================================-======================-======================-==========================================================================
ii nvidia-331 331.38-0ubuntu7.1 amd64 NVIDIA binary driver - version 331.38

Now when I try to install playonlinux, it asks me to remove

nvidia-libopencl1-331

$ sudo apt-get install playonlinux
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libdrm-nouveau2:i386 libdrm-radeon1:i386 libelf1:i386 libgnome2-gconf-perl
  libllvm3.4:i386 libtxc-dxtn-s2tc0:i386 module-assistant ttf-ancient-fonts
  va-driver-all vdpau-va-driver
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  attr binfmt-support curl fonts-horai-umefont fonts-unfonts-core
  fonts-wqy-microhei gnome-exe-thumbnailer icoutils libaio1
  libasn1-8-heimdal:i386 libcapi20-3 libcapi20-3:i386 libdb5.3:i386
  libexif12:i386 libgd3:i386 libgif4:i386 libglu1-mesa:i386 libgphoto2-6:i386
  libgphoto2-port10:i386 libgpm2:i386 libgssapi3-heimdal:i386
  libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386
  libhcrypto4-heimdal:i386 libhdb9-heimdal libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhx509-5-heimdal:i386 libieee1284-3:i386
  libkdc2-heimdal libkrb5-26-heimdal:i386 liblcms2-2:i386 libldap-2.4-2:i386
  libltdl7:i386 libmpg123-0:i386 libncurses5:i386 libodbc1 libopenal1:i386
  libosmesa6:i386 libp11-kit-gnome-keyring:i386 libroken18-heimdal:i386
  libsane:i386 libsasl2-2:i386 libsasl2-modules:i386 libsasl2-modules-db:i386
  libusb-1.0-0:i386 libv4l-0:i386 libv4lconvert0:i386 libvpx1:i386
  libwind0-heimdal:i386 libwxgtk-media2.8-0 libxpm4:i386 ocl-icd-libopencl1
  ocl-icd-libopencl1:i386 odbcinst odbcinst1debian2 p11-kit-modules:i386 p7zip
  python-dnspython python-wxgtk2.8 python-wxversion samba samba-dsdb-modules
  samba-vfs-modules tdb-tools ttf-wqy-microhei unixodbc winbind wine
  wine-gecko2.21 wine-gecko2.21:i386 wine-mono0.0.8 wine1.6 wine1.6-amd64
  wine1.6-i386:i386 winetricks
Suggested packages:
  libterm-readline-gnu-perl libterm-readline-perl-perl isdnutils-doc
  isdnutils-doc:i386 libgd-tools:i386 gphoto2:i386 gtkam:i386 gpm:i386
  libvisual-0.4-plugins:i386 gstreamer-codec-install:i386
  gnome-codec-install:i386 gstreamer0.10-tools:i386
  gstreamer0.10-plugins-base:i386 liblcms2-utils:i386 libmyodbc
  odbc-postgresql tdsodbc unixodbc-bin libportaudio2:i386 libroar-compat2:i386
  hplip:i386 hpoj:i386 libsane-extras:i386 libsasl2-modules-otp:i386
  libsasl2-modules-ldap:i386 libsasl2-modules-sql:i386
  libsasl2-modules-gssapi-mit:i386 libsasl2-modules-gssapi-heimdal:i386
  opencl-icd:i386 scrot wx2.8-doc wx2.8-examples editra bind9 bind9utils
  ldb-tools...

Read more...

Graham Inggs (ginggs) wrote :

@sayantan13: nvidia-libopencl1-331 is being replaced by ocl-icd-libopencl1, this is not a bug, see LP: #1333008.

tags: added: packaging
no longer affects: nvidia-cuda-toolkit (Ubuntu Trusty)
no longer affects: nvidia-cuda-toolkit (Ubuntu)
no longer affects: ocl-icd (Ubuntu Trusty)
no longer affects: ocl-icd (Ubuntu)
no longer affects: nvidia-graphics-drivers-340 (Ubuntu Trusty)
Shacharm (shacharm) wrote :

The exact bug also exists on ububtu 14.04
Nvidia-346

However - couldn't find an open bug for it.

Graham Inggs (ginggs) wrote :

> The exact bug also exists on ububtu 14.04
> Nvidia-346

@shacharm: Are you sure?
I've just checked debian/control from 346.96-0ubuntu0.0.1 and I do not see the lines:
Conflicts: opencl-icd
Replaces: opencl-icd
These lines were removed in 331.38-0ubuntu7.1 in order to fix this bug (see debdiff in comment #21).

Shacharm (shacharm) wrote :

@graham -

checking again more thoroughly.
straight out of terminal though:

:~$ sudo apt-get install ocl-icd-libopencl1
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  nvidia-libopencl1-346
The following NEW packages will be installed:
  ocl-icd-libopencl1
0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
Need to get 28.1 kB of archives.
After this operation, 43.0 kB of additional disk space will be used.
Do you want to continue? [Y/n]

Shacharm (shacharm) wrote :

I also found the following:

 https://answers.launchpad.net/~kranich/+archive/ubuntu/cubuntu/+sourcepub/4799588/+listing-archive-extra

" * debian/templates/control.in: nvidia driver shouldn't provide a transitional
    `ocl-icd-libopencl1` package as that's built from an unrelated source
    package still in the archive; instead, replace `ocl-icd-libopencl1` with an
    `nvidia-libopencl1-343` --> `nvidia-libopencl1-346` transitional package
"

Graham Inggs (ginggs) wrote :

@shacharm: This is the expected behaviour:

> The following packages will be REMOVED:
> nvidia-libopencl1-346
> The following NEW packages will be installed:
> ocl-icd-libopencl1

You can only have one OpenCL ICD Loader installed on your system, so removing nvidia-libopencl1-346 when installing ocl-icd-libopencl1 is the correct course of action.
You can however, have multiple OpenCL ICDs installed (e.g. nvidia-opencl-icd-346).

When this bug was present, it prevented nvidia-opencl-icd-* from being installed alongside ocl-icd-libopencl1. Can you do that now?

Mathew Hodson (mathew-hodson) wrote :

This should be fixed with https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304/304.125-0ubuntu0.0.2 and https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304-updates/304.125-0ubuntu0.0.2

---------------
nvidia-graphics-drivers-304 (304.125-0ubuntu0.0.2) trusty-proposed; urgency=medium

  * debian/templates/control.in:
    - Avoid circular dependencies. The nvidia driver will depend on
      nvidia-opencl-icd-$ver, which, in turn, will pull in
      nvidia-libopencl1-$ver. The open icd (i.e. ocl-icd-libopencl1)
      is also available for use as an alternative.
  * debian/substvars:
    - Drop lts-utopic and lts-vivid, as depending on xserver-xorg-core and on the ABI is enough.
  * debian/templates/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_3.19.patch,
    debian/dkms/patches/buildfix_kernel_4.0.patch:
    - Add support for Linux 3.19 and Linux 4.0 (LP: #1465706).

 -- Alberto Milone <email address hidden> Tue, 23 Jun 2015 11:56:01 +0200

---------------
nvidia-graphics-drivers-304-updates (304.125-0ubuntu0.0.2) trusty-proposed; urgency=medium

  * debian/templates/control.in:
    - Avoid circular dependencies. The nvidia driver will depend on
      nvidia-opencl-icd-$ver, which, in turn, will pull in
      nvidia-libopencl1-$ver. The open icd (i.e. ocl-icd-libopencl1)
      is also available for use as an alternative.
  * debian/substvars:
    - Drop lts-utopic and lts-vivid, as depending on xserver-xorg-core and on the ABI is enough.
  * debian/templates/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_3.19.patch,
    debian/dkms/patches/buildfix_kernel_4.0.patch:
    - Add support for Linux 3.19 and Linux 4.0 (LP: #1465706).

 -- Alberto Milone <email address hidden> Mon, 29 Jun 2015 15:48:57 +0200

Changed in nvidia-graphics-drivers-304 (Ubuntu):
importance: Undecided → Medium
Changed in nvidia-graphics-drivers-304-updates (Ubuntu):
importance: Undecided → Medium
Changed in nvidia-graphics-drivers-304 (Ubuntu Trusty):
importance: Undecided → Medium
Changed in nvidia-graphics-drivers-331 (Ubuntu):
importance: Undecided → Medium
Changed in nvidia-graphics-drivers-331 (Ubuntu Trusty):
importance: Undecided → Medium
Changed in nvidia-graphics-drivers-331-updates (Ubuntu):
importance: Undecided → Medium
Changed in nvidia-graphics-drivers-331-updates (Ubuntu Trusty):
importance: Undecided → Medium
Changed in nvidia-graphics-drivers-304 (Ubuntu Trusty):
status: Confirmed → Fix Released
Changed in nvidia-graphics-drivers-304-updates (Ubuntu Trusty):
importance: Undecided → Medium
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers