nvidia-331-updates fails on Asus UX302LG with Nvidia GT 730M (Optimus Technology)

Bug #1268184 reported by tehownt on 2014-01-11
This bug report is a duplicate of:  Bug #1268771: NVIDIA Prime fails with Linux 3.13. Edit Remove
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-331-updates (Ubuntu)
Critical
Unassigned

Bug Description

Installing nvidia-331 or nvidia-331-updates (nvidia-current does not support GPU from kern.log message), X fails to start / driver fails to load properly.

Nouveau works "OK" with the haswell GPU upstream patch targetted there https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1265544

Tried using bumblebee, handles both drivers but nvidia fails to start (either nvidia-331 or nvidia-331-updates) nvidia-319 points to 331.

Error message is as follows under nvidia-331-updates (same with nvidia-331) :

NVRM: failed to copy vbios to system memory.
NVRM: RmInitAdapter failed! (0x30:0xffffffff:720)
NVRM: rm_init_adapter failed for device bearing minor number 0
NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -5

Was the same message when running under bumblebee and trying to 'optirun' apps w/ nVidia's GPU (tested glxgears -info etc.).

Lots of content in Xorg.failsafe.log / Xorg.0.log too.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: nvidia-331-updates 331.20-0ubuntu9
ProcVersionSignature: Ubuntu 3.13.0-2.17~lp1265544v1-generic 3.13.0-rc7
Uname: Linux 3.13.0-2-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.13.1-0ubuntu1
Architecture: amd64
Date: Sat Jan 11 14:28:30 2014
InstallationDate: Installed on 2013-12-31 (11 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20131231)
SourcePackage: nvidia-graphics-drivers-331-updates
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.modprobe.d.nvidia.331.updates.hybrid.conf: [deleted]

tehownt (tehownt) wrote :
tehownt (tehownt) wrote :
tehownt (tehownt) wrote :
tehownt (tehownt) wrote :
Sergio Benjamim (sergio-br2) wrote :

I tried this nvidia 331 in NVIDIA GT218 [NVS 300] card, and X fails to start too, after a buggy splash.

When you installed nvidia-331, it installed nvidia-prime too, and I think after reboot, nvidia card is the default by nvidia-prime, instead of your Intel HD Graphics 4400.

So, maybe this bug is not specific to your hardware, maybe it is duplicate of bug #1267442

summary: - nvidia-331-updates fails on UX302LG with Nvidia 730M (GK208)
+ nvidia-331-updates fails on Asus UX302LG with Nvidia GT 730M (Optimus
+ Technology)
tehownt (tehownt) wrote :

The bug exists when only using nvida-331 and nouveau is blacklisted. Therefore I would expect the nvidia card to be the default and only card visible but it does not start.
It only starts if hd4000 is present (either because nvida-331 not installed or with bumblebee that manages both).
Bumblebee is not installed in the configuration the bug was reported against, though it can be installed w/o major issues, yet optirun fails when trying to address the nvidia card w/ bumblebee.
It doesn't look like a duplicate unless the laptop cannot start under nvidia for whatever reason and absolutely has to start under the hd4000 (wouldn't be normal).

tehownt (tehownt) wrote :

I tried the config in bug #1267442 and since by forcing the nvidia card to be the one used at lightdm it triggers an X failsafe display, I think it might confirm the issue with nvidia-331 and the laptop.

Sergio Benjamim (sergio-br2) wrote :

I installed nvidia-331-updates, and now plimouth is loading forever and it does not go to login screen. I went to other tty and I purged all package that nvidia-331-updates installed, but it can not go to login screen anymore.

How did you reverse it?

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-331-updates (Ubuntu):
status: New → Confirmed
tehownt (tehownt) wrote :

I don't know what you did, I don't think we have the same configuration or that the problems even relate (different computer, different GPU, etc).

If you want to reverse your installation just either boot 'recovery' and remove the packages that are in conflict (or try the standard boot with 'nomodeset' option added). I never got Plymouth stuck, I either have nouveau working, or minimal X if nvida is the only driver installed when nouveau is blacklisted.

Daniel Letzeisen (dtl131) wrote :

"Therefore I would expect the nvidia card to be the default and only card visible"

That's not how it works. You can't just install the nvidia driver directly on an Optimus/hybrid GPU system, or it will mess up the intel driver.

tehownt (tehownt) wrote :

The problem exists w/ bumblebee, w/o bumblebee, using primus, using virtualgl and is exactly the same behaviour with the aforementionned log messages.

Changed in nvidia-graphics-drivers-331-updates (Ubuntu):
importance: Undecided → Critical
Alberto Milone (albertomilone) wrote :

Please remove bumblebee, install nvidia-prime, and upgrade to the latest nvidia-331-updates. That will fix your problem.

This is a duplicate of bug #1268771

tehownt (tehownt) wrote :

Alberto,

I confirm this is indeed duplicate of bug #1268771 and got "resolved" by following suggested actions. I can now confirm that I have bug #1274733 and I'm unable to switch to Intel Power Savings Mode with the same error.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers