Ubuntu

[nVidia GTX645][10de:11c4] Unable to boot to desktop with nvidia-319 driver

Reported by Po-Hsu Lin on 2013-09-09
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-319 (Ubuntu)
High
Alberto Milone
Precise
High
Alberto Milone
nvidia-graphics-drivers-319-updates (Ubuntu)
High
Alberto Milone
Precise
High
Alberto Milone

Bug Description

CID: 201303-13031 Dell Alienware X51

According to bug 1199342, this video card should be supported by nvidia-graphics-drivers-319.
But it can't boot to desktop with nvidia-319 / nvidia-319-updates driver.

Steps:
1. Install 12.04.3, boot to desktop.
2. Install the proprietary nvidia-319 video driver via jockey.
3. Reboot.

Expected results:
1. System should be able to boot to desktop with the proprietary driver.

Actual results:
1. Unable to boot to destop, the screen is totally black (screen won't enter idle mode). But I can still access this system via ssh.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nvidia-319 319.32-0ubuntu0.0.1
ProcVersionSignature: Ubuntu 3.8.0-29.42~precise1-generic 3.8.13.5
Uname: Linux 3.8.0-29-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.4
Architecture: amd64
Date: Mon Sep 9 02:01:57 2013
InstallationMedia: Ubuntu 12.04.3 LTS "Precise Pangolin" - Release amd64 (20130820.1)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nvidia-graphics-drivers-319
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.modprobe.d.nvidia.319.hybrid.conf: [deleted]

Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) wrote :

Verified with the proprietary driver downloaded from nvidia's website
(version 319.49, however, the version number with dpkg -l | grep nvidia shows 319.32-0ubuntu0.0.1)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-319 (Ubuntu):
status: New → Confirmed
Matt Edmunds (drmattedmunds) wrote :

This bug effects me too. Is there any workaround?

Po-Hsu Lin (cypressyew) wrote :

Sorry, I forgot to clarify that for Comment #2, the driver from nVidia's website works.

Matt, you could give it a try. (You will need to disable the nouveau driver first)

Changed in nvidia-graphics-drivers-319 (Ubuntu):
assignee: Anthony Wong (anthonywong) → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-319 (Ubuntu Precise):
status: New → Triaged
Changed in nvidia-graphics-drivers-319 (Ubuntu):
status: Confirmed → Triaged
Changed in nvidia-graphics-drivers-319-updates (Ubuntu):
status: New → In Progress
Changed in nvidia-graphics-drivers-319-updates (Ubuntu Precise):
status: New → Triaged
Changed in nvidia-graphics-drivers-319 (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-319 (Ubuntu Precise):
importance: Undecided → High
Changed in nvidia-graphics-drivers-319-updates (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-319-updates (Ubuntu Precise):
importance: Undecided → High
Changed in nvidia-graphics-drivers-319 (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-319-updates (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-319-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-319-updates - 319.49-0ubuntu1

---------------
nvidia-graphics-drivers-319-updates (319.49-0ubuntu1) saucy; urgency=low

  * debian/templates/nvidia-graphics-drivers.{links|links32}.in:
    - Create links for the new NvIFROpenGL library.
  * debian/additional_card_ids:
    - Remove card id 11C4 which is now officially supported.
  * New upstream release (LP: #1219908, LP: #1222670):
    - Added support for the following GPUs:
      o GeForce GT 740A
      o GeForce GT 745A
      o GeForce GT 755M
      o GeForce GT 625
      o GeForce GTX 645
      o GRID K340
      o GRID K350
      o NVS 315
      o Quadro K500M
   - Fixed a bug that caused DisplayPort monitors connected
     to Quadro FX 3800, 4800, or 5800 to remain off after
     DPMS.
   - Added the NVIDIA OpenGL-based Inband Frame Readback
     (NvIFROpenGL) library to the Linux driver package.
     This library provides a high performance, low latency
     interface to capture and optionally encode an
     individual OpenGL framebuffer. NvIFROpenGL captures
     pixels rendered by OpenGL only and is ideally suited
     to application capture and remoting.
   - Fixed a bug that caused applications using CUDA-GL
     interop to crash when run on X servers with Xinerama
     enabled.
   - Fixed a bug that could prevent some double-bit ECC
     errors from being properly reported.
   - Fixed a bug which could cause a blank screen when
     changing house sync settings on Quadro Kepler GPUs
     with Quadro Sync boards.
   - Fixed a bug that prevented nested loops with
     identical loop conditions in GLSL shaders from
     terminating correctly. This could cause hangs in
     applications such as Exa PowerVIZ.
   - Fixed a bug that resulted in corrupt texels when a
     previously empty texture image was specified with
     glXBindTexImageEXT. In GNOME 3, this caused
     gnome-screenshot to produce garbled window
     screenshots.
   - Fixed a bug that caused the X server to crash when
     querying the current mode of disabled displays.
 -- Alberto Milone <email address hidden> Mon, 16 Sep 2013 17:35:57 +0200

Changed in nvidia-graphics-drivers-319-updates (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-319 - 319.32-0ubuntu7

---------------
nvidia-graphics-drivers-319 (319.32-0ubuntu7) saucy; urgency=low

  * debian/additional_card_ids:
    - Remove card id 11C4 which is not supported (LP: #1222670).
 -- Alberto Milone <email address hidden> Tue, 17 Sep 2013 08:04:14 +0200

Changed in nvidia-graphics-drivers-319 (Ubuntu):
status: Triaged → Fix Released
Matt Edmunds (drmattedmunds) wrote :

Tryed version 319.49, works OK. Thanks.

Matt Edmunds (drmattedmunds) wrote :

Is there a time frame for 319.32-0ubuntu7 or 319.49 to be released to the repositories? Thanks.

Alberto Milone (albertomilone) wrote :

@Matt: what Ubuntu release are you talking about? 319.49 is in Ubuntu 13.10

Matt Edmunds (drmattedmunds) wrote :

Appologies should have stated: Ubuntu 12.04.3

Po-Hsu Lin (cypressyew) wrote :

Verified with 13.10 Saucy daily image (9/17) on 201303-13031
No proprietary drivers could be found in the software-properties-gtk

Therefore nvidia-319-updates was manually installed.

ubuntu@201303-13031:~$ dpkg -l | grep nvidia
ii nvidia-319-updates 319.49-0ubuntu2 amd64 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings-319-updates 319.49-0ubuntu1 amd64 Tool for configuring the NVIDIA graphics driver

With this driver installed, display works fine after boot to desktop.
Thanks!

(However, no display after resume from suspend, log attached.)

Alberto Milone (albertomilone) wrote :

@Po-Hsu: there's a backtrace in the log. Maybe there's a reason why the card is not officially supported by the driver.

Hello Po-Hsu, or anyone else affected,

Accepted nvidia-graphics-drivers-319-updates into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-319-updates/319.49-0ubuntu0.0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nvidia-graphics-drivers-319-updates (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Po-Hsu Lin (cypressyew) wrote :

Hello, Stéphane

TEST CASE:
 1. Enable -proposed on 201303-13031 (12.04.3 + 3.8.0-29)
 2. Install nvidia-319-updates via jockey-gtk
 3. Reboot

VERIFICATION DONE:
 The monitor was connected with HDMI cable, but still no display,
 error message could be found in X.org.log:
 (II) NVIDIA(GPU-0): Display (AOC 2460W (DFP-2)) does not support NVIDIA 3D Vision

ubuntu@201303-13031:/var/log$ dpkg -l | grep nvidia
 ii nvidia-319-updates 319.49-0ubuntu0.0.1 NVIDIA binary Xorg driver, kernel module and VDPAU library
 ii nvidia-common 1:0.2.44.2 Find obsolete NVIDIA drivers
 ii nvidia-prime 0.4.2~hybrid0.0.1 Tools to enable NVIDIA's Prime
 rc nvidia-settings-319 319.32-0ubuntu0.0.1 Tool for configuring the NVIDIA graphics driver
 ii nvidia-settings-319-updates 319.49-0ubuntu0.0.1 Tool for configuring the NVIDIA graphics driver

tags: added: 201303-13031 taipei-lab verification-failed
removed: verification-needed
Chris Halse Rogers (raof) wrote :

That looks like it might be a configuration issue, not directly an nvidia-graphics-drivers issue?

Xorg.0.log contains:
[ 19.176] (**) NVIDIA(0): Option "UseDisplayDevice" set to "none"; enabling NoScanout
[ 19.176] (**) NVIDIA(0): mode
and, indeed, the nvidia driver does not try to drive the internal display.

Secondly, the log indicates that X is using the modesetting driver for the hybrid display; is that expected? The modesetting driver is the one unable to detect the HDMI output.

Alberto Milone (albertomilone) wrote :

According to the log there are two graphics cards on a desktop system. Jockey tries to offload rendering to the discrete card. This, however, should not happen on a desktop system, where I would expect users to use the NVIDIA card directly (and have the monitor connected to it).

When LP: #1259237 is approved, nvidia-prime will do the offloading only when dealing with a laptop.

The ideal solution would be to disable the integrated card from the BIOS. We should probably also update Jockey so that it doesn't provide the nvidia driver on desktop systems with Intel+NVIDIA.

bill (wemember) wrote :

It happens when installing freecad dependencies ,The following terminal output shows the extra packages required to fulfill dependencies. can anyone work out why this caused the GUI to crash.

ted@ted-Satellite-C660D:~$ sudo apt-get install python-pyOpenCL
[sudo] password for ted:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  dkms fakeroot freeglut3 libjs-jquery libjs-sphinxdoc libjs-underscore
  libvdpau1 nvidia-319-updates nvidia-settings-319-updates python-opengl
  python-pyopencl-doc python-pytools python-xkit python3-decorator
  python3-mako python3-markupsafe python3-numpy python3-pyopencl
  python3-pytools screen-resolution-extra
Suggested packages:
  javascript-common nvidia-vdpau-driver vdpau-driver libgle3 python-imaging-tk
  python-pytest python-pyopencl-dbg python3-beaker python-mako-doc
  python-numpy-doc python3-numpy-dbg python3-nose python3-dev
  python3-imaging-tk python3-opengl python3-pytest python3-matplotlib
  python3-pyopencl-dbg
Recommended packages:
  nvidia-persistenced
The following NEW packages will be installed
  dkms fakeroot freeglut3 libjs-jquery libjs-sphinxdoc libjs-underscore
  libvdpau1 nvidia-319-updates nvidia-settings-319-updates python-opengl
  python-pyopencl python-pyopencl-doc python-pytools python-xkit
  python3-decorator python3-mako python3-markupsafe python3-numpy
  python3-pyopencl python3-pytools screen-resolution-extra
0 upgraded, 21 newly installed, 0 to remove and 0 not upgraded.
Need to get 75.0 MB of archives.
After this operation, 232 MB of additional disk space will be used.
Do you want to continue [Y/n]? n

I chose not to continue this time after 3 reinstalls

Alberto Milone (albertomilone) wrote :

@bill: that's really a separate problem, caused by the fact that python-opencl pulls in the nvidia driver. This shouldn't happen in Ubuntu 14.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers