[nvidia-prime] Xorg freeze after resume from suspend

Bug #1220865 reported by Loris Zinsou on 2013-09-04
166
This bug affects 35 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-319 (Ubuntu)
Critical
Unassigned
nvidia-graphics-drivers-331 (Ubuntu)
Critical
Unassigned

Bug Description

Resuming from suspend freezes my display while usind nvidia+intel option with nvidia-prime.
I have to do a VT switch to get it moving again, but rendering is garbled.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: xorg 1:7.7+1ubuntu5
ProcVersionSignature: Ubuntu 3.11.0-4.9-generic 3.11.0-rc7
Uname: Linux 3.11.0-4-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] est un dossier: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 319.32 Wed Jun 19 15:51:20 PDT 2013
 GCC version: gcc version 4.8.1 (Ubuntu/Linaro 4.8.1-9ubuntu1)
.tmp.unity.support.test.0:

ApportVersion: 2.12.1-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Wed Sep 4 20:48:44 2013
DistUpgraded: Fresh install
DistroCodename: saucy
DistroVariant: ubuntu
DkmsStatus: nvidia-319-updates, 319.32, 3.11.0-4-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GpuHangFrequency: Several times a day
GpuHangReproducibility: Always occurs after resume from suspend
GpuHangStarted: Immediately after installing this version of Ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:15f2]
 NVIDIA Corporation GF108M [GeForce GT 540M] [10de:0df4] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:15f2]
InstallationDate: Installed on 2013-08-30 (5 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130829)
MachineType: ASUSTeK Computer Inc. N43SL
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-4-generic root=UUID=dd997685-cbb7-4674-843c-8b773b41224b ro quiet splash
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/15/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: N43SL.302
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: N43SL
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrN43SL.302:bd02/15/2011:svnASUSTeKComputerInc.:pnN43SL:pvr1.0:rvnASUSTeKComputerInc.:rnN43SL:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: N43SL
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
version.compiz: compiz 1:0.9.10+13.10.20130828.2-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.46-1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2-1ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.14.2.901-2ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.14-4ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
xserver.bootTime: Wed Sep 4 18:05:52 2013
xserver.configfile: /etc/X11/xorg.conf
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.14.2.901-2ubuntu4

Loris Zinsou (nepenthes) wrote :
Loris Zinsou (nepenthes) on 2013-09-04
summary: - Xorg freeze, nvidia-prime
+ [nvidia-prime] Xorg freeze after resume from suspend
description: updated
Timo Aaltonen (tjaalton) on 2013-09-05
affects: xorg (Ubuntu) → nvidia-graphics-drivers-319 (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-319 (Ubuntu):
status: New → Confirmed
Flittermice (flittermice) wrote :

I found this bug when searching for the reason that my desktop stops working after resuming from suspend or hibernation.

It's not a real freeze. I can see the desktop, I can move the mouse pointer, Gnome 3 even reacts when I move the mouse pointer to the top left corner (animation). But it doesn't react to keys or mouse clicks. It's possible to switch to a virtual console once (Ctrl-Alt-F1), but going back to the graphical desktop stops the computer working finally.

I don't even have the nvidia drivers installed, but nouveau. And it's the same with Unity.
Therefore I think this is a bigger bug.

Loris Zinsou (nepenthes) wrote :

Any changes with nvidia 331.20 drivers ?

Lauri Siltala (latelol) wrote :

I've been having this problem as well, still not working with 331.20.
Kernel 3.9 works fine, but newer ones don't seem to.

Using an Acer v3-517g laptop with the nvidia 640M graphics for the record. And to me it really sounds like Flittermice's problem is not the same one as the reporter's (and mine)

For me, when resuming from suspend, all I basically see are black and white diagonal zigzag patterns spanning the entire screen. After switching to a VT and back to X, I can see the desktop but there are rendering issues (for instance, having a png file open shows those same diagonal patterns, and there are other weird artifacts and stuff) which sounds more similar to the reporter's.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: New → Confirmed
sandipt (sandipt) wrote :

Pl set correct bug status . Mistakenly it got changed to Fix Released .

Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: Confirmed → Fix Released
Loris Zinsou (nepenthes) on 2013-12-27
Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: Fix Released → Confirmed
Changed in nvidia-graphics-drivers-319 (Ubuntu):
importance: Undecided → Critical
Changed in nvidia-graphics-drivers-331 (Ubuntu):
importance: Undecided → Critical
Malte Finsterwalder (malte-6) wrote :

I have the same behaviour as Flittermice described.
Lenovo ThinkPad T530 with Ubuntu 3.10 using nouveau drivers.
Installing Kernel 3.13.6 didn't help.

Installing the nvidia drivers cause a host of other problems.

Lauri Siltala (latelol) wrote :

This is fixed for me with nvidia-graphics-drivers-331 version 331.38-0ubuntu5
(see also https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-331/+bug/1210077 which the original issue seems to be a duplicate of)

reg32 (bauer-matthias23) wrote :

Not for me, I have version 331.49 installed and the problem still persists...

Devin (thatguyweallknow) wrote :

I too still have this problem as lats checked 04/18/2014.

Seth Miers (miers-seth) wrote :

I still have this problem on 3/31/2014
It seems to go along with the touchpad bug as well:
https://bugs.launchpad.net/ubuntu/+source/nvidia-prime/+bug/1220426

To post a comment you must log in.