[needs-packaging] nvidia-304 (304.137) missing in Ubuntu 18.04

Bug #1763648 reported by Ricardo Almeida on 2018-04-13
86
This bug affects 17 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-304 (Ubuntu)
Wishlist
Unassigned

Bug Description

nvidia-304 is not available in the Ubuntu 18.04. Newer versions are available but I have an old nVidia 7600 GT, so I need 304.137.

I searched online and found that at https://answers.launchpad.net/ubuntu/bionic/amd64/nvidia-304/304.137-0ubuntu2 it has Status: Deleted :(

Could you please pack this for the new release of Ubuntu?

Hans Joachim Desserud (hjd) wrote :

Looks like it was removed from bionic due to bug 1748000. (Found via the publishing history link in the upper right corner on the package overview page, see https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304/+publishinghistory for details)

affects: ubuntu → nvidia-graphics-drivers-304 (Ubuntu)
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - nvidia-304 (304.137) missing in Ubuntu 18.04
+ [needs-packaging] nvidia-304 (304.137) missing in Ubuntu 18.04
Changed in nvidia-graphics-drivers-304 (Ubuntu):
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-304 (Ubuntu):
status: New → Confirmed
Tong Sun (suntong001) wrote :

Unmaintained or not, it's the only driver that works correctly with my card.

From
http://www.nvidia.com/download/driverResults.aspx/123709/en-us

Version: 304.137
Release Date: 2017.9.19

2017.9.19 isn't really far away, and Seth Forshee (sforshee) has already provided a patch months ago on bug 1737750 for it.

Please provide it in Ubuntu 18.04 again.

Tong Sun (suntong001) wrote :

The nvidia-libopencl1-304 driver is missing from Ubuntu 18.04 bionic as well.
Trying to report nvidia-libopencl1-304 missing directs me here, so please provide nvidia-libopencl1-304 as well. thanks.

dino99 (9d9) wrote :

Tou can still get it via that ppa: ppa:graphics-drivers/ppa

Ricardo Almeida (ric-almeida) wrote :

Trying to install from ppa I get:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cinnamon-screensaver-x-plugin : Depends: cinnamon-screensaver (>= 3.1.0) but it is not going to be installed
                                 Recommends: xscreensaver-gl but it is not going to be installed
                                 Recommends: xscreensaver-gl-extra but it is not going to be installed
 gnome-keyring : Depends: gcr (>= 3.4) but it is not going to be installed
                 Depends: pinentry-gnome3 but it is not going to be installed
 gvfs : Depends: gvfs-daemons (>= 1.36.1-0ubuntu1)
        Depends: gvfs-daemons (< 1.36.1-0ubuntu1.1~)
 gvfs:i386 : Depends: gvfs-daemons:i386 (>= 1.36.1-0ubuntu1)
             Depends: gvfs-daemons:i386 (< 1.36.1-0ubuntu1.1~)
 libappindicator3-1 : Depends: libindicator3-7 (>= 0.4.90) but it is not going to be installed
 libgtk-3-0 : Depends: libwayland-egl1-mesa (>= 10.0.2) but it is not going to be installed or
                       libwayland-egl1
              Recommends: libgtk-3-bin
 libkf5service5 : Depends: libkf5dbusaddons5 (>= 4.97.0) but it is not going to be installed
                  Recommends: libkf5service-bin (= 5.44.0-0ubuntu1) but it is not going to be installed
 libkf5su-bin : Depends: libkf5su5 (>= 4.96.0) but it is not going to be installed
 libqt5gui5 : Depends: libegl1 but it is not going to be installed
              Depends: libgl1 but it is not going to be installed
              Recommends: libqt5svg5 but it is not going to be installed
              Recommends: qt5-gtk-platformtheme but it is not going to be installed
 mupen64plus-rsp-all : Depends: mupen64plus-rsp-hle but it is not going to be installed
                       Recommends: mupen64plus-rsp-z64 but it is not going to be installed
 nvidia-304 : Depends: xorg-video-abi-11 but it is not installable or
                       xorg-video-abi-12 but it is not installable or
                       xorg-video-abi-13 but it is not installable or
                       xorg-video-abi-14 but it is not installable or
                       xorg-video-abi-15 but it is not installable or
                       xorg-video-abi-18 but it is not installable or
                       xorg-video-abi-19 but it is not installable or
                       xorg-video-abi-20 but it is not installable or
                       xorg-video-abi-23
              Depends: xserver-xorg-core but it is not going to be installed
              Recommends: nvidia-settings (>= 331.20) but it is not going to be installed
 zeitgeist : Depends: zeitgeist-datahub but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Gary Caine (skgary) wrote :

I am getting the same error as Ricardo

Tong Sun (suntong001) wrote :

I am getting the same error as Ricardo trying to install from ppa in Ubuntu 18.04

Giova (giovamyhero) wrote :

I am getting the same error as Ricardo trying to install from ppa in Ubuntu MATE 18.04 x86_64.
I get:
The following packages have unmet dependencies:
 gvfs : Depends: gvfs-daemons (>= 1.36.1-0ubuntu1)
        Depends: gvfs-daemons (< 1.36.1-0ubuntu1.1~)
 libgtk-3-0 : Depends: libwayland-egl1-mesa (>= 10.0.2) but it is not going to be installed or
                       libwayland-egl1
 nvidia-304 : Depends: xorg-video-abi-11 but it is not installable or
                       xorg-video-abi-12 but it is not installable or
                       xorg-video-abi-13 but it is not installable or
                       xorg-video-abi-14 but it is not installable or
                       xorg-video-abi-15 but it is not installable or
                       xorg-video-abi-18 but it is not installable or
                       xorg-video-abi-19 but it is not installable or
                       xorg-video-abi-20 but it is not installable or
                       xorg-video-abi-23
              Depends: xserver-xorg-core but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Paul (hexapuma) wrote :

I am getting the same error as Ricardo installing from PPA on Ubuntu 18.04. It also fails if I attempt to install from the script provided on the NVidia website for my card (nVidia GeForce 7800 GT)

Timo Aaltonen (tjaalton) on 2018-05-30
Changed in nvidia-graphics-drivers-304 (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers