no login possible after update to nvidia 304.132

Bug #1639180 reported by Jan Herold on 2016-11-04
328
This bug affects 62 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-304 (Ubuntu)
Critical
Alberto Milone
Xenial
Critical
Unassigned
Yakkety
Critical
Unassigned
nvidia-graphics-drivers-legacy-304xx (Debian)
Fix Released
Unknown

Bug Description

Ubuntu 16.04 LTS

NVIDIA driver:
- nvidia-graphics-drivers-304
- update to version 304.132

dpkg.log:
upgrade nvidia-304-updates:amd64 304.131-0ubuntu3 304.132-0ubuntu0.16.04.2

- reboot
- lightdm login screen
- login
- a few seconds some flickering
- and the lightdm login screen appears again

It is not possible to login. Unity is not loading.

.xsession-errors:
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 155 (GLX)
  Minor opcode of failed request: 3 (X_GLXCreateContext)
  Value in failed request: 0x0
  Serial number of failed request: 34
  Current serial number in output stream: 35

See also bug 1634802

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-304 (Ubuntu):
status: New → Confirmed
Jamie Strandboge (jdstrand) wrote :

I see this on:
01:00.0 VGA compatible controller: NVIDIA Corporation GT218M [GeForce 305M] (rev a2) (prog-if 00 [VGA controller])
 Subsystem: Lenovo Device 395a
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at d2000000 (32-bit, non-prefetchable) [size=16M]
 Memory at c0000000 (64-bit, prefetchable) [size=256M]
 Memory at d0000000 (64-bit, prefetchable) [size=32M]
 I/O ports at 4000 [size=128]
 [virtual] Expansion ROM at d3080000 [disabled] [size=512K]
 Capabilities: <access denied>
 Kernel driver in use: nvidia
 Kernel modules: nvidia_304, nouveau, nvidiafb

Jamie Strandboge (jdstrand) wrote :

More details:
- this is on Ubuntu 12.04
- the module does load into the kernel
- lightdm does present a login screen
- nvidia-340 doesn't work on this system
- compiz fails to start (from ~/.xsession-errors):
gnome-session[6632]: WARNING: App 'compiz.desktop' respawning too quickly
gnome-session[6632]: WARNING: Application 'compiz.desktop' killed by signal
gnome-session[6632]: WARNING: App 'compiz.desktop' respawning too quickly
- no amount of moving ~/.compiz* ~/.nv* ~/.cache/compiz* ~/.config/compiz* aside made a difference

The only thing that worked was grabbing the previous version from here:
https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304/304.131-0ubuntu0.12.04.1

and apt-pinning it like so:
/etc/apt/preferences.d/nvidia.pref
Package: nvidia-304
Pin: version 304.131-0ubuntu0.12.04.1
Pin-Priority: 1001

Package: nvidia-current
Pin: version 304.131-0ubuntu0.12.04.1
Pin-Priority: 1001

'sudo apt-get update && sudo apt-get upgrade' now does not upgrade to the problematic version.

jokrebel (jokrebel) wrote :

Same here.
Since upgrade with "nvidia-304:i386 (304.131-0ubuntu3, 304.132-0ubuntu0.16.04.2" I am no more able to login into Unity or Gnome (Compiz). After a vew Seconds the Login-Screen gets back.
With Gnome (Metacity) login is possible

Alberto Milone (albertomilone) wrote :

Can you run the following command, and attach the resulting nvidia-bug-report.log.gz (from your home directory), please?

Alberto Milone (albertomilone) wrote :

sudo nvidia-bug-report.sh

Jan Herold (yzle) wrote :

bug report created with sudo nvidia-bug-report.sh as suggested at comment 6 for bug 1639180

Peter (freeswiss) wrote :

I can log in but have other side effects:

0ad shows the map but no buildings, landscape features, soldiers, trees etc. its unplayable.
totem media player shows a black window with sound but no picture.

nomentero (toni7) wrote :

I can log in 16.04 and 16.10 too....please roll back to 304.131-0ubuntu3.

Scott Leggett (smlx) wrote :

I'm also affected by this. It renders my HTPC unusable. See attached for my nvidia-bug-report.log

FYI, downgrade “solved” the problem for me too.

A debdiff between the packages shows the difference is mainly a version upgrade from 304.131 to 304.132.

And it seems a lot of people are experiencing problems with version 304.132, cf https://devtalk.nvidia.com/search/more/sitecommentsearch/304.132/

A specific thread retained my attention: https://devtalk.nvidia.com/default/topic/968892/linux/geforce-7300le-with-304-132-glxinfo-fails-now-with-quot-x-error-of-failed-request-badvalue-quot-/

Since this problem greatly affects usability (no graphic login anymore), may be it's worth (in the users' point of view) creating a “fake version” security-upgrade like "304.132-0ubuntu0.16.04.2+really304.131" to fill the gap while waiting for Nvidia to provide a fix for 304.132, IMHO.

Changed in nvidia-graphics-drivers-legacy-304xx (Debian):
status: Unknown → Confirmed
Igor Djuric (idjuric) wrote :

Dear Jean, could you please describe how to successfully __downgrade__ driver from 304.132 to the previous version 304.131.

I've tried everything I could find on the web, at no avail. For example, directly running the NVIDIA-*.run file didn't succeed as some remnants of nouveau driver were present, or so.

Thank you in advance!!

Changed in nvidia-graphics-drivers-304 (Ubuntu):
status: Confirmed → New
status: New → Confirmed
Paul Eggert (eggert-cs) wrote :

I also observed the problem on my desktop running Ubuntu 16.04.1 LTS x86. lspci | grep VGA reports "02:00.0 VGA compatible controller: NVIDIA Corporation C77 [GeForce 8300] (rev a2)". I am attaching /var/log/Xorg.1.log, which says "NVIDIA GPU GeForce 8300 (C77) at PCI:2:0:0 (GPU-0)". This system worked fine with the previous 304xx package. I have worked around the problem by dropping 304xx and using Nouveau.

Igor Djuric (idjuric) wrote :

Dear all, I am so glad I can post a solution (or at least workaround) for this.

Instead of downgrading from 304.132 to the previous version 304.131, I've followed the suggestion on http://askubuntu.com/questions/845632/nvidia-304-132-driver-update-wont-boot and checked which nVidia driver version should be compatible with my graphic card at http://www.geforce.com/drivers.

It came out that I should install version 340.98, which I did and subsequently were able to login into my user session again.

Just why Ubuntu 16.04 LTS automatic upgrade mechanism thinks my nVidia 8600 GT graphic card should work with version 304 of these drivers is probably due to some misconfiguration bugs or similar.

Jan Herold (yzle) wrote :

Installing version 340 is not suitable for my graphics card. I need the 304 series.

Downgrade from 304.132 to 304.131:
- CTRL+ALT+1 to console
- login
- sudo apt-get remove nvidia*
- sudo apt-get autoremove
- sudo apt-get install nvidia-304=304.131-0ubuntu3

In my case I have a GeForce 6150SE so I really need this 304.131 and can't higher version like 340.xx.

For people needing to downgrade, this is one (among others) correct way to do so with Ubuntu 16.04:

- first create a file named /etc/apt/preferences.d/local-nvidia-quirks with the following content:

Explanation: block this specifique update because of OpenGL problem with 304.132
Package: nvidia-304
Pin: version 304.132-0ubuntu0.16.04.2
Pin-Priority: -10

Explanation: block this specifique update because of OpenGL problem with 304.132
Package: nvidia-opencl-icd-304
Pin: version 304.132-0ubuntu0.16.04.2
Pin-Priority: -10

- then reinstall the working old packages (they are still available in the repository):

sudo apt install nvidia-304=304.131-0ubuntu3 nvidia-opencl-icd-304=304.131-0ubuntu3

- finally, reboot your computer (because it also affects the initrd boot image)

The previous way only blocks the currently known not working version, without blocking future updates.

If you want a way to stay at the known working version without further updates, here is the content you should use for your /etc/apt/preferences.d/local-nvidia-quirks:

Explanation: do not use any other version than this one, ever (priority 1001 will ensure that)
Package: nvidia-304
Pin: version 304.131-0ubuntu3
Pin-Priority: 1001

Explanation: do not use any other version than this one, ever (priority 1001 will ensure that)
Package: nvidia-opencl-icd-304
Pin: version 304.131-0ubuntu3
Pin-Priority: 1001

Sorry for the typos and long-lines… Can't find a way to edit back my posts… :-/

Jan Herold (yzle) wrote :

Sorry, there is a error in my comment 17.

correction:
Downgrade from 304.132 to 304.131:
- CTRL+ALT+F1 to console
- login
- sudo apt-get remove nvidia*
- sudo apt-get autoremove
- sudo apt-get install nvidia-304=304.131-0ubuntu3
- reboot

And prevent updates of the driver like shown in comment 18.

Jose Bartolome (zubzou) wrote :

Have the same problem. Resolved with #20
GPU Nvidia Quadro FX 770M in a Celsius H270
Thanks a lot for the solution

Nearly same effect to my HTPC (Geforce 8200 onboard). Workarounded with #20 under "trusty" but fall back to 304.117-0ubuntu1 required since no other package was available in the repo/cache any more. Afterwards my HTPC works again.

On 2016-11-06.16:10, Jean Christophe André wrote:
> For people needing to downgrade, this is one (among others) correct way to do so with Ubuntu 16.04:
>
> - first create a file named /etc/apt/preferences.d/local-nvidia-quirks
> with the following content:
>
> Explanation: block this specifique update because of OpenGL problem with 304.132
> Package: nvidia-304
> Pin: version 304.132-0ubuntu0.16.04.2
> Pin-Priority: -10
>
> Explanation: block this specifique update because of OpenGL problem with 304.132
> Package: nvidia-opencl-icd-304
> Pin: version 304.132-0ubuntu0.16.04.2
> Pin-Priority: -10
>
> - then reinstall the working old packages (they are still available in
> the repository):
>
> sudo apt install nvidia-304=304.131-0ubuntu3 nvidia-opencl-
> icd-304=304.131-0ubuntu3
>
> - finally, reboot your computer (because it also affects the initrd boot
> image)

Great how-to, thanks for saving me from having to muddle through this
myself!

Jim Byrnes (jf-byrnes) wrote :

I also cannot log on since the update to 304.132.
Ubuntu 14.04
Geforce 9100

Right now I am using the nouveau driver but it is not a satisfactory solution. I have two monitors and with the nouveau driver one runs at a much lower resolution that the other. With the 304.131 driver this was not the case. Having struggled to get a system that works I am hesitant to try the workaround in comment #20

Doug McCrary (dougmccrary) wrote :

Jim,
I just did #20, and works for me. If you were using 304.131, it should work for you too.
Good luck.

Doug McCrary (dougmccrary) wrote :

...but that was on 16.04.
Not found in 14.04. Crud.

Christian Kroll (tunix79) wrote :

Even a tool as innocent as glxinfo fails with an Xsession error similar to that of the original post. As I am on a Quadro NVS 110M, upgrading to a newer driver series is not an option. At least non-composited X-Sessions (e.g. Xfce) still work.

Nick Lott (o-nick-5) wrote :

Just hit this and judging from various comments online lots of other people have to. You might want to withdraw version 304.132...

SteveS (sstasino) wrote :

Same bug. Thanks to yzle and progfrou for the work around.

Robie Basak (racb) wrote :

Alberto, what's the plan here please? With 34 people reporting a regression, should this not be reverted?

tags: added: regression-update
Changed in nvidia-graphics-drivers-304 (Ubuntu):
importance: Undecided → Critical
Oliver (grimmoliver) wrote :

Bug affects me on Xubuntu 16.04 LTS, GeForce 7200 GS, NVIDIA legacy binary driver 304.132. Several programs crashing immediately, for example when opening some plugs-ins on Ardour 5.4.

Please fix asap, such a bug on an LTS release is double worrisome.

ewanchic (ewanchic) wrote :

Same bug, effects me too (Ubuntu 16.04.1)

$ lspci -v

01:00.0 VGA compatible controller: NVIDIA Corporation G73 [GeForce 7300 GT] (rev a1) (prog-if 00 [VGA controller])
 Subsystem: BFG Tech G73 [GeForce 7300 GT]
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at f9000000 (32-bit, non-prefetchable) [size=16M]
 Memory at d0000000 (64-bit, prefetchable) [size=256M]
 Memory at f8000000 (64-bit, non-prefetchable) [size=16M]
 I/O ports at e000 [size=128]
 [virtual] Expansion ROM at fa000000 [disabled] [size=128K]
 Capabilities: <access denied>
 Kernel driver in use: nvidia
 Kernel modules: nvidiafb, nouveau, nvidia_304

Solution that worked...downgrading to 304.131-0ubuntu3
See issue #20

Changed in nvidia-graphics-drivers-304 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)

FYI, after a kernel upgrade the NVIDIA driver was unusable again. This time was because of the DKMS mechanism which, for whatever reason I didn't investigate yet (could it be because of the apt-pinning??), didn't success to build and install the nvidia_304.ko module for the new kernel.

If that happens to you, the solution is to run these commands:
 dpkg-reconfigure nvidia-304
 service lightdm restart (no need to reboot)

Bran Z (branzzz) wrote :

It also affects to my computer. (Ubuntu 16.04. Then I updated to 16.10 and still the same bug, so now I'm using the open drivers).

I don't understand why this critical bug which makes your computer useless is not solved yet.

You should realize that maybe thousands of computers can't log in because of this bug.
And you should understand that an average person isn't going to know that the problem is in their drivers, and they also won't be able to update their computers because they can't login.

So, in conclusion, most of the computers which are broken now won't be able to work again because many users don't know how to update them without a graphical interface.

But the worst of it is that one month after the bug appeared, it is still unsolved.
This bug should be solved one month ago!

Sergio Zanchetta (primes2h) wrote :

As stated by jokrebel in comment #4, a possible temporary workaround could be to use Gnome (Metacity) desktop session.

1) Press Ctrl + Alt + F1 and login with username and password
2) sudo apt install gnome-session-flashback
3) sudo service lightdm restart
4) Select Gnome (metacity) session and login.

Christian Kroll (tunix79) wrote :

To all those who could hardly await a fix: Since it is closed source driver, this issue has to be resolved upstream. So far, Nvidia has not provided an update, although (according to Aaron Plattner) they are working on it [1]. Just downgrading isn't always preferable, either. Last update was supposed to fix a security problem so you will leave your system vulnerable by rolling back to an earlier version. Waiting for upstream seems to be the only reasonable choice.

You have several options, though:
* temporarily(?) switch to nouveau
* use a non-composited desktop (some apps will fail but you can login)
* replace the card (304 driver series is going to be discontinued anyway)

[1] http://goo.gl/2RQUjB

Well… Switching to another window manager doesn't solve the “any 3D/GLX app would crash” issue…

In my case I would have preferred to use the nouveau driver from the beginning, except that for ancient cards like the 6150SE it makes the whole system freeze after only a few minutes…

Finally, I was so p*ssed off about this bug and the fact that I have to tune this or that after some security update, that I looked back into this nouveau driver bug for 2 days and finally found a way to use it without patching/installing anything or totally disabling all graphic accelerations. (options nouveau config="PMPEG=0" => works for me/my card)

So now that I have returned to The open and happy world and am not concerned with this bug anymore. Goodluck everybody else! :-P

FRLinux (frlinux-frlinux) wrote :

Affected by the same issue, downgrading drivers worked.

philip (wilmot) wrote :

I was afflicted by a version of this problem after updating 12.04 LTS Precise via the Update Manager on 20/11/2016. The principal problem is that the icons on the desktop launchpad became invisible, though hovering over where I suspected that they were with the mouse did result in a small text banner identifying the application being displayed. Some colours might not be right also, but the problems are minor compared with what some people have reported.

I attempted to downgrade manually using advice given here but to no avail, possibly because I wasn't sure what version of nvidia-304 I'd been on previously, though I think it was .131. After quite a lot of fiddling I gave up and reverted to the unsatisfactory 304.132, hoping that a fix, possibly consisting of a downgrade, would be forthcoming soon.

I've only just subscribed to e-mails about this bug so apologies if this question has already been answered but is a fix going to be released, and if so roughly when? My Ubuntu instance is a secondary machine but I do use it and like it be working, which it was doing well until the update.

If it helps my GPU is an NVIDIA GeForce 6200 TurboCache and requires a 304.xx driver, and my CPU is AMD Athlon 64 X2 3800+.

Thanks.

With nvidia-driver 304 134 taken from PPA https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa the problem seems to be solved in my case.

Changed in nvidia-graphics-drivers-legacy-304xx (Debian):
status: Confirmed → Fix Released
Changed in nvidia-graphics-drivers-304 (Ubuntu):
status: Confirmed → Fix Released
Changed in nvidia-graphics-drivers-304 (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Critical
21 comments hidden view all 101 comments
philip (wilmot) wrote :

This fixed worked for me in 12.04 on AMD Athlon 64 X2 3800+ with an NVIDIA GeForce 6200 TurboCache GPU which requires a 304.xx driver.

Thanks to all who contributed to this.

JPM electronics (sedvice) wrote :

Update 304-134 worked with 16.04 and geforce 7025 / nforce 630

Cian Davis (davisc) wrote :

Update 304-134 worked here with 16.04.1 and GeForce 7600 GT (and just before I either tore my hair out or threw a monitor through a window).

Paul Eggert (eggert-cs) wrote :

I am still observing the problem on my Ubuntu 16.04.1 x86 desktop, which has C77 [GeForce 8300] (rev a2) graphics. I assume this is because 304.134 has not yet been backported to 16.04.1 LTS. I hope the bug is fixed soon, as it's a little disconcerting that the latest stable Ubuntu release does not work on my non-bleeding-edge desktop. (Nouveau crashes too often to be useful, and the more up-to-date proprietary driver has so many artifacts on the screen that it is unusable.) For now, I have worked around the problem by using the recipe in #20 to go back to 304.131-0ubuntu3.

Oleksandr Pikozh (o-pikozh) wrote :

@eggert-cs, have you tried the "ppa:graphics-drivers/ppa" PPA?

Paul Eggert (eggert-cs) wrote :

> @eggert-cs, have you tried the "ppa:graphics-drivers/ppa" PPA?

No, sorry, I just followed the recipe in #20 to downgrade from 304.132 to 304.131, plus the file /etc/apt/preferences.d/local-nvidia-quirks as described in #18 to make sure 304.132 is not reinstalled as part of an upgrade. This desktop is being used by others for their daily work, so I'm conservative about making changes to it. Is there a reliable recipe for trying out ppa:graphics-drivers/ppa for a little bit and then reverting to what I have now?

Oleksandr Pikozh (o-pikozh) wrote :

Yes, there is:

1. To try PPA:
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-304=304.134-0ubuntu0.16.04.1 \
                     nvidia-opencl-icd-304=304.134-0ubuntu0.16.04.1 \
                     libcuda1-304=304.134-0ubuntu0.16.04.1 \
                     nvidia-settings=375.26-0ubuntu0~gpu16.04.1 \
                     libxnvctrl0=375.26-0ubuntu0~gpu16.04.1

2. To revert:
sudo rm /etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-xenial.list
sudo apt-get update
sudo apt-get install nvidia-304=304.131-0ubuntu3 \
                     nvidia-opencl-icd-304=304.131-0ubuntu3 \
                     libcuda1-304=304.131-0ubuntu3 \
                     nvidia-settings=361.42-0ubuntu1 \
                     libxnvctrl0=361.42-0ubuntu1

(Note 1: This recipe is valid now. It refers specific versions that are in Ubuntu 16.04.1 and in PPA _now_. Not sure if it will work later, if a repository removes old versions.)

(Note 2: Every command looking like:
    part1 \
        part2 \
        … \
        lastPart
-- is a single command. You can either paste it all-at-once, or line-by-line (last line is without "\", other lines must end with "\"). Or you may merge it into single line _with removing slashes_ ("part1 part2 … lastPart").)

But, as 304.131 works for you, you have no need to explicitly upgrade to 304.134. Just wait until 304.134 will appear itself. (Sorry, first I didn't realize that 304.131 works for you.)

Oleksandr Pikozh (o-pikozh) wrote :

BTW:
sudo apt-add-repository --remove ppa:graphics-drivers/ppa
can (and should) be used instead of:
sudo rm /etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-xenial.list
(I just didn't know that apt-add-repository has --remove option.)
And the recipe in #68-#69 in only for Ubuntu 16.04.1.

Kees Cook (kees) wrote :

Is this fixed in Xenial?

Solved for me on Xenial. nvidia-304 upgraded to 304.134-0ubuntu0.16.04.1.

Oleksandr Pikozh (o-pikozh) wrote :

Yes, I confirm that nvidia-304=304.134-0ubuntu0.16.04.1 is now not only in PPA, but also in xenial-{updates,security}/restricted repos.

Brian Murray (brian-murray) wrote :

Setting to Fix Released then.

bdmurray@flash:~$ apt-cache policy nvidia-304
nvidia-304:
  Installed: 304.134-0ubuntu0.16.04.1
  Candidate: 304.134-0ubuntu0.16.04.1
  Version table:
 *** 304.134-0ubuntu0.16.04.1 500
        500 http://192.168.10.7/ubuntu xenial-security/restricted amd64 Packages
        500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
     304.131-0ubuntu3 500
        500 http://192.168.10.7/ubuntu xenial/restricted amd64 Packages

Changed in nvidia-graphics-drivers-304 (Ubuntu Xenial):
status: Triaged → Fix Released
Bran Z (branzzz) wrote :

I have just installed nvidia-304 version 304.134-0ubuntu0.16.10.1 on Ubuntu Xenial and it is still broken. My Ubuntu 16.10 still can't login with this driver... So I don't know what is the problem now, because it should work.

(However, I don't care anymore about this driver because I got used to use the open drivers).

I can confirm this bug still persists in latest package 304.134 on XUbuntu 16.04 LTS.

The card is nForce 6150SE

OpenGL does not work, but I can login to xfce because it does not need a compositor.

Version 304.131 works OK. It was listed in aptitude for some reason, so I could just downgrade.

I cannot use nouveau on this card because it hard-crashes (entire screen becomes filled with lots of lines in a slightly diagonal screen gray & blue pattern, stops responding, only solution is to do a hard reset) when doing "intensive" graphics usage (intensive = opening a web browser and browser one or two pages). I didn't try PPA nouveau with latest drivers, just the ones provided by stock Ubuntu.

Bran Z (branzzz) wrote :

Please reopen the bug. The problem is not solved on Ubuntu 16.10

Brian Murray (brian-murray) wrote :

On Thu, Feb 02, 2017 at 10:44:32PM -0000, comu wrote:
> Please reopen the bug. The problem is not solved on Ubuntu 16.10

Could you provide some more information about how you tested and what
leads you believe that this not fixed. Plenty of people have
indicated, with details, that it works for them.

--
Brian Murray

Gary Caine (skgary) wrote :

I agree it's not solved on 16.10

I believe there is an open bug about it on 16.10 but I can't find it.

Gary Caine (skgary) wrote :

I have

NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)

with 16.10 nvidia-304 304.134-0ubuntu1 isn't available just nvidia-304 304.134-0ubuntu0 which still cause the login loop

Bran Z (branzzz) wrote :

Brian, nobody had said that the problem was solved for Ubuntu 16.10.

If you read their messages, they only said that the new version of the driver (nvidia 304.134-0ubuntu0.16.10.1) is already published on the repos.

However, when I install this new version, my computer don't login, so the problem is not solved.

Bran Z (branzzz) wrote :

Moreover, what I don't understand is why people said that they have the version nvidia 304.134-0ubuntu0.16.04.1 in Ubuntu 16.10.

I have checked it, and in Ubuntu 16.10 the available version is this one: 304.134-0ubuntu0.16.10.1 (note the difference in the lasts digits).

Maybe both oh them are the same? I don't know, but my computer says 304.134-0ubuntu0.16.10.1 and not 04.1.
Or maybe they have added the repos of Ubuntu 16.04 on their Ubuntu 16.10? I don't know.

Changed in nvidia-graphics-drivers-304 (Ubuntu Yakkety):
status: New → Triaged
importance: Undecided → Critical
Brian Murray (brian-murray) wrote :

The versions of nvida-304 in 16.04 and 16.10. seem the same. They were released on the same day and copied from the X staging PPA.

https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304

Gary Caine (skgary) wrote :

What is availble in 16.10 is -0ubuntu0 not -0ubuntu1

Gary Caine (skgary) wrote :

I just tried installing Nvidia again and still same login loop problem.

Gary Caine (skgary) wrote :

Just reread your message it's version 304.134-unbuntu1 that fixed the problem in 16.104 not 304.132

Bran Z (branzzz) wrote :

Ok, sorry. I thought Ubuntu Xenial was Ubuntu 16.10... but 16.10 is Yakkety.

So the problem is in Ubuntu 16.10.

Gary Caine (skgary) wrote :

yes the problem is in 16.10 Yakkety

Brian Murray (brian-murray) wrote :

Please try this version of the package - 304.134-0ubuntu0.16.10.1.

Gary Caine (skgary) wrote :

Already did, but just tried again. Still get login loop

According to what I've seen it's

304.134-0ubuntu1.16.10.1 not 304.134-0ubuntu0.16.10.1 that fixed the problem in 16.04

Note the 0ubuntu1 not 0ubuntu0

If i try to load 304.134-0ubuntu1.16.10.1 I get this mesage E: Version '304.134-0ubuntu1.16.10.1' for 'nvidia-304' was not found

Note 0ubuntu1 not availaible just 0ubuntu0

Trying 0ubuntu1 gives this message E: Version '304.134-0ubuntu1.16.10.1' for 'nvidia-304' was not found

Nouveau "sort of" works but I get a freeze up with diagonal lines occasionally

Brian Murray (brian-murray) wrote :

That's not the version that fixed it in Xenial, my comment (https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304/+bug/1639180/comments/73) indicates it was 304.134-0ubuntu0.16.04.1. There is no 304.134-0ubuntu1.16.xyz in the official archive for either Xenial or Yakkety.

 $ rmadison nvidia-304
 nvidia-304 | 304.117-0ubuntu1 | trusty/restricted | amd64, i386
 nvidia-304 | 304.125-0ubuntu2 | vivid/restricted | amd64, i386
 nvidia-304 | 304.131-0ubuntu0.15.04.1 | vivid-security/restricted | amd64, i386
 nvidia-304 | 304.131-0ubuntu0.15.04.1 | vivid-updates/restricted | amd64, i386
 nvidia-304 | 304.131-0ubuntu3 | xenial/restricted | amd64, i386
 nvidia-304 | 304.132-0ubuntu1 | yakkety/restricted | amd64, i386
 nvidia-304 | 304.134-0ubuntu0.12.04.1 | precise-security/restricted | amd64, i386
 nvidia-304 | 304.134-0ubuntu0.12.04.1 | precise-updates/restricted | amd64, i386
 nvidia-304 | 304.134-0ubuntu0.14.04.1 | trusty-security/restricted | amd64, i386
 nvidia-304 | 304.134-0ubuntu0.14.04.1 | trusty-updates/restricted | amd64, i386
 nvidia-304 | 304.134-0ubuntu0.16.04.1 | xenial-security/restricted | amd64, i386
 nvidia-304 | 304.134-0ubuntu0.16.04.1 | xenial-updates/restricted | amd64, i386
 nvidia-304 | 304.134-0ubuntu0.16.10.1 | yakkety-security/restricted | amd64, i386
 nvidia-304 | 304.134-0ubuntu0.16.10.1 | yakkety-updates/restricted | amd64, i386
 nvidia-304 | 304.134-0ubuntu1 | zesty/restricted | amd64, i386

Gary Caine (skgary) wrote :

OK I thought I saw that it was 304.134-0ubuntu1 that fixed it in 16.04

Anyway 304.134-0ubuntu0.16.10.1 is causing the login loop on my system

JPM electronics (sedvice) wrote :

Newest 304.135 update bring back login loop :(

Oleksandr Pikozh (o-pikozh) wrote :

I confirm that after upgrade to 304.135-0ubuntu0~gpu16.04.1 my KUbuntu 16.04.1 LTS (linux x86_64 4.4.0-63-generic) no more logs in in graphics mode.

Gary Caine (skgary) wrote :

I just installed 304.135 on 16.10 (not 16.04) and was able to log in

Frau Tukka (frautukka) wrote :

Did anyone try 304.135-0ubuntu0.16.04.1 on 16.04.2? I would not want to mess up my system if it doesn't work. Any success?
Thanks.

Jan Herold (yzle) wrote :

I installed 304.135-0ubuntu0.16.04.1 on 16.04.2. Works flawlessly.

Frau Tukka (frautukka) wrote :

Great. Thanks Jan!
304.135-0ubuntu0.16.04.1 on 16.04.2 works for me too with card:
05:00.0 VGA compatible controller: NVIDIA Corporation NV43GL [Quadro FX 540] (rev a2)

philip (wilmot) wrote :

Could someone offer advice please?

I was affected by this bug in 12.04 LTS Precise but in practical terms fixed it by installing nvidia-304=304.134-0ubuntu0.12.04.1 . Subsequent security updates to nvidia packages were offered but I ignored them following comments in this thread that they reintroduced the bug. All was well until I upgraded to 14.04 Trusty yesterday but I've now hit problems.

I established through investigations following the evident loss of my XWindows interface that PPAs are disabled on upgrades. I believe however that I have successfully re-enabled them in Trusty. I have a semi-functional desktop through having purged all NVIDIA drivers, and have tried to install nvidia-304=304.134-0ubuntu0.14.04.1 (and also 14.04, and 14.04.2) thinking that this would exist and correspond with the version that worked under Precise. Unfortunately they weren't found, and so I'm hoping that someone knows which nvidia package in which repository I should install in order to regain functioning graphics.

My graphics card is a GeForce 6200 TurboCache (Device Id 0x0161) and it requires a 304.xx driver. Incidentally I intend upgrading very soon to Xenial but would much prefer to do this from a stable base.

TIA.

dino99 (9d9) wrote :

philip

your question is welcome on ubuntuforums; here it is about the reported bug.

That said here is where you can download the driver:
https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304

Bran Z (branzzz) wrote :

The last update works fine in Ubuntu 16.10

 :)

nvidia-304-updates 304.135-0ubuntu0.16.10.1
nvidia-304 304.135-0ubuntu0.16.10.1

So, in my computer the bug is fixed.

dino99 (9d9) on 2017-04-13
Changed in nvidia-graphics-drivers-304 (Ubuntu Yakkety):
status: Triaged → Fix Released
Displaying first 40 and last 40 comments. View all 101 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.