mouse trapped in box for Open Motif

Bug #553415 reported by J Lorieau on 2010-04-01
144
This bug affects 31 people
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Critical
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: xorg

A recent update of Kubuntu 10.03 beta1 has made a lesstif application, grace, unusable. Right-clicking traps the cursor within the menu, and the user is forced to switch to a text console and kill the application--or reboot.

I have filed this bug for grace as well, but Fedora developers have traced this bug back to xorg-xserver :

https://bugzilla.redhat.com/show_bug.cgi?id=543647
(see comment #32.)

The bug and the relevant patches are included in the discussion. My bug report in grace can be found here:

https://bugs.launchpad.net/ubuntu/+source/grace/+bug/552681

thanks,

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xserver-xorg 1:7.5+3ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Uname: Linux 2.6.32-16-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Apr 1 12:28:42 2010
DkmsStatus:
 nvidia-current, 195.36.15, 2.6.32-16-generic, x86_64: installed
 virtualbox-ose-guest, 3.1.4, 2.6.32-16-generic, x86_64: installed
 virtualbox-ose, 3.1.4, 2.6.32-16-generic, x86_64: installed
InstallationMedia: Kubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
MachineType: Dell Inc. Precision WorkStation 390
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=1b723b3f-6877-48e1-a25d-3dd4bcf90753 ro quiet splash
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
dmi.bios.date: 07/28/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 2.4.0
dmi.board.name: 0DN075
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 7
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr2.4.0:bd07/28/2007:svnDellInc.:pnPrecisionWorkStation390:pvr:rvnDellInc.:rn0DN075:rvr:cvnDellInc.:ct7:cvr:
dmi.product.name: Precision WorkStation 390
dmi.sys.vendor: Dell Inc.
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-16-generic

Created an attachment (id=31735)
tar file including source code and compile options for sample app

Running into what I believe is the same issue:

Problem only occurs when trying to use Motif to display a popup menu. Mouse
cursor gets locked inside of the parent window, and the popup menu is not
displayed.

X server version:

1.7.1-9.fc12.i686

Reproducible steps:
1. Install openmotif (openmotif-2.3.2-5.fc12.i686)
2. Run test app (compile options used in "README" file)
3. right click on drawing area to bring up popup menu

Expected results: pop-up menu displays.

Additional info:
Problem does not occur using Fedora 11 (Kernel 2.6.29.6-217.2.16.fc11.i686.PAE,
X-server version 1.6.3.901). We tried openmotif 2.3.0 and 2.3.2.

Problem does not occur using X Toolkit methods of popup creation. For example
XtMenuPopup(). Only when using motif, such as XmCreatePopupMenu().

In some further testing, we've narrowed the problem down a bit to the XtGrabButton in RCPopup.C in the Xm library. When using motif to create a popup, using, for example XmCreatePopupMenu, it seems to use XtGrabButton. We found that if XtUngrabButton is called, the problem doesn't occur.

For example, a popup is created like so in example code:
menuRC = XmCreatePopupMenu(parent, (char*)(const char*)menuName, NULL, 0);

Then Ungrabbed immediately after:

for (i=0; i < ((_XmRowColumnRec *)menuRC)->row_column.postFromCount; i++)
{
    XtUngrabButton( ((_XmRowColumnRec *)menuRC)->row_column.postFromList[i], AnyButton, AnyModifier);
}

Now the pop-up works with mouse button 3 correctly. I'm not sure what other effects this workaround would have, but it seems to be working for us so far.

As an additional datapoint, I'm experiencing the exact same trouble with
openMotif apps in Gentoo, xorg-server-1.7.3 on both 32-bit and 64-bit builds.

Before I upgraded, xorg-server-1.6.4 was *not* experiencing the problem with
exactly the same test app and openMotif library. (I was using 'ddd' as my test
application).

More info about my experiences in Gentoo, and my test cases with 'ddd':
  https://bugs.gentoo.org/296514

@Peter,

This bug appeared with server 1.7. Obviously, a change in the input subsystem is making openmotif unhappy. Question is : which one is doing it wrong?

Thanks

(In reply to comment #5)
> @Peter,
> Question is : which one is doing it wrong?
>

I think the fact that the bug affects Open Motif and Lesstif the same way is a clue.

from what I can tell by looking at the requests coming in, the test app in Comment #1 issues a passive grab in mode Sync.

the confine_to is part of that same grab, hence when the grab activates the cursor is confined to the window. the application never issues a AllowEvents request to the server, hence the events get queued up indefinitely.

which means either of two things:
- the app doesn't get an event that it used do get and thus doesn't trigger the AllowEvent request. In this case it's definitely the server that's at fault but the trick bit will be finding this event.
- the server does the right thing, the app just relies on previously broken behaviour.

still looking at the event stream on 1.6

Created an attachment (id=32100)
0001-dix-if-owner-events-is-true-for-passive-grabs-add-th.patch

Please try this patch, it seems to fix the problem for me.

The patch seems to be fixing the issue for me as well. Thanks!

Agreed, this patch also solves my issues with 'ddd' and a proprietary 'trace32' app that were both exhibiting this issue.

Thanks both of you for testing, I'll send it to the list and leave it in my local server for a while. stuff like this can have unexpected side-effects.

(In reply to comment #9)
> The patch seems to be fixing the issue for me as well. Thanks!

If you would like your tested-by attached to the patch, I'd need your full name please (it's just a way to acknowledge your contribution).

I also have to use the proprietary trace32 app at work and was
afflicted by this bug. The patch works for me, so I would
like to encourage you to push it into mainline soon.
I'm using Debian unstable, Xorg 1.7.4, and just rebuilt the
Debian xserver-xorg-core package with the patch applied.

Bug #24059 "ddd blocks server" is also fixed by the patch.

*** Bug 24059 has been marked as a duplicate of this bug. ***

I have updated to
xorg-x11-server-Xorg-1.7.4-6.fc12.x86_64 and
xorg-x11-server-common-1.7.4-6.fc12.x86_64

from the fedora-updates-testing repo and the problem is fixed for me. Sorry about not trying it sooner, but I didn't want to mess around with source code.

So Fedora has applied the patch in their package for testing
(xserver-1.7.4-owner-events.patch in
ftp://download.fedora.redhat.com/pub/fedora/linux/updates/testing/12/SRPMS/xorg-x11-server-1.7.4-6.fc12.src.rpm),
but please keep this bug open until the patch is in xorg git.

I've had some reports against XWin of similar problems where the input device is frozen due a passive grab, but the application never recieves the event to cause it to request a thaw.

See http://sourceware.org/bugzilla/show_bug.cgi?id=11301

Reproduction steps:

X -query solaris10vm
start CDE session
click on one of the uparrows on the panel to expand it, launch something
note that you can interact with that application, reize etc.
go back to click on the panel
input is now frozen

Note that I can also reproduce this problem with FC12 xorg-x11-xserver-Xorg-1.7.5-1, so this doesn't seem to be a XWin-specific problem.

commit cf72b5437d2d620521279077a29c5df6d0fbb576
Author: Peter Hutterer <email address hidden>
Date: Thu Feb 25 12:49:21 2010 +1000

    dix: Use DeliverGrabbedEvent for implicit passive grabs (#25400)

This patch causes problems with several windowmanagers:
http://bugs.archlinux.org/task/18598

fluxbox, openbox and icewm are affected.
This was also brought up on the mailinglists:
http://<email address hidden>/msg05737.html

Same issue with CDE session note in comment #16 is still present with current git master.

I did a little bit of debugging to confirm this is due to VCK/VCP getting frozen but never thawed.

patch is reverted in 1.7 nominations branch. I found that the original patch
(attachment 3 here) doesn't suffer from this issue, can you confirm this?

(In reply to comment #20)
> patch is reverted in 1.7 nominations branch. I found that the original patch
> (attachment 3 [details] here) doesn't suffer from this issue, can you confirm this?

Not sure who this question is directed at, but for the avoidance of doubt, the CDE panel does not work correctly with either version of the patch applied.

(The behaviour is changed slightly vs. unpatched 1.7.5 in that the input freeze doesn't occur until the second interaction with the panel)

(In reply to comment #18)
> This patch causes problems with several windowmanagers:
> fluxbox, openbox and icewm are affected.

Affects KDE 3.5 app-switching using Alt+Tab: http://bugs.gentoo.org/308795

(In reply to comment #20)
> patch is reverted in 1.7 nominations branch. I found that the original patch
> (attachment 3 [details] here) doesn't suffer from this issue, can you confirm this?

I can confirm that with the attachment 3 patch, fluxbox works just fine.

(In reply to comment #20)
> I found that the original patch doesn't suffer from this issue,
> can you confirm this?

I can confirm that attachment 32100 doesn't break KDE 3.5 for me.
cf72b5437d2d620521279077a29c5df6d0fbb576 did, as I wrote in comment 22.

alrighty, thanks to all for testing. This still leaves CDE broken with the original patch applied, suggesting that we're not there yet.

Another, possibly related test:

1. flash plugin in firefox

2. right-click context-menu -> settings

3. try to click "close"

there are 3 possibilities:

1. works fine

2. replayed click ignored, second one works - if wm releases grab

3. click never works - if wm doesn't release grab

icewm also works fine again with reverted patch (problem was in task bar
not receiving replayed event -- because taskbar is also a toplevel window).

re: #26

I'm not sure this is an X server bug or a bug in firefox or flash plugin.

Proper behavior would be 1, but currently (with revert) it's 2 (metacity)
or 3 (current icewm which never releases the button grabs).

(In reply to comment #25)
> alrighty, thanks to all for testing. This still leaves CDE broken with the
> original patch applied, suggesting that we're not there yet.

If I understand correctly, CDE is broken in 1.7.5 already. So it does not matter whether the patch is applied or not in that regard.
But as it fixes other issues and does not worsen CDE's situation it might be good to apply it.

Keith just merged the patch into master.

commit 1c612acca8568fcdf9761d23f112adaf4d496f1b
Author: Peter Hutterer <email address hidden>
Date: Wed Mar 17 14:32:38 2010 +1000

    dix: if owner-events is true for passive grabs, add the window mask (#25400)

Closing the bug as the fix is in 1.7.99.902.

As this bug has been resolved and the original issue fixed, I've created bug #27295 to track the problem with CDE sessions.

J Lorieau (justin-lorieau) wrote :

Binary package hint: xorg

A recent update of Kubuntu 10.03 beta1 has made a lesstif application, grace, unusable. Right-clicking traps the cursor within the menu, and the user is forced to switch to a text console and kill the application--or reboot.

I have filed this bug for grace as well, but Fedora developers have traced this bug back to xorg-xserver :

https://bugzilla.redhat.com/show_bug.cgi?id=543647
(see comment #32.)

The bug and the relevant patches are included in the discussion. My bug report in grace can be found here:

https://bugs.launchpad.net/ubuntu/+source/grace/+bug/552681

thanks,

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xserver-xorg 1:7.5+3ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Uname: Linux 2.6.32-16-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Apr 1 12:28:42 2010
DkmsStatus:
 nvidia-current, 195.36.15, 2.6.32-16-generic, x86_64: installed
 virtualbox-ose-guest, 3.1.4, 2.6.32-16-generic, x86_64: installed
 virtualbox-ose, 3.1.4, 2.6.32-16-generic, x86_64: installed
InstallationMedia: Kubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
MachineType: Dell Inc. Precision WorkStation 390
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=1b723b3f-6877-48e1-a25d-3dd4bcf90753 ro quiet splash
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
dmi.bios.date: 07/28/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 2.4.0
dmi.board.name: 0DN075
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 7
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr2.4.0:bd07/28/2007:svnDellInc.:pnPrecisionWorkStation390:pvr:rvnDellInc.:rn0DN075:rvr:cvnDellInc.:ct7:cvr:
dmi.product.name: Precision WorkStation 390
dmi.sys.vendor: Dell Inc.
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-16-generic

J Lorieau (justin-lorieau) wrote :
Bryce Harrington (bryce) on 2010-04-02
Changed in xorg (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2010-04-03
tags: added: kubuntu
Bryce Harrington (bryce) on 2010-04-03
affects: xorg (Ubuntu) → nvidia-graphics-drivers-180 (Ubuntu)
pato101 (pato101) wrote :

Affects also to me, I've even compiled myself latest OpenMotif to see if it worked right, but no. I do some Motif devel and all my popup menus are affected.

My googling has thrown me across Gentoo forums and I've ended at xorg bug:

http://cgit.freedesktop.org/xorg/xserver/commit/?id=cf72b5437d2d620521279077a29c5df6d0fbb576

Jon Kåre Hellan (hellan) wrote :

See also bug #572620 in xastir: locks desktop when righclicking on a icon. The right click problems also happens with lesstif and the radeon driver

Hein Zelle (zelle) wrote :

I something going to happen with this bug, and has it been filed for the x.org package properly?
It's not related to the nvidia driver, but to the xorg package.

The fix is to rebuild the xorg package xorg-xserver-base with the patch as discussed on the xorg upstream bug. I obtained the patch through here: http://lists.x.org/archives/xorg-devel/2010-February/005845.html (see attachments)

rebuilt with

- aptitude source xorg-xserver-base
- prepared package according to http://www.cyberciti.biz/faq/rebuilding-ubuntu-debian-linux-binary-package/
- applied patch manually (didn't pick it up automatically, but that's due to my lack of experience with debian source packages)
- built packages
- installed with dpkg -i

This is a critical bug for anybody using motif applications (nedit and plenty of others).
It would be nice if the patch could be reviewed and applied in an update quickly - it's preventing us from upgrading the office to 10.04 at the moment.

Hein Zelle (zelle) wrote :

patch attached, as discussed in previous comment,.

pato101 (pato101) wrote :

I agree this is a critical bug for anybody using motif!. Thanks, Hein, to point that.

To Hein Zelle: do you use any options through the source package compilation (I mean, DEB_BUILD_OPTIONS )?

tags: added: patch
Hein Zelle (zelle) wrote :

pato101: no, no special build options were used. I just applied the patch manually before the build command.

Callum Potter (callum-potter) wrote :

I am having this problem too on Xephem - only recently discovered after an uprading to 10.04 - a fix is needed.

Akkana Peck (akkzilla) wrote :

There's an easier workaround than recompiling the X server, posted on the Xephem yahoo group: http://tech.groups.yahoo.com/group/xephem/message/3103 -- may require group membership to read, but it says:
  "I am using xephem 3.7.4 debs for 64bit Ubuntu from http://e2rd.piekielko.pl/debian/
  These debs work fine for me on Lucid (Ubuntu 10.04) as they also did on Karmic (9.10) and Jaunty (9.04)
  I use 32bit debs on my laptop and 64bit debs on my desktop machine."

That deb works for me too. I don't understand why the 3.7.4 deb works on Lucid when the 3.7.4 I compiled myself doesn't work, or why it would make a difference if the bug is really in the X server. But it might help as a temporary workaround for those who don't want to recompile X.

Chris Carlin (crcarlin) wrote :

Easily installable packages including the patch are in my ppa: https://launchpad.net/~crcarlin/+archive/ppa

(crossposted from a duplicate, Bug #581032)

Stephen Warren (srwarren) wrote :

Marking "invalid" in "nvidia-graphics-drivers-180 (Ubuntu)" since this is an X server bug, not an NVIDIA graphics driver bug.

Adding "xorg-server (Ubuntu)" to "Affects" list, and marking "Confirmed" per confirmed status here (albeit wrong module) and in other bugs.

See bug 574157 for other discussion and background.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Confirmed → Invalid
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Stephen Warren (srwarren) wrote :

Nominate for Lucid and Maverick per status in duplicate bug 581032.

Graham Inggs (ginggs) wrote :

This is fixed in Maverick, marking as "Fix Released" and requesting SRU.

Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
Chris Halse Rogers (raof) wrote :

Earlier versions of this fix resulted in other breakage. The final patch was http://cgit.freedesktop.org/xorg/xserver/commit/?id=e7154e9375e6b624db01a787d9ec6c8cedc2eb81 cherry-picked onto the 1.7 branch.

Chris Carlin (crcarlin) wrote :

Quick pedantic note (since I received questions about it): this is not fixed in the 1.7.6-2ubuntu7.3 lucid-proposed release that superseded the patched build in my ppa. I'll upload a 7.4~ppa0 as soon as I can.

Is there any sort of status update on the SRU request? I was contacted by a developer of an application used by "thousands of scientists around the world" whose program is killed by this bug. Would testimony from such people help the SRU along?

Akkana Peck (akkzilla) wrote :

Chris: did you follow all the "Procedure" steps for SRU in https://wiki.ubuntu.com/StableReleaseUpdates ? I just looked for people to ping so we can get this in, but it looks like it doesn't have the needed info in the bug description, or ubuntu-sru subscribed to the bug.

Chris Carlin (crcarlin) wrote :

I assumed Graham was taking care of the procedure when he said he was requesting SRU.

Graham Inggs (ginggs) wrote :

I did subscribe ubuntu-src and requested an SRU on #ubuntu-x on freenode. This was shortly before Chris Halse Rogers joined in.

Graham Inggs (ginggs) wrote :
Graham Inggs (ginggs) on 2010-08-19
Changed in nvidia-graphics-drivers-180 (Ubuntu Lucid):
status: New → Invalid
Chris Carlin (crcarlin) wrote :

Alright, so where are we on the SRU? Going through the checklist,
1) Fix released in Maverick

2) Impact of bug: rightclick in many (all?) motif/lesstif applications disables the computer
--How the bug is addressed: small patch to X that other distributions accepted long ago
--Patch against stable: see above or my ppa
--Instructions for reproduction: open any (?) motif application, or install medm from my ppa, and rightclick inside of it
--Regression potential: seems small because of the short patch and aformentioned inclusion in other distributions, as well as my own testing in a heterogeneous mix of computers

3) Nominated for release, and I just subscribed ubuntu-sru

4) Upload to release-proposed... I don't know how, but again, I uploaded the patched xorg-server to my ppa so hopefully someone who does know how can grab it from there. Also, I believe the diff is attached above.

That should be it, right?

Graham Inggs (ginggs) on 2010-08-20
Changed in xorg-server (Ubuntu Lucid):
status: New → Confirmed
Graham Inggs (ginggs) wrote :

After testing and uploading the patch I asked for a lucid task to be created on #ubuntu-x on freenode, Timo Aaltonen kindly did so and said he could even sponsor the fix, but would like to talk to the release manager about pulling the whole of 1.7.7.

phil (fongpwf) wrote :

Any update on the SRU? This makes many apps unusable on Lucid.

Graham Inggs (ginggs) wrote :
Changed in xorg-server:
importance: Unknown → Critical
status: Unknown → Fix Released
Hertatijanto Hartono (dvertx) wrote :

I previously had locked mouse problem while using DDD (Data Display Debugger) on Ubuntu 10.04 (lucid). Upgrading xorg-server to 2:1.7.6-2ubuntu7.4~ppa0 provided by Chris Carlin (comment #42) resolved the issue. Thanks, Chris, for the fix.

Chris Carlin (crcarlin) wrote :

Any news on the Lucid SRU? Is Timo watching this bug?

There is a class of users who are completely sunk by this bug. If backporting 1.7.7 is going to take a while, I'd suggest just putting this fix through now.

Alex Waite (alexqw85) wrote :

Any update on whether all of 1.7.7 is being back-ported or if this fix will be released? My lab is affected by this bug and we're choosing to stick with the LTS releases, so upgrading to Maverick isn't an option for us.

---Alex

Hein Zelle (zelle) wrote :

I would very much appreciate an update on the backport to 10.04 as well. We're currently running a custom-patched X server on 2 workstations, but it's basically preventing a company-wide rollout of 10.04 so far. We intend to upgrade to 10.04 and stay there until the next LTS release.

If this fix will NOT be backported anytime soon, could we get a confirmation of that?

Changed in xorg-server (Ubuntu Lucid):
status: Confirmed → Triaged
milestone: none → lucid-updates
Sebastien Bacher (seb128) wrote :

Chris, could you sponsor that if you think it makes sense for a sru?

Timo Aaltonen (tjaalton) wrote :

This is now uploaded to the proposed queue, thanks Graham!

Chris Carlin (crcarlin) wrote :

So, just to be pedantic, where are we on this?

Sebastien, you asked Chris to sponsor this... were you talking to me or another Chris? Has it been appropriately sponsored?

Timo says it's now in the proposed queue... does that mean there's nothing left to do but wait for the queue to be acted upon?

Stefano Rivera (stefanor) wrote :

> Has it been appropriately sponsored?
Yes: https://launchpad.net/ubuntu/lucid/+queue?queue_state=1

> does that mean there's nothing left to do but wait for the queue to be acted upon?

Yes, waiting for stage 5 of https://wiki.ubuntu.com/SRU

Jonathan Riddell (jr) wrote :

Upload in lucid-proposed unapproved queue, awaiting approval from ubuntu-sru

Accepted xorg-server into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xorg-server (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Akkana Peck (akkzilla) wrote :

Thanks! Working well here so far on two Lucid machines, and right-clicks in xephem are working again.

Alex Waite (alexqw85) wrote :

I mis-clicked and switched this to "Fix-released" but I don't seem to be able to change this back. I was surprised that I was able to make this change.
Anyways, thanks for working on this. I look forward to seeing it make its way out of proposed and into stable.

Changed in xorg-server (Ubuntu Lucid):
status: Fix Committed → Fix Released

Thanks for testing.

Changed in xorg-server (Ubuntu Lucid):
status: Fix Released → Fix Committed
tags: added: verification-done
removed: verification-needed
Stephen Warren (srwarren) wrote :

Yup, fixes the issue in ddd too (see dup bug 574157 comment #1). Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.7.6-2ubuntu7.4

---------------
xorg-server (2:1.7.6-2ubuntu7.4) lucid-proposed; urgency=low

  [ Graham Inggs ]
  * Add 202_trappedMouseCursor.patch patch: Patch from upstream to fix
    trapped mouse cursor within Lesstif/Openmotif buttons.
    (LP: #553415)
 -- Timo Aaltonen <email address hidden> Fri, 05 Nov 2010 23:51:58 +0200

Changed in xorg-server (Ubuntu Lucid):
status: Fix Committed → Fix Released

Unfortunately following the Ubuntu 2:1.7.6-2ubuntu7.4 update, it appears to have caused the similar instability in the following wireless mouse.

After 20-30s the cursor freezes, however both left mouse buttons are operational and bring up and close menus within Gnome.

input: HID 2c1a:0000 as /devices/pci0000:00/0000:00:0a.1/0000:06:00.1/usb4/4-1/4-1:1.0/input/input1

2c1a Dolphin Peripherals
 0000 Wireless Optical Mouse

`cat /dev/input/event1 ` show activity on all mouse events but these are not visible in the form of cursor movement on the X display.

This mouse was fully functional before the update.

Changed in xorg-server:
importance: Critical → Unknown
Chris Carlin (crcarlin) wrote :

Steve, you should probably file a new bug. This one is closed, and the problem it was meant to solve was fixed.

Changed in xorg-server:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.