package nvidia-glx-185 (not installed) failed to install/upgrade: subprocess new pre-installation script returned error exit status 2

Bug #464113 reported by Garvit Singh on 2009-10-30
66
This bug affects 15 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned

Bug Description

unable to install nvidia driver

nvidia-185-kernel-source: Install
nvidia-185-libvdpau: Install
nvidia-glx-185: Install
nvidia-settings: Install
nvidia-185-kernel-source: Configure
nvidia-185-libvdpau: Configure
nvidia-glx-185: Configure
nvidia-settings: Configure

ProblemType: Package
Architecture: i386
Date: Fri Oct 30 08:59:17 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess new pre-installation script returned error exit status 2
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
MachineType: Hewlett-Packard Compaq Presario CQ45 Notebook PC
Package: nvidia-glx-185 (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=UUID=30761c54-bbe8-4f92-834f-e8533e09d706 ro quiet splash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: nvidia-graphics-drivers-180
Title: package nvidia-glx-185 (not installed) failed to install/upgrade: subprocess new pre-installation script returned error exit status 2
Uname: Linux 2.6.31-14-generic i686
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 06/23/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.04
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 30F8
dmi.board.vendor: Compal
dmi.board.version: 99.44
dmi.chassis.type: 10
dmi.chassis.vendor: Compal
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.04:bd06/23/2008:svnHewlett-Packard:pnCompaqPresarioCQ45NotebookPC:pvrF.04:rvnCompal:rn30F8:rvr99.44:cvnCompal:ct10:cvrN/A:
dmi.product.name: Compaq Presario CQ45 Notebook PC
dmi.product.version: F.04
dmi.sys.vendor: Hewlett-Packard
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-14-generic

Garvit Singh (kant1) wrote :
Bryce Harrington (bryce) wrote :

Hmm, unfortunately the files included in this bug report do not indicate *why* it is failing. nvidia seems to be stuck in the configuration stage though. Please attach your /var/log/apt/term.log, /var/log/dist-upgrade/apt-term.log, and /var/log/dist-upgrade/apt.log.

Bryce Harrington (bryce) wrote :

Also, could you please find and attach your build log that shows this issue? The file will be found someplace like:

 /var/lib/dkms/nvidia/185.18.36/build/make.log

The numbered directory may be different depending on what version you have installed, but if you poke around it should be somewhere like that.

Bryce Harrington (bryce) on 2009-11-05
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) on 2009-11-06
description: updated
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Invalid
Eyad Salah (eyad-salah) wrote :

I use Lucid and I've got this error while updating packages. I realized after marking it as (Affects me) that it's been close. Should start a new ticket?

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Invalid → Incomplete
George Prowse (torqueing) wrote :

I'm on Lucid and this is affecting me as well.

Installing the nvidia drivers removes xorg and ubuntu-desktop amongs others and leaves the system at the command line after a restart

George Prowse (torqueing) wrote :

term.log and apt-term.log are useless but apt.log may be useful

George Prowse (torqueing) wrote :

added apt-term.log anyway

Bryce Harrington (bryce) on 2010-03-01
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) on 2010-03-02
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2010-03-18
tags: added: karmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers